Σάββατο, 27 Δεκεμβρίου 2014

Απλοποίηση

Θεωρήστε τον πραγματικό πίνακα Α[10, 7].
Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
    Για κ από 1 μέχρι 10
       Για λ από 1 μέχρι 7
           Αν (κ = 10) ΚΑΙ (λ < 4) τότε
                Εμφάνισε Α[κ, λ]
           Τέλος_αν
       Τέλος_επανάληψης
    Τέλος_επανάληψης

Λύση
  
       Για λ από μέχρι 3
           Εμφάνισε Α[10, λ]
       Τέλος_επανάληψης

Διορθώστε τις λανθασμένες προτάσεις

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Μια εγγραφή αποτελείται από πολλά αρχεία.
2. Προγράμματα+Διαγράμματα = Αλγόριθμοι.
3. Το ελάχιστο στοιχείο στον αλφαριθμητικό πίνακα
    Α[200] που είναι ταξινομημένος κατά αλφαβητική
    σειρά είναι το Α[200].
4. Ο πίνακας Α[12, 5, 2, 3] έχει 22 στοιχεία.
5. Ο πίνακας Α[12, 12, 12 ] είναι τετραγωνικός.


Απάντηση

1. Μια εγγραφή αποτελείται από πολλά πεδία.
2. Αλγόριθμοι+Δομές Δεδομένων = Προγράμματα.
3. Το ελάχιστο στοιχείο στον αλφαριθμητικό πίνακα
    Α[200] που είναι ταξινομημένος κατά αλφαβητική
    σειρά είναι το Α[1].
4. Ο πίνακας Α[12, 5, 2, 3] έχει 360 στοιχεία.
5. Ο πίνακας Α[12, 12, 12 ] είναι τρισδιάστατος.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Μια δυναμική δομή δεδομένων
    Α. αξιοποιεί τη μνήμη κατά το βέλτιστο τρόπο
    Β. δεσμεύει μνήμη καθ' όλη τη διάρκεια εκτέλεσης
         του προγράμματος
    Γ. είναι και ο πίνακας
    Δ. αποθηκεύεται πάντοτε σε ένα αρχείο εγγραφών

2. Ένας δυσδιάστατος πίνακας
    Α. μπορεί να σχεδιαστεί σαν ένα κύβο
    Β. έχει τύπο στοιχείων ίδιο με τον τύπο των
         δεικτών του
    Γ. μπορεί να θεωρηθεί ως τρισδιάστατος πίνακας
        με βάθος 2
    Δ. μπορεί να καταλαμβάνει λιγότερο χώρο στη
        μνήμη από ένα μονοδιάστατο πίνακα.

3. Για να προσδιορίσουμε τη θέση μεγίστου σε μια
    συγκεκριμένη γραμμή ενός δυσδιάστατου πίνακα
    πρέπει να εντοπίσουμε:
    Α. τη γραμμή στην οποία ανήκει το μέγιστο
    Β. τη στήλη στην οποία ανήκει το μέγιστο
    Γ. τη γραμμή και τη στήλη στην οποία ανήκει
        το μέγιστο
    Δ. την απόσταση από το κέντρο του πίνακα

4. Η σειριακή αναζήτηση
    Α. δεν μπορεί να χρησιμοποιηθεί σε ταξινομημένο
         πίνακα
    Β. είναι πολύ απλή και γρήγορη μέθοδος αναζήτησης
    Γ. είναι πολύ απλή αλλά αργή μέθοδος αναζήτησης
    Δ. είναι πιο γρήγορη από τη δυαδική

Απαντήσεις

1. Α
2. Δ
3. Β
4. Γ


Βρείτε το κέντρο του πίνακα

Θεωρήστε τον πίνακα Α[Ν, Ν], όπου Ν >=3 και
περιττός ακέραιος. Γράψτε τις εντολές που
απαιτούνται προκειμένου να εμφανίσετε την τιμή
του κεντρικού στοιχείου του Α.

Λύση

α' τρόπος

Το κεντρικό στοιχείο βρίσκεται στη μεσαία
γραμμή και στη μεσαία στήλη. Άρα αρκεί να
γράψουμε :
     Εμφάνισε Α[ (Ν+1) div 2, (N+1) div 2]

β' τρόπος

Όταν το Ν είναι περιττό, το κεντρικό στοιχείο
είναι το μοναδικό στοιχείο που ανήκει και στις
δύο κύριες διαγωνίους του πίνακα. Κατά συνέπεια
γράφουμε:
       Για κ από 1 μέχρι Ν
            Για λ από 1 μέχρι Ν
                 Αν (κ = λ) ΚΑΙ (κ+λ  = Ν+1) τότε
                     Εμφάνισε Α[κ, λ]
                 Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης

Βήμα-βήμα εκτέλεση

Θεωρήστε τον πίνακα Α[5] που περιέχει τις τιμές
     4, 5, 3, 13, -6
Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
Για κ από 1 μέχρι 3 με_βήμα 2
     Εμφάνισε (Α[κ]+Α[κ+1)^2 div 17
     Εμφάνισε Τ_Ρ(Α[κ]+Α[κ+1])/2
Τέλος_επανάληψης
Εμφάνισε Α_Τ(Α[κ]-100)


Λύση

κ = 1
      Αφού (Α[κ]+Α[κ+1)^2 div 17 = (Α1]+Α[2])^2 div 17 =
                (4+5)^2 div 17 =  9^2 div 17 = 81 div 17 = 4
      η Εμφάνισε τυπώνει : 4
     Αφού Τ_Ρ(Α[κ]+Α[κ+1])/2 =
               Τ_Ρ(Α[1]+Α[2])/2 = Τ_Ρ(4+5)/2 =
               Τ_Ρ(9)/2 = 3.0/2 = 1.5
     η Εμφάνισε τυπώνει : 1.5
κ = 3
      Αφού (Α[κ]+Α[κ+1)^2 div 17 = (Α3]+Α[4])^2 div 17 =
                (3+13)^2 div 17 =  16^2 div 17 = 256 div 17 = 15
      η Εμφάνισε τυπώνει : 15
     Αφού Τ_Ρ(Α[κ]+Α[κ+1])/2 =
               Τ_Ρ(Α[3]+Α[4])/2 = Τ_Ρ(3+13)/2 =
               Τ_Ρ(16)/2 = 4.0/2 = 2.0
     η Εμφάνισε τυπώνει : 2.0
Η Για τερματίζεται με κ = 5.
Αφού Α_Τ(Α[κ]-100) = Α_Τ(Α[5]-100) =
          Α_Τ(-6-100) = Α_Τ(-106) = 106
η Εμφάνισε τυπώνει : 106

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το στοιχείο Α[2, 7] ανήκει στην 2η κύρια __________
    του πίνακα Α[8, 8].
2. Ο αλφαριθμητικός πίνακας Α[100] μπορεί να περιέχει
    100 ___________.
3. Ένα δυσδιάστατος πίνακας έχει τουλάχιστον δύο
    γραμμές και τουλάχιστον δύο _____.
4. Ο ________ ενός μονοδιάστατου πίνακα είναι
    πάντοτε ακεραίου τύπου.
5. Οι τιμές ενός ______ πίνακα δεν μπορούν να
    ταξινομηθούν.

Απαντήσεις

1. διαγώνιο
2. συμβολοσειρές
3. στήλες
4. δείκτης




Παρασκευή, 26 Δεκεμβρίου 2014

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Κάθε τετραγωνικός πίνακας έχει δύο κυρίες διαγωνίους.
2. Το μέγιστο στοιχείο ενός πίνακα είναι πάντα μοναδικό.
3. Η εισαγωγή τιμών σε ένα δυσδιάστατο πίνακα γίνεται
    με ένα και μοναδικό τρόπο.
4. Αν διασχίσουμε τα στοιχεία ενός δυσδιάστατου πίνακα
    στήλη προς στήλη προκειμένου να βρούμε το γινόμενό
    τους, θα καταλήξουμε στο ίδιο αποτέλεσμα με αυτό
   που θα προέκυπτε αν διασχίζαμε τον πίνακα
   γραμμή-γραμμή.
5. Όταν δεν γνωρίζουμε το πλήθος των στοιχείων ενός
    ακέραιου μονοδιάστατου πίνακα Α, στο τμήμα δήλωσης
    των  μεταβλητών του προγράμματος γράφουμε:
        ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α[Ν]
   όπου Ν ακέραια μεταβλητή που αντιπροσωπεύει το
   πλήθος των στοιχείων του πίνακα.
           
   

Απάντηση

1. Σ
2. Λ
3. Λ
4. Σ
5. Λ



Επεξεργασία δυσδιάστατου πίνακα

Γράψτε αλγόριθμο που :
α) διαβάζει 25 ακέραιες τιμές και τις
    καταχωρεί σε κατάλληλο δυσδιάστατο πίνακα,
β) εμφανίζει όλα τα στοιχεία του πίνακα που
    έχουν τιμή μεγαλύτερη από την τιμή
    του κεντρικού στοιχείου του πίνακα,
γ)  εμφανίζει όλα τα στοιχεία του πίνακα που
    βρίσκονται κάτω από τη δεύτερη κύρια
    διαγώνιο.

Λύση

Αλγόριθμος Ασκ
Για κ από 1 μέχρι 5
   Για λ από 1 μέχρι 5
         Διάβασε Α[κ, λ]
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από μέχρι 5
   Για λ από μέχρι 5
         Αν Α[κ, λ] > Α[3, 3] τότε
              Εμφάνισε Α[κ, λ]
         Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από μέχρι 5
   Για λ από μέχρι 5
         Αν κ+λ > 6 τότε
              Εμφάνισε Α[κ, λ]
         Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ

Τρίτη, 23 Δεκεμβρίου 2014

Γέμισμα πίνακα με βάση κάποιο μαθηματικό τύπο


Αναζήτηση

Θεωρήστε τον πίνακα Απ[30, 50] που περιέχει
τις απαντήσεις 30 φοιτητών σε 50 ερωτήσεις
πολλαπλής επιλογής. Το περιεχόμενο κάθε
στοιχείου του πίνακα μπορεί να είναι:
* Σ, αν ο φοιτητής απάντησε σωστά
* Λ, αν ο φοιτητής απάντησε λάθος
Γράψτε αλγόριθμο που, με δεδομένο τον
παραπάνω πίνακα υπολογίζει το ποσοστό (%)
των φοιτητών που απάντησαν σωστά σε
τουλάχιστον 10 ερωτήσεις πριν κάνουν το
πρώτο τους λάθος.

Λύση


Αντιμετάθεση στοιχείων της διαγωνίου σε τετραγωνικό πίνακα


Γέμισμα δυσδιάστατου πίνακα


Σάββατο, 20 Δεκεμβρίου 2014

Έξοδος αποτελεσμάτων

Θεωρήστε ένα πίνακα Α[10] που περιέχει εναλλάξ τις
τιμές :
     2, 4, 5, 7, 20, 4, 12, 8, 1, 11
Τι θα εμφανίσει το παρακάτω σύνολο
εντολών;
     Για κ από 1 μέχρι 9 με_βήμα 2
         Εμφάνισε ( (Α[κ]+Α[κ+1]) div 2 )^2
     Τέλος_επανάληψης
     Εμφάνισε Α[κ-4]

Λύση

κ=1
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[1]+Α[2]) div 2 )^2 = ( (2+4) div 2 )^2 =
              (6 div 2 )^2 = 3^2 = 9, η Εμφάνισε τυπώνει : 9
κ=3
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[3]+Α[4]) div 2 )^2 = ( (5+7) div 2 )^2 =
              (12 div 2 )^2 = 6^2 = 36, η Εμφάνισε τυπώνει : 36
κ=5
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[5]+Α[6]) div 2 )^2 = ( (20+4) div 2 )^2 =
              (24 div 2 )^2 = 12^2 = 144,
     η Εμφάνισε τυπώνει : 144
κ=7
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[7]+Α[8]) div 2 )^2 = ( (12+8) div 2 )^2 =
              (20 div 2 )^2 = 10^2 = 100,
     η Εμφάνισε τυπώνει : 100
κ=9
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[9]+Α[10]) div 2 )^2 = ( (1+11) div 2 )^2 =
              (12 div 2 )^2 = 6^2 = 36, η Εμφάνισε τυπώνει : 36
Η Για τερματίζεται με κ = 11.
Αφού κ-4 = 11-4 = 7 και Α[7] = 12, η Εμφάνισε τυπώνει : 12

Εμφωλευμένες δομές επανάληψης

Γράψτε αλγόριθμο που εντοπίζει τετράδες ακεραίων
αριθμών στο διάστημα [-200, 300] που έχουν άθροισμα
περιττό.

Λύση

Αλγόριθμος Ασκ
Για κ από -200  μέχρι  300
    Για λ από -200  μέχρι  300
       Για μ από -200  μέχρι  300
            Για ρ από -200  μέχρι  300
                 Αν (κ+λ+μ+ρ) mod 2 = 1 τότε
                      Εμφάνισε κ, λ, μ, ρ
                 Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ

Παρασκευή, 12 Δεκεμβρίου 2014

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η απαιτούμενη μνήμη για ένα πίνακα διατίθεται από
    το μεταγλωττιστή κατά την εκτέλεση του προγράμματος.
2. Ο πίνακας Α[10, 30] έχει 40 στοιχεία.
3. Το στοιχείο Α[3, 3] ανήκει στην 1η κύρια διαγώνιο του
    τετραγωνικού πίνακα Α[100, 100].
4. Ο πίνακας Α[9, 9, 9] είναι τριγωνικός.
5. Ο δείκτης ενός πίνακα είναι αριθμητικού τύπου
    (ακέραιος ή πραγματικός).




Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Λ



Τετάρτη, 3 Δεκεμβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Ο πίνακας Α[9,9] είναι:
    α. τρισδιάστατος  
    β. μονοδιάστατος
    γ. τετραγωνικός
    δ. τίποτα από τα παραπάνω

2. Τα στοιχεία ενός πίνακα
    α. ονομάζονται και κλειδιά
    β. μπορεί να είναι και διαφορετικού τύπου
    γ. αποθηκεύονται στη δευτερεύουσα μνήμη
    δ. τίποτα από τα παραπάνω

3. Η σειριακή αναζήτηση
    α. είναι ο πιο γρήγορος τρόπος αναζήτησης
    β. είναι η πιο δύσκολη μέθοδος αναζήτησης
    γ. χρησιμοποιείται μόνο σε ταξινομημένους πίνακες
    δ. τίποτα από τα παραπάνω

4, Αν η 3η στήλη του ακέραιου πίνακα Α[12, 8]
    έχει ταξινομηθεί, το μέγιστο στοιχείο της είναι
    το
    α. Α[1,3] ή Α[12, 3]
    β. Α[1, 3]
    γ. Α[12, 3]
    δ. τίποτα από τα παραπάνω

5, Αν η 7η γραμμή του ακέραιου πίνακα Α[12, 8]
    έχει ταξινομηθεί, το ελάχιστο στοιχείο της είναι
    το
    α. Α[7, 1]
    β. Α[7, 1] ή Α[7, 8]
    γ. Α[7, 8]
    δ. τίποτα από τα παραπάνω

Απαντήσεις

1. γ
2. α
3. δ
4. α
5. β




Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  (Χ mod 2 < > 0) = (X mod 2 = ____ ), αν Χ θετικός ακέραιος.
2.  Η είσοδος σε κάθε βρόχο γίνεται από την ______ του.
3.  Για να προσδιορίσουμε το στοιχείο ενός πίνακα
     χρησιμοποιούμε ένα ή περισσότερους _________.
4.  Η ________ σχεδίαση είναι μια μεθοδολογία/τεχνική
     διάσπασης ενός σύνθετου προβλήματος σε υποπροβλήματα.
5.  Η δομή ενός προβλήματος καταγράφεται κατά το στάδιο της
     ________.



Απαντήσεις

1. 1
2. αρχή
3. δείκτες
4. ιεραρχική
5. ανάλυσης






Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για την εντολή 
Για..από..μέχρι;
1. Χρησιμοποιείται μόνο όταν γνωρίζουμε επακριβώς το
    πλήθος των επαναλήψεων.
2. Είναι ιδανική για τη δημιουργία προγραμμάτων που
    λειτουργούν με μενού.
3. Είναι η πιο ισχυρή επαναληπτική δομή.
4. Είναι ιδανική για την επεξεργασία μονοδιάστατων
    πινάκων.
5. Έχει παραπλήσια διαγραμματική αναπαράσταση με
    την Όσο..επανάλαβε.
6. Χρησιμοποιείται σπάνια στους αλγορίθμους.

Απαντήσεις

1, 4, 5

Τετάρτη, 26 Νοεμβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το ελεύθερο κείμενο είναι ένας τρόπος αναπαράστασης
     του αλγόριθμου που κινδυνεύει να παραβιάσει το κριτήριο
     της _______.
2. Μια από τις σκοπιές εξέτασης των δεδομένων από την
    Πληροφορική είναι και αυτή του ________.
3. Οι τυπικές και οι _________ παράμετροι ενός υποπρογράμματος
    μπορεί να έχουν το ίδιο όνομα.
4. Μια σύγκριση δεδομένων αποτελεί μια _______ έκφραση.
5. Ο πίνακας Α[3,5,8] είναι _______________.

Απαντήσεις

1. αποτελεσματικότητας
2. υλικού
3. πραγματικές
4. λογική
5. τρισδιάστατος




Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τις λειτουργίες
επί των δομών δεδομένων
1. Η αναζήτηση είναι το αντίστροφο της ταξινόμησης.
2. Η συγχώνευση είναι το αντίστροφο του διαχωρισμού.
3. Η ίδια λειτουργία μπορεί να εκτελείται γρηγορότερα
    σε μια δομή δεδομένων από ότι σε μια άλλη.
4. Οι μοναδικές λειτουργίες που δεν μπορούν να γίνουν
    σ' ένα πίνακα είναι η εισαγωγή και η διαγραφή.
5. Η ταξινόμηση μας επιτρέπει να εντοπίσουμε ένα ή
    περισσότερους κόμβους που ικανοποιούν κάποιους
    συγκεκριμένους περιορισμούς.
6. Η προσπέλαση είναι μια λειτουργία που σπάνια
    χρησιμοποιείται στις δομές δεδομένων.
   

Απαντήσεις

2, 3, 4

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Ο μεταγλωττιστής είναι απαραίτητος για τη μετάφραση ενός
    προγράμματος σε γλώσσα μηχανής.
2. Το λογικό διάγραμμα είναι ένας γραφικός τρόπος αναπαράστασης
    ενός αλγορίθμου.
3. Ο δομημένος προγραμματισμός στηρίζεται στη χρήση των δομών
    ακολουθίας, επιλογής και επανάληψης.
4. Τα λογικά λάθη σ' ένα πρόγραμμα εντοπίζονται ευκολότερα από
     τα συντακτικά.
5. Η γλώσσα COBOL είναι 4ης γενιάς.

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Λ




Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
χρησιμοποιώντας μια μόνο Μέχρις_ότου
και μια εντολή Εμφάνισε

     Για κ από 12 μέχρι 19 με_βήμα 9
          Για λ από 22 μέχρι 13 με_βήμα -15
              Για μ από 2 μέχρι 170 με_βήμα 200
                  Για ρ από 45 μέχρι 17 με_βήμα -50
                          Εμφάνισε (λ*κ+ρ)^μ
                  Τέλος_επανάληψης
              Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση
   
      Για κ από 12 μέχρι 19 με_βήμα 9
            Εμφάνισε (22*κ+45)^2
      Τέλος_επανάληψης
    

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών με ισοδύναμο
τρόπο αντικαθιστώντας τις εμφωλευμένες δομές επιλογής
με μια Αν..τότε. 
Περιορισμός : Ο μοναδικός λογικός τελεστής που μπορείτε
να χρησιμοποιήσετε είναι ο ΚΑΙ
           Αν Α > 10 τότε
               Αν (Β < 5) Ή (Β = 5) τότε
                    Αν Α_Τ(Γ) < Γ τότε
                         Εμφάνισε Α, Β, Γ
                    αλλιώς
                         Αν ΟΧΙ (Γ mod 6 = 2) τότε
                                Εμφάνισε Α+Β+Γ
                         Τέλος_αν
                    Τέλος_αν
               Τέλος_αν
           Τέλος_αν

Απάντηση
Ξέρουμε ότι Α_Τ(Γ) <= Γ για κάθε τιμή του Γ, κατά συνέπεια
η εντολή  Εμφάνισε Α, Β, Γ δεν εκτελείται ποτέ. Έτσι έχουμε:

 Αν (Α > 10) ΚΑΙ (Β <= 5) ΚΑΙ (Γ mod 6 < > 2) τότε
            Εμφάνισε Α+Β+Γ                        
 Τέλος_αν



Παρασκευή, 21 Νοεμβρίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 10 μέχρι 20 με_βήμα 10
         Για λ από 30 μέχρι 10 με_βήμα -10
             Για μ από 20 μέχρι 25 με_βήμα 4
                  Εμφάνισε (κ+λ) div 4 + μ
             Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

κ = 10
     λ = 30
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+30) div 4 + 20 =
                          40 div 4 + 20 = 10+20 = 30
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+30) div 4 + 24 =
                          40 div 4 + 24 = 10+24 = 34
     λ = 20
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+20) div 4 + 20 =
                          30 div 4 + 20 = 7+20 = 27
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+20) div 4 + 24 =
                          30 div 4 + 24 = 7+24 = 31
     λ = 10
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+10) div 4 + 20 =
                         20 div 4 + 20 = 5+20 = 25
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+10) div 4 + 24 =
                          20 div 4 + 24 = 5+24 = 29
κ = 20
     λ = 30
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+30) div 4 + 20 =
                          50 div 4 + 20 = 12+20 = 32
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+30) div 4 + 24 =
                          50 div 4 + 24 = 12+24 = 36
     λ = 20
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+20) div 4 + 20 =
                          40 div 4 + 20 = 10+20 = 30
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+20) div 4 + 24 =
                          40 div 4 + 24 = 10+24 = 34
     λ = 10
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+10) div 4 + 20 =
                         30 div 4 + 20 = 7+20 = 27
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+10) div 4 + 24 =
                          30 div 4 + 24 = 7+24 = 31
   


   



Πέμπτη, 20 Νοεμβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Η ιδανική δομή επανάληψης για τη δημιουργία
    προγράμματος με μενού λειτουργιών είναι η
    α. Μέχρις_ότου
    β. Όσο..επανάλαβε
    γ. Για..από..μέχρι
    δ. Αν..τότε..αλλιώς_αν

2. Η ιδανική δομή επανάληψης για την επεξεργασία
    δοσμένου πλήθους δεδομένων είναι η :
    α. Μέχρις_ότου
    β. Όσο..επανάλαβε
    γ. Για..από..μέχρι
    δ. Αν..τότε..αλλιώς

3. Η ιδανική γλώσσα προγραμματισμού για τη 
    δημιουργία εφαρμογών τεχνητής νοημοσύνης
    είναι η :
    α. JAVA
    β. LISP
    γ. SQL
    δ. ALGOL

4. Ένα πρόβλημα
    α. μπορεί να μην έχει καθόλου δεδομένα
    β. μπορεί να μην έχει καθόλου ζητούμενα
    γ. μπορεί να έχει προφανή λύση
    δ. έχει ένα χώρο που πρέπει να καθοριστεί
        επακριβώς πριν επιχειρηθεί οποιαδήποτε
        προσπάθεια επίλυσής του.

Απαντήσεις

1. α
2. γ
3. β
4. δ



Σάββατο, 15 Νοεμβρίου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παραμέτρους
δύο ακέραιους αριθμούς Α, Β και εμφανίζει ένα
χαρακτηρισμό για τα πρόσημα τους.
Για παράδειγμα αν Α = 7, Β = -2 θα εμφανίζεται
το μήνυμα:
      Ο πρώτος είναι θετικός και ο δεύτερος αρνητικός
Για παράδειγμα αν Α = -17, Β = 0 θα εμφανίζεται
το μήνυμα:
      Ο πρώτος είναι αρνητικός και ο δεύτερος μηδέν

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΗΜΑ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
        ΑΝ Α > 0 ΤΟΤΕ
             ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ Α = 0 ΤΟΤΕ
             ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
              ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρασκευή, 14 Νοεμβρίου 2014

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
     Για κ από 4 μέχρι 56 με_βήμα 60
          Για λ από 100 μέχρι 20 με_βήμα -90
               Διάβασε Χ
               Εμφάνισε (λ+Χ)^κ              
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Εμφάνισε κ+λ

Απάντηση
Η εξωτερική Για εκτελείται μία φορά, μόνο για κ = 4 και η
τελική τιμή του κ είναι 64.
Η εσωτερική Για εκτελείται μία φορά, μόνο για λ = 100 και η
τελική τιμή του λ είναι 10.
Κατά συνέπεια έχουμε:

       Διάβασε Χ
       Εμφάνισε (100+Χ)^4
       Εμφάνισε  74     ! 74 = 64+10

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις με σωστό
τρόπο
1. Η αρχική τιμή μιας ακέραιας μεταβλητής είναι μηδέν.
2. Μια δομή επιλογής αποκαλείται και βρόχος.
3. Η γλώσσα C++ είναι συναρτησιακή.
4. Στη διαγραμματική αναπαράστασης της ανάλυσης ενός
    προβλήματος, το μοναδικό γεωμετρικό σχήμα που μπορεί
    να χρησιμοποιηθεί είναι το τετράγωνο.





Απαντήσεις

1. Η αρχική τιμή μιας ακέραιας μεταβλητής είναι απροσδιόριστη.
2. Μια δομή επανάληψης αποκαλείται και βρόχος.
3. Η γλώσσα C++ είναι αντικειμενοστραφής.
4. Στη διαγραμματική αναπαράστασης της ανάλυσης ενός
    προβλήματος, το μοναδικό γεωμετρικό σχήμα που μπορεί
    να χρησιμοποιηθεί είναι το ορθογώνιο παραλληλόγραμμο.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση η περιεχόμενη ομάδα εντολών
εκτελείται
1. Όταν το βήμα σε μια Για..από..μέχρι είναι μηδενικό
    α.  άπειρες φορές
    β. 0 φορές
    γ. 0 ή άπειρες φορές
    δ. 1 φορά

2. Η ολίσθηση κατά μια θέση προκαλεί
    α. αύξηση του αριθμού
    β. μείωση του αριθμού
    γ. διπλασιασμό του αριθμού
    δ. διπλασιασμό ή υποδιπλασιασμό του αριθμού
   
3. Οι συμβολικές γλώσσες
    α. αποκαλούνται και γλώσσες 4ης γενιάς
    β. είναι στενά συνδεδεμένες με την αρχιτεκτονική
        του υπολογιστή
    γ. είναι πανίσχυρες γλώσσες προγραμματισμού
        γενικής χρήσης
    δ. εξασφαλίζουν τη δημιουργία μικρών και
        ευκολοσυντήρητων προγραμμάτων

4.  Η εντολή εκχώρησης
     α. είναι ένας από τους τρόπους με τους οποίους
         μπορεί να αλλάξει το περιεχόμενο μιας
         μεταβλητής
     β. παριστάνεται με το σύμβολο +=
     γ. μπορεί να χρησιμοποιηθεί για την αλλαγή του
        περιεχομένου μιας συμβολικής σταθεράς κατά
        τη διάρκεια εκτέλεσης του προγράμματος
     δ. χρησιμοποιείται σπάνια στους αλγορόθμους

Απαντήσεις

1. γ
2. δ
3. β
4. α



Τετάρτη, 12 Νοεμβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  (Χ > Υ) Ή (Χ = Υ) = Χ _____ Υ
2. (Χ < Υ) Ή (Χ > Υ) = Χ _____Υ
3. (Χ = 1) Ή (Χ = 2) Ή  (Χ = 3) Ή (Χ = 4)
                  = (Χ ___ 1) ____ (Χ ___ 4),
    όπου Χ ακέραια μεταβλητή

Απαντήσεις

1.  Χ >= Υ
2. Χ < > Υ
3. (Χ >= 1) ΚΑΙ (Χ <= 4)


Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Οι γλώσσες 3ης γενιάς έχουν υψηλή μεταφερσιμότητα.
2. Οι συμβολικές γλώσσες αποκαλούνται και γλώσσες
    υψηλού επιπέδου.
3. Η σημασιολογία στις τεχνητές γλώσσες καθορίζεται
    από το δημιουργό τους.
4. Η PASCAL είναι μια γλώσσα γενικής χρήσης.
5. Τα προγράμματα σε BASIC εκτελούνται με τη
    βοήθεια μεταγλωττιστή.


Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ



Τετάρτη, 29 Οκτωβρίου 2014

Βρείτε τις τιμές

Ποιές τιμές πρέπει να έχουν οι λογικές μεταβλητές Χ, Υ
προκειμένου οι παρακάτω παραστάσεις να είναι Αληθής;
α) ΟΧΙΚΑΙ Υ)
β) ΟΧΙ Χ ΚΑΙ Υ
γ) Χ ΚΑΙ ΟΧΙ Υ
δ) ΟΧΙ Ή Υ)
ε) ΟΧΙ Χ Ή ΟΧΙ Υ

Λύση

α) Πρέπει Χ ΚΑΙ Υ = Ψευδής. Άρα έχουμε τις ακόλουθες
    περιπτώσεις:
         Χ = Αληθής, Υ = Ψευδής
         Χ = Ψευδής, Υ = Αληθής
         Χ = Ψευδής, Υ = Ψευδής
β) Πρέπει ΟΧΙ  Χ = Αληθής και Υ = Αληθής. Άρα:
         Χ = Ψευδής, Υ = Αληθής
γ) Πρέπει Χ = Αληθής και ΟΧΙ Υ = Αληθής. Άρα:
         Χ = Αληθής, Υ = Ψευδής
δ) Πρέπει Χ Ή Υ = Ψευδής. Άρα:
         Χ = Ψευδής, Υ = Ψευδής
ε) Πρέπει :
       ΟΧΙ Χ = Αληθής, ΟΧΙ Υ = Ψευδής
       ΟΧΙ Χ = Ψευδής, ΟΧΙ Υ = Αληθής
       ΟΧΙ Χ = Ψευδής, ΟΧΙ Υ = Ψευδής
   Άρα :
        Χ = Ψευδής, Υ = Αληθής
        Χ = Αληθής, Υ = Ψευδής
        Χ = Αληθής, Υ = Αληθής

Τρίτη, 28 Οκτωβρίου 2014

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τις συμβολικές
σταθερές
1. Είναι υποχρεωτικές στα προγράμματα.
2. Εμφανίζονται συχνά μέσα σε αλγορίθμους.
3. Είναι ονόματα που αντιπροσωπεύουν σταθερές
    τιμές.
4. Έχουν το δικό τους τμήμα δήλωσης μέσα στα
    προγράμματα.
5. Δεν καταλαμβάνουν χώρο στη μνήμη.
6. Έχουν τύπο δεδομένων που αναγράφεται στο
    τμήμα δήλωσης των μεταβλητών του προγράμματος.
7. Απαγορεύεται οποιαδήποτε μεταβολή του περιεχομένου
    τους.
8. Δυσχεραίνουν την κατανόηση και συντήρηση του
    προγράμματος.

Απαντήσεις

3, 4, 7

Εύρεση τελικής τιμής (εμφωλευμένες Για..από..μέχρι)


Μετατροπή


Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για μια μεταβλητή
προγράμματος;
1. Έχει ένα τύπο δεδομένων που μπορεί να αλλάζει
    κατά τη διάρκεια εκτέλεσης του προγράμματος.
2. Έχει ένα μοναδικό όνομα που τη χαρακτηρίζει.
3. Καταλαμβάνει συγκεκριμένο χώρο στην κύρια
    μνήμη του υπολογιστή.
4. Μπορεί να περιέχει μόνο αριθμητικές ή λογικές
    τιμές.
5. Η εμβέλεια του ονόματός της είναι τοπική.
6. Δηλώνεται υποχρεωτικά στο τμήμα δήλωσης
    των μεταβλητών του προγράμματος.
7. Πρέπει υποχρεωτικά μέσα στο πρόγραμμα να
    υπάρχει σχόλιο που να επεξηγεί το ρόλο της.

Απάντηση

2, 3, 5, 6

Φρουρός+Απάντηση σε ερώτηση+δοσμένο πλήθος (συνδυασμός)


Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
αντικαθιστώντας την Αν..τότε..αλλιώς_αν
με εντολές Αν..τότε
     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     αλλιώς_αν  Β < 100 τότε
          Εμφάνισε Α^2
     αλλιώς
          Εμφάνισε Β+1
     Τέλος_αν

Λύση

     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     Τέλος_αν
     Αν  (Β < 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Α^2
     Τέλος_αν
     Αν  (Β >= 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Β+1
     Τέλος_αν

Λογικό διάγραμμα

Κατασκευάστε το λογικό διάγραμμα του παρακάτω
αλγόριθμου



















Λύση

Κυριακή, 26 Οκτωβρίου 2014

Εκφώνηση προβλήματος

Δώστε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος

Αλγόριθμος Ασκ
Για κ από 120 μέχρι 300
      Αν mod 4 = 0) KAI mod 12 < > 0) τότε
           Εμφάνισε κ
      Τέλος_αν
Τέλος_επανάληψης
Τέλος Ασκ

Λύση

Γράψτε αλγόριθμο που εμφανίζει όλους τους
ακέραιους στο διάστημα [120, 300] που είναι
πολλαπλάσια του 4 αλλά όχι του 12

Τετάρτη, 22 Οκτωβρίου 2014

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Μια μεταβλητή που εμπεριέχει τη χωρητικότητα
    μιας αίθουσας είναι πραγματικού τύπου.
2. Η λογική πράξη ¨Η αποκαλείται σύζευξη.
3. Ο τελεστής < > είναι λογικός.
4. Κάθε δομή επιλογής τελειώνει με τη δεσμευμένη
    λέξη Τέλοςαν


Απαντήσεις

1. Μια μεταβλητή που εμπεριέχει τη χωρητικότητα
    μιας αίθουσας είναι ακεραίου τύπου.
2. Η λογική πράξη ¨Η αποκαλείται διάζευξη.
3. Ο τελεστής < > είναι συγκριτικός.
4. Κάθε δομή επιλογής τελειώνει με τη δεσμευμένη
    λέξη Τέλος_αν

Σάββατο, 18 Οκτωβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ο πολλαπλασιασμός αλά ρωσικά
    α. στηρίζεται στην πράξη της αφαίρεσης
    β. στηρίζεται στη λειτουργία της ολίσθησης
    γ. υλοποιείται μέσω της διαίρεσης
    δ. εφαρμόζεται μόνο σε αρνητικούς ακεραίους

2. Η σειριακή αναζήτηση
    α. δεν μπορεί να εφαρμοστεί σε ταξινομημένο πίνακα
    β. είναι μια μέθοδος ταξινόμησης
    γ. είναι η πιο γρήγορη μέθοδος αναζήτησης
    δ. τίποτα από τα παραπάνω

3. Στην εντολή Για..από..μέχρι
    α. το βήμα μπορεί να είναι αλφαριθμητικού τύπου
    β. το βήμα είναι πάντοτε θετικό
    γ. το βήμα μπορεί να είναι και αρνητικό
    δ. τίποτα από τα παραπάνω

4. Σε μια Όσο..επανάλαβε
    α. η περιεχόμενη ομάδα εντολών εκτελείται
        τουλάχιστον μία φορά
    β. απαγορεύεται η περιεχόμενη ομάδα εντολών
        να αλλάζει την τιμή της συνθήκης ελέγχου
    γ. η περιεχόμενη ομάδα εντολών πρέπει να
        επηρεάζει με κάποιον τρόπο τη συνθήκη
        ελέγχου ώστε κάποτε ο βρόχος να τερματιστεί
    δ. τίποτα από τα παραπάνω

Απαντήσεις

1. β
2. δ
3. γ
4. γ



Δώστε την εκφώνηση

Ποια είναι η εκφώνηση του προβλήματος που
επιλύει ο παρακάτω αλγόριθμος;
      Αλγόριθμος Ασκ
      Για Χ από -300 μέχρι 10
          Για Υ από -300 μέχρι 10
               Για Ζ από -300 μέχρι 10
                     Αν 2*Χ-4*Υ+Ζ = 6 τότε
                          Εμφάνισε Χ, Υ, Ζ
                     Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που επιλύει την εξίσωση
2*Χ-4*Υ+Ζ = 6 στο ακέραιο διάστημα
τιμών [-300, 10]

Δευτέρα, 6 Οκτωβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  Αν Χ < Υ τότε  ΟΧΙ (Χ < Υ) = ........
2,  Αν  Χ = 2.3 η εντολή ΓΡΑΨΕ Α_Μ(Χ)^2 θα
     εμφανίσει την τιμή ......
3.  Αν  Χ = 'ΑΛΦΑ' και ΒΗΤΑ = 'ΑΛΛΑ'
     Χ >=  ΒΗΤΑ = .............
4. Αν το βήμα είναι 0 σε μια Για,,από,,μέχρι τότε
    η περιεχόμενη ομάδα εντολών είτε δεν εκτελείται
    καθόλου είτε εκτελείται .............. φορές.
5. Η εντολή που είναι ιδανική για έλεγχο εγκυρότητας
    των εισερχόμενων δεδομένων είναι η ................  

Απαντήσεις

1, Ψευδής
2, 4
3. Αληθής
4. άπειρες
5. Μέχρις_ότου



Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Σε μια εντολή εκχώρησης πρέπει να υπάρχει
    απόλυτη ταύτιση ανάμεσα στον τύπο της
    μεταβλητής και της εκχωρηθείσας έκφρασης.
2. Ένας μονοδιάστατος πίνακας καταλαμβάνει
    πάντοτε λιγότερη μνήμη από ένα δυσδιάστατο
    πίνακα με το ίδιο πλήθος στοιχείων.
3. Η περιεχόμενη ομάδα εντολών μιας Αν..τότε
    εκτελείται τουλάχιστον μια φορά.
4, Αν ένα πρόβλημα είναι ημιδομημένο, αποκλείεται
    να είναι άλυτο.
5. Η γλώσσα C είναι κατάλληλη για τη δημιουργία
    λειτουργικών συστημάτων.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ




    

Σάββατο, 20 Σεπτεμβρίου 2014

Διορθώστε τις λανθασμένες προτάσεις

Διορθώστε τις παρακάτω λανθασμένες προτάσεις
και επαναδιατυπώστε τις με σωστό τρόπο
1. Μια λογική παράσταση αποτιμάται με την τιμή
    'Ψευδής' ή 'Αληθής'.
2. Μια έλλειψη έχει μία ή περισσότερες εξόδους
    για απάντηση σ' ένα λογικό διάγραμμα.
3. Κάθε πρόγραμμα έχει τουλάχιστον μια μεταβλητή.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις
    της δευτερεύουσας μνήμης του υπολογιστή.
5. Ένα υποπρόγραμμα πρέπει να εξαρτάται άμεσα
    από το κύριο πρόγραμμα.



Απάντηση

1. Μια λογική παράσταση αποτιμάται με την τιμή  
    Ψευδής ή Αληθής.
2. Ένας ρόμβος  έχει μία ή περισσότερες εξόδους
    για απάντηση σ' ένα λογικό διάγραμμα.
3. Ένα πρόγραμμα μπορεί να  μην έχει καμία 
     μεταβλητή.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις
    της κύριας μνήμης του υπολογιστή.
5. Ένα υποπρόγραμμα πρέπει να είναι ανεξάρτητο
    από το κύριο πρόγραμμα.

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τους αλγόριθμους;
1. Γράφονται σε μια γλώσσα προγραμματισμού
2. Γράφονται σε ψευδογλώσσα.
3. Πληρούν συγκεκριμένα κριτήρια.
4. Εκτελούνται απευθείας στον υπολογιστή.
5. Δεν έχουν καμιά σχέση με τα προγράμματα.

Απάντηση

2, 3

Κυριακή, 14 Σεπτεμβρίου 2014

Ερωτήσεις σωστού/λάθους

Ποιες από τις παρακάτω προτάσεις είναι
σωστές και ποιες λάθος;
1. Η κωδικοποίηση των αλγορίθμων είναι
    ένα αλγοριθμικό κριτήριο.
2. Η περατότητα είναι ένας από τους τρόπους
   αναπαράστασης των αλγορίθμων.
3. Τα διαγράμματα ροής ολοκληρώνονται με
    έναν κύκλο.
4. Αν Χ πραγματική μεταβλητή, Α_Μ(Χ) <= Χ.
5. Αν Χ ακέραια μεταβλητή και Α_Τ(Χ) < > Χ,
    το περιεχόμενο της μεταβλητής είναι αρνητικό.


Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ


Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1.  _____ Ή Χ = Χ
2.  _____ ΚΑΙ Χ = Χ
3. _____ ΚΑΙ Χ = Ψευδής
4. _____ Ή Χ = Αληθής

Απαντήσεις

1. Ψευδής
2. Αληθής
3. Ψευδής
4. Αληθής

Κυριακή, 7 Σεπτεμβρίου 2014

Ποιο είναι πιο γρήγορο;

Δίνονται τα παρακάτω ισοδύναμα τμήματα εντολών:

Τμήμα Α

     Αν  Χ < 100 τότε
         Εμφάνισε Χ
     αλλιώς_αν Χ < 200 τότε
         Εμφάνισε Χ+1
     αλλιώς_αν Χ < 300 τότε
         Εμφάνισε Χ+2
     αλλιώς
         Εμφάνισε Χ+3
     Τέλος_αν

Τμήμα Β

     Αν  Χ < 100 τότε
         Εμφάνισε Χ
     αλλιώς
          Αν Χ < 200 τότε
                Εμφάνισε Χ+1
          αλλιώς
               Αν Χ < 300 τότε
                   Εμφάνισε Χ+2
               αλλιώς
                   Εμφάνισε Χ+3
               Τέλος_αν
           Τέλος_αν
      Τέλος_αν

   Τμήμα Γ

     Αν  Χ < 100 τότε
         Εμφάνισε Χ
     Τέλος_αν
     Αν (Χ >= 100) ΚΑΙ (Χ < 200) τότε
          Εμφάνισε Χ+1
     Τέλος_αν
     Αν (Χ >= 200) ΚΑΙ (Χ < 300) τότε
           Εμφάνισε Χ+2
     Τέλος_αν
     Αν  Χ >= 300 τότε
            Εμφάνισε Χ+3
     Τέλος_αν

Ποιο είναι γρηγορότερο και γιατί;

Απάντηση

Το πιο αργό από τα τρία είναι το τμήμα Γ, αφού κατά
την εκτέλεσή του θα πραγματοποιηθούν και οι τέσσερις
έλεγχοι (κάθε Αν..τότε είναι ανεξάρτητη από τις άλλες).
Τα τμήματα Α και Β έχουν την ίδια ακριβώς ταχύτητα
εκτέλεσης η οποία και είναι η μεγαλύτερη δυνατή για
τη συγκεκριμένη υπολογιστική διαδικασία (μόλις
αποτιμηθεί μια συνθήκη ως Αληθής εκτελείται η
αντίστοιχη Εμφάνισε και η αλληλουχία εντολών
ολοκληρώνεται επί τόπου).





Πέμπτη, 4 Σεπτεμβρίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 10 μέχρι 28 με_βήμα 19
         Για λ από 5 μέχρι 12 με_βήμα 8
              Για μ από 12 μέχρι 36 με_βήμα 45
                   Για ν από 32 μέχρι 40 με_βήμα 8
                        Εμφάνισε κ+λ+μ-ν
                   Τέλος_επανάληψης
              Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης

Απάντηση

Η πρώτη Για εκτελείται μόνο για κ = 10, η δεύτερη μόνο
για λ = 5, η τρίτη μόνο για μ = 12 και η τέταρτη για ν = 32
και ν = 40. Αφού 10+5+12-32 = -5 και 10+5+12-40 = -13,
στη μονάδα εξόδου θα εμφανιστούν οι τιμές:
      -5
      -13

Δώστε την εκφώνηση

Ποιά είναι η εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος;
    Αλγόριθμος Ασκ
    Δεδομένα // Ν //
    Για κ από 1 μέχρι Ν
        Αρχή_επανάληψης
             Διάβασε Χ
        Μέχρις_ότου Χ > 99
        Εμφάνισε Χ mod 10
    Τέλος_επανάληψης
    Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που διαβάζει Ν (θεωρήστε το
ως δεδομένο) ακέραιους αριθμούς μεγαλύτερους
του 99 και εμφανίζει το τελευταίο ψηφίο του καθενός.
Ο αλγόριθμος πρέπει να διασφαλίζει την εγκυρότητα
των εισερχόμενων δεδομένων.

Τετάρτη, 27 Αυγούστου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
    Για κ από 2 μέχρι 38 με_βήμα 2
          Αν mod 4 = 0) KAI mod 3 = 0) τότε
              Εμφάνισε κ
          Τέλος_αν
    Τέλος_επανάληψης 

Απάντηση

Το παραπάνω σύνολο εντολών εμφανίζει όλους τους ζυγούς
ακέραιους αριθμούς στο διάστημα [2, 38] που είναι πολλαπλάσια
τόσο του 4 όσο και του 3. Κατά συνέπεια η έξοδος των εντολών
είναι:
        12
        24
        36

Σάββατο, 23 Αυγούστου 2014

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω
σύνολο εντολών

  Για κ από (7 mod 8) μέχρι (11 div 12) με βήμα -1
     Διάβασε Χ
     Αν Χ < 15 τότε
         Εμφάνισε Α_Τ(15-Χ)+4
     αλλιώς_αν Χ > 15 τότε
         Εμφάνισε Α_Τ(15-Χ)+15
     αλλιώς
         Εμφάνισε Χ*20
     Τέλος_αν
  Τέλος_επανάληψης

Απάντηση

   Για κ από μέχρι με βήμα -1
     Διάβασε Χ
     Αν Χ < 15 τότε
         Εμφάνισε 19-Χ
     αλλιώς_αν Χ > 15 τότε
         Εμφάνισε Χ
     αλλιώς
         Εμφάνισε 300
     Τέλος_αν
  Τέλος_επανάληψης

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια κριτήρια παραβιάζει ο
ακόλουθος υποτιθέμενος αλγόριθμος;
   Αλγόριθμος  Ασκ
   Διάβασε Χ
   Όσο (Χ > 0) Ή (Χ <=0) επανάλαβε
        Εμφάνισε 3/(Χ-4)
        Διάβασε Χ
   Τέλος_επανάληψης
   Τέλος Ασκ

Απαντήσεις

Παραβιάζεται η :
α) περατότητα γιατί η συνθήκη της Όσο..επανάλαβε
    είναι πάντοτε αληθής και η επανάληψη δεν
    τερματίζεται ποτέ, και
β) καθοριστικήτητα, γιατί αν Χ = 4 η εντολή
    Εμφάνισε δεν μπορεί να εκτελεστεί.

Πίνακας αλήθειας

Αν Κ, Λ, Μ, Ν λογικές μεταβλητές, να κατασκευάσετε
τον πίνακα αλήθειας της λογικής παράστασης
    ΟΧΙ Κ Ή (Λ ΚΑΙ ΟΧΙ Μ)

Απάντηση

Ας συμβολίσουμε με Α την τιμή Αληθής και 
Ψ την τιμή ψευδής.
Αν Σ1 = Λ ΚΑΙ ΟΧΙ Μ και
Σ = ΟΧΙ Κ Ή (Λ ΚΑΙ ΟΧΙ Μ) = ΟΧΙ Κ Ή Σ1 
έχουμε:

Κ      Λ   Μ     Ν        ΟΧΙ Κ   ΟΧΙ Μ        Σ1    Σ
Α     Α   Α    Α       Ψ            Ψ        Ψ     Ψ
Α     Α   Α    Ψ       Ψ            Ψ        Ψ     Ψ
Α     Α   Ψ    Α       Ψ            Α        Α      Α
Α     Α   Ψ    Ψ       Ψ            Α        Α      Α
Α     Ψ   Α    Α       Ψ            Ψ        Ψ      Ψ
Α     Ψ   Α    Ψ       Ψ            Ψ        Ψ      Ψ
Α     Ψ   Ψ    Α       Ψ            Α        Ψ      Ψ
Α     Ψ   Ψ    Ψ       Ψ            Α        Ψ      Ψ
Ψ     Α   Α    Α        Α            Ψ       Ψ      Α
Ψ     Α   Α    Ψ        Α            Ψ       Ψ      Α
Ψ     Α   Ψ    Α        Α            Α       Α       Α
Ψ     Α   Ψ    Ψ        Α           Α        Α       Α
Ψ     Ψ   Α    Α        Α           Ψ        Ψ       Α
Ψ     Ψ   Α    Ψ        Α           Ψ        Ψ       Α
Ψ     Ψ   Ψ    Α        Α           Α         Ψ      Α
Ψ     Ψ   Ψ    Ψ        Α           Α         Ψ      Α

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Ο αλγόριθμος του πολλαπλασιασμού αλά ρωσικά
    πραγματοποιεί προκαθορισμένο πλήθος
    επαναλήψεων.
2. Κάθε πρόγραμμα δεσμεύει συγκεκριμένο χώρο
    της δευτερεύουσας μνήμης του υπολογιστή.
3. Δεν επιτρέπεται να εκχωρήσουμε μια τιμή σε
    μια συμβολική σταθερά.
4. ΟΧΙ (Χ ΚΑΙ Υ) = ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ
5. Αληθής Ή (Κ <= Λ) = Αληθής


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Σ



Σάββατο, 9 Αυγούστου 2014

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Οι σταθερές είναι ονόματα που αντιπροσωπεύουν
    σταθερές τιμές.
2. Όταν το Χ δεν είναι πολλαπλάσιο του 7 ισχύει η
    σχέση Χ mod 7 = 1
3.  (2*M+4*K) div 2 = 0
4. Η συνάρτηση Α_Μ(Χ) υπολογίζει την απόλυτη
    τιμή του Χ.


Απαντήσεις

1. Οι συμβολικές σταθερές είναι ονόματα που αντιπροσωπεύουν
    σταθερές τιμές.
2. Όταν το Χ δεν είναι πολλαπλάσιο του 7 ισχύει η
    σχέση Χ mod 7 < > 0
3.  (2*M+4*K) mod 2 = 0
4. Η συνάρτηση Α_Τ(Χ) υπολογίζει την απόλυτη
    τιμή του Χ.


Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η διαδικασία μπορεί να επιτελέσει οποιαδήποτε
    _________.
2. Η τοποθέτηση των κόμβων μιας δομής δεδομένων
    κατά αύξουσα ή φθίνουσα σειρά αποκαλείται _______.
3. Η ______ σχεδίαση είναι μια μεθοδολογία
    διάσπασης ενός προβλήματος σε υποπροβλήματα.
4. Τα ________ προβλήματα επιλύονται μέσα από
    μια αυτοματοποιημένη διαδικασία.


Απαντήσεις

1. λειτουργία
2. ταξινόμηση
3. ιεραρχική
4. δομημένα

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Ένα πρόβλημα
    Α. μπορεί να έχει προφανή λύση
    Β. μπορεί να επιδέχεται μία ή περισσότερες λύσεις
    Γ. επιλύεται μόνο με τη βοήθεια του ηλεκτρονικού
        υπολογιστή
    Δ. επιλύεται μόνο με τη βοήθεια του ανθρώπινου
        εγκεφάλου

2. Μια συνάρτηση
    Α. γράφεται σε ψευδογλώσσα
    Β. δεν έχει δικό της τμήμα δήλωσης συμβολικών
        σταθερών
    Γ. είναι ιδανική για την είσοδο δεδομένων
        σ' ένα πρόγραμμα
    Δ. έχει το δικό της σύνολο εντολών

3. Ο πίνακας
    Α. είναι μια δυναμική δομή δεδομένων
    Β. είναι μια μορφή αρχείου
    Γ. περιέχει δεδομένα διαφορετικών τύπων
    Δ. έχει αποθηκευμένα τα στοιχεία του σε
        συνεχόμενες θέσεις της κύριας μνήμης
        του υπολογιστή

4. Ο αλγόριθμος
    Α. έχει άπειρο πλήθος βημάτων
    Β. γράφεται σε ΓΛΩΣΣΑ
    Γ. μπορεί να μην εμπεριέχει καμιά μεταβλητή
    Δ. μπορεί να μην εξάγει κανένα αποτέλεσμα

Απαντήσεις

1. Β
2. Δ
3. Δ
4. Γ

Τρίτη, 29 Ιουλίου 2014

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Δεν υπάρχει ανώτατο όριο στο πλήθος των
    μεταβλητών ενός αλγορίθμου.
2. Μια σταθερά είναι ένα συγκεκριμένο κείμενο
    ή μια αριθμητική τιμή.
3. Η λογική πράξη ΚΑΙ μπορεί να έχει ως τελεστέο
    της μια σύγκριση ανάμεσα σε αριθμητικά δεδομένα.
4. Η μνήμη που καταλαμβάνουν οι πίνακες είναι
    απειροελάχιστη σε σχέση με το χώρο που κατα-
    λαμβάνουν οι υπόλοιπες μεταβλητές.
5. ΟΧΙ(ΟΧΙ(ΟΧΙ(ΟΧΙ(Χ)))) = Χ, όπου Χ λογική
    μεταβλητή.

Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Λ
5. Σ

Συγγραφή διαδικασίας

Γράψτε διαδικασία που εμφανίζει όλους τους
συνδυασμούς τιμών των Χ,Υ, Ζ στο ακέραιο
διάστημα [-90, 90] που ικανοποιούν τη σχέση
    Χ + Υ = Ζ

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΕΞΙΣ
ΜΕΤΑΒΛΗΤΕΣ
       ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ
ΑΡΧΗ
      ΓΙΑ Χ ΑΠΟ -90 ΜΕΧΡΙ 90
           ΓΙΑ Υ ΑΠΟ -90 ΜΕΧΡΙ 90
               ΓΙΑ Ζ ΑΠΟ -90 ΜΕΧΡΙ 90
                      ΑΝ Χ+Υ = Ζ ΤΟΤΕ
                          ΓΡΑΨΕ Χ, Υ, Ζ
                      ΤΕΛΟΣ_ΑΝ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ 

Σάββατο, 19 Ιουλίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Η  επεξεργασία των δεδομένων
    Α. είναι ένας μηχανισμός παραγωγής πληροφοριών.
    Β. δεν μπορεί να πραγματοποιηθεί με τη βοήθεια
         του ηλεκτρονικού υπολογιστή.
    Γ. γίνεται αποκλειστικά από τον ανθρώπινο εγκέφαλο
    Δ. δίνει πάντοτε ένα αριθμητικό αποτέλεσμα

2. Ο αλγόριθμος
    Α. γράφεται σε γλώσσα προγραμματισμού
    Β. γράφεται σε ψευδογλώσσα
    Γ. δεν μπορεί να αναπαρασταθεί διαγραμματικά
    Δ. ονομάζεται και υποπρόγραμμα

3. Οι πίνακες
    Α. είναι δυναμικές δομές δεδομένων
    Β. αποθηκεύονται στην δευτερεύουσα μνήμη
    Γ. καταλαμβάνουν συνεχόμενες θέσεις της
        κύριας μνήμης
    Δ. επεκτείνουν τις δυνατότητες του προγραμματιστή

4. Ένα υποπρόγραμμα
    Α. μπορεί να μην έχει είσοδο
    Β. μπορεί να μην έχει έξοδο
    Γ. έχει μεγάλη εξάρτηση από το κύριο πρόγραμμα
    Δ. εκτελεί αυτόνομο έργο

Απαντήσεις

1. Α
2. Β
3. Γ
4. Δ



Πέμπτη, 17 Ιουλίου 2014

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει 20 πραγματικές
τιμές και εμφανίζει το ακέραιο μέρος τους.

Λύση

Αλγόριθμος Ασκ
Για κ από 1 μέχρι 20
     Διάβασε Χ
     Εμφάνισε Α_Μ(Χ)
Τέλος_επανάληψης
Τέλος Ασκ

Διόρθωση λανθασμένων προτάσεων και επαναδιατύπωσή τους

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Οι πληροφορίες γίνονται αντιληπτές από έναν
    εξωτερικό παρατηρητή με μία από τις πέντε
    ανθρώπινες αισθήσεις.
2. Η αντιμετάθεση είναι μια από τις βασικές λειτουργίες
    του υπολογιστή με τη βοήθεια της οποίας γίνονται
    οι λογικές πράξεις.
3. Η κωδικοποίηση ενός αλγορίθμου γίνεται με
    φυσική γλώσσα κατά βήματα.
4. Αλγόριθμοι+Προγράμματα = Επεξεργασία
5. Η τιμή 'ΑΛΗΘΗΣ' είναι μια λογική σταθερά.


Απαντήσεις

1. Τα δεδομένα γίνονται αντιληπτά από έναν
    εξωτερικό παρατηρητή με μία από τις πέντε
    ανθρώπινες αισθήσεις.
2. Η σύγκριση είναι μια από τις βασικές λειτουργίες
    του υπολογιστή με τη βοήθεια της οποίας γίνονται
    οι λογικές πράξεις.
3.  Η κωδικοποίηση ενός αλγορίθμου γίνεται σε 
     ψευδογλώσσα.
4.  Αλγόριθμοι+Δομές δεδομένων = Προγράμματα
5.  Η τιμή ΑΛΗΘΗΣ είναι μια λογική σταθερά.


Τετάρτη, 16 Ιουλίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μια δομή επανάληψης ελέγχεται από μια _______
    συνθήκη.
2. Τα σχόλια σε ένα πρόγραμμα είναι μη _______.
3. Μια σειρά ενεργειών που δεν τερματίζεται ποτέ
    ονομάζεται _________ διαδικασία.
4. Οι πίνακες _______ τις δυνατότητες των προγραμματιστών.
5. Μια παράμετρος είναι μια ειδική μορφή ________.

Απαντήσεις

1. συνθήκη
2. εκτελέσιμα
3. υπολογιστική
4. περιορίζουν
5. μεταβλητής


Ερωτήσεις σωστού λάθους

Ποιες από τις ερωτήσεις είναι σωστές και ποιες
λάθος;
1. Οι πράξεις div και mod εφαρμόζονται μόνο
    πάνω σε ακέραιους τελεστέους.
2. Ο τμηματικός προγραμματισμός στηρίζεται
    στην εκτεταμένη χρήση της εντολής GOTO.
3. Το πρόβλημα του έτους 2000 είχε να κάνει
    με τον τρόπο αποθήκευσης της ημερομηνίας
    στους παλιούς υπολογιστές.
4. Οι διαγραμματικές τεχνικές εμφανίζονται
    ολοένα και σπανιότερα στη βιβλιογραφία.
5. Οι κόμβοι μιας δυναμικής δομής δεδομένων
    καταλαμβάνουν συνεχόμενες θέσεις στην
   κύρια μνήμη.



Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ




Τρίτη, 15 Ιουλίου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία διαβάζει 120 πραγματικές
τιμές και τις καταχωρεί στον πραγματικό πίνακα
Α[3, 4, 10].

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΔιαβΠιν(Α)
ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Κ, Λ, Μ
        ΠΡΑΓΜΑΤΙΚΕΣ: Α[3, 4, 10]
ΑΡΧΗ
        ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
             ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                  ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                         ΔΙΑΒΑΣΕ Α[Κ, Λ, Μ]
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει 35 ακέραιους αριθμούς
και εμφανίζει το τετράγωνο και την τετραγωνική τους ρίζα
(εφόσον είναι εφικτό).

Λύση

Αλγόριθμος Επεξ
Για κ από 1 μέχρι 35
     Διάβασε Χ
     Εμφάνισε Χ^2
     Αν Χ >= 0 τότε
         Εμφάνισε Τ_Ρ(Χ)
     αλλιώς
         Εμφάνισε 'Δεν ορίζεται τετραγωνική ρίζα για το ', Χ
     Τέλος_αν
Τέλος_επανάληψης
Τέλος  Επεξ

Συγγραφή διαδικασίας

Γράψτε διαδικασία που διαβάζει μια ακολουθία
ακεραίων αριθμών (η είσοδος τερματίζεται μόλις
δοθεί η τιμή 0) και εμφανίζει το τελευταίο ψηφίο
του καθενός.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΨΗΦΙΟ
ΜΕΤΑΒΛΗΤΕΣ
       ΑΚΕΡΑΙΕΣ: Ν
ΑΡΧΗ
       ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΔΙΑΒΑΣΕ Ν
              ΑΝ Ν < > 0 ΤΟΤΕ
                   ΓΡΑΨΕ Ν MOD 10
              ΤΕΛΟΣ_ΑΝ
       ΜΕΧΡΙΣ_ΟΤΟΥ Ν = 0
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Σάββατο, 28 Ιουνίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών
    Για κ από 100 μέχρι 150 με_βήμα 70
        Για λ από 140 μέχρι 100 με_βήμα -80
             Εμφάνισε κ+λ
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    Εμφάνισε κ+λ

Απαντήσεις

Η εξωτερική Για πραγματοποιεί μία μόνο επανάληψη (κ = 100)
και ολοκληρώνεται με κ = 170.
Η εσωτερική  Για πραγματοποιεί μία μόνο επανάληψη (λ = 140)
και ολοκληρώνεται με λ = 60.
Κατά συνέπεια:
* αφού κ+λ = 100+140 = 240, η εσωτερική Εμφάνισε 
   τυπώνει:    240
* αφού κ+λ = 170+60 = 230, η εξωτερική Εμφάνισε
   τυπώνει : 230

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις
με σωστό τρόπο
1. Το αποτέλεσμα μιας επεξεργασίας πληροφοριών
    ονομάζεται δεδομένο.
2. Η περιεχόμενη ομάδα εντολών σε μια Όσο..επανάλαβε
    εκτελείται τουλάχιστον μια φορά.
3. Η εισαγωγή και η συγχώνευση είναι οι δύο λειτουργίες
    που δεν μπορούν να γίνουν σ' ένα πίνακα.
4. Μια διαδικασία ενεργοποιείται με την εντολή
    ΚΑΛΕΣΕ_ΔΙΑΔΙΚΑΣΙΑ.
5. Ένας δυσδιάστατος πίνακας έχει τουλάχιστον
    δύο στοιχεία.





Απαντήσεις

1. Το αποτέλεσμα μιας επεξεργασίας δεδομένων
    ονομάζεται πληροφορία.
2. Η περιεχόμενη ομάδα εντολών σε μια Μέχρις_ότου
    εκτελείται τουλάχιστον μια φορά.
3. Η εισαγωγή και η διαγραφή είναι οι δύο λειτουργίες
    που δεν μπορούν να γίνουν σ' ένα πίνακα.
4. Μια διαδικασία ενεργοποιείται με την εντολή
    ΚΑΛΕΣΕ.
5. Ένας δυσδιάστατος πίνακας έχει τουλάχιστον
    τέσσερα στοιχεία.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Ένα ημιδομημένο πρόβλημα
    Α. μπορεί να είναι και ανοιχτό
    Β. δεν έχει καθόλου δομή
    Γ. αποκλείεται να είναι άλυτο
    Δ. τίποτα από τα παραπάνω

2. Ο τελεστής *
    Α. είναι ο αριθμητικός τελεστής με τη μεγαλύτερη
         προτεραιότητα
    Β. αντιστοιχεί στην πράξη της διαίρεσης
    Γ. είναι ο συγκριτικός τελεστής με τη μικρότερη
        προτεραιότητα
    Δ. τίποτα από τα παραπάνω

3. Η εντολή ΔΙΑΒΑΣΕ
    Α. μπλοκάρει την εκτέλεση του προγράμματος
         μέχρι να δοθεί μια τιμή εισόδου από το πληκτρολόγιο
    Β. μπλοκάρει την εκτέλεση του προγράμματος
         μέχρι να δοθούν τιμές εισόδου από την οθόνη
    Γ. χρησιμοποιείται συχνά μέσα στο σύνολο εντολών
        μιας συνάρτησης.
    Δ. μπορεί να αλλάξει το περιεχόμενο μιας μεταβλητής

4. Μια δυναμική δομή δεδομένων
    Α. έχει μεταβλητό πλήθος κόμβων
    Β. δεσμεύει προκαθορισμένο χώρο στη μνήμη
    Γ. έχει πάντοτε το ίδιο πλήθος κόμβων σ' όλη
        τη διάρκεια εκτέλεσης ενός προγράμματος.
    Δ. τίποτα από τα παραπάνω

Απαντήσεις

1. Γ
2. Δ
3. Δ
4. Α

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν στις παρακάτω
προτάσεις.
1. Ο _________ προγραμματισμός είναι μια τεχνική
    σχεδίασης προγραμμάτων που στηρίζεται στη
    χρήση υποπρογραμμάτων.
2. Οι γλώσσες ________ επιπέδου απαιτούν τη
    χρήση συμβολομεταφραστή για την εκτέλεση
    των προγραμμάτων τους.
3. Οι πίνακες είναι στατικές ________ δεδομένων.
4. Η δομή ακολουθίας είναι μια ________ συνιστώσα.
5. Η ________ σχεδίαση είναι μια τεχνική ανάλυσης του
    προβλήματος σε υποπροβλήματα, από πάνω προς τα κάτω.

Απαντήσεις

1. τμηματικός
2. χαμηλού
3. δομές
4. αλγοριθμική
5. ιεραρχική


Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Τα αδόμητα προβλήματα έχουν ακαθόριστο χώρο.
2. Τα σχόλια σ'  ένα πρόγραμμα είναι εκτελέσιμα.
3.  Δεν μπορούμε να εκτελέσουμε την πράξη div
     ανάμεσα σε τελεστέους πραγματικού τύπου.
4. Αν ο πίνακας Α[30] είναι αλφαριθμητικού τύπου,
    η εντολή  Διάβασε Α εισάγει 30 κείμενα μέσα στον
    πίνακα αυτό.
5. Τα υποπρογράμματα έχουν το δικό τους τμήμα
     δήλωσης μεταβλητών και συμβολικών σταθερών.
 


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Σ



Σάββατο, 7 Ιουνίου 2014

Λύσεις Πανελληνίων Εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2014




Θέματα Πανελληνίων εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2014




Θέματα Πανελληνίων Εξετάσεων Γ' τάξης Ημερήσιου Γενικού Λυκείου 2014





































































































Παρασκευή, 6 Ιουνίου 2014

Σχολιασμός των θεμάτων στο μάθημα της Ανάπτυξης Εφαρμογών σε Προγραμματιστικό Περιβάλλον της Γ’ Τάξης Ημερήσιου Γενικού Λυκείου 2014


Σχολιασμός των θεμάτων στο μάθημα της
Ανάπτυξης Εφαρμογών σε Προγραμματιστικό Περιβάλλον
της Γ’ Τάξης Ημερήσιου Γενικού Λυκείου 2014

Σε γενικές γραμμές τα  θέματα ήταν βατά χωρίς κάποια ιδιαίτερη δυσκολία.  Πιο συγκεκριμένα:
ΘΕΜΑ Α
Οι ερωτήσεις ανάπτυξης ήταν 12 μονάδες, ανισομερώς ωστόσο κατανεμημένες (6 μονάδες από το κεφάλαιο 6 και 6 μονάδες από το κεφάλαιο 8). Στο ζήτημα Α1-2 υπάρχει ένα μικρό προβληματάκι ως προς την προτεινόμενη λύση (Σωστό) αφού κάλλιστα θα μπορούσε ένας υποψήφιος να απαντήσει Λάθος, στηριζόμενος στο γεγονός ότι η ταξινόμηση έχει ως κύριο στόχο της την παρουσίαση κάποιων αποτελεσμάτων κατά φθίνουσα ή αύξουσα σειρά, χωρίς να είναι απαραίτητο ότι θα  ακολουθήσει η λειτουργία της αναζήτησης.

ΘΕΜΑ Β
Μόνο το ερώτημα Β1 θα μπορούσε να προβληματίσει κάποιο υποψήφιο, η αναλυτική ωστόσο περιγραφή της μεθόδου απλοποιεί αρκετά τα πράγματα. Από την άλλη μεριά, το λογικό διάγραμμα του ερωτήματος Β2 είναι εξαιρετικά απλό και κατά την κωδικοποίηση του σε ψευδογλώσσα μπορεί να χρησιμοποιηθεί είτε η εντολή Όσο..επανάλαβε είτε η Για..από..μέχρι.

ΘΕΜΑ Γ  
Μια κλασσική επεξεργασία τιμών εισόδου που ολοκληρώνεται μόλις δοθεί από τη μονάδα εισόδου τιμή-φρουρός. Το μοναδικό ερώτημα που μπορεί να προβληματίσει είναι το Γ4, αφού η αδυναμία χρήσης πίνακα απαιτεί μια πολύ προσεκτική προσέγγιση για  την εύρεση και άθροιση όλων των τεμαχίων με τη μέγιστη τιμή τεμαχίου.    

ΘΕΜΑ Δ

Το ενδιαφέρον εδώ είναι ότι πρώτη φορά μετά από τόσα χρόνια που εξετάζεται το μάθημα πανελλαδικά, παρέχεται η δυνατότητα στον υποψήφιο να χρησιμοποιήσει τρισδιάστατο πίνακα για την επίτευξη της λύσης. Το θέμα βεβαίως μπορεί να λυθεί εναλλακτικά και με δυσδιάστατο πίνακα. Τα ζητούμενα είναι όλα αναμενόμενα, με μικρό βαθμό δυσκολίας ενώ υπάρχει και η δυνατότητα διαφορετικών λύσεων στα επιμέρους ερωτήματα Δ3 και Δ4.

Λύσεις Θεμάτων Πανελλαδικών εξετάσεων Γ' Τάξης Ημερήσιων Γενικών Λυκείων 2014