Τετάρτη, 27 Αυγούστου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
    Για κ από 2 μέχρι 38 με_βήμα 2
          Αν mod 4 = 0) KAI mod 3 = 0) τότε
              Εμφάνισε κ
          Τέλος_αν
    Τέλος_επανάληψης 

Απάντηση

Το παραπάνω σύνολο εντολών εμφανίζει όλους τους ζυγούς
ακέραιους αριθμούς στο διάστημα [2, 38] που είναι πολλαπλάσια
τόσο του 4 όσο και του 3. Κατά συνέπεια η έξοδος των εντολών
είναι:
        12
        24
        36

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου