Τετάρτη, 26 Νοεμβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το ελεύθερο κείμενο είναι ένας τρόπος αναπαράστασης
     του αλγόριθμου που κινδυνεύει να παραβιάσει το κριτήριο
     της _______.
2. Μια από τις σκοπιές εξέτασης των δεδομένων από την
    Πληροφορική είναι και αυτή του ________.
3. Οι τυπικές και οι _________ παράμετροι ενός υποπρογράμματος
    μπορεί να έχουν το ίδιο όνομα.
4. Μια σύγκριση δεδομένων αποτελεί μια _______ έκφραση.
5. Ο πίνακας Α[3,5,8] είναι _______________.

Απαντήσεις

1. αποτελεσματικότητας
2. υλικού
3. πραγματικές
4. λογική
5. τρισδιάστατος




Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τις λειτουργίες
επί των δομών δεδομένων
1. Η αναζήτηση είναι το αντίστροφο της ταξινόμησης.
2. Η συγχώνευση είναι το αντίστροφο του διαχωρισμού.
3. Η ίδια λειτουργία μπορεί να εκτελείται γρηγορότερα
    σε μια δομή δεδομένων από ότι σε μια άλλη.
4. Οι μοναδικές λειτουργίες που δεν μπορούν να γίνουν
    σ' ένα πίνακα είναι η εισαγωγή και η διαγραφή.
5. Η ταξινόμηση μας επιτρέπει να εντοπίσουμε ένα ή
    περισσότερους κόμβους που ικανοποιούν κάποιους
    συγκεκριμένους περιορισμούς.
6. Η προσπέλαση είναι μια λειτουργία που σπάνια
    χρησιμοποιείται στις δομές δεδομένων.
   

Απαντήσεις

2, 3, 4

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Ο μεταγλωττιστής είναι απαραίτητος για τη μετάφραση ενός
    προγράμματος σε γλώσσα μηχανής.
2. Το λογικό διάγραμμα είναι ένας γραφικός τρόπος αναπαράστασης
    ενός αλγορίθμου.
3. Ο δομημένος προγραμματισμός στηρίζεται στη χρήση των δομών
    ακολουθίας, επιλογής και επανάληψης.
4. Τα λογικά λάθη σ' ένα πρόγραμμα εντοπίζονται ευκολότερα από
     τα συντακτικά.
5. Η γλώσσα COBOL είναι 4ης γενιάς.

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Λ




Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
χρησιμοποιώντας μια μόνο Μέχρις_ότου
και μια εντολή Εμφάνισε

     Για κ από 12 μέχρι 19 με_βήμα 9
          Για λ από 22 μέχρι 13 με_βήμα -15
              Για μ από 2 μέχρι 170 με_βήμα 200
                  Για ρ από 45 μέχρι 17 με_βήμα -50
                          Εμφάνισε (λ*κ+ρ)^μ
                  Τέλος_επανάληψης
              Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση
   
      Για κ από 12 μέχρι 19 με_βήμα 9
            Εμφάνισε (22*κ+45)^2
      Τέλος_επανάληψης
    

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών με ισοδύναμο
τρόπο αντικαθιστώντας τις εμφωλευμένες δομές επιλογής
με μια Αν..τότε. 
Περιορισμός : Ο μοναδικός λογικός τελεστής που μπορείτε
να χρησιμοποιήσετε είναι ο ΚΑΙ
           Αν Α > 10 τότε
               Αν (Β < 5) Ή (Β = 5) τότε
                    Αν Α_Τ(Γ) < Γ τότε
                         Εμφάνισε Α, Β, Γ
                    αλλιώς
                         Αν ΟΧΙ (Γ mod 6 = 2) τότε
                                Εμφάνισε Α+Β+Γ
                         Τέλος_αν
                    Τέλος_αν
               Τέλος_αν
           Τέλος_αν

Απάντηση
Ξέρουμε ότι Α_Τ(Γ) <= Γ για κάθε τιμή του Γ, κατά συνέπεια
η εντολή  Εμφάνισε Α, Β, Γ δεν εκτελείται ποτέ. Έτσι έχουμε:

 Αν (Α > 10) ΚΑΙ (Β <= 5) ΚΑΙ (Γ mod 6 < > 2) τότε
            Εμφάνισε Α+Β+Γ                        
 Τέλος_αν



Παρασκευή, 21 Νοεμβρίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 10 μέχρι 20 με_βήμα 10
         Για λ από 30 μέχρι 10 με_βήμα -10
             Για μ από 20 μέχρι 25 με_βήμα 4
                  Εμφάνισε (κ+λ) div 4 + μ
             Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

κ = 10
     λ = 30
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+30) div 4 + 20 =
                          40 div 4 + 20 = 10+20 = 30
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+30) div 4 + 24 =
                          40 div 4 + 24 = 10+24 = 34
     λ = 20
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+20) div 4 + 20 =
                          30 div 4 + 20 = 7+20 = 27
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+20) div 4 + 24 =
                          30 div 4 + 24 = 7+24 = 31
     λ = 10
          μ = 20
                Αφού (κ+λ) div 4 + μ = (10+10) div 4 + 20 =
                         20 div 4 + 20 = 5+20 = 25
           μ = 24
                Αφού (κ+λ) div 4 + μ = (10+10) div 4 + 24 =
                          20 div 4 + 24 = 5+24 = 29
κ = 20
     λ = 30
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+30) div 4 + 20 =
                          50 div 4 + 20 = 12+20 = 32
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+30) div 4 + 24 =
                          50 div 4 + 24 = 12+24 = 36
     λ = 20
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+20) div 4 + 20 =
                          40 div 4 + 20 = 10+20 = 30
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+20) div 4 + 24 =
                          40 div 4 + 24 = 10+24 = 34
     λ = 10
          μ = 20
                Αφού (κ+λ) div 4 + μ = (20+10) div 4 + 20 =
                         30 div 4 + 20 = 7+20 = 27
           μ = 24
                Αφού (κ+λ) div 4 + μ = (20+10) div 4 + 24 =
                          30 div 4 + 24 = 7+24 = 31
   


   



Πέμπτη, 20 Νοεμβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Η ιδανική δομή επανάληψης για τη δημιουργία
    προγράμματος με μενού λειτουργιών είναι η
    α. Μέχρις_ότου
    β. Όσο..επανάλαβε
    γ. Για..από..μέχρι
    δ. Αν..τότε..αλλιώς_αν

2. Η ιδανική δομή επανάληψης για την επεξεργασία
    δοσμένου πλήθους δεδομένων είναι η :
    α. Μέχρις_ότου
    β. Όσο..επανάλαβε
    γ. Για..από..μέχρι
    δ. Αν..τότε..αλλιώς

3. Η ιδανική γλώσσα προγραμματισμού για τη 
    δημιουργία εφαρμογών τεχνητής νοημοσύνης
    είναι η :
    α. JAVA
    β. LISP
    γ. SQL
    δ. ALGOL

4. Ένα πρόβλημα
    α. μπορεί να μην έχει καθόλου δεδομένα
    β. μπορεί να μην έχει καθόλου ζητούμενα
    γ. μπορεί να έχει προφανή λύση
    δ. έχει ένα χώρο που πρέπει να καθοριστεί
        επακριβώς πριν επιχειρηθεί οποιαδήποτε
        προσπάθεια επίλυσής του.

Απαντήσεις

1. α
2. γ
3. β
4. δ



Σάββατο, 15 Νοεμβρίου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παραμέτρους
δύο ακέραιους αριθμούς Α, Β και εμφανίζει ένα
χαρακτηρισμό για τα πρόσημα τους.
Για παράδειγμα αν Α = 7, Β = -2 θα εμφανίζεται
το μήνυμα:
      Ο πρώτος είναι θετικός και ο δεύτερος αρνητικός
Για παράδειγμα αν Α = -17, Β = 0 θα εμφανίζεται
το μήνυμα:
      Ο πρώτος είναι αρνητικός και ο δεύτερος μηδέν

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΗΜΑ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
        ΑΝ Α > 0 ΤΟΤΕ
             ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι θετικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ_ΑΝ Α = 0 ΤΟΤΕ
             ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι μηδέν και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
              ΑΝ Β > 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι θετικός'
             ΑΛΛΙΩΣ_ΑΝ Β = 0 ΤΟΤΕ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι μηδέν'
             ΑΛΛΙΩΣ
                  ΓΡΑΨΕ 'Ο πρώτος είναι αρνητικός και'
                  ΓΡΑΨΕ 'ο δεύτερος είναι αρνητικός'
             ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρασκευή, 14 Νοεμβρίου 2014

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
     Για κ από 4 μέχρι 56 με_βήμα 60
          Για λ από 100 μέχρι 20 με_βήμα -90
               Διάβασε Χ
               Εμφάνισε (λ+Χ)^κ              
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Εμφάνισε κ+λ

Απάντηση
Η εξωτερική Για εκτελείται μία φορά, μόνο για κ = 4 και η
τελική τιμή του κ είναι 64.
Η εσωτερική Για εκτελείται μία φορά, μόνο για λ = 100 και η
τελική τιμή του λ είναι 10.
Κατά συνέπεια έχουμε:

       Διάβασε Χ
       Εμφάνισε (100+Χ)^4
       Εμφάνισε  74     ! 74 = 64+10

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις με σωστό
τρόπο
1. Η αρχική τιμή μιας ακέραιας μεταβλητής είναι μηδέν.
2. Μια δομή επιλογής αποκαλείται και βρόχος.
3. Η γλώσσα C++ είναι συναρτησιακή.
4. Στη διαγραμματική αναπαράστασης της ανάλυσης ενός
    προβλήματος, το μοναδικό γεωμετρικό σχήμα που μπορεί
    να χρησιμοποιηθεί είναι το τετράγωνο.





Απαντήσεις

1. Η αρχική τιμή μιας ακέραιας μεταβλητής είναι απροσδιόριστη.
2. Μια δομή επανάληψης αποκαλείται και βρόχος.
3. Η γλώσσα C++ είναι αντικειμενοστραφής.
4. Στη διαγραμματική αναπαράστασης της ανάλυσης ενός
    προβλήματος, το μοναδικό γεωμετρικό σχήμα που μπορεί
    να χρησιμοποιηθεί είναι το ορθογώνιο παραλληλόγραμμο.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση η περιεχόμενη ομάδα εντολών
εκτελείται
1. Όταν το βήμα σε μια Για..από..μέχρι είναι μηδενικό
    α.  άπειρες φορές
    β. 0 φορές
    γ. 0 ή άπειρες φορές
    δ. 1 φορά

2. Η ολίσθηση κατά μια θέση προκαλεί
    α. αύξηση του αριθμού
    β. μείωση του αριθμού
    γ. διπλασιασμό του αριθμού
    δ. διπλασιασμό ή υποδιπλασιασμό του αριθμού
   
3. Οι συμβολικές γλώσσες
    α. αποκαλούνται και γλώσσες 4ης γενιάς
    β. είναι στενά συνδεδεμένες με την αρχιτεκτονική
        του υπολογιστή
    γ. είναι πανίσχυρες γλώσσες προγραμματισμού
        γενικής χρήσης
    δ. εξασφαλίζουν τη δημιουργία μικρών και
        ευκολοσυντήρητων προγραμμάτων

4.  Η εντολή εκχώρησης
     α. είναι ένας από τους τρόπους με τους οποίους
         μπορεί να αλλάξει το περιεχόμενο μιας
         μεταβλητής
     β. παριστάνεται με το σύμβολο +=
     γ. μπορεί να χρησιμοποιηθεί για την αλλαγή του
        περιεχομένου μιας συμβολικής σταθεράς κατά
        τη διάρκεια εκτέλεσης του προγράμματος
     δ. χρησιμοποιείται σπάνια στους αλγορόθμους

Απαντήσεις

1. γ
2. δ
3. β
4. α



Τετάρτη, 12 Νοεμβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  (Χ > Υ) Ή (Χ = Υ) = Χ _____ Υ
2. (Χ < Υ) Ή (Χ > Υ) = Χ _____Υ
3. (Χ = 1) Ή (Χ = 2) Ή  (Χ = 3) Ή (Χ = 4)
                  = (Χ ___ 1) ____ (Χ ___ 4),
    όπου Χ ακέραια μεταβλητή

Απαντήσεις

1.  Χ >= Υ
2. Χ < > Υ
3. (Χ >= 1) ΚΑΙ (Χ <= 4)


Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Οι γλώσσες 3ης γενιάς έχουν υψηλή μεταφερσιμότητα.
2. Οι συμβολικές γλώσσες αποκαλούνται και γλώσσες
    υψηλού επιπέδου.
3. Η σημασιολογία στις τεχνητές γλώσσες καθορίζεται
    από το δημιουργό τους.
4. Η PASCAL είναι μια γλώσσα γενικής χρήσης.
5. Τα προγράμματα σε BASIC εκτελούνται με τη
    βοήθεια μεταγλωττιστή.


Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ