Σάββατο, 28 Δεκεμβρίου 2013

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τον αλγόριθμο;
1. Εκτελείται στον υπολογιστή.
2. Είναι γραμμένος σε μια γλώσσα προγραμματισμού.
3. Μπορεί να γραφεί σε ψευδογλώσσα.
4. Είναι ένας μηχανισμός παραγωγής πληροφοριών.
5. Επιλύει μόνο μαθηματικά προβλήματα.
6. Έχει αυστηρά καθορισμένες εντολές.
7. Οι εντολές του μπορεί να επαναλαμβάνονται για πάντα.
8. Ικανοποιεί τα κριτήρια της αποτελεσματικότητας και της
    εξόδου.

Απαντήσεις

3, 4, 6, 8

Πέμπτη, 26 Δεκεμβρίου 2013

Εκφώνηση προβλήματος

Δώστε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος
     Αλγόριθμος Ασκ
     Αρχή_επανάληψης
           Διάβασε Χ
           Αν Χ > 0 τότε
                Αν Χ mod 2 = 0 τότε
                      Εμφάνισε 'Ο', Χ ' είναι άρτιος'
                αλλιώς
                      Εμφάνισε 'Ο', Χ, 'είναι περιττός'
                Τέλος_αν                
           Τέλος_αν
     Μέχρις_ότου Χ <= 0
     Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που :
α) διαβάζει μια ακολουθία ακεραίων αριθμών
    (η είσοδος ολοκληρώνεται μόλις δοθεί μια
     μη θετική τιμή),
β) ελέγχει καθένα από αυτούς ως προς την
    αρτιότητα τους και εμφανίζει κατάλληλα
    ενημερωτικά μηνύματα.


Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η συγχώνευση είναι μια λειτουργία επί των δομών
    δεδομένων που αποτελεί το αντίστροφο του _______.
2. Ο _________ πίνακας έχει τουλάχιστον δύο γραμμές και
    τουλάχιστον δύο στήλες.
3. Τα στοιχεία ενός πίνακα καταλαμβάνουν ________
    θέσεις στην κύρια μνήμη του υπολογιστή.
4. Ο ______ είναι προσδιορίζει τη θέση ενός στοιχείου
    στον πίνακα.
5. Ένας δυσδιάστατος πίνακας μπορεί να θεωρηθεί ως
    μονοδιάστατος που τα στοιχεία του είναι ________
    πίνακες.


Απαντήσεις

1. διαχωρισμού
2. δυσδιάστατος
3. συνεχόμενες
4. δείκτης
5. μονοδιάστατοι



Παρασκευή, 20 Δεκεμβρίου 2013

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Κάθε αλγόριθμος υλοποιεί μια επεξεργασία δεδομένων.
2. Η ταξινόμηση μπορεί να γίνει είτε κατά αύξουσα είτε κατά
    φθίνουσα σειρά.
3. Η εντολή Για..από..μέχρι έχει πάντοτε βήμα μεταβολής
    θετικό ή μηδέν.
4. Το κριτήριο της καθοριστικότητας  παραβιάζεται όταν
    η εντολή δεν είναι απλή και άμεσα εκτελέσιμη.
5. Ο τμηματικός προγραμματισμός είναι μια μεθοδολογία
    δημιουργίας αλγορίθμων.

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ


Κυριακή, 15 Δεκεμβρίου 2013

Λογικό διάγραμμα

Διατυπώστε τον αλγόριθμο σε ψευδογλώσσα που αντιστοιχεί
στο παρακάτω διάγραμμα

































Λύση

Αλγόριθμος Ασκ
Για Κ από 1 μέχρι 20
    Για Λ από μέχρι 20
        Για Μ από μέχρι 20
             Εμφάνισε  Α[Κ], Α[Λ], Α[Μ]
        Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ



Συγγραφή διαδικασίας


Παρασκευή, 13 Δεκεμβρίου 2013

Ερωτήσεις πολλαπλής επιλογής

Κυκλώστε τη σωστή επιλογή

1. Το μέγιστο στοιχείο στον ταξινομημένο πίνακα
    Α[90] είναι:
    α. το Α[1]
    β. το Α[90]
    γ. το Α[45]
    δ. το Α[1] ή το Α[90]

2. Ένας τετραγωνικός πίνακας
    α. έχει τρεις κύριες διαγωνίους
    β. έχει περισσότερες γραμμές από στήλες
    γ. είναι πάντοτε αριθμητικού τύπου (ακέραιου
        ή πραγματικού)
    δ. έχει τόσες γραμμές όσες και στήλες 

3. Ο δυσδιάστατος πίνακας Α[11, 10]
    α. έχει δύο τουλάχιστον μέγιστα στοιχεία
    β.  έχει ένα τουλάχιστον ελάχιστο στοιχείο
    γ.  έχει 110 στοιχεία ίδιου τύπου
    δ. έχει  21 στοιχεία ίδιου τύπου

4. Ο πίνακας Α[11, 2, 3] είναι:
    α. τετραδιάστατος
    β. δυσδιάστατος, με βάθος 3
    γ. τρισδιάστατος 
    δ. μονοδιάστατος

5. Ο πίνακας :
    α. αποθηκεύει τα στοιχεία του σε συνεχόμενες
        θέσεις της δευτερεύουσας μνήμης
    β. είναι μια δυναμική δομή δεδομένων
    γ. είναι μια μορφή αρχείου
    δ. περιορίζει τις δυνατότητες του προγράμματος

Απαντήσεις

1. δ
2. δ
3. γ
4. γ
5. δ


Επαναδιατύπωση

Θεωρείστε τον ακέραιο πίνακα Α[345].
Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
    Για κ από 1 μέχρι 100 με_βήμα 200
         Για λ από 200 μέχρι 50 με_βήμα -190
              Για μ από 30 μέχρι 60 με_βήμα 40
                     Εμφάνισε Α[κ]*Α[λ]+Α[μ]
              Τέλος_επανάληψης
         Τέλος_επανάληψης
    Τέλος_επανάληψης
   

Απάντηση
Η πρώτη Για εκτελείται μόνο για κ = 1
Η δεύτερη Για εκτελείται μόνο για λ = 200
Η τρίτη Για εκτελείται μόνο για μ = 30.
Άρα όλο το σύνολο των εντολών μπορεί να αντικατασταθεί
από την εντολή :
    Εμφάνισε Α[1]*Α[200]+Α[30]

Πέμπτη, 5 Δεκεμβρίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω
προτάσεις.
1. Ο πίνακας Α[10, 20] έχει _______ στοιχεία.
2. Ο ακέραιος πίνακας Α[3, 4, 2] απαιτεί ____ bytes
    για την αποθήκευση του στην κύρια μνήμη RAM.
3. Αν ο πίνακας Α[200] είναι ταξινομημένος κατά
   φθίνουσα σειρά, το μεγαλύτερο στοιχείο είναι το
   ____.
4. Η συνάρτηση που ελέγχει αν μια αριθμητική τιμή
    είναι ακέραια είναι ________ τύπου.
5. Η  γλώσσα προγραμματισμού ______ είναι
    συναρτησιακή.

Απαντήσεις 

1. 200
2. 48
3. Α[1]
4. λογικού
5. LISP



Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η δυαδική αναζήτηση είναι ο λιγότερο αποδοτικός
   τρόπος αναζήτησης τιμής σε πίνακα.
2. Όταν το βήμα μεταβολής είναι 1 σε μια
    Για..από..μέχρι παραλείπεται.
3. Η μέθοδος ταξινόμησης που επιλέγουμε εξαρτάται
    και από την αρχική διάταξη των στοιχείων του
    πίνακα.
4. Τα στοιχεία ενός πίνακα συχνοτήτων είναι
    μετρητές ιδιότητας.
5. Στους εμφωλευμένους βρόχους, ο βρόχος που
    βρίσκεται εξωτερικά ολοκληρώνεται πρώτος.

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Σ
5. Λ