Πέμπτη, 26 Δεκεμβρίου 2013

Εκφώνηση προβλήματος

Δώστε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος
     Αλγόριθμος Ασκ
     Αρχή_επανάληψης
           Διάβασε Χ
           Αν Χ > 0 τότε
                Αν Χ mod 2 = 0 τότε
                      Εμφάνισε 'Ο', Χ ' είναι άρτιος'
                αλλιώς
                      Εμφάνισε 'Ο', Χ, 'είναι περιττός'
                Τέλος_αν                
           Τέλος_αν
     Μέχρις_ότου Χ <= 0
     Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που :
α) διαβάζει μια ακολουθία ακεραίων αριθμών
    (η είσοδος ολοκληρώνεται μόλις δοθεί μια
     μη θετική τιμή),
β) ελέγχει καθένα από αυτούς ως προς την
    αρτιότητα τους και εμφανίζει κατάλληλα
    ενημερωτικά μηνύματα.


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου