Πέμπτη, 30 Μαΐου 2013

Εκφωνήσεις Θεμάτων Πανελλαδικών Εξετάσεων Γ' Τάξης Ημερήσιου Γενικού Λυκείου 2013






Εκφωνήσεις Θεμάτων Πανελλαδικών Εξετάσεων Δ' Τάξης Εσπερινού Γενικού Λυκείου 2013





Σχολιασμός Θεμάτων Πανελλαδικών Εξετάσεων Δ' Τάξης Εσπερινού Λυκείου 2013

Τα θέματα ήταν πολύ βατά χωρίς κανένα ιδιαίτερο
επίπεδο δυσκολίας. Για τα ερωτήματα Α4-β και Β2
ισχύουν ότι έχω αναφέρει και στο σχολιασμό
των θεμάτων Γ' Τάξης του Ημερήσιου Γενικού Λυκείου
2013. Θα ήθελα να κάνω ωστόσο δύο μικρές επισημάνσεις:

1. Στο ΘΕΜΑ Γ παρατηρείται μια μικρή διαφοροποίηση
     ανάμεσα στο χαρακτηρισμό της επικινδυνότητας ως
     μέτρια, που υπάρχει στο αρχικό εισαγωγικό κείμενο,
     και στο ζητούμενο του ερωτήματος Γ2 όπου
     χαρακτηρίζεται ως Μεσαία.

2. Στο ΘΕΜΑ Δ υπάρχει μια λανθασμένη αναφορά στο
    ερώτημα Δ3. Αναφέρεται συγκεκριμένα :
    "Στην περίπτωση που η προκύπτουσα τιμή δεν είναι
    ακέραια, πραγματοποιείται αποκοπή δεκαδικών
    ψηφίων". Ο υποψήφιος μπορεί να υποθέσει (και πάλι)
    τι του ζητούν, ωστόσο η διατύπωση αυτή έχει πρόβλημα
    αφού ο πολλαπλασιασμός οποιασδήποτε τιμής με το
    1,3 δίνει αποτέλεσμα πραγματικού τύπου (κατά συνέπεια
    η προκύπτουσα τιμή δεν μπορεί να είναι ποτέ ακεραίου
    τύπου). Η σωστή διατύπωση θα ήταν:
    "Στην περίπτωση που η προκύπτουσα τιμή έχει
    δεκαδικά ψηφία να πραγματοποιείται αποκοπή των
    ψηφίων αυτών"

Λύσεις Θεμάτων Πανελλαδικών Εξετάσεων Δ' Τάξης Εσπερινού Γενικού Λυκείου 2013




Τετάρτη, 29 Μαΐου 2013

Σχολιασμός Θεμάτων Πανελλαδικών Εξετάσεων Γ' Τάξης Ημερήσιου Γενικού Λυκείου

Σε γενικές γραμμές τα θέματα ήταν βατά χωρίς κανένα ιδιαίτερο
επίπεδο δυσκολίας. Σε πολλές περιπτώσεις η λύση των
ερωτημάτων μπορούσε να προκύψει με διαφορετικούς
τρόπους (βλέπε σχετικό άρθρο). Θα ήθελα  να κάνω ωστόσο
κάποιες επισημάνσεις:
1. Στο ερώτημα Α4-β πρέπει ρητά να αναφέρεται ότι οι αριθμοί
    Α, Β είναι διαφορετικοί μεταξύ τους. Με το δοσμένο σύνολο
    εντολών, δεν υπάρχει πρόβλεψη για την περίπτωση που το
    Α = Β (σε αυτή την περίπτωση θα τυπωθεί απλά το Α που
    δεν είναι όμως ο μεγαλύτερος των 2 αριθμών και έτσι δεν
    επιτυγχάνεται το ζητούμενο της εκφώνησης)
2. Είναι από τις σπάνιες περιπτώσεις θεμάτων που απουσίαζε
    η αναλυτική βήμα προς βήμα εκτέλεση κάποιων δοσμένων
    εντολών. Ομολογουμένως αυτό αποτέλεσε έκπληξη για
    τους διαγωνιζόμενους.
3. Στο ερώτημα Β2, η αναφορά "....χωρίς τη χρήση αλγορίθμων
    ταξινόμησης" είναι παντελώς άστοχη και περιττή. Το σχολικό
    βιβλίο αναφέρει ρητά ότι οι μοναδικοί λογικοί τελεστές που
    μπορούν να εφαρμοστούν πάνω σε λογικά δεδομένα είναι το
    = και το < >. Κατά συνέπεια οι τιμές ΑΛΗΘΗΣ και ΨΕΥΔΗΣ
    δεν μπορούν να συγκριθούν μεταξύ τους και ο πίνακας Π
    ΔΕΝ ΜΠΟΡΕΙ ΝΑ ΤΑΞΙΝΟΜΗΘΕΙ ΕΤΣΙ ΚΙ ΑΛΛΙΩΣ!!!
 4. Και πάμε στο ερώτημα Γ4 όπου υπάρχει ένα σημαντικό
     πρόβλημα στη διατύπωση του. Αναφέρεται συγκεκριμένα :
     "........βαρύτητα θα έχει ο μέσος όρος, ο οποίος θα βρίσκεται σε 
      μεγαλύτερη περιοχή τιμών". Εδώ υπάρχει ζήτημα : τι ορίζεται
      ως μεγαλύτερη περιοχή τιμών; Παίρνοντας κατά λέξη την
      εκφώνηση θα πρέπει ο υποψήφιος να συγκρίνει το ΜΟ[Κ, 1]
      (ΜΟ SAR κεφαλής) με το ΜΟ[Κ, 2] (ΜΟ SAR άκρου)
       να ελέγξει σε ποια περιοχή τιμών ανήκει ο κάθε μέσος όρος
       και να εμφανίσει ανάλογο μήνυμα.
       Προσέξτε τώρα:
             Αν ΜΟ[Κ, 1]  = 2.7 και ΜΟ[Κ, 2] = 3.7 κανονικά πρέπει
             να εμφανιστεί το μήνυμα 'Κοντά στα όρια'
       Αν η επιτροπή ήθελε να υπερισχύσει σε ένα τέτοιο σενάριο
       η εμφάνιση του μηνύματος 'Εκτός ορίων' θα έπρεπε να
       βάλει ένα επιπλέον κριτήριο : το βαθμό σπουδαιότητας 
       της περιοχής τιμών του κάθε μέσου όρου. Νομίζω ότι αν
       το ερώτημα διορθωθεί με τη λογική "μα αυτό εννοείται..."
       υπάρχει μείζων θέμα για την αντικειμενική βαθμολόγηση
       των υποψηφίων.
      

Λύσεις Πανελλαδικών εξετάσεων Γ' Τάξης Ημερήσιου Γενικού Λυκείου 2013















































































Κυριακή, 26 Μαΐου 2013

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τους αριθμητικούς
τελεστές
1. χρησιμοποιούνται για τη δημιουργία αριθμητικών
    παραστάσεων
2. έχουν μικρότερη προτεραιότητα από τους λογικούς
    τελεστές
3. έχουν μεγαλύτερη προτεραιότητα από τους συγκριτικούς
    τελεστές
4. δεν μπορούν να χρησιμοποιηθούν μέσα σε λογικές
    παραστάσεις
5. δίνουν ως αποτέλεσμα μια τιμή ακεραίου ή
    πραγματικού τύπου
6. εκτελούνται πάντοτε με κατεύθυνση από τα αριστερά
    προς τα δεξιά



Απαντήσεις

1, 3, 5

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Αν ο πίνακας Α[100] είναι πραγματικού τύπου
    α. δεν έχει μέγιστο στοιχείο
    β. δεν έχει ελάχιστο στοιχείο
    γ. καταλαμβάνει 400 bytes στην κύρια μνήμη
    δ. δεν μπορεί να περιέχει τιμές μεγαλύτερες του 100

2. Αν μια ακολουθία τιμών εισόδου τερματίζεται με μια ειδική
    τιμή (φρουρός)
    α. το πλήθος των τιμών εισόδου είναι μεγαλύτερο ή
         ίσο του 1
    β. δεν μπορούμε να υπολογίσουμε το πλήθος των τιμών
        εισόδου
    γ. υπάρχει ανώτατο όριο στο πλήθος των επαναλήψεων
       που πραγματοποιούνται
    δ. η ειδική τιμή (φρουρός) δε συμμετέχει στην
        επεξεργασία των τιμών εισόδου
 
3. Όταν ένα πρόγραμμα λειτουργεί με μενού
    α. η επεξεργασία των δεδομένων ολοκληρώνεται
        μόλις δοθεί η απάντηση 'ΝΑΙ' σε μια ερώτηση
        που υποβάλλεται στο χρήστη
    β. οι δυνατές επιλογές του μενού είναι αριθμημένες
    γ. δεν μπορεί να χρησιμοποιηθεί για την υλοποίησή
        του η εντολή Για..από..μέχρι
    δ. υπάρχει περιορισμός ως προς το είδος της επε-
        ξεργασίας που μπορούμε να κάνουμε σε
        κάθε επιλογή του μενού 

4. Αν θέλουμε να επεξεργαστούμε 100 τιμές εισόδου
    α. Μπορούμε να χρησιμοποιήσουμε την εντολή
        Για..από..μέχρι
    β. Είμαστε υποχρεωμένοι να χρησιμοποιήσουμε την
        εντολή Για..από..μέχρι
    γ. Δεν μπορούμε να χρησιμοποιήσουμε την
        εντολή Μέχρις_ότου
    δ. Η εντολή Όσο..επανάλαβε είναι η καταλληλότερη
        για την περίσταση.

5. Αν ο πίνακας Α[10, 20] είναι ακεραίου τύπου
    α. μπορούμε να ταξινομήσουμε ξεχωριστά τις
        γραμμές αλλά όχι τις στήλες του
    β.  μπορούμε να ταξινομήσουμε ξεχωριστά τις
        στήλες αλλά όχι τις γραμμές του
    γ.   μπορούμε να ταξινομήσουμε ξεχωριστά τόσο
        τις στήλες όσο και τις γραμμές του
    δ.  δεν μπορούμε να ταξινομήσουμε ξεχωριστά ούτε
        τις στήλες και ούτε  τις γραμμές του

Απαντήσεις

1. γ
2. δ
3. β
4. α
5. γ

Κυριακή, 19 Μαΐου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  Ο υπολογιστής υπερτερεί σε _________ επίπεδο σε σχέση
     με τον ανθρώπινο εγκέφαλο.
2.  Οι τελεστές με τη μεγαλύτερη προτεραιότητα από όλους τους
     άλλους είναι οι _________.
3.  Τα στοιχεία των στατικών δομών δεδομένων αποθηκεύονται σε
     _________ θέσεις της κύριας μνήμης.
4. Η γλώσσα LISP είναι ιδανική για την ανάπτυξη εφαρμογών
    _________ νοημοσύνης.
5. Οι πιο γνωστές μέθοδοι αναζήτησης τιμής σε πίνακα είναι
    η σειριακή και η ________.

Απαντήσεις

1. ποσοτικό
2. αριθμητικοί
3. συνεχόμενες
4. τεχνητής
5. δυαδική

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Ένα διεθνές πολιτικό ζήτημα που βρίσκεται στο στάδιο
    των διαπραγματεύσεων είναι:
    α. άλυτο
    β. ανοικτό
    γ. επιλύσιμο
    δ. τίποτα από τα παραπάνω

2. Η εντολή ΓΡΑΨΕ Ε(Χ)
    α. εμφανίζει ένα ακέραιο αποτέλεσμα
    β. περιέχει συντακτικό λάθος
    γ. περιέχει λογικό λάθος
    δ. τίποτα από τα παραπάνω

3. Η εντολή ΔΙΑΒΑΣΕ 'Χ'
    α. έχει συντακτικό λάθος
    β. διαβάζει μια τιμή
    γ. έχει λογικό λάθος
    δ. τίποτα από τα παραπάνω

4. Η εντολή
        ΟΣΟ  Χ > 0 ΕΠΑΝΑΛΑΒΕ
             ΓΡΑΨΕ 'ΑΕΠΠ'
             ΔΙΑΒΑΣΕ Χ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    α. εμφανίζει τη λέξη ΑΕΠΠ μία ή περισσότερες φορές
    β. μπορεί να μην εμφανίσει τίποτα
    γ. παραβιάζει το κριτήριο της καθοριστικότητας
    δ. εμφανίζει τη λέξη ΑΕΠΠ άπειρες φορές

5. Αν ο πίνακας ΟΝ[89] είναι αλφαριθμητικού τύπου
    α. δεν έχει ούτε μέγιστο ούτε ελάχιστο στοιχείο
    β. δεν μπορεί να ταξινομηθεί
    γ. όλα τα στοιχεία του είναι συμβολοσειρές
    δ. τίποτα από τα παραπάνω

Απαντήσεις

1. β
2. δ
3. α
4. β
5. γ


Ποιό είναι το αποτέλεσμα;

Θεωρήστε ότι ο ακέραιος πίνακας Α[10, 20] περιέχει εναλλάξ 100
άρτιες και 100 περιττές τιμές. Τι θα εμφανιστεί στη μονάδα
εξόδου μετά την εκτέλεση των παρακάτω εντολών;
     Για κ από 1 μέχρι 10
         Για λ από 1 μέχρι 20
               Αν Α[κ, λ] mod 2 = 0 τότε
                    Εμφάνισε 'ΕΝΑ'
               αλλιώς_αν Α[κ, λ] mod 2 = 1 τότε
                    Εμφάνισε 'ΚΑΛΟ'
               αλλιώς
                    Εμφάνισε 'ΠΑΙΔΙ'
               Τέλος_αν
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Αν κ+λ = 30 τότε
         Εμφάνισε  'ΑΕΠΠ'
     αλλιώς
         Εμφάνισε 'ΤΕΧΝΟΛΟΓΙΚΗ'
     Τέλος_αν

Απαντήσεις

Επειδή το αποτέλεσμα της πράξης Α[κ, λ] mod 2 είναι 0 ή 1 και
ο πίνακας περιέχει 100 άρτιες και 100 περιττές τιμές (εναλλάξ)
θα εμφανιστούν :
       ΕΝΑ ΚΑΛΟ ΕΝΑ ΚΑΛΟ ..... ΕΝΑ ΚΑΛΟ
(100 φορές η λέξη ΕΝΑ και άλλες 100 η λέξη ΚΑΛΟ)
Όταν ολοκληρωθούν οι Για..από..μέχρι οι τελικές τιμές των κ, λ
είναι :
    κ = 11 και λ = 21
Αφού κ+λ = 32, στο τέλος θα εμφανιστεί : ΤΕΧΝΟΛΟΓΙΚΗ

Παρασκευή, 17 Μαΐου 2013

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Κάθε Για..από..μέχρι  τελειώνει κάποτε.
2. Το αλγοριθμικό κριτήριο της εισόδου προβλέπει ότι
    καμία, μία ή περισσότερες τιμές εισόδου δίνονται
    στον αλγόριθμο.
3. Κάθε συνάρτηση έχει το δικό της τύπο δεδομένων,
    ο οποίος εξαρτάται από τον τύπο του αποτελέσματος
    που υπολογίζει.
4. Μια διαδικασία δεν μπορεί να κληθεί ποτέ μέσα
    από μια συνάρτηση.
5. Ένα αδόμητο πρόβλημα είναι σίγουρα επιλύσιμο.

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Σ


Κυριακή, 12 Μαΐου 2013

Πίνακας αντιστοίχησης

Δίνονται οι παρακάτω ενέργειες
   1. Μενού λειτουργιών
   2. Επεξεργασία δοσμένου πλήθους δεδομένων
   3. Προσπάθεια επίτευξης συγκεκριμένου στόχου
   4. Διάθεση δοσμένου χρηματικού ποσού για την
       αγορά αγαθών
   5. Επεξεργασία τιμών εισόδου που τερματίζεται μόλις
       δοθεί μια ειδική τιμή
   6. Επεξεργασία τιμών εισόδου που τερματίζεται μόλις
       δοθεί μια συγκεκριμένη απάντηση σε μια ερώτηση που
       υποβάλλεται από το χρήστη
και οι εντολές
   α. Όσο..επανάλαβε
   β. Μέχρις_ότου
   γ. Για..από..μέχρι
Γράψτε τον αριθμό 1-6 και δίπλα το γράμμα α-γ της εντολής
που θεωρείται πιο κατάλληλη για την υλοποίηση των αντίστοιχων
ενεργειών.

Απάντηση

1. β
2. γ
3. α
4. α
5. β
6. β

Παρασκευή, 10 Μαΐου 2013

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με ένα
μόνο Για..από..μέχρι
     Για κ από 2 μέχρι 9 με_βήμα 3
           Για λ από 10 μέχρι 100 με_βήμα 5
                 Αν λ = 35 τότε
                      Για μ από 1 μέχρι 100
                           Αν  μ = λ τότε
                               Εμφάνισε (κ-λ)*μ
                           Τέλος_αν
                      Τέλος_επανάληψης
                 Τέλος_αν
           Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

    Για κ από 2 μέχρι 9 με_βήμα 3
           Εμφάνισε (κ-35)*35                          

    Τέλος_επανάληψης

Εντοπισμός λαθών

Οι παρακάτω εντολές επιχειρούν λανθασμένα να
εμφανίσουν το τελευταίο ψηφίο του ακέραιου Ν.
Γράψτε τον αριθμό της εντολής (1-5) και δίπλα το
χαρακτηρισμό του λάθους (λογικό ή συντακτικό)
    1. Εμφάνισε  Ν div 10
    2. Εμφάνισε  mod 10'
    3. Εμφάνισε Νmod10
    4. Γράψτε Ν mod 10
    5. Εκτύπωσε Ν / 10
    

Απαντήσεις 

1. λογικό
2. λογικό
3. συντακτικό
4. συντακτικό
5. λογικό


 

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών
     Διάβασε Χ
     Για κ από 2013 μέχρι 2013 με_βήμα 2
           Εμφάνισε κ*Χ
     Τέλος_επανάληψης
     Εμφάνισε κ+Χ

Λύση

    Διάβασε Χ
    Εμφάνισε 2013*Χ
    Εμφάνισε 2015+Χ

Πέμπτη, 2 Μαΐου 2013

Ερωτήσεις πολλαπλής επιλογής

1. Αν Χ θετικός ακέραιος, το αποτέλεσμα της πράξης
    Χ mod 4
    A. είναι μικρότερο του 3
    Β. είναι τουλάχιστον 1
    Γ. είναι μικρότερο του 4
    Δ είναι το πηλίκο της διαίρερης του Χ με το 4

2. Αν Χ, Υ αλφαριθμητικές μεταβλητές, η εντολή
       ΓΡΑΨΕ Χ = Υ
    Α. έχει συντακτικό λάθος
    Β. έχει λογικό λάθος
    Γ. εμφανίζει στην οθόνη την τιμή 'ΑΛΗΘΗΣ'
        ή 'ΨΕΥΔΗΣ'
    Δ. εμφανίζει στην οθόνη μια λογική τιμή

3.  Σε έναν πίνακα
     Α. όλα τα στοιχεία του προσδιορίζονται με ένα
          δείκτη
     Β. ο τύπος του δείκτη είναι πραγματικός
     Γ. δεν επιτρέπεται να προσθέσουμε ή να
         αφαιρέσουμε ένα στοιχείο κατά τη διάρκεια
        εκτέλεσης του προγράμματος
     Δ. το μέγιστο πλήθος των τιμών που θα
          καταχωρηθούν σε αυτόν, πρέπει να είναι
          γνωστό πριν την εκτέλεση του προγράμματος

4.  Μια δικιά μας συνάρτηση
     Α. ενεργοποιείται με την εντολή ΚΑΛΕΣΕ
     Β. έχει πιο περιορισμένο πεδίο δράσης από
          μια διαδικασία
     Γ. καλείται μόνο μέσα από μια εντολή εκχώρησης
     Δ. δεν μπορεί να χρησιμοποιηθεί μέσα σε μια
          παράσταση (αριθμητική ή λογική)

5. Οι χιλιάδες του θετικού τετραψήφιου Ν είναι:
    Α. Ν DIV 1000
    B. N MOD 1000
    Γ.  Ν / 1000
    Δ. Ν * 1000
   
Απαντήσεις

1. Γ
2. Δ
3. Δ
4. Β
5. Α



Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Το παρακάτω σύνολο εντολών
          Διάβασε Χ
          Αν Χ > 0 τότε
              Εμφάνισε 1/(Χ+2)
          αλλιώς
              Εμφάνισε 1/(Χ-2)
          Τέλος_αν
     παραβιάζει το κριτήριο της καθοριστικότητας.

2. Αν η τιμή εισόδου είναι 'ΑΕΠΠ',οι εντολές
           Διάβασε Χ
           Οσο Χ < > 'ΑΕΠΠ' επανάλαβε
                 Εμφάνισε Χ
           Τέλος_επανάληψης
    εμφανίζουν τη λέξη ΑΕΠΠ άπειρες φορές.

3. Ο τμηματικός προγραμματισμός απαιτεί ταλέντο
     εμπειρίες και γνώσεις.

4. Η επιλογή του κατάλληλου αλγόριθμου
    ταξινόμησης εξαρτάται και από την αρχική
    διάταξη των στοιχείων του πίνακα.

5. Αν Α_Μ(Χ) = Α_Τ(Χ), ο Χ είναι θετικός και
    ακέραιος.
Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Σ

Τετάρτη, 1 Μαΐου 2013

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τις πράξεις
div και mod.
1. Εφαρμόζονται μόνο πάνω σε ακέραιες τιμές.
2. Ανήκουν στην κατηγορία των αριθμητικών
    τελεστών.
3. Έχουν τη μεγαλύτερη ιεραρχία από όλους
    τους τελεστές.
4. Δίνουν αποτέλεσμα πραγματικού τύπου.
5. Το αποτέλεσμά τους μπορεί να αποθηκευτεί
    σε μια ακέραια ή πραγματική μεταβλητή.
6. Χρησιμοποιούνται πολύ σπάνια.

Απαντήσεις

1, 2, 5

Διατύπωση συνθηκών

Διατυπώστε τους παρακάτω περιορισμούς με
κατάλληλες συνθήκες στη ΓΛΩΣΣΑ
1. Το Χ είναι μικρό γράμμα του ελληνικού
    αλφαβήτου ή κεφαλαίο γράμμα του
    αγγλικού αλφαβήτου.
2. Το Υ είναι θετικός πενταψήφιος ακέραιος
    που έχει 7 εκατοντάδες (δεν απαιτείται
    έλεγχος του τύπου)
3. Το Ζ δεν είναι ίσο με καμία από τις τιμές 0, 1, 2
4. Ικανοποιείται η λογική πρόταση Π1 και όχι οι
    λογικές προτάσεις Π2, Π3
 


Απαντήσεις

1. ( (Χ >= 'α') ΚΑΙ (Χ <= 'ω') ) Ή ( (Χ >= 'Α') ΚΑΙ (Χ <= 'Ζ') )
2. ( Υ >= 10000) ΚΑΙ (Υ <= 99999) ΚΑΙ
    ( ( (Υ MOD 10000) MOD 1000) DIV 100 = 7 )
3. (Ζ < > 0) ΚΑΙ (Ζ < > 1) ΚΑΙ (Ζ < > 2)
4. Π1 ΚΑΙ ΟΧΙ (Π2) ΚΑΙ ΟΧΙ (Π3)

    

Συμπλήρωση κενών