Κυριακή, 19 Μαΐου 2013

Ποιό είναι το αποτέλεσμα;

Θεωρήστε ότι ο ακέραιος πίνακας Α[10, 20] περιέχει εναλλάξ 100
άρτιες και 100 περιττές τιμές. Τι θα εμφανιστεί στη μονάδα
εξόδου μετά την εκτέλεση των παρακάτω εντολών;
     Για κ από 1 μέχρι 10
         Για λ από 1 μέχρι 20
               Αν Α[κ, λ] mod 2 = 0 τότε
                    Εμφάνισε 'ΕΝΑ'
               αλλιώς_αν Α[κ, λ] mod 2 = 1 τότε
                    Εμφάνισε 'ΚΑΛΟ'
               αλλιώς
                    Εμφάνισε 'ΠΑΙΔΙ'
               Τέλος_αν
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Αν κ+λ = 30 τότε
         Εμφάνισε  'ΑΕΠΠ'
     αλλιώς
         Εμφάνισε 'ΤΕΧΝΟΛΟΓΙΚΗ'
     Τέλος_αν

Απαντήσεις

Επειδή το αποτέλεσμα της πράξης Α[κ, λ] mod 2 είναι 0 ή 1 και
ο πίνακας περιέχει 100 άρτιες και 100 περιττές τιμές (εναλλάξ)
θα εμφανιστούν :
       ΕΝΑ ΚΑΛΟ ΕΝΑ ΚΑΛΟ ..... ΕΝΑ ΚΑΛΟ
(100 φορές η λέξη ΕΝΑ και άλλες 100 η λέξη ΚΑΛΟ)
Όταν ολοκληρωθούν οι Για..από..μέχρι οι τελικές τιμές των κ, λ
είναι :
    κ = 11 και λ = 21
Αφού κ+λ = 32, στο τέλος θα εμφανιστεί : ΤΕΧΝΟΛΟΓΙΚΗ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου