Κυριακή, 17 Νοεμβρίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η πρώτη γλώσσα προγραμματισμού υψηλού επιπέδου
    ήταν η _______.
2. Ο ακέραιος πίνακας Α[20] απαιτεί _____ bytes για την
    αποθήκευσή του στην κύρια μνήμη.
3. Μια μεταβλητή αρχικά έχει _________ τιμή.
4. Τα σχόλια δεν είναι ___________.
5. Ο δομημένος προγραμματισμός εμπεριέχει τόσο την
     ________ σχεδίαση όσο και τον ______ προγραμματισμό.



Απαντήσεις 

1. FORTRAN
2. 40
3. απροσδιόριστη
4. εκτελέσιμα
5. ιεραρχική, τμηματικό




Πέμπτη, 14 Νοεμβρίου 2013

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι
σωστές και ποιες λάθος;
1. Ένας αλγόριθμος μπορεί να περιλαμβάνει
    μία ή περισσότερες συμβολικές σταθερές.
2. Πίνακες+Αρχεία = Προγράμματα
3. Ένας δείκτης είναι μια μεταβλητή πραγματικού
    τύπου που χρησιμοποιείται για να προσδιορίσει
    τη θέση κάποιου στοιχείου μέσα σ' ένα πίνακα.
4. Τα προγράμματα σε BASIC εκτελούνται με τη
    βοήθεια διερμηνευτή.
5. Η FORTRAN υστερεί στη διαχείριση αλφαρι-
    θμητικών πληροφοριών.

Απάντηση

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ




Τετάρτη, 6 Νοεμβρίου 2013

Μετατροπή λογικού διαγράμματος σε ψευδοκώδικα

Γράψτε τον αλγόριθμο σε ψευδογλώσσα που αντιστοιχεί
στο παρακάτω λογικό διάγραμμα






































Λύση

Αλγόριθμος Ασκ
Για Κ από 1 μέχρι 30 με_βήμα 3
     Για Λ από 20 μέχρι 3 με_βήμα -1
          Για Μ από 4 μέχρι 37 με_βήμα 2
               Εμφάνισε Κ, Λ, Μ
          Τέλος_επανάληψης
     Τέλος_επανάληψης 
Τέλος_επανάληψης
Τέλος Ασκ