Πέμπτη, 30 Ιανουαρίου 2014

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για ένα τελεστή
1. Μπορεί να είναι αριθμητικός ή συγκριτικός
2.  Έχει μια συγκεκριμένη προτεραιότητα έναντι των
     άλλων τελεστών.
3. Αντιστοιχεί σε κάποια πράξη ή σύγκριση.
4. Μπορεί να εφαρμοστεί μόνο σε σταθερές ή
    μεταβλητές αριθμητικού τύπου.
5. Μπορεί να εφαρμοστεί και σε πίνακες.

Απαντήσεις

2, 3

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η πιο απλή αλγοριθμική δομή είναι η __________.
2. Η ύψωση στη δύναμη είναι ένας _______ τελεστής.
3. Η σύγκριση ανάμεσα σε αλφαριθμητικά δεδομένα
    γίνεται με βάση την _________ σειρά.
4. Ο __________ τύπος περιλαμβάνει τις τιμές
    ΑΛΗΘΗΣ και ΨΕΥΔΗΣ.
5. Μέσα σε μια συνάρτηση δεν επιτρέπεται η χρήση της
    εντολής ΓΡΑΨΕ ή ________.


Απαντήσεις

1. ακολουθιακή
2. αριθμητικός
3. αλφαβητική
4.  λογικός
5. ΔΙΑΒΑΣΕ


Κυριακή, 26 Ιανουαρίου 2014

Απλοποίηση

Θεωρήστε το παρακάτω σύνολο εντολών
     Για κ από 1 μέχρι 10
          Για λ από 1 μέχρι 7
              Για μ από 1 μέχρι 3
                   Αν (κ = 3) ΚΑΙ (μ = 2) τότε
                        Εμφάνισε Α[κ, λ, μ]
                   Τέλος_αν
              Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης
Αντικαταστήστε το με ένα μόνο Για..από..μέχρι που
να επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.

Λύση

              Για λ από μέχρι 7
                   Εμφάνισε Α[3, λ, 2]
              Τέλος_επανάληψης


Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Οι τρισδιάστατοι πίνακες είναι μια μορφή πολυδιάστατων
    πινάκων.
2. Η στοίβα χρόνου εκτέλεσης χρησιμοποιείται από το
   μεταγλωττιστή προκειμένου να διαχειρίζεται τις
   κλήσεις και τις επιστροφές των υποπρογραμμάτων.
3. Η μέθοδος της φυσσαλίδας μπορεί να εφαρμοστεί
   μόνο σε ταξινομημένους πίνακες.
4. Η εντολή Αντιμετάθεσε επιτρέπει την αντιμετάθεση
   του περιεχομένου δύο μεταβλητών.
5. Για να εισάγουμε δεδομένα από το πληκτρολόγιο
    χρησιμοποιούμε την εντολή Δεδομένα.



Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Σ
5. Λ



Τρίτη, 14 Ιανουαρίου 2014

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Κάθε πίνακας έχει μέγιστο και ελάχιστο στοιχείο.
2. Μια διαδικασία μπορεί να κληθεί και μέσα από μια συνάρτηση.
3. Ένα επιλύσιμο πρόβλημα μπορεί να είναι και αδόμητο.
4. Η γλώσσα C είναι ιδανική για την εισαγωγή μικρών μαθητών
    στον προγραμματισμό.
5. Ένα λογικό διάγραμμα είναι γραμμένο σε μια γλώσσα
    προγραμματισμού.



Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Λ


Πέμπτη, 9 Ιανουαρίου 2014

Επεξεργασία δυσδιάστατου πίνακα (αθροίσματα ανά γραμμή)


Επεξεργασία δυσδιάστατου πίνακα


Λογικό διάγραμμα






















Διατυπώστε τον αλγόριθμο σε ψευδογλώσσα που
αντιστοιχεί στο παραπάνω διάγραμμα.

Λύση

Αλγόριθμος Ασκ
Διάβασε Α, Β, Γ
Αν Α > Β^2 τότε
    Εμφάνισε Α^Β-Γ
αλλιώς_αν Α < Β^2 τότε
    Εμφάνισε Β^Α-Γ
αλλιώς
    Εμφάνισε Α, Β^2, Γ-1
Τέλος_αν
Τέλος Ασκ