Τρίτη, 30 Αυγούστου 2011

Άσκηση : επίτευξη στόχου

Μια εφημερίδα δίνει τη δυνατότητα στους αναγνώστες της
να συλλέγουν γραμματόσημα παλαιότερων εποχών, από
διάφορες χώρες της Ευρωπαϊκής ένωσης. Σε κάθε φύλλο
της εφημερίδας διατίθεται και διαφορετικός αριθμός γραμ-
ματοσήμων. Στόχος ενός αναγνώστη είναι η συλλογή του-
λάχιστον 150 γραμματοσήμων. Γράψτε αλγόριθμο που:
α) διαβάζει πόσα γραμματόσημα διαθέτει καθημερινά η
    εφημερίδα στους αναγνώστες της,
β) υπολογίζει και εμφανίζει:
     * πόσες ημέρες απαιτούνται για να επιτύχει ο αναγνώστης
        το στόχο του,
     * το σύνολο των γραμματοσήμων που συνέλεξε τελικά
        ο αναγνώστης αυτός.

Λύση

      Αλγόριθμος Γραμματόσημα
      Ημερ <-- 0
      Σύνολο <-- 0
      Όσο Σύνολο < 150 επανάλαβε
             Διάβασε Γραμ
             Ημερ <-- Ημερ+1
             Σύνολο <-- Σύνολο+Γραμ
      Τέλος_επανάληψης
      Εμφάνισε Σύνολο, Ημερ
      Τέλος Γραμματόσημα

Κυριακή, 28 Αυγούστου 2011

Άσκηση : κατανάλωση διαθεσίμων

Θέλετε να γεμίσετε μια νταλίκα (που το ανώτατο όριο φόρτωσής της είναι ΜΕΓ κιλά) με κιβώτια
διαφορετικού βάρους.  Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει το βάρος κάθε κιβωτίου (η φόρτωση της νταλίκας ολοκληρώνεται μόλις εντοπιστεί ένα κιβώτιο το οποίο δεν μπορεί να φορτωθεί γιατί υπάρχει υπέρβαση του ανώτατου ορίου φόρτωσης),
β) υπολογίζει και εμφανίζει:
·         πόσα κιβώτια φορτώθηκαν,
·         το συνολικό βάρος φόρτωσης της νταλίκας.

Λύση


Αλγόριθμος Νταλίκα
Δεδομένα // ΜΕΓ //
Διαθ <-- ΜΕΓ
Κιβ <-- 0
ΣΤΟΠ <-- Ψευδής
Αρχή_επανάληψης
      Διάβασε Κιλά
      Αν Κιλά <= Διαθ τότε
            Διαθ <-- Διαθ-Κιλά
            Κιβ <-- Κιβ+1
      αλλιώς
            ΣΤΟΠ <-- Αληθής
      Τέλος_αν
Μέχρις_ότου ΣΤΟΠ = Αληθής
Φορτίο <-- ΜΕΓ-Διαθ
Εμφάνισε Κιβ, Φορτίο
Τέλος Νταλίκα



Σάββατο, 27 Αυγούστου 2011

Εξαφανίστε την GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ικανοποιεί τις αρχές του δομημένου προγραμματισμού
     10:    ΔΙΑΒΑΣΕ Α
              ΑΝ Α > 200 ΤΟΤΕ GOTO 50
              AN A > 100 TOTE GOTO 60
              ΓΡΑΨΕ  Α-2
              GOTO 70
     50:    ΓΡΑΨΕ  Α+2
              GOTO 70
     60:    ΓΡΑΨΕ  Α*2
     70:    ΓΡΑΨΕ Α
             ΑΝ Α < 500 GOTO 10

Λύση


       ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΔΙΑΒΑΣΕ Α
            ΑΝ Α > 200 ΤΟΤΕ 
                 ΓΡΑΨΕ  Α+2

            ΑΛΛΙΩΣ_ΑΝ Α > 100 ΤΟΤΕ

                 ΓΡΑΨΕ  Α*2
            ΑΛΛΙΩΣ
                 ΓΡΑΨΕ Α-2
            ΤΕΛΟΣ_ΑΝ
            ΓΡΑΨΕ Α
        ΜΕΧΡΙΣ_ΟΤΟΥ Α >= 500
           

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών μόνο με εντολές
Αν..τότε

         Αν Χ = 'α' τότε
              Υ <-- '@'
         αλλιώς_αν  (Χ = 'γ') Ή (Χ = 'δ') τότε
              Υ <-- '$'
         αλλιώς_αν (Χ = 'ε') Ή (Χ = 'ζ') τότε
              Υ <-- '%'
         αλλιώς
              Υ <-- '*'
         Τέλος_αν


Λύση


         Αν Χ = 'α' τότε
              Υ <-- '@'
         Τέλος_αν
         Αν  (Χ = 'γ') Ή (Χ = 'δ') τότε
              Υ <-- '$'
         Τέλος_αν      
         Αν (Χ = 'ε') Ή (Χ = 'ζ') τότε
              Υ <-- '%'
         Τέλος_αν
         Αν (Χ < > 'α') ΚΑΙ (Χ < > 'γ') ΚΑΙ (Χ < > 'δ') ΚΑΙ
              (Χ < > 'ε') ΚΑΙ (Χ < > 'ζ') τότε
               Υ <-- '*'
         Τέλος_αν        

Παρασκευή, 26 Αυγούστου 2011

Μετατροπές

Ξαναγράψτε το παρακάτω σύνολο εντολών
       Για κ από 120 μέχρι 10 με_βήμα -1
             Διάβασε Χ
             Αν Χ > 20 τότε 
                    Εμφάνισε κ*Χ
             αλλιώς_αν Χ > 5 τότε
                    Εμφάνισε (κ+1)*Χ
             αλλιώς
                    Εμφάνισε (κ+2)*Χ
             Τέλος_αν
       Τέλος_επανάληψης
αντικαθιστώντας :
α) την εντολή Για με Όσο
β) την εντολή Αν..τότε..αλλιώς_αν με εντολές Αν..τότε

Λύση

      κ <-- 120
      Όσο κ >= 10 επανάλαβε 
             Διάβασε Χ
             Αν Χ > 20 τότε 
                    Εμφάνισε κ*Χ
             Τέλος_αν            
             Αν (Χ > 5) ΚΑΙ (Χ <= 20) τότε
                    Εμφάνισε (κ+1)*Χ
             Τέλος_αν
             Αν Χ <= 5 τότε
                    Εμφάνισε (κ+2)*Χ
             Τέλος_αν
             κ <-- κ-1
       Τέλος_επανάληψης

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία:
α) διαβάζει τον όγκο σε λίτρα κάποιων πλαστικών δοχείων
     (η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί από
      το πληκτρολόγιο μια τιμή <= 0),
β) υπολογίζει:
    * το συνολικό πλήθος των δοχείων,
    * το μεγαλύτερο όγκο δοχείου,
    * τον αύξοντα αριθμό του δοχείου που είχε αυτό
       το μεγαλύτερο όγκο.
Παρατήρηση : Θεωρείστε ότι δόθηκαν στοιχεία για τουλάχιστον
ένα δοχείο.

Λύση

       ΔΙΑΔΙΚΑΣΙΑ ΔΟΧΕΙΑ(ΠΛΗΘ, ΜΕΓ, ΑΑΜΕΓ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: ΠΛΗΘ, ΑΑΜΕΓ
             ΠΡΑΓΜΑΤΙΚΕΣ : ΟΓΚ, ΜΕΓ
       ΑΡΧΗ
              ΠΛΗΘ <-- 0
              ΜΕΓ <-- -100
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ ΟΓΚ
                    ΑΝ ΟΓΚ > 0 ΤΟΤΕ
                          ΠΛΗΘ <-- ΠΛΗΘ+1
                          ΑΝ ΟΓΚ > ΜΕΓ ΤΟΤΕ
                                 ΜΕΓ <-- ΟΓΚ
                                 ΑΑΜΕΓ <-- ΠΛΗΘ
                          ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ ΟΓΚ <= 0
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τετάρτη, 24 Αυγούστου 2011

Ποιο είναι το περιεχόμενο του πίνακα

Τι θα περιέχει ο πίνακας Α[6, 6] μετά την εκτέλεση των
παρακάτω εντολών΄
      Για κ από 1 μέχρι 6
           Για λ από 1 μέχρι 6
                 Αν κ = λ τότε
                      Α[κ, λ] <-- 2*κ
                 αλλιώς_αν κ+λ = 7 τότε
                      Α[κ, λ] <-- 2*λ
                 αλλιώς
                      Α[κ, λ] <-- κ+λ
                 Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης


Λύση


   Ο κανόνας γεμίσματος του πίνακα είναι ο ακόλουθος:
       * τα στοιχεία της 1ης κυρίας διαγωνίου παίρνουν ως τιμή
          τους το διπλάσιο του δείκτη γραμμής,
       * τα στοιχεία της 2ης κυρίας διαγωνίου παίρνουν ως τιμή
          τους το διπλάσιο του δείκτη στήλης,
       * όλα τα άλλα στοιχεία του πίνακα  παίρνουν ως τιμή
          τους το άθροισμα των συντεταγμένων τους.
   Κατά συνέπεια το περιεχόμενο του πίνακα είναι :
       
         2     3     4     5      6      12
         3     4     5     6      10    8
         4     5     6     8      8      9
         5     6     6     8      9     10
         6     4     8     9     10    11
         2     8     9    10    11    12

Ποιο είναι το περιεχόμενο του πίνακα

Τι θα περιέχει ο πίνακας Α[8] μετά την εκτέλεση των
παρακάτω εντολών΄
      Για κ από 1 μέχρι 8
            Α[κ] <-- 3+(κ-1)*2
      Τέλος_επανάληψης


Λύση


    Α[1] = 3+(1-1)*2 = 3
    Α[2] = 3+(2-1)*2 = 5
    Α[3] = 3+(3-1)*2 = 7
    Α[4] = 3+(4-1)*2 = 9
    Α[5] = 3+(5-1)*2 = 11
    Α[6] = 3+(6-1)*2 = 13
    Α[7] = 3+(7-1)*2 = 15
    Α[8] = 3+(8-1)*2 = 17

    Κατά συνέπεια το περιεχόμενο του πίνακα είναι:

         3   5   7   9   11   13   15   17

Τρίτη, 23 Αυγούστου 2011

Ποιά είναι η τελική τιμή της μεταβλητής

Ποιά είναι η τελική τιμή της μεταβλητής ζ μετά την εκτέλεση
των παρακάτω εντολών
      ζ <-- 100
      Για κ από 2 μέχρι 9
           Για λ από 12 μέχρι 1 με_βήμα -1
                Για μ από 15 μέχρι 3 με_βήμα -7
                      ζ <-- ζ-1
                Τέλος_επανάληψης
           Τέλος_επανάληψης
      Τέλος_επανάληψης


Απάντηση


      Η εξωτερική Για εκτελείται 8 φορές, η δεύτερη 12
      φορές και η πιο εσωτερική Για 2 φορές. Άρα η
      εντολή ζ <-- ζ-1 εκτελείται:
             8Χ12Χ2 = 192 φορές
     Συνεπώς ζ = 100-192*1 = 100-192 = -92

Άσκηση : Εμφωλευμένα Για

Γράψτε αλγόριθμο που:
α) διαβάζει το ημερήσιο πλήθος των επισκεπτών ενός
    μουσείου τους τελευταίους 3 μήνες,
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των επισκεπτών για το παραπάνω
       χρονικό διάστημα,
    * το συνολικό πλήθος επισκεπτών για κάθε μήνα
       ξεχωριστά,
    * τον αύξοντα αριθμό (1-3) του μήνα όπου καταγράφηκε
       το μεγαλύτερο συνολικό πλήθος επισκεπτών.
Παρατήρηση : Για λόγους απλότητας θεωρείστε ότι κάθε
μήνας έχει 30 μέρες.

Απάντηση

       Αλγόριθμος ΜΟΥΣΕΙΟ
       Μεγ <-- -100
       Αθρ <-- 0
       Για κ από 1 μέχρι 3
            σ <-- 0
            Για λ από 1 μέχρι 30
                 Διάβασε Επισκ
                 σ <-- σ+Επισκ
                 Αθρ <-- Αθρ+Επισκ   
            Τέλος_επανάληψης
            Εμφάνισε σ
            Αν σ > Μεγ τότε
                      Μεγ <-- σ
                      ΑΑμεγ <-- κ
            Τέλος_αν
       Τέλος_επανάληψης
        Εμφάνισε Αθρ, ΑΑμεγ
       Τέλος ΜΟΥΣΕΙΟ


Δευτέρα, 22 Αυγούστου 2011

Κλιμακωτός υπολογισμός

Μια καντίνα κοστολογεί τα σουβλάκια που πουλάει με
κλιμακωτό τρόπο ως εξής:

    Σουβλάκια                         Τιμή ανά σουβλάκι
    Μέχρι και 3                                     1.0
    Από 4 έως και 7                              0.8
    Από 8 έως και 12                            0.7
    Από 13 και πάνω                             0.5

Γράψτε πρόγραμμα το οποίο διαβάζει πόσα σουβλάκια
κατανάλωσε ένας πελάτης, υπολογίζει και εμφανίζει το
συνολικό κόστος τους.
Παρατήρηση : Το πρόγραμμα πρέπει να διασφαλίζει ότι
η τιμή εισόδου είναι θετικός αριθμός.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΣΟΥΒΛΑΚΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: ΣΟΥΒ
             ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡ
      ΑΡΧΗ
             ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΔΙΑΒΑΣΕ ΣΟΥΒ
             ΜΕΧΡΙΣ_ΟΤΟΥ ΣΟΥΒ > 0
             ΑΝ ΣΟΥΒ <= 3 ΤΟΤΕ
                   ΧΡ <-- ΣΟΥΒ*1.0
             ΑΛΛΙΩΣ_ΑΝ ΣΟΥΒ <= 7 ΤΟΤΕ
                   ΧΡ <-- 3*1.0+(ΣΟΥΒ-3)*0.8
             ΑΛΛΙΩΣ_ΑΝ ΣΟΥΒ <= 12 ΤΟΤΕ
                   ΧΡ <-- 3*1.0+4*0.8+(ΣΟΥΒ-7)*0.7
             ΑΛΛΙΩΣ
                   ΧΡ <-- 3*1.0+4*0.8+5*0.7+(ΣΟΥΒ-12)*0.5
             ΤΕΛΟΣ_ΑΝ
              ΓΡΑΨΕ ΧΡ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Εμφωλευμένες δομές επιλογής

Ως γνωστόν, αν η ηλικία ενός ατόμου είναι πάνω από 18 
χαρακτηρίζεται ως  ενήλικος και σε διαφορετική περίπτωση
ανήλικος. Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει το φύλο (λογικού τύπου) και την ηλικία ενός 
    ατόμου,
β) εμφανίζει στη μονάδα εξόδου ένα συνολικό 
    χαρακτηρισμό για το άτομο αυτό 
    (π.χ ανήλικος άνδρας).

Λύση

    Αλγόριθμος Άτομο
    Διάβασε Φύλο
    Διάβασε Ηλικία
    Αν Φύλο = Αληθής τότε   ! Άνδρας
         Αν Ηλικία > 18 τότε
              Εμφάνισε 'Άνδρας ενήλικος'
         αλλιώς
              Εμφάνισε 'Άνδρας ανήλικος'
         Τέλος_αν
    αλλιώς   ! γυναίκα
         Αν Ηλικία > 18 τότε
              Εμφάνισε 'Γυναίκα ενήλικη'
         αλλιώς
              Εμφάνισε 'Γυναίκα ανήλικη'
         Τέλος_αν
    Τέλος_αν
    Τέλος Άτομο

Βρείτε τα συντακτικά και τα λογικά λάθη

Οι παρακάτω (λανθασμένες) εντολές φιλοδοξούν να
εκχωρήσουν στη μεταβλητή Υ το υπόλοιπο της διαίρεσης
του πενταπλασίου του Χ με το τριπλάσιο του Z.
Ποιες από αυτές έχουν συντακτικά και ποιες λογικά λάθη;
Αιτιολογήστε την απάντησή σας.
1.  Υ = (5*Χ) mod (3*Z)
2.  Υ <-- 5*Χ mod 3*Z
3.  Υ <-- (5*Χ) div (3*Ζ)
4.  Y <-- (5*X)mod(3*Z)

Απάντηση

1. Συντακτικό (χρησιμοποιείται το σύμβολο = αντί
    του <-- )
2. Λογικό (η έλλειψη παρενθέσεων αλλάζει την ιεραρχία
    των πράξεων)
3. Λογικό (χρησιμοποιείται ο τελεστής div αντί του mod)
4. Συντακτικό (δεν υπάρχουν κενά διαστήματα)




Πέμπτη, 11 Αυγούστου 2011

Διατύπωση περιορισμών

Διατυπώστε τους παρακάτω περιορισμούς στη ΓΛΩΣΣΑ
1. Η πραγματική μεταβλητή  Ζ έχει ακέραιο περιεχόμενο.
2. Χ = 5 ή -5 ή 0
3. Το Υ δεν είναι πολλαπλάσιο ούτε του 3 ούτε και του 6.
4. Το Μ είναι εκτός του διαστήματος [13, 67].
5. Το Χ είναι τουλάχιστον όσο και το Υ.
6. Το Χ δεν υπερβαίνει το Υ

Απάντηση

1. Α_Μ(Ζ) = Ζ
2. (Χ = 5) Ή (Χ = -5) Ή (Χ = 0)
3. (Υ ΜΟD 3 < > 0) KAI (Y MOD 6 < > 0)
4. (Μ < 13) Ή (Μ > 67)
5. Χ >= Υ
6. Χ <= Υ



Τετάρτη, 10 Αυγούστου 2011

Έλεγχος εγκυρότητας εντολών εκχώρησης

Θεωρήστε το παρακάτω τμήμα δήλωσης μεταβλητών
ΜΕΤΑΒΛΗΤΕΣ
       ΑΚΕΡΑΙΕΣ: Α
       ΠΡΑΓΜΑΤΙΚΕΣ: Β
       ΧΑΡΑΚΤΗΡΕΣ : Γ
       ΛΟΓΙΚΕΣ : Δ
Ποιές από τις παρακάτω εντολές εκχώρησης είναι σωστές
και ποιές λανθασμένες. Αιτιολογήστε μόνο τις περιπτώσεις
λάθους.

1. Α <-- Β+3
2. Β <-- Α+3
3. Γ <-- προγραμματάκι
4. Δ <-- 'ΟΧΙ(Α>β)'
5. Δ <-- (Γ < > 'τεστ') ΚΑΙ (Α*Β > 0)
6. Γ <-- '1+(Α-Β)*2'

Απάντηση

Σωστές : 2, 5, 6
Λανθασμένες : 1 (το δεξιό μέλος είναι πραγματική παράσταση),
                        3 (λείπουν οι απόστροφοι),
                        4 (το δεξιό μέλος είναι αλφαριθμητικό)

Έλεγχος ορθότητας ονομάτων

Ποιά από τα παρακάτω αποτελούν έγκυρα ονόματα
συμβολικών σταθερών στη ΓΛΩΣΣΑ και ποιά όχι;
Αιτιολογήστε μόνο τις λανθασμένες περιπτώσεις.

1. ΣΤΑΘΕΡΑ
2. ΣΤΑΘΕ_ΡΕΣ
3. Α  1Β
4. 112β
5. MOD
6. A2_B3_G4
7. Φ.Π.Α.

Απάντηση

¨Εγκυρα : 1, 2, 6
 Άκυρα :   3 (έχει κενό διάστημα)
                 4 (ξεκινάει με αριθμό)
                 5 (δεσμευμένη λέξη)
                 7 (έχει την τελεία)

Κυκλώστε τα σωστά

Παρακάτω διατυπώνονται κάποιες προτάσεις που αφορούν
τις συμβολικές σταθερές. Γράψτε στο τετράδιο σας τα νούμερα
 (1-6) των προτάσεων που είναι σωστές.

1. Οι συμβολικές σταθερές είναι αναπόσπαστο κομμάτι ενός
    αλγόριθμου.
2. Οι συμβολικές σταθερές δηλώνονται σε ξεχωριστό τμήμα
    ενός προγράμματος.
3. Οι συμβολικές σταθερές είναι μόνο αριθμητικού τύπου.
4. Οι κανόνες ονοματολογίας των συμβολικών σταθερών και
    των μεταβλητών  διαφέρουν.
5. Απαγορεύεται να αλλάξουμε το περιεχόμενο μιας συμβο-
    λικής σταθεράς.
6. Οι συμβολικές σταθερές κάνουν το πρόγραμμα πιο κατανοητό
     και επιτρέπουν την ευκολότερη διόρθωση και συντήρησή του.

Απάντηση

2,  5, 6

Τρίτη, 9 Αυγούστου 2011

Ερωτήσεις σωστού λάθους

Συμπληρώστε τα κενά στις παρακάτω προτάσεις
1. Ένα ανοικτό πρόβλημα μπορεί να επιδέχεται πολλές
    λύσεις.
2. Ο ρόμβος είναι ένα γεωμετρικό σχήμα που απουσιάζει
    από τα διαγράμματα ροής επαναληπτικών δομών.
3. Η κωδικοποίηση των αλγορίθμων μπορεί να γίνει και
    με ελεύθερο κείμενο.
4. Αν η εντολή
        Εμφάνισε Α[13]
    είναι έγκυρη, συνάγουμε το συμπέρασμα ότι ο Α είναι
    ένας μονοδιάστατος πίνακας με τουλάχιστον 13 στοιχεία.
5. Η εντολή εκχώρησης
         Ζ <-- Ζ*3
   τριπλασιάζει το περιεχόμενο της αριθμητικής μεταβλητής
   Ζ.


Απάντηση

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ

Παρασκευή, 5 Αυγούστου 2011

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις
με σωστό τρόπο
1. Η επίλυση μιας δευτεροβάθμιας εξίσωσης είναι αδόμητο
    πρόβλημα.
2. Μια υπολογιστική διαδικασία που ολοκληρώνεται μετά
    από κάποιο αριθμό βημάτων είναι αλγόριθμος.
3. Για να περιγράψουμε το φύλο ενός ανθρώπου χρειαζό-
    μαστε μια μεταβλητή ακεραίου ή πραγματικού τύπου.
4. Η συνάρτηση Α_Μ επιστρέφει ένα αποτέλεσμα
    ακέραιου ή πραγματικού τύπου.
5. Ένας μονοδιάστατος πίνακας έχει τουλάχιστον ένα
    στοιχείο.

Απαντήσεις

1.  Η επίλυση μιας δευτεροβάθμιας εξίσωσης είναι δομημένο
    πρόβλημα.
2.  Μια υπολογιστική διαδικασία που ολοκληρώνεται μετά
    από πεπερασμένο αριθμό βημάτων είναι αλγόριθμος.
3. Για να περιγράψουμε το φύλο ενός ανθρώπου χρειαζό-
    μαστε μια μεταβλητή λογικού ή αλφαριθμητικού τύπου.
4. Η συνάρτηση Α_Μ επιστρέφει ένα αποτέλεσμα
    ακέραιου  τύπου.
5. Ένας μονοδιάστατος πίνακας έχει τουλάχιστον δύο
    στοιχεία.

Πέμπτη, 4 Αυγούστου 2011

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1.  Η επίλυση ενός ανοικτού προβλήματος είναι πάντοτε
     εφικτή.
2.  Η καθοριστικότητα παραβιάζεται όταν οι εντολές
     δεν είναι απλές και άμεσα εκτελέσιμες.
3.  Στη δομή επιλογής όλες οι περιεχόμενες εντολές
     εκτελούνται τουλάχιστον μια φορά.
4.  Ο πολλαπλασιασμός αλά ρωσικά είναι μια μέθοδος
     υπολογισμού του γινομένου δύο θετικών ακεραίων,
     η οποία στηρίζεται στη λειτουργία της ολίσθησης.
5. Μια συνάρτηση η οποία ελέγχει αν ισχύει ή όχι μια
    ιδιότητα είναι λογικού τύπου.



Απάντηση

1. Σ
2. Λ
3. Λ
4. Σ
5. Σ