Τρίτη, 23 Αυγούστου 2011

Ποιά είναι η τελική τιμή της μεταβλητής

Ποιά είναι η τελική τιμή της μεταβλητής ζ μετά την εκτέλεση
των παρακάτω εντολών
      ζ <-- 100
      Για κ από 2 μέχρι 9
           Για λ από 12 μέχρι 1 με_βήμα -1
                Για μ από 15 μέχρι 3 με_βήμα -7
                      ζ <-- ζ-1
                Τέλος_επανάληψης
           Τέλος_επανάληψης
      Τέλος_επανάληψης


Απάντηση


      Η εξωτερική Για εκτελείται 8 φορές, η δεύτερη 12
      φορές και η πιο εσωτερική Για 2 φορές. Άρα η
      εντολή ζ <-- ζ-1 εκτελείται:
             8Χ12Χ2 = 192 φορές
     Συνεπώς ζ = 100-192*1 = 100-192 = -92

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου