Παρασκευή, 26 Αυγούστου 2011

Μετατροπές

Ξαναγράψτε το παρακάτω σύνολο εντολών
       Για κ από 120 μέχρι 10 με_βήμα -1
             Διάβασε Χ
             Αν Χ > 20 τότε 
                    Εμφάνισε κ*Χ
             αλλιώς_αν Χ > 5 τότε
                    Εμφάνισε (κ+1)*Χ
             αλλιώς
                    Εμφάνισε (κ+2)*Χ
             Τέλος_αν
       Τέλος_επανάληψης
αντικαθιστώντας :
α) την εντολή Για με Όσο
β) την εντολή Αν..τότε..αλλιώς_αν με εντολές Αν..τότε

Λύση

      κ <-- 120
      Όσο κ >= 10 επανάλαβε 
             Διάβασε Χ
             Αν Χ > 20 τότε 
                    Εμφάνισε κ*Χ
             Τέλος_αν            
             Αν (Χ > 5) ΚΑΙ (Χ <= 20) τότε
                    Εμφάνισε (κ+1)*Χ
             Τέλος_αν
             Αν Χ <= 5 τότε
                    Εμφάνισε (κ+2)*Χ
             Τέλος_αν
             κ <-- κ-1
       Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου