Σάββατο, 31 Δεκεμβρίου 2011

Εξαφανίστε την GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ακολουθεί τις αρχές του δομημένου προγραμματισμού
     Α <-- 0
     Κ <-- 100
10 : ΑΝ Κ < 0 ΤΟΤΕ GOTO 60
       Λ <-- 4
20 : ΑΝ Λ > 80 ΤΟΤΕ GOTO 70
       ΓΡΑΨΕ Κ^2+Λ^2
       Λ <-- Λ+4
       GOTO 20
       K <-- K-1
       GOTO 10
       ΓΡΑΨΕ 'ΑΝΤΙΟ 2011'

Λύση

     Α <-- 0
     Κ <-- 100
     ΟΣΟ Κ >= 0 ΕΠΑΝΑΛΑΒΕ
          Λ <-- 4
          ΟΣΟ Λ <= 80 ΕΠΑΝΑΛΑΒΕ
               ΓΡΑΨΕ Κ^2+Λ^2
               Λ <-- Λ+4
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          K <-- K-1
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΓΡΑΨΕ 'ΑΝΤΙΟ 2011'

      

Παρασκευή, 30 Δεκεμβρίου 2011

Πίνακας αλήθειας

Κατασκευάστε τον πίνακα αλήθειας της παράστασης
     ΟΧΙ ΚΑΙ Υ) Ή  Ζ

Λύση
Ας συμβολίσουμε για λόγους εξοικονόμησης χώρου με Α την
τιμή Αληθής και Ψ την τιμή Ψευδής. Ο πίνακας αλήθειας είναι
ο ακόλουθος:

Χ   Υ   Ζ   Χ ΚΑΙ Υ  ΟΧΙ(Χ ΚΑΙ Υ)  ΟΧΙ(Χ ΚΑΙ Υ) Ή Ζ
Α   Α   Α        Α                 Ψ                            Α
Α   Α   Ψ        Α                 Ψ                            Ψ
Α   Ψ   Α        Ψ                 Α                            Α
Α   Ψ   Ψ        Ψ                 Α                            Α
Ψ   Α   Α        Ψ                 Α                            Α
Ψ   Α   Ψ        Ψ                 Α                            Α
Ψ   Ψ   Α        Ψ                 Α                            Α
Ψ   Ψ   Ψ        Ψ                 Α                            Α

Πέμπτη, 29 Δεκεμβρίου 2011

Γέμισμα δυσδιάστατου πίνακα

Γράψτε αλγόριθμο που γεμίζει (γραμμή-γραμμή) τον πίνακα
Α[5, 2] με την προπαίδεια του Μ (θεωρείστε το Μ ως
δεδομένο).

Λύση

    Αλγόριθμος Ασκ
    Δεδομένα // Μ //
    Ρ <-- 1
    Για κ από 1 μέχρι 5
         Για λ από 1 μέχρι 2
               Α[κ, λ] <-- Ρ*Μ
               Ρ <-- Ρ+1
         Τέλος_επανάληψης
    Τέλος_επανάληψης
    Αποτελέσματα // Α //
    Τέλος Ασκ

Δευτέρα, 26 Δεκεμβρίου 2011

Επεξεργασία μονοδιάστατου πίνακα

Γράψτε αλγόριθμο που:
α) διαβάζει 15 ακέραιες  τιμές και τις καταχωρεί στον
    ακέραιο πίνακα Α[15],
β) υπολογίζει και εμφανίζει:
    * πόσα στοιχεία του πίνακα είναι μικρότερα του 5,
    * το ποσοστό (%) των στοιχείων του πίνακα που
       είναι θετικά,
    * το μέσο όρο των αρνητικών στοιχείων του πίνακα.

Λύση

     Αλγόριθμος ΑΣΚ
     Για κ από 1 μέχρι 15
           Διάβασε Α[κ]
     Τέλος_επανάληψης
     φ5 <-- 0
     θετ <-- 0
     σ <-- 0
     Αρν <-- 0
     Για κ από 1 μέχρι 15
          Αν Α[κ] < 5 τότε
               φ5 <-- φ5+1
          Τέλος_αν
          Αν Α[κ] > 0 τότε
              θετ  <-- θετ+1
          Τέλος_αν
          Αν Α[κ] < 0 τότε
                σ <-- σ+Α[κ]
                Αρν <-- Αρν+1
          Τέλος_αν
     Τέλος_επανάληψης
     Αν  Αρν > 0 τότε
          ΜΟΑρν <-- σ/Αρν
          Εμφάνισε ΜΟΑρν
     αλλιώς
          Εμφάνισε 'Δεν υπάρχουν καθόλου αρνητικοί!'
     Τέλος_αν
     ΠΟΣ <-- 100*Θετ/15
     Εμφάνισε ΠΟΣ
     Τέλος ΑΣΚ

Σάββατο, 24 Δεκεμβρίου 2011

Εμφωλευμένες δομές επανάληψης

Γράψτε αλγόριθμο που:
α) διαβάζει τις μηνιαίες εισπράξεις των τελευταίων 10 ετών
    για 15 επιχειρήσεις του Ηρακλείου,
β) υπολογίζει και εμφανίζει:
    * τις ετήσιες εισπράξεις κάθε επιχείρησης, για κάθε χρόνο
       ξεχωριστά,
    * τη μέση ετήσια είσπραξη για κάθε επιχείρηση ξεχωριστά,
    * τη μεγαλύτερη μηνιαία είσπραξη, τον αύξοντα αριθμό
       (1- 15) της επιχείρησης που την πραγματοποίησε και
       πότε συνέβη αυτό (αύξοντα αριθμό μήνα, αύξοντα αριθμό
       έτους).

Λύση

       Αλγόριθμος Επιχειρ
       Μεγ <-- -100
       Για κ από 1 μέχρι 15
            Αθρ <-- 0
            Για λ από 1 μέχρι 10
                  σ <-- 0
                  Για μ από 1 μέχρι 12
                       Διάβασε Μην
                       Αν Μην > Μεγ τότε
                             Μην <-- Μεγ
                             ΑΑΕπ <-- κ
                             ΑΑΧρ <-- λ
                             ΑΑΜην <-- μ
                       Τέλος_αν
                       σ <-- σ+Μην
                  Τέλος_επανάληψης
                  Εμφάνισε σ
                  Αθρ <-- Αθρ+σ
            Τέλος_επανάληψης
            ΜΟ <-- Αθρ/10
            Εμφάνισε ΜΟ
       Τέλος_επανάληψης
       Εμφάνισε Μεγ, ΑΑΕπ, ΑΑΧρ, ΑΑΜην
       Τέλος Επιχειρ

Παρασκευή, 23 Δεκεμβρίου 2011

Επιλέξτε είδος υποπρογράμματος

Προσδιορίστε το είδος του υποπρογράμματος (Σ - συνάρτηση,
Δ - διαδικασία) που απαιτείται για τα ακόλουθα έργα:
1. Εισαγωγή τριών ακεραίων αριθμών
2. Έλεγχος για την επιβεβαίωση μιας συγκεκριμένης ιδιότητας
    από όλα τα στοιχεία ενός πίνακα
3. Ταξινόμηση ενός πίνακα
4. Υπολογισμός περιμέτρου τραπεζίου
5. Υπολογισμός μέσου όρου κάποιων τιμών (η είσοδος
    δεδομένων ολοκληρώνεται μόλις δοθεί από το
    πληκτρολόγιο τιμή μη θετική)

Απαντήσεις

1. Δ
2. Σ
3. Δ
4. Σ
5. Δ

Πέμπτη, 22 Δεκεμβρίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[100, 3] και αντιγράφει τα στοιχεία της
1ης, 2ης και 3ης στήλης στους ακέραιους πίνακες Β[100],
Γ[100], και Δ[100] αντίστοιχα.

Λύση

    ΔΙΑΔΙΚΑΣΙΑ ΑΝΤΙΓΡ(Α, Β, Γ, Δ)
    ΜΕΤΑΒΛΗΤΕΣ
         ΑΚΕΡΑΙΕΣ: Α[100, 3], Β[100], Γ[100], Δ[100], Κ
    ΑΡΧΗ
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 100
                Β[Κ] <-- Α[Κ, 1]
                Γ[Κ] <-- Α[Κ, 2]
                Δ[Κ] <-- Α[Κ, 3]
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τετάρτη, 21 Δεκεμβρίου 2011

Χρησιμοποιήστε μόνο την λογική πράξη ΚΑΙ

Ξαναγράψτε τις παρακάτω λογικές εκφράσεις χρησιμοποιώντας
μόνο τη λογική πράξη ΚΑΙ
1. ΟΧΙ (Χ = 18) ΚΑΙ  ( (Χ > 5) Ή (Χ = 5) )
2. ΟΧΙ ( (Χ < 2) Ή (Χ >= 19) )
3. ΟΧΙ (ΟΧΙ ( (Χ > 0) ΚΑΙ MOD 2 = 0) ) )
4. ΟΧΙ ΟΧΙ (Χ < 0) Ή ΟΧΙ (Υ = 'Α') )

Απαντήσεις


1. (Χ < > 18) ΚΑΙ (Χ >=5)
2. (Χ >= 2) ΚΑΙ (Χ < 19)
3. (Χ > 0) ΚΑΙ (Χ MOD 2 = 0)
4. (Χ < 0) ΚΑΙ (Υ = 'Α')

Τρίτη, 20 Δεκεμβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[11, 11] και ελέγχει αν το άθροισμα των
στοιχείων της 1ης κυρίας διαγωνίου είναι ίσο με το
άθροισμα των στοιχείων της 2ης κυρίας διαγωνίου.

Λύση

    ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ (Α) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Α[11, 11], Κ, ΑΘΡ1, ΑΘΡ2
    ΑΡΧΗ
          ΑΘΡ1 <-- 0
          ΑΘΡ2 <-- 0
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 11
                ΑΘΡ1 <-- ΑΘΡ1+Α[Κ, Κ]
                ΑΘΡ2 <-- ΑΘΡ2+Α[Κ, 12-Κ]
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΕΛΕΓΧΟΣ <-- (ΑΘΡ1 = ΑΘΡ2)
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Κυριακή, 18 Δεκεμβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μια εντολή _________ είναι ιδανική για τον έλεγχο
    εγκυρότητας εισερχόμενων δεδομένων.
2. Η ισχύς των μεταβλητών και των συμβολικών σταθερών
    σε ένα υποπρόγραμμα είναι _______.
3. Μεγαλύτερη προτεραιότητα από όλους τους τελεστές
    έχουν οι _________.
4. Για να προσδιορίσουμε ένα στοιχείο κάποιου πίνακα
    απαιτούνται ένας ή περισσότεροι ______.
5. Ένα ______ πρόβλημα επιδέχεται τουλάχιστον μια λύση.

Απαντήσεις

1. Μέχρις_ότου
2. τοπική
3. αριθμητικοί
4. δείκτες
5. επιλύσιμο

Πέμπτη, 15 Δεκεμβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μια _________ παράσταση έχει ως αποτέλεσμά την τιμή
    ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ.
2. Οι λειτουργίες της εισαγωγής και της _______ δεν μπορούν
    να γίνουν σε έναν πίνακα.
3. Ένα υποπρόγραμμα εκτελεί ένα ___________ έργο.
4. Ο ____________ είναι ένα μέσο παραγωγής πληροφοριών.
5. Για να περιγράψουμε το αποτέλεσμα μιας εξεταστικής
    διαδικασίας (επιτυχημένη ή αποτυχημένη) μπορούμε να
    χρησιμοποιήσουμε μια λογική ή _______ μεταβλητή.


Απαντήσεις

1. λογική
2. διαγραφής
3. αυτόνομο
4. αλγόριθμος
5. αλφαριθμητική

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος
1. Ένα πρόγραμμα  έχει τουλάχιστον μια εντολή.
2. Ο τύπος των συμβολικών σταθερών δηλώνεται σε
    ξεχωριστό τμήμα δηλώσεων του προγράμματος.
3. Εμφωλευμένες δομές ακολουθίας είναι δύο ή
   περισσότερες δομές ακολουθίας που βρίσκονται η
   μία μέσα στην άλλη.
4. Τα αλφαριθμητικά δεδομένα δεν μπορούν να
    ταξινομηθούν.
5. Μια διαδικασία μπορεί να κληθεί και μέσα από μια
    εντολή ΓΡΑΨΕ.


Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Λ
5. Λ

Τετάρτη, 14 Δεκεμβρίου 2011

Συγγραφή διαδικασίας

Θεωρείστε τους ακόλουυθους πίνακες:
* ΣΥΓΚ[200], που περιέχει τα ονόματα 200 μουσικών
   συγκροτημάτων,
* ΕΘΝ[200], που περιέχει τη χώρα προέλευσης των
  συγκροτημάτων αυτών.
Γράψτε διαδικασία που δέχεται ως παραμέτρους τους
δύο παραπάνω πίνακες και :
α) υπολογίζει το συνολικό πλήθος των συγκροτημάτων
    που προέρχονται από την ΕΛΛΑΔΑ,
β) καταχωρεί σε πίνακα τα ονόματα των συγκροτημάτων
    αυτών.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΜΟΥΣΙΚΗ(ΣΥΓΚ, ΕΘΝ, Ελλ, ΣυγκΕλλ)
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Ελλ, Κ
          ΧΑΡΑΚΤΗΡΕΣ: ΣΥΓΚ[200], ΕΘΝ[200], ΣυγκΕλλ[200]
     ΑΡΧΗ
           Ελλ <-- 0
           ΓΙΑ Κ ΑΠΌ 1 ΜΕΧΡΙ 200
               ΑΝ ΕΘΝ[Κ] = 'ΕΛΛΑΔΑ' ΤΟΤΕ
                    Ελλ <-- Ελλ+1
                    ΣυγκΕλλ[Ελλ] <-- ΣΥΓΚ[Κ]
               ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τρίτη, 13 Δεκεμβρίου 2011

Άσκηση : δυσδιάστατοι πίνακες

Οι 25 μαθητές μιας τάξης υποβάλλονται σε 10 ερωτήσεις
προκειμένου να αξιολογηθούν από τον καθηγητή τους.
Γράψτε αλγόριθμο που:
α) διαβάζει τι απάντησαν οι μαθητές σε κάθε ερώτηση
    και καταχωρεί τα δεδομένα αυτά στον αλφαριθμητικό
    πίνακα ΑΠ[25, 10] (δυνατές τιμές εισόδου είναι:
    Σ - σωστή απάντηση, Λ - λανθασμένη απάντηση,
    ΔΕΝ - δεν δόθηκε απάντηση),
β) υπολογίζει και καταχωρεί στον πίνακα ΕΡ[10, 3]
     πόσες σωστές, λανθασμένες και καθόλου απαντήσεις
     δόθηκαν σε κάθε ερώτηση,
γ) εμφανίζει τον αριθμό της ερώτησης που αποδείχθηκε
    πιο εύκολη (θεωρείστε ότι είναι μοναδική).
Παρατήρηση : Ο αλγόριθμος πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων.

Λύση

      Αλγόριθμος Τάξη
      Για κ από 1 μέχρι 25
          Για λ από 1 μέχρι 10
               Αρχή_επανάληψης
                     Διάβασε ΑΠ[κ, λ]
               Μέχρις_ότου (ΑΠ[κ, λ] = 'Σ') Ή (ΑΠ[κ, λ] = 'Λ')
                                     Ή (ΑΠ[κ, λ] = 'ΔΕΝ')
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για κ από 1 μέχρι 10
          Για λ από 1 μέχρι 3
               ΕΡ[κ, λ] <-- 0  
         Τέλος_επανάληψης

      Τέλος_επανάληψης
      Για λ από 1 μέχρι 10
          Για κ από 1 μέχρι 25
               Αν ΑΠ[κ, λ] = 'Σ' τότε
                    ΕΡ[λ, 1] <-- ΕΡ[λ, 1]+1   
               αλλιώς_αν ΑΠ[κ, λ] = 'Λ' τότε
                    ΕΡ[λ, 2] <-- ΕΡ[λ, 2]+1
               αλλιώς
                    ΕΡ[λ, 3] <-- ΕΡ[λ, 3]+1
                Τέλος_αν 
         Τέλος_επανάληψης

      Τέλος_επανάληψης
      Μεγ <-- ΕΡ[1, 1]
      ΑΑΜεγ <-- 1
      Για κ από 2 μέχρι 10
          Αν ΕΡ[κ, 1] > Μεγ τότε
               Μεγ <-- ΕΡ[κ, 1]
               ΑΑΜεγ <-- κ
          Τέλος_αν
      Τέλος_επανάληψης
      Εμφάνισε ΑΑΜεγ
      Αποτελέσματα // ΕΡ // 
      Τέλος Τάξη


     

Παρασκευή, 9 Δεκεμβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιές από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος;
1. Κάθε πρόγραμμα μπορεί να υλοποιηθεί και ως συνάρτηση.
2. Η στοίβα χρόνου εκτέλεσης "φιλοξενεί" τις διευθύνσεις
    επιστροφής των υποπρογραμμάτων.
3. Μια συνάρτηση μπορεί να κληθεί μόνο μέσα από το
    κύριο πρόγραμμα και ποτέ μέσα από κάποιο άλλο
    υποπρόγραμμα.
4. Οι πίνακες δίνουν απεριόριστες δυνατότητες στους
    προγραμματιστές.
5. Τα αρχεία εγγραφών είναι δομές δεδομένων
    δευτερεύουσας μνήμης.


Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους δύο
τιμές Ν, Μ (θεωρείστε ότι το Ν είναι διάφορο του μηδενός)
και ελέγχει αν το Μ είναι πολλαπλάσιο του Ν ή όχι.

Λύση

     ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Ν, Μ) : ΛΟΓΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Ν, Μ
     ΑΡΧΗ
          ΑΝ M MOD N = 0 TOTE
                 ΕΛΕΓΧΟΣ <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
                 ΕΛΕΓΧΟΣ <-- ΨΕΥΔΗΣ

          ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Παρατήρηση
Η ΑΝ..ΤΟΤΕ..ΑΛΛΙΩΣ θα μπορούσε να αντικατασταθεί
ως εξής:
       ΕΛΕΓΧΟΣ <-- (Μ MOD N = 0)
   

Τετάρτη, 7 Δεκεμβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[200] και εξετάζει αν ισχύει η
ιδιότητα :
       Α[Κ] <= Α[Κ+2] <= Α[Κ+1]
για Κ = 1, 2, ..., 198

Λύση

      ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Α) : ΛΟΓΙΚΗ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Α[200], Κ
             ΛΟΓΙΚΕΣ : ΑΠ
      ΑΡΧΗ
             ΑΠ <-- ΑΛΗΘΗΣ
             Κ <-- 1
             ΟΣΟ (Κ <= 198) ΚΑΙ (ΑΠ = ΑΛΗΘΗΣ) ΕΠΑΝΑΛΑΒΕ
                   ΑΝ (Α[Κ] > Α[Κ+2]) Ή (Α[Κ+2] > Α[Κ+1) ΤΟΤΕ
                          ΑΠ <-- ΨΕΥΔΗΣ
                   ΑΛΛΙΩΣ
                          Κ <-- Κ+1
                   ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΕΛΕΓΧΟΣ <-- ΑΠ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δευτέρα, 5 Δεκεμβρίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που διαβάζει τα χρώματα κάποιων
t-shirt (η είσοδος δεδομένων τερματίζεται μόλις
δοθεί ως χρώμα η λέξη 'ΑΧΡΩΜΟ') και υπολογίζει :
α) πόσα t-shirt είχαν χρώμα ΛΕΥΚΟ,
β) το ποσοστό (%) των t-shirt  που είχαν χρώμα ΜΑΥΡΟ,
γ) το συνολικό πλήθος όλων των t-shirt.
Παρατήρηση : Θεωρείστε ότι δόθηκαν δεδομένα για
τουλάχιστον ένα t-shirt.

Λύση


       ΔΙΑΔΙΚΑΣΙΑ ΧΡΩΜΑΤΑ(Πληθ, Λευκ, ΠΟΣ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ : Πληθ, Λευκ, Μαυρ
             ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
             ΧΑΡΑΚΤΗΡΕΣ: Χρ
       ΑΡΧΗ
              Πληθ <-- 0
              Λευκ <-- 0
              Μαυρ <-- 0
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                     ΔΙΑΒΑΣΕ Χρ
                     ΑΝ Χρ < > 'ΑΧΡΩΜΟ' ΤΟΤΕ
                           Πληθ <-- Πληθ+1
                           ΑΝ Χρ = 'ΛΕΥΚΟ' ΤΟΤΕ
                                 Λευκ <-- Λευκ+1
                           ΤΕΛΟΣ_ΑΝ
                           ΑΝ Χρ = 'ΜΑΥΡΟ' ΤΟΤΕ
                                 Μαυρ <-- Μαυρ+1
                           ΤΕΛΟΣ_ΑΝ
                     ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ Χρ = 'ΑΧΡΩΜΟ'
              ΠΟΣ <-- 100*Μαυρ/Πληθ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ




Σάββατο, 3 Δεκεμβρίου 2011

Άσκηση : Εμφωλευμένα Για+βοηθητικός πίνακας

Θέλετε να σχεδιάσετε πάνω σε μια κόλλα χαρτί  τέσσερα
τετράγωνα. Γράψτε αλγόριθμο που εμφανίζει όλους τους
δυνατούς συνδυασμούς χρωμάτων με τους οποίους μπορείτε να
τα σχεδιάσετε.Τα χρώματα που μπορείτε να χρησιμοποιήσετε
για το καθένα είναι μπλε, κόκκινο, πράσινο και κίτρινο.

Λύση

     Αλγόριθμος Ασκ
     Χ[1] <-- 'μπλε'
     Χ[2] <-- 'κόκκινο'
     Χ[3] <-- 'πράσινο'
     Χ[4] <-- 'κίτρινο'
     Για κ από 1 μέχρι 4
         Για λ από 1 μέχρι 4
              Για μ από 1 μέχρι 4
                   Για ρ από 1 μέχρι 4
                       Εμφάνισε Χ[κ], Χ[λ], Χ[μ], Χ[ρ]
                   Τέλος_επανάληψης
              Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Τέλος Ασκ

Πέμπτη, 1 Δεκεμβρίου 2011

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η εντολή Διαβάστε Χ έχει ένα λογικό λάθος.
2. Η εντολή Εμφάνισε '1+2*3' εμφανίζει στη μονάδα
    εξόδου : 5
3. Μια αριθμητική μεταβλητή χρειάζεται για την
    αποθήκευσή της στη μνήμη 2 bytes.
4. Οι εντολές Όσο..επανάλαβε και Για..από..μέχρι
    είναι ισοδύναμες μεταξύ τους.
5. Ένας μονοδιάστατος πίνακας έχει τουλάχιστον ένα
    στοιχείο.



Απαντήσεις

1. Η εντολή Διαβάστε Χ έχει ένα συντακτικό λάθος.
2. Η εντολή Εμφάνισε '1+2*3' εμφανίζει στη μονάδα
    εξόδου :1+2*3
3. Μια αριθμητική μεταβλητή χρειάζεται για την
    αποθήκευσή της στη μνήμη 2 ή 4  bytes.
4. Οι εντολές Όσο..επανάλαβε και Μέχρις_ότου
    είναι ισοδύναμες μεταξύ τους.
5.  Ένας μονοδιάστατος πίνακας έχει τουλάχιστον δύο 
     στοιχεία.