Δευτέρα, 5 Δεκεμβρίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που διαβάζει τα χρώματα κάποιων
t-shirt (η είσοδος δεδομένων τερματίζεται μόλις
δοθεί ως χρώμα η λέξη 'ΑΧΡΩΜΟ') και υπολογίζει :
α) πόσα t-shirt είχαν χρώμα ΛΕΥΚΟ,
β) το ποσοστό (%) των t-shirt  που είχαν χρώμα ΜΑΥΡΟ,
γ) το συνολικό πλήθος όλων των t-shirt.
Παρατήρηση : Θεωρείστε ότι δόθηκαν δεδομένα για
τουλάχιστον ένα t-shirt.

Λύση


       ΔΙΑΔΙΚΑΣΙΑ ΧΡΩΜΑΤΑ(Πληθ, Λευκ, ΠΟΣ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ : Πληθ, Λευκ, Μαυρ
             ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
             ΧΑΡΑΚΤΗΡΕΣ: Χρ
       ΑΡΧΗ
              Πληθ <-- 0
              Λευκ <-- 0
              Μαυρ <-- 0
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                     ΔΙΑΒΑΣΕ Χρ
                     ΑΝ Χρ < > 'ΑΧΡΩΜΟ' ΤΟΤΕ
                           Πληθ <-- Πληθ+1
                           ΑΝ Χρ = 'ΛΕΥΚΟ' ΤΟΤΕ
                                 Λευκ <-- Λευκ+1
                           ΤΕΛΟΣ_ΑΝ
                           ΑΝ Χρ = 'ΜΑΥΡΟ' ΤΟΤΕ
                                 Μαυρ <-- Μαυρ+1
                           ΤΕΛΟΣ_ΑΝ
                     ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ Χρ = 'ΑΧΡΩΜΟ'
              ΠΟΣ <-- 100*Μαυρ/Πληθ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ




Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου