Τρίτη, 13 Δεκεμβρίου 2011

Άσκηση : δυσδιάστατοι πίνακες

Οι 25 μαθητές μιας τάξης υποβάλλονται σε 10 ερωτήσεις
προκειμένου να αξιολογηθούν από τον καθηγητή τους.
Γράψτε αλγόριθμο που:
α) διαβάζει τι απάντησαν οι μαθητές σε κάθε ερώτηση
    και καταχωρεί τα δεδομένα αυτά στον αλφαριθμητικό
    πίνακα ΑΠ[25, 10] (δυνατές τιμές εισόδου είναι:
    Σ - σωστή απάντηση, Λ - λανθασμένη απάντηση,
    ΔΕΝ - δεν δόθηκε απάντηση),
β) υπολογίζει και καταχωρεί στον πίνακα ΕΡ[10, 3]
     πόσες σωστές, λανθασμένες και καθόλου απαντήσεις
     δόθηκαν σε κάθε ερώτηση,
γ) εμφανίζει τον αριθμό της ερώτησης που αποδείχθηκε
    πιο εύκολη (θεωρείστε ότι είναι μοναδική).
Παρατήρηση : Ο αλγόριθμος πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων.

Λύση

      Αλγόριθμος Τάξη
      Για κ από 1 μέχρι 25
          Για λ από 1 μέχρι 10
               Αρχή_επανάληψης
                     Διάβασε ΑΠ[κ, λ]
               Μέχρις_ότου (ΑΠ[κ, λ] = 'Σ') Ή (ΑΠ[κ, λ] = 'Λ')
                                     Ή (ΑΠ[κ, λ] = 'ΔΕΝ')
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για κ από 1 μέχρι 10
          Για λ από 1 μέχρι 3
               ΕΡ[κ, λ] <-- 0  
         Τέλος_επανάληψης

      Τέλος_επανάληψης
      Για λ από 1 μέχρι 10
          Για κ από 1 μέχρι 25
               Αν ΑΠ[κ, λ] = 'Σ' τότε
                    ΕΡ[λ, 1] <-- ΕΡ[λ, 1]+1   
               αλλιώς_αν ΑΠ[κ, λ] = 'Λ' τότε
                    ΕΡ[λ, 2] <-- ΕΡ[λ, 2]+1
               αλλιώς
                    ΕΡ[λ, 3] <-- ΕΡ[λ, 3]+1
                Τέλος_αν 
         Τέλος_επανάληψης

      Τέλος_επανάληψης
      Μεγ <-- ΕΡ[1, 1]
      ΑΑΜεγ <-- 1
      Για κ από 2 μέχρι 10
          Αν ΕΡ[κ, 1] > Μεγ τότε
               Μεγ <-- ΕΡ[κ, 1]
               ΑΑΜεγ <-- κ
          Τέλος_αν
      Τέλος_επανάληψης
      Εμφάνισε ΑΑΜεγ
      Αποτελέσματα // ΕΡ // 
      Τέλος Τάξη


     

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου