Δευτέρα, 26 Δεκεμβρίου 2011

Επεξεργασία μονοδιάστατου πίνακα

Γράψτε αλγόριθμο που:
α) διαβάζει 15 ακέραιες  τιμές και τις καταχωρεί στον
    ακέραιο πίνακα Α[15],
β) υπολογίζει και εμφανίζει:
    * πόσα στοιχεία του πίνακα είναι μικρότερα του 5,
    * το ποσοστό (%) των στοιχείων του πίνακα που
       είναι θετικά,
    * το μέσο όρο των αρνητικών στοιχείων του πίνακα.

Λύση

     Αλγόριθμος ΑΣΚ
     Για κ από 1 μέχρι 15
           Διάβασε Α[κ]
     Τέλος_επανάληψης
     φ5 <-- 0
     θετ <-- 0
     σ <-- 0
     Αρν <-- 0
     Για κ από 1 μέχρι 15
          Αν Α[κ] < 5 τότε
               φ5 <-- φ5+1
          Τέλος_αν
          Αν Α[κ] > 0 τότε
              θετ  <-- θετ+1
          Τέλος_αν
          Αν Α[κ] < 0 τότε
                σ <-- σ+Α[κ]
                Αρν <-- Αρν+1
          Τέλος_αν
     Τέλος_επανάληψης
     Αν  Αρν > 0 τότε
          ΜΟΑρν <-- σ/Αρν
          Εμφάνισε ΜΟΑρν
     αλλιώς
          Εμφάνισε 'Δεν υπάρχουν καθόλου αρνητικοί!'
     Τέλος_αν
     ΠΟΣ <-- 100*Θετ/15
     Εμφάνισε ΠΟΣ
     Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου