Κυριακή, 29 Ιουλίου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η δομή επανάληψης είναι μια ________ συνιστώσα.
2. Η δομή _______ είναι η απλούστερη αλγοριθμική δομή.
3. Η δομή ______ μας επιτρέπει να ελέγχουμε μια συνθήκη
    και ανάλογα να αποφασίζουμε για τη συνέχεια των ενεργειών
    μας.
4. Η εντολή α <-- β/γ παραβιάζει το κριτήριο της _________
    εφόσον προηγουμένως δεν έχει διασφαλιστεί ότι γ < > 0.
5. Η εντολή ________ επιτρέπει την εναλλαγή τιμών ανάμεσα
   σε δύο μεταβλητές.


Απαντήσεις

1. συνιστώσα
2. ακολουθίας
3. επιλογής
4. καθοριστικότητας
5. αντιμετάθεσε

Παρασκευή, 20 Ιουλίου 2012

Ερωτήσεις σωστού/λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η διατύπωση ενός προβλήματος πρέπει να γίνεται με σαφήνεια
    και ακρίβεια.
2. Ο αλγόριθμος πρέπει να ολοκληρώνει την επίλυση του
    προβλήματος μέσα σε πεπερασμένο χρόνο.
3. Τα στοιχεία ενός πίνακα καταλαμβάνουν μη συνεχόμενες
    θέσεις της κύριας μνήμης του υπολογιστή.
4. Τα υποπρογράμματα είναι βασικό και αναπόσπαστο
    στοιχείο του δομημένου προγραμματισμού.
5. Κάθε πρόγραμμα περιλαμβάνει τουλάχιστον μια
    δομή επιλογής

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ

Πέμπτη, 19 Ιουλίου 2012

Συγγραφή συνάρτησης

Θεωρήστε την ακόλουθη δομή επανάληψης:
     Για κ από Α μέχρι Β με_βήμα Γ
          Εμφάνισε 'φορές'
     Τέλος_επανάληψης
Γράψτε συνάρτηση η οποία δέχεται ως παραμέτρους
τις ακέραιες τιμές Α, Β, Γ και επιστρέφει το χαρακτήρα:
* Μ, αν πραγματοποιείται τουλάχιστον μια επανάληψη,
* Τ, αν ο βρόχος είναι ατέρμων,
* Κ, αν δεν πραγματοποιείται καμία επανάληψη

Λύση


     ΣΥΝΑΡΤΗΣΗ ΕΛ(Α, Β, Γ) : ΧΑΡΑΚΤΗΡΑΣ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Γ
     ΑΡΧΗ
           ΑΝ Γ = 0 ΤΟΤΕ
                 ΑΝ Α <= Β ΤΟΤΕ
                      ΕΛ <-- 'Τ'
                 ΑΛΛΙΩΣ
                      ΕΛ <-- 'Κ'
                 ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ_ΑΝ Γ > 0 ΤΟΤΕ
                  ΑΝ Α <= Β ΤΟΤΕ
                        ΕΛ <-- 'Μ'
                  ΑΛΛΙΩΣ
                        ΕΛ <-- 'Κ'
                  ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ   ! Γ < 0
                  ΑΝ Α >= Β ΤΟΤΕ
                        ΕΛ <-- 'Μ'
                  ΑΛΛΙΩΣ
                        ΕΛ <-- 'Κ'
                  ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους
τρεις ακέραιους Χ, Υ, Ζ και ελέγχει αν κάποιος
από αυτούς ισούται με το γινόμενο των δύο άλλων.

Λύση


    ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Χ, Υ, Ζ) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ
    ΑΡΧΗ
          ΑΝ  (Χ = Υ*Ζ) Ή (Υ = Χ*Ζ ) Ή (Ζ = Χ*Υ) ΤΟΤΕ
               ΕΛΕΓΧΟΣ <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
               ΕΛΕΓΧΟΣ <-- ΨΕΥΔΗΣ
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σάββατο, 14 Ιουλίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο ένα σύνολο bytes και
υπολογίζει σε πόσα GB, MB, ΚΒ και bytes αντιστοιχεί.
Υπενθυμίζεται ότι:
      ΚΒ = 1024 bytes
      MB = 1024 KB
      GB = 1024 MB

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΠΟΛ(TOTAL, GB, MB, KB, BYTES)
     METAΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: ΤΟΤΑL, GB, MB, KB, BYTES
     ΑΡΧΗ
            GB <-- TOTAL DIV 1024^3
            MB <-- (TOTAL MOD 1024^3) DIV 1024^2
            KB <-- ( (TOTAL MOD 1024^3) MOD 1024^2) DIV 1024
      BYTES <-- ( (TOTAL MOD 1024^3) MOD 1024^2) MOD 1024
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρασκευή, 13 Ιουλίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που υπολογίζει το πλήθος των
ακέραιων λύσεων της εξίσωσης ΑΧ+ΒΥ+ΓΖ+Δ = 0 στο
διάστημα [-1000, 1000]. Θεωρείστε ότι οι συντελεστές
Α, Β, Γ, Δ είναι ακεραίου τύπου.

Λύση

       ΣΥΝΑΡΤΗΣΗ Εξίσωση(Α, Β, Γ, Δ) : ΑΚΕΡΑΙΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α, Β, Γ, Δ, ΠΛΗΘ, Χ, Υ, Ζ
       ΑΡΧΗ
              ΠΛΗΘ <-- 0
              ΓΙΑ Χ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                    ΓΙΑ Υ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                         ΓΙΑ Ζ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                               ΑΝ Α*Χ+Β*Υ+Γ*Ζ+Δ = 0 ΤΟΤΕ
                                      ΠΛΗΘ <-- ΠΛΗΘ+1
                               ΤΕΛΟΣ_ΑΝ
                         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              Εξίσωση <-- ΠΛΗΘ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Πίνακας αντιστοίχησης

Αντιστοιχήστε τις συναρτήσεις (1-5) με τον τύπο τους
(α-δ).
Συναρτήσεις
1. Υπολογισμός απόστασης δύο σημείων
2. Έλεγχος αν δύο αριθμητικές ποσότητες Χ, Υ είναι
    ίσες μεταξύ τους.
3. Εντοπισμός του πρώτου γράμματος σε μια λέξη.
4. Υπολογισμός του ποσοστού (%) των ανδρών σε
    ένα σύλλογο
5. Υπολογισμός του πλήθους των αριστούχων μαθητών
    σε ένα λύκειο.

Τύπος
α. ΑΚΕΡΑΙΑ
β. ΛΟΓΙΚΗ
γ. ΧΑΡΑΚΤΗΡΑΣ
δ. ΠΡΑΓΜΑΤΙΚΗ

Απαντήσεις
1. δ
2. β
3. γ
4. δ
5. α


Πίνακας αντιστοίχησης

Αντιστοιχήστε τα προβλήματα (1-5) με την
κατηγορία στην οποία ανήκουν (α-γ).
Προβλήματα
1. Υπολογισμός όγκου σφαίρας
2.  Επιλογή θρησκεύματος
3.  Ψηφοφορία σε εθνικές εκλογές
4.  Υπολογισμός περιμέτρου τετραγώνου
5.  Διαχείριση ελεύθερου χρόνου

Κατηγορίες
α. δομημένα
β. ημιδομημένα
γ. αδόμητα

Απαντήσεις

1. α
2. β
3. β
4. α
5. γ






Πέμπτη, 12 Ιουλίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Ο ρόμβος σε ένα λογικό διάγραμμα έχει μία ή περισσότερες
    εξόδους για απάντηση.
2. Η πράξη Χ ΚΑΙ Υ δίνει αποτέλεσμα ΑΛΗΘΗΣ όταν
    τουλάχιστον μια από τις μεταβλητές Χ, Υ έχει την τιμή
    ΑΛΗΘΗΣ.
3. Η πράξη * έχει μεγαλύτερη προτεραιότητα από την
    πράξη div.
4. Τα δομημένα προβλήματα μπορεί να είναι επιλύσιμα.
5. Η εντολή ΚΑΛΕΣΕ χρησιμοποιείται για να αρχικοποιή-
    σουμε το περιεχόμενο ενός πίνακα.




Απαντήσεις


1. Ο ρόμβος σε ένα λογικό διάγραμμα έχει δύο ή περισσότερες
    εξόδους για απάντηση.

2. Η πράξη Χ ΚΑΙ Υ δίνει αποτέλεσμα ΑΛΗΘΗΣ όταν
   και οι δύο  μεταβλητές Χ, Υ έχουν την τιμή  ΑΛΗΘΗΣ.

3. Η πράξη * έχει ίδια προτεραιότητα από την
    πράξη div.
4. Τα επιλύσιμα προβλήματα μπορεί να είναι δομημένα.

5. Η εντολή ΚΑΛΕΣΕ χρησιμοποιείται για να καλέσουμε μια
    διαδικασία.






Σάββατο, 7 Ιουλίου 2012

Κυκλώστε τα σωστά

Κυκλώστε τα νούμερα (1-6) που αντιστοιχούν σε
σωστές προτάσεις
1. Ένα πρόβλημα μπορεί να μην έχει λύση.
2. Ο αλγόριθμος είναι ένας μηχανισμός
    δημιουργίας υποπρογραμμάτων.
3. Ένα πρόγραμμα έχει το δικό του τμήμα δήλωσης
    συμβολικών σταθερών.
4. Η συνάρτηση επιστρέφει ένα ή περισσότερα 
    αποτελέσματα.
5. Ο πίνακας είναι μια συλλογή δεδομένων ίδιου
    αριθμητικού τύπου.
6. Η γλώσσα C χρησιμοποιείται για τη δημιουργία
    λειτουργικών συστημάτων.

Απαντήσεις

1, 3, 6

Τετάρτη, 4 Ιουλίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο έναν
πραγματικό πίνακα Α[14, 14] και υπολογίζει πόσα
στοιχεία της 1ης κυρίας διαγωνίου έχουν τιμή μεγαλύτερη
από το μέσο όρο του πίνακα.

Απάντηση

     ΣΥΝΑΡΤΗΣΗ ΠΟΣΑ(Α) : ΑΚΕΡΑΙΑ
     ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Α[14, 14], Σ, ΜΟ
          ΑΚΕΡΑΙΕΣ:  ΠΛΗΘ, Κ, Λ
     ΑΡΧΗ
           Σ <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 14
               ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 14
                    Σ <-- Σ+Α[Κ, Λ]
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΜΟ <-- Σ/196
           ΠΛΗΘ <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 14
                ΑΝ Α[Κ, Κ] > ΜΟ ΤΟΤΕ
                      ΠΛΗΘ <-- ΠΛΗΘ+1
                ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΠΟΣΑ <-- ΠΛΗΘ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παραμέτρους δύο
ακέραιους Α, Β ( Α < Β) και εμφανίζει όλους τους
ακέραιους στο διάστημα [Α, Β] που είναι περιττοί
και πολλαπλάσια του 7.

Απάντηση

     ΔΙΑΔΙΚΑΣΙΑ Διάστημα(Α, Β)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Κ
     ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ Α  ΜΕΧΡΙ Β
                ΑΝ MOD 2 = 1) KAI (K MOD 7 = 0) TOTE
                      ΓΡΑΨΕ Κ
                ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω
προτάσεις
1. Η _________ ενός προβλήματος εξαρτάται από
    τη σωστή διατύπωση του εκ μέρους του δημιουργού
    και τη σωστή ερμηνεία του εκ μέρους του ______.
2. Η ______ με την οποία διατυπώνεται ένα πρόβλημα
    πρέπει να είναι τέτοια ώστε να μπορεί να γίνει
    αντιληπτή με μια από τις πέντε ανθρώπινες
    _________.
3. Το αποτέλεσμα της επεξεργασίας των _________
     αποκαλείται ____________.
4. Η ______ ενός προβλήματος καθορίζεται κατά τη φάση
    της _________.
5. Η ανάλυση ενός προβλήματος μπορεί να αναπαρασταθεί
    είτε _______ είτε ________.



Απαντήσεις

1. κατανόηση, επιλυτή
2. μορφή, αισθήσεις
3. δεδομένων, πληροφορία
4. δομή, ανάλυσης
5. λεκτικά, διαγραμματικά

Σαφήνεια διατύπωσης

Επιλύστε τη δευτεροβάθμια εξίσωση
    Χ^2+3*Χ+5 = 0
Είναι το παραπάνω πρόβλημα καθορισμένο με σαφήνεια;

Απάντηση

Η διατύπωση του προβλήματος είναι ασαφής αφού δεν
προσδιορίζει το πεδίο ορισμού της εξίσωσης. Για
παράδειγμα στο R είναι αδύνατη ενώ στους μιγαδικούς
έχει λύσεις.

Τρίτη, 3 Ιουλίου 2012

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η συνάρτηση ΑΠΟΛ είναι προκαθορισμένη συνάρτηση
    της ΓΛΩΣΣΑΣ
2. Ο τελεστής + έχει μεγαλύτερη προτεραιότητα από τον
    τελεστή -
3. Μια λογική παράσταση έχει τιμή 'ΑΛΗΘΗΣ' ή 'ΨΕΥΔΗΣ'
4. Σε μια εντολή εκχώρησης μπορούμε να συναντήσουμε
    μια μεταβλητή και στα δύο μέρη της.
5. Η συνάρτηση δεν μπορεί να μεταβάλλει τις τιμές των
    πραγματικών παραμέτρων της.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ


Πίνακας δεδομένων-ζητουμένων

Το βάρος μου είναι κατά 12 κιλά μεγαλύτερο από το βάρος
του αδερφού μου. Αν και οι δυο μαζί ζυγίζουμε 132 κιλά.
πόσα είναι το βάρος καθενός;
α) Κατασκευάστε πίνακα δεδομένων-ζητουμένων
β) Μορφοποιήστε με μαθηματικό τρόπο το πρόβλημα.

Λύση

α)
    
      Δεδομένα         
               * Το βάρος μου είναι 12  κιλά
               * Το συνολικό βάρος εμένα και του αδερφού
                  μου είναι 132 κιλά
      Ζητούμενα
               * Πόσο είναι το βάρος μου;
               * Πόσο είναι το βάρος του αδερφού μου;

β)
     Ας συμβολίσουμε με:
            Β1, το βάρος μου
            Β2, το βάρος του αδερφού μου
     Ισχύουν οι σχέσεις:
            Β1 = Β2+12
            Β1+Β2 = 132