Παρασκευή, 13 Ιουλίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που υπολογίζει το πλήθος των
ακέραιων λύσεων της εξίσωσης ΑΧ+ΒΥ+ΓΖ+Δ = 0 στο
διάστημα [-1000, 1000]. Θεωρείστε ότι οι συντελεστές
Α, Β, Γ, Δ είναι ακεραίου τύπου.

Λύση

       ΣΥΝΑΡΤΗΣΗ Εξίσωση(Α, Β, Γ, Δ) : ΑΚΕΡΑΙΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α, Β, Γ, Δ, ΠΛΗΘ, Χ, Υ, Ζ
       ΑΡΧΗ
              ΠΛΗΘ <-- 0
              ΓΙΑ Χ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                    ΓΙΑ Υ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                         ΓΙΑ Ζ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                               ΑΝ Α*Χ+Β*Υ+Γ*Ζ+Δ = 0 ΤΟΤΕ
                                      ΠΛΗΘ <-- ΠΛΗΘ+1
                               ΤΕΛΟΣ_ΑΝ
                         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              Εξίσωση <-- ΠΛΗΘ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου