Τετάρτη, 4 Ιουλίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παραμέτρους δύο
ακέραιους Α, Β ( Α < Β) και εμφανίζει όλους τους
ακέραιους στο διάστημα [Α, Β] που είναι περιττοί
και πολλαπλάσια του 7.

Απάντηση

     ΔΙΑΔΙΚΑΣΙΑ Διάστημα(Α, Β)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Κ
     ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ Α  ΜΕΧΡΙ Β
                ΑΝ MOD 2 = 1) KAI (K MOD 7 = 0) TOTE
                      ΓΡΑΨΕ Κ
                ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου