Τρίτη, 31 Μαΐου 2011

Σχολιασμός θεμάτων Εσπερινού Γενικού Λυκείου 2011

Τα θέματα ήταν πολύ βατά, χωρίς καμιά ιδιαίτερη δυσκολία.
Αυτό που προκάλεσε ιδιαίτερη εντύπωση είναι ότι υπήρχε
ένα μεγάλο μέρος θεμάτων που ήταν κοινό ή παραπλήσιο με
αντίστοιχα θέματα του ημερήσιου γενικού λυκείου.

ΘΕΜΑ Α
Α1. Ακριβώς ίδιο με το Α1 του Ημερήσιου Γενικού Λυκείου
Α2. Ακριβώς ίδιο με το Α2 του Ημερήσιου Γενικού Λυκείου
       (εκτός από το ερώτηση 5)
Α3. Λυμένο παράδειγμα από το σχολικό βιβλίο, σελ. 169
Α4. Πολύ εύκολη μετατροπή της Για σε Όσο
Α5. Όλες οι ερωτήσεις ανάπτυξης από το κεφάλαιο 2,
       με υπερβολική θα έλεγα βαθμολογική βαρύτητα.

ΘΕΜΑ Β
Β1. 
    Ο αλγόριθμος κάνει την ίδια ακριβώς επεξεργασία που
    έκανε και το αντίστοιχο πρόγραμμα στο ερώτημα Β1 του
   Ημερήσιου Γενικού Λυκείου. Κατά συνέπεια βγαίνουν
   τα ίδια αποτελέσματα στη μονάδα εξόδου!
Β2.
   Εύκολη μετατροπή ψευδογλώσσας σε λογικό διάγραμμα.

ΘΕΜΑ Γ
Κλασσική επεξεργασία μονοδιάστατων πινάκων, χωρίς κάποια
ιδιαίτερη δυσκολία ή παγίδα.


ΘΕΜΑ Δ
Κλασσική επεξεργασία δυσδιάστατου πίνακα, χωρίς κάποια
ιδιαίτερη δυσκολία ή παγίδα. Το σενάριο πάνω στο οποίο βασίζεται
η άσκηση είναι κοινό με το ΘΕΜΑ Δ του Ημερήσιου Γενικού
Λυκείου. Κοινό επίσης είναι και το ερώτημα Δ1.

Παρατήρηση
Και σε αυτά τα θέματα δε ζητήθηκε:
* τίποτα από το κεφάλαιο 6,
* η δημιουργία προγράμματος με τη βοήθεια υποπρογραμμάτων


Κυριακή, 29 Μαΐου 2011

Σχολιασμός θεμάτων Ημερήσιου Γενικού Λυκείου 2011

Τα θέματα ήταν πολύ βατά και δεν απαιτούσαν ιδιαίτερες
δεξιότητες από τους μαθητές. Αναλυτικότερα:

ΘΕΜΑ Α
Ιδιαίτερη εντύπωση προκαλεί το γεγονός ότι 20 μονάδες
αντιστοιχούν σε ερωτήσεις σωστού-λάθους. Μεγάλη κατά
τη γνώμη μου είναι και η βαθμολογική αξία των
ερωτήσεων ανάπτυξης (ερώτημα Α5) , αφού η έκταση των
σωστών απαντήσεων δε δικαιολογεί τις 4 μονάδες ανά
υποερώτημα.Πιθανά σημεία που μπορούν να μπερδέψουν
τους μαθητές είναι :
* η 5η πρόταση σωστού-λάθους στο ερώτημα Α2,
* το ερώτημα Α4 λόγω της πρωτοτυπίας που το
   χαρακτηρίζει.

ΘΕΜΑ Β
Β1.
     Μια τυποποιημένη άσκηση μετατροπής λογικού
     διαγράμματος σε ψευδογλώσσα, χωρίς κάτι το
     ιδιαίτερο.
Β2.
     Μια βήμα-βήμα εκτέλεση προγράμματος με
     αρκετές επαναλήψεις και κλήσεις υποπρογράμματος.
     Ιδιαίτερη προσοχή πρέπει να δοθεί στα ονόματα
     των τυπικών και των πραγματικών παραμέτρων.
     Ίσως θα έπρεπε να έχει μεγαλύτερη βαθμολογική
     αξία αφού απαιτούσε αρκετή δουλεία από τους
     μαθητές για την ολοκλήρωσή του.

ΘΕΜΑ Γ
Μια τυπική επεξεργασία δεδομένων που ολοκληρώνεται
με τιμή φρουρό, χωρίς ιδιαίτερες απαιτήσεις. Μπορεί
να λυθεί με 2 τρόπους (βλέπε σχετικό άρθρο).

ΘΕΜΑ Δ
Μια τυπική επεξεργασία πινάκων. Το μοναδικό λεπτό σημείο
ήταν ότι έπρεπε ο μαθητής να σκεφτεί από μόνος του την
αναγκαιότητα ύπαρξης βοηθητικού μονοδιάστατου πίνακα,
γεμάτου με τους αύξοντες αριθμούς (1-22) των παικτών.
Όλα τα ζητούμενα στη συνέχεια ήταν απλά και εύκολα
αντιμετωπίσιμα.

Παρατήρηση
Ιδιαίτερη εντύπωση προκάλεσε το γεγονός ότι :
* δε ζητήθηκε τίποτα απολύτως από το κεφάλαιο 6
* όλες οι ερωτήσεις ανάπτυξης ήταν από το
   κεφάλαιο 10,
* για άλλη μια χρονιά δε ζητήθηκε δημιουργία
   προγράμματος με τη βοήθεια υποπρογραμμάτων



Παρασκευή, 27 Μαΐου 2011

Εκφωνήσεις θεμάτων Πανελληνίων Εξετάσεων Δ' Τάξης Εσπερινού Γενικού Λυκείου 2011






Εκφωνήσεις θεμάτων Πανελληνίων Εξετάσεων Γ' Τάξης Ημερήσιου Γενικού Λυκείου 2011







































































































































































Λύσεις Απολυτήριων εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2011

ΘΕΜΑ Α

Α1.
     1. ΣΩΣΤΟ
     2. ΣΩΣΤΟ
     3. ΛΑΘΟΣ
     4. ΛΑΘΟΣ
     5. ΛΑΘΟΣ

Α2.
     1. ΣΩΣΤΟ
     2. ΣΩΣΤΟ
     3. ΣΩΣΤΟ
     4. ΛΑΘΟΣ
     5. ΛΑΘΟΣ

Α3.
     Αν (Β < 80) ΚΑΙ (Υ < 1.70) τότε
              Γράψε "Ελαφρύς, κοντός"
     Τέλος_αν


Α4.
     Σ <-- 0
     i <-- 1
     Όσο i <= 100 επανάλαβε
           Διάβασε Χ
           Σ <-- Σ+Χ
           i <-- i+1
     Τέλος_επανάληψης


Α5.
     α. Βλέπε σχολικό βιβλίο, σελ. 25
     β. Βλέπε σχολικό βιβλίο, σελ. 26
     γ. Βλέπε σχολικό βιβλίο, σελ. 28

ΘΕΜΑ Β


Β1.
     z = 1
     w = 3
     1η επανάληψη
           z = z+w = 1+3 = 4
           w = w+2 = 3+2 = 5
           H Γράψε τυπώνει :     5     4
     2η επανάληψη
           z = z+w = 4+5 = 9
           w = w+2 = 5+2 = 7
           H Γράψε τυπώνει :     7     9
     3η επανάληψη
           z = z+w = 9+7 = 16
           w = w+2 = 7+2 = 9
           H Γράψε τυπώνει :     9     16
      4η επανάληψη
           z = z+w = 16+9 = 25
           w = w+2 = 9+2 = 11
           H Γράψε τυπώνει :     11     25
      5η επανάληψη
           z = z+w = 25+11 = 36
           w = w+2 = 11+2 = 13
           H Γράψε τυπώνει :     13     36
      Αφού z <= 35 = 36 <= 35 = Ψευδής, η Όσο τερματίζεται.



Β2.

































































ΘΕΜΑ Γ

          Αλγόριθμος ΘΕΜΑ_Γ
          Για κ από 1 μέχρι 12
                  Διάβασε Εισπ9[κ], Εισπ10[κ]
          Τέλος_επανάληψης
          Μεγ9 <-- Εισπ9[1]
          ΘΜεγ9 <-- 1
          Μεγ10 <-- Εισπ10[1]
          ΘΜεγ10 <-- 1
           Για κ από μέχρι 12
                  Αν Εισπ9[κ] > Μεγ9 τότε
                         Μεγ9 <-- Εισπ9[κ]
                         ΘΜεγ9 <-- κ
                  Τέλος_αν
                  Αν Εισπ10[κ] > Μεγ10 τότε
                         Μεγ10 <-- Εισπ10[κ]
                         ΘΜεγ10 <-- κ
                  Τέλος_αν
          Τέλος_επανάληψης
          Εμφάνισε Εισπ9[ΘΜεγ9], Εισπ10[ΘΜεγ10]
          Αν ΘΜεγ9 = ΘΜεγ10 τότε
                Εμφάνισε 'Η μεγαλύτερη είσπραξη σημειώθηκε τον'
                Εμφάνισε 'ίδιο μήνα και για τα δύο έτη'
          Τέλος_αν
          Αθρ9 <-- 0
          Αθρ10 <-- 0
          Για κ από μέχρι 12
                  Αθρ9 <-- Αθρ9+Εισπ9[κ]
                  Αθρ10 <-- Αθρ10+Εισπ10[κ]
          Τέλος_επανάληψης 
          ΜΟ9 <-- Αθρ9/12
          ΜΟ10 <-- Αθρ10/12
          Εμφάνισε ΜΟ9, ΜΟ10
          Πληθ <-- 0
          Για κ από 1 μέχρι 12
                 Αν Εισπ9[κ]  > Εισπ10[κ] τότε
                        Πληθ <-- Πληθ+1
                 Τέλος_αν
          Τέλος_επανάληψης
          Εμφάνισε Πληθ
          Τέλος ΘΕΜΑ_Γ

ΘΕΜΑ Δ
   
       Αλγόριθμος ΘΕΜΑ_Δ
      Για από μέχρι 22
           Για από μέχρι 22
               Αρχή_επανάληψης
                     Διάβασε ΨΗΦΟΣ[i, j]
                   Μέχρις_ότου (ΨΗΦΟΣ[i, j] = 0) Ή 
                                   (ΨΗΦΟΣ[i, j] = 1)
           Τέλος_επανάληψης
        Τέλος_επανάληψης

        Για από μέχρι 22

           σ <-- 0
           Για από μέχρι 22
               σ <-- σ+
ΨΗΦΟΣ[i, j]              
           Τέλος_επανάληψης
              Εμφάνισε σ
        Τέλος_επανάληψης
        Μεγ <-- -1
      Για από μέχρι 22

           σ <-- 0           
              Για από μέχρι 22
               σ <-- σ+
ΨΗΦΟΣ[i, j]              
           Τέλος_επανάληψης
              Εμφάνισε σ
           Αν σ > Μεγ τότε
                Μεγ <-- σ
                ΘΜεγ <-- j
           Τέλος_αν
       Τέλος_επανάληψης
       Εμφάνισε ΘΜεγ
      Για i από 1 μέχρι 22
          Αν  ΨΗΦΟΣ[i, i] = 0 τότε
              Εμφάνισε i
          Τέλος_αν
      Τέλος_επανάληψης
       Τέλος ΘΕΜΑ_Δ
     


Τετάρτη, 25 Μαΐου 2011

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με ισοδύναμο
τρόπο, χρησιμοποιώντας μόνο μια εντολή εκχώρησης
      Αν (Χ < 0) Ή (Χ > 100) τότε
            Υ <-- Ψευδής
      αλλιώς
             Υ <-- Αληθής
      Τέλος_αν


Απάντηση


     Υ <-- (Χ >= 0) ΚΑΙ (Χ <= 100)

                      ή

     Υ <-- ΟΧΙ ( (Χ < 0) Ή (Χ > 100) )

Δευτέρα, 23 Μαΐου 2011

Λύσεις Απολυτήριων εξετάσεων Γ' τάξης Ημερήσιου Γενικού Λυκείου 2011

ΘΕΜΑ Α

Α1. 
    1.  ΣΩΣΤΟ
    2.  ΣΩΣΤΟ
    3.  ΛΑΘΟΣ
    4.  ΛΑΘΟΣ
    5.  ΛΑΘΟΣ

Α2. 
    1.  ΣΩΣΤΟ
    2.  ΣΩΣΤΟ
    3.  ΣΩΣΤΟ
    4.  ΛΑΘΟΣ
    5.  ΛΑΘΟΣ

Α3. 
    1.  Αληθής
    2.  Ψευδής
    3.  Αληθής
    4.  Ψευδής
    5.  Αληθής

Α4.
    Κ <-- Χ > 1

Α5.
     α. Βλέπε σχολικό βιβλίο, σελ. 205
     β. Βλέπε σχολικό βιβλίο, σελ. 206
     γ. Βλέπε σχολικό βιβλίο, σελ. 210

ΘΕΜΑ Β

B1.
       Αρχή_επανάληψης
             Σ <-- 0
             Κ <-- 1
             Όσο Κ <= 100 επανάλαβε
                   Διάβασε Χ
                   Σ <-- Σ+Χ
                   Κ <-- Κ+1
             Τέλος_επανάληψης
       Μέχρις_ότου Σ > 1000

Β2.
    z = 1
    w = 3
    1η επανάληψη
          Κλήση της Διαδ με w = z = 1 και z = w = 3
               w = w+z = 1+3 = 4
               z = z+2 = 3+2 = 5
               H Γράψε τυπώνει : 5
          Μόλις ολοκληρωθεί η Διαδ οι μεταβλητές z, w
          του κυρίου προγράμματος έχουν τις τιμές:
              z = w = 4
              w = z = 5
          Η Γράψε  τυπώνει : 4
    2η επανάληψη
          Κλήση της Διαδ με w = z = 4 και z = w = 5
               w = w+z = 4+5 = 9
               z = z+2 = 5+2 = 7
               H Γράψε τυπώνει : 7
          Μόλις ολοκληρωθεί η Διαδ οι μεταβλητές z, w 
          του κυρίου προγράμματος έχουν τις τιμές:
              z = w = 9
              w = z = 7
          Η Γράψε  τυπώνει : 9
     3η επανάληψη
          Κλήση της Διαδ με w = z = 9 και z = w = 7
               w = w+z = 9+7 = 16
               z = z+2 = 7+2 = 9
               H Γράψε τυπώνει : 9
          Μόλις ολοκληρωθεί η Διαδ οι μεταβλητές z, w 
          του κυρίου προγράμματος έχουν τις τιμές:
              z = w = 16
              w = z = 9
          Η Γράψε  τυπώνει : 16
      4η επανάληψη
          Κλήση της Διαδ με w = z = 16 και z = w = 9
               w = w+z = 16+9 = 25
               z = z+2 = 9+2 = 11
               H Γράψε τυπώνει : 11
          Μόλις ολοκληρωθεί η Διαδ οι μεταβλητές z, w 
          του κυρίου προγράμματος έχουν τις τιμές:
              z = w = 25
              w = z = 11
          Η Γράψε  τυπώνει : 25
      5η επανάληψη
          Κλήση της Διαδ με w = z = 25 και z = w = 11
               w = w+z = 25+11 = 36
               z = z+2 = 11+2 = 13
               H Γράψε τυπώνει : 13
          Μόλις ολοκληρωθεί η Διαδ οι μεταβλητές z, w 
          του κυρίου προγράμματος έχουν τις τιμές:
              z = w = 36
              w = z = 13
          Η Γράψε  τυπώνει : 36
      Αφού z <= 35 = 36 <= 35 = ΨΕΥΔΗΣ, η Όσο
      τερματίζεται.
   
ΘΕΜΑ Γ

    α' τρόπος

      Αλγόριθμος ΘΕΜΑ_Γ
      Μικ <-- 101
      Αρχή_επανάληψης
            Διάβασε ΟΝ
            Αν ΟΝ < > 'ΤΕΛΟΣ' τότε
                 Μεγ <-- -100
                 σ <-- 0
                 Φ <-- 0
                 Για κ από 1 μέχρι 3
                      Διάβασε Βαθμός
                      σ <-- σ+Βαθμός
                      Αν Βαθμός > Μεγ τότε
                           Μεγ <-- Βαθμός
                      Τέλος_αν
                      Αν Βαθμός >= 50  τότε
                           Φ<-- Φ+1
                      Τέλος_αν
                 Τέλος_επανάληψης
                 Εμφάνισε Μεγ
                 ΜΟ <-- σ/3
                 Αν (ΜΟ >= 55) ΚΑΙ (Φ = 3) τότε
                      Εμφάνισε ΟΝ, ΜΟ
                      Αν ΜΟ < Μικ τότε
                           Μικ <-- ΜΟ
                           ΟνΜικ <-- ΟΝ
                      Τέλος_αν
                 Τέλος_αν
            Τέλος_αν
      Μέχρις_ότου ΟΝ = 'ΤΕΛΟΣ'
      Εμφάνισε ΟνΜικ
      Τέλος ΘΕΜΑ_Γ


   β' τρόπος

      Αλγόριθμος ΘΕΜΑ_Γ
      Μικ <-- 101
      Αρχή_επανάληψης
            Διάβασε ΟΝ
            Αν ΟΝ < > 'ΤΕΛΟΣ' τότε
                 Διάβασε Β1, Β2, Β3
                 Μεγ <-- Β1
                 Αν Β2 > Μεγ τότε
                       Μεγ <-- Β2
                 Τέλος_αν
                 Αν Β3 > Μεγ τότε
                       Μεγ <-- Β3
                 Τέλος_αν
                 Εμφάνισε Μεγ
                 ΜΟ <-- (Β1+Β2+Β3)/3
                 Αν (ΜΟ >= 55) ΚΑΙ (Β1 >= 50) ΚΑΙ
                       (Β2 >= 50) ΚΑΙ (Β3 >= 50) τότε
                      Εμφάνισε ΟΝ, ΜΟ
                      Αν ΜΟ < Μικ τότε
                           Μικ <-- ΜΟ
                           ΟνΜικ <-- ΟΝ
                      Τέλος_αν
                 Τέλος_αν
            Τέλος_αν
      Μέχρις_ότου ΟΝ = 'ΤΕΛΟΣ'
      Εμφάνισε ΟνΜικ
      Τέλος ΘΕΜΑ_Γ



ΘΕΜΑ Δ

      Αλγόριθμος ΘΕΜΑ_Δ
      Για από μέχρι 22
           ΑΑ[i] <-- i
      Τέλος_επανάληψης
      Για i από 1 μέχρι 22
           Για j από 1 μέχρι 22
               Αρχή_επανάληψης
                     Διάβασε ΨΗΦΟΣ[i, j]
               Μέχρις_ότου (ΨΗΦΟΣ[i, j] = 0) Ή (ΨΗΦΟΣ[i, j] = 1)
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      Κανένα <-- 0
      Εαυτό <-- 0
      Για από μέχρι 22
           Φ <-- 0
           Για από μέχρι 22
               Αν ΨΗΦΟΣ[i, j] = 0 τότε
                     Φ <-- Φ+1
               Τέλος_αν
               Αν (i = j) KAI (ΨΗΦΟΣ[i, j] = 1) τότε
                     Εαυτό <-- Εαυτό+1
               Τέλος_αν
           Τέλος_επανάληψης
           Αν Φ = 22 τότε
                 Κανένα <-- Κανένα+1 
           Τέλος_αν
      Τέλος_επανάληψης
      Εμφάνισε Κανένα, Εαυτό
      Για από μέχρι 22
           Φ <-- 0
           Για από μέχρι 22
               Αν ΨΗΦΟΣ[i, j] = 1 τότε
                     Φ <-- Φ+1
               Τέλος_αν
           Τέλος_επανάληψης
           Έλαβαν[j] <-- Φ           
      Τέλος_επανάληψης
      Για από μέχρι 22
           Για από 22 μέχρι i με_βήμα -1
               Αν Έλαβαν[j-1] < Έλαβαν[j] τότε
                     Bοηθ <-- Έλαβαν[j-1]
                     Έλαβαν[j-1] <-- Έλαβαν[j]
                     Έλαβαν[j] <-- Βοηθ
                     Bοηθ <-- ΑΑ[j-1]
                     ΑΑ[j-1] <-- ΑΑ[j]
                     ΑΑ[j] <-- Βοηθ
               Τέλος_αν
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για i από 1 μέχρι 3
           Εμφάνισε ΑΑ[i], Έλαβαν[i]
      Τέλος_επανάληψης
      Τέλος ΘΕΜΑ_Δ

Παρατηρήσεις


1. Το ερώτημα Δ2 θα μπορούσε να απαντηθεί και ως εξής:
     .....
     Κανένα <-- 0
     Για από μέχρι 22
           βρεθ <-- Ψευδής
           j <-- 1
           Όσο (j <= 22) KAI (βρεθ = Ψευδής) επανάλαβε
                 Αν ΨΗΦΟΣ[i, j] = 1 τότε
                       βρεθ <-- Αληθής
                 αλλιώς
                       j <-- j+1
                 Τέλος_αν
           Τέλος_επανάληψης
           Αν βρεθ = Ψευδής τότε
                  Κανένα <-- Κανένα+1
           Τέλος_αν
      Τέλος_επανάληψης
      .......


2. Το ερώτημα Δ3 θα μπορούσε να απαντηθεί και ως εξής:
    .....
    Εαυτό <-- 0
    Για i από 1 μέχρι 22
        Αν ΨΗΦΟΣ[i, i] = 1 τότε
            Εαυτό <-- Εαυτό+1
        Τέλος_αν
    Τέλος_επανάληψης
    .....

Παρασκευή, 20 Μαΐου 2011

Πόσες επαναλήψεις πραγματοποιούνται

Δίνεται η παρακάτω δομή επανάληψης
     Για κ από α-1 μέχρι β+2 με_βήμα γ-9
           Εμφάνισε 'τεστ'
     Τέλος_επανάληψης
Πόσες φορές τυπώνεται η λέξη 'τεστ';

Απάντηση


    1η περίπτωση : γ = 9
           * Αν α-1 > β+2 = α > β+3  έχουμε 0 επαναλήψεις
           * Αν α <= β+3 έχουμε άπειρες επαναλήψεις
    2η περίπτωση : γ > 9
           * Αν α = β+3 έχουμε 1 επανάληψη
           * Αν α < β+3 έχουμε τουλάχιστον 1 επανάληψη
           * Αν α > β+3 έχουμε 0 επαναλήψεις
    3η περίπτωση : γ < 9
           * Αν α = β+3 έχουμε 1 επανάληψη
           * Αν α > β+3 έχουμε τουλάχιστον 1 επανάληψη
           * Αν α < β+3 έχουμε 0 επαναλήψεις

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο η ποια αλγοριθμικά κριτήρια παραβιάζονται στο
παρακάτω σύνολο εντολών;
     κ <-- 3
     Οσο κ < > 102 επανάλαβε
           Εμφάνισε 1/κ-5
           κ <-- κ+2
     Τέλος_επανάληψης


Απάντηση


     Παραβιάζεται μόνο η περατότητα γιατί το κ δεν πρόκειται
     ποτέ να πάρει την τιμή 102 και η Όσο δε θα τερματιστεί.
     

Άσκηση με GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να ικανο-
ποιεί τις αρχές του δομημένου προγραμματισμού
      Α <-- 0
      Κ <-- 21
10: ΔΙΑΒΑΣΕ Χ
      Α <-- Α+Χ*Κ
      Κ <-- Κ+3
      ΑΝ Α < 9999 ΤΟΤΕ GOTO 10
      ΓΡΑΨΕ Α

Λύση

     Α <-- 0
     Κ <-- 21
     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
           ΔΙΑΒΑΣΕ Χ
           Α <-- Α+Χ*Κ
           Κ <-- Κ+3
     ΜΕΧΡΙΣ_ΟΤΟΥ Α >= 9999
     ΓΡΑΨΕ Α

Τετάρτη, 18 Μαΐου 2011

Μετατροπή συνάρτησης σε διαδικασία

Μετατρέψτε την παρακάτω συνάρτηση σε διαδικασία
     ΣΥΝΑΡΤΗΣΗ Φ(Α, Β, Γ) : ΠΡΑΓΜΑΤΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α, Β
            ΠΡΑΓΜΑΤΙΚΕΣ: Γ
     ΑΡΧΗ
            ΑΝ Α > Β ΤΟΤΕ
                    Α <-- Α+1
                    Β <-- Β*2
            ΑΛΛΙΩΣ_ΑΝ Α < Β ΤΟΤΕ
                    Α <-- Α-1
                    Β <-- Β-2
            ΑΛΛΙΩΣ
                    Α <-- 2*Α
                    Β <-- Β+7
            ΤΕΛΟΣ_ΑΝ
            Φ <-- 100*Α+200*Β+300*Γ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Λύση


     ΔΙΑΔΙΚΑΣΙΑ Φ(Α, Β, Γ, Δ)
     ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α, Β, Χ, Υ
            ΠΡΑΓΜΑΤΙΚΕΣ: Γ, Δ
     ΑΡΧΗ
            Χ <-- Α
            Υ <-- Β
            ΑΝ Χ > Υ ΤΟΤΕ
                    Χ <-- Χ+1
                    Υ <-- Υ*2
            ΑΛΛΙΩΣ_ΑΝ Χ < Υ ΤΟΤΕ
                    Χ <-- Χ-1
                    Υ <-- Υ-2
            ΑΛΛΙΩΣ
                    Χ <-- Χ*Α
                    Υ <-- Υ+7
            ΤΕΛΟΣ_ΑΝ
            Δ <-- 100*Χ+200*Υ+300*Γ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δευτέρα, 16 Μαΐου 2011

Συμπληρώστε τα κενά

Δίνονται οι παρακάτω προτάσεις
1.  ______________ είναι γραμμένος σε ψευδογλώσσα.
2.  ___________ τελειώνει με τη δεσμευμένη λέξη
    Τέλος και το όνομά του.
3. _________ είναι γραμμένο σε μια γλώσσα προ-
    γραμματισμού.
4. ____________ είναι ένα σύνολο εντολών που
    κατευθύνουν τον υπολογιστή προκειμένου να
    εκτελέσει μια συγκεκριμένη εργασία.
και οι λέξεις:
    α. Ο αλγόριθμος
    β. Το πρόγραμμα
Γράψτε τον αριθμό της πρότασης (1-4) και δίπλα το
γράμμα (α ή β) των λέξεων με τις οποίες πρέπει να
συμπληρωθεί το αντίστοιχο κενό.

Λύση

    1. α
    2. α
    3. β
    4. β

Σάββατο, 14 Μαΐου 2011

Συμπλήρωση κενών

Δίνονται οι παρακάτω προτάσεις
   1.  Τα ______________ προβλήματα έχουν τουλάχιστον μια
        λύση.
   2.  Τα ___________ προβλήματα είναι ακόμα υπό διερεύνηση
        ως προς τη δυνατότητα επίλυσής τους.
   3.   ___________ χαρακτηρίζονται και προβλήματα που
         μπορεί να είναι συναφή με άλλα προβλήματα που έχει
         αποδειχθεί ότι λύνονται.
   4.  __________ προβλήματα είναι εκείνα για τα οποία δεν
        είμαστε σίγουροι ούτε αν λύνονται ούτε αν δε λύνονται.
   5. Η ύπαρξη ζωής σε άλλους πλανήτες και η θεραπεία του
       καρκίνου είναι _______ προβλήματα.
   6. Ο υπολογισμός της περιμέτρου ενός ορθογωνίου και
       ο υπολογισμός του συνολικού εμβαδού μιας πλατείας
       είναι __________ προβλήματα.
και οι λέξεις:
     α. επιλύσιμα
     β. ανοικτά
Γράψτε τον αριθμό της πρότασης (1-6) και δίπλα το γράμμα
(α ή β) της λέξης που πρέπει να μπει στο αντίστοιχο κενό.

Λύση

    1. α
    2. β
    3. α
    4. β
    5. β
    6. α

Πέμπτη, 12 Μαΐου 2011

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[13, 13], μια ακέραια τιμή Ν (τέτοια
ώστε 1 <=Ν <= 13 και μια λογική τιμή Τ και εμφανίζει
ταξινομημένα κατά αύξουσα σειρά τα στοιχεία της:
* Ν γραμμής, αν Τ = ΑΛΗΘΗΣ
* Ν στήλης, αν Τ = ΨΕΥΔΗΣ

Λύση

      ΔΙΑΔΙΚΑΣΙΑ ΤΑΞ(Α, Ν, Τ)
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Α[13, 13], Ν, Β[13], Κ, Λ, ΒΟΗΘ
             ΛΟΓΙΚΕΣ: Τ
      ΑΡΧΗ
             ΑΝ Τ = ΑΛΗΘΗΣ ΤΟΤΕ
                     ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 13
                           Β[Κ] <-- Α[Ν, Κ]
                     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΑΛΛΙΩΣ
                     ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 13
                           Β[Κ] <-- Α[Κ, Ν]
                     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΑΝ
             ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 13
                  ΓΙΑ Λ ΑΠΟ 13 ΜΕΧΡΙ Κ ΜΕ_ΒΗΜΑ -1
                           ΑΝ Β[Λ-1] > Β[Λ] ΤΟΤΕ
                                 ΒΟΗΘ <-- Β[Λ-1]
                                 Β[Λ-1] <-- Β[Λ]
                                 Β[Λ] <-- ΒΟΗΘ
                           ΤΕΛΟΣ_ΑΝ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
             ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 13
                   ΓΡΑΨΕ Β[Κ] 
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Τρίτη, 10 Μαΐου 2011

Διορθώστε τα λάθη

Διορθώστε τα λάθη έτσι ώστε το παρακάτω σύνολο
εντολών να υπολογίζει το μέσο όρο 15 θετικών
τιμών.
      σ <-- 0
      Για κ από 1 μέχρι 15
           Αρχή_επανάληψης
                 Διάβασε Χ
           Μέχρις_ότου Χ  <= 0
      Τέλος_επανάληψης
      σ <-- σ+Χ
      Εμφάνισε σ

Λύση

      σ <-- 0
      Για κ από μέχρι 15
           Αρχή_επανάληψης
                 Διάβασε Χ
           Μέχρις_ότου Χ > 0
           σ <-- σ+Χ
      Τέλος_επανάληψης
      Εμφάνισε σ/15

Υπολογισμός πλήθους επαναλήψεων

Πόσες φορές τυπώνει 'ΚΑΛΗΜΕΡΑ' η παρακάτω
Για..από..μέχρι;

     Για κ από 1.2 μέχρι 8.7 με_βήμα 0.2
           Εμφάνισε 'ΚΑΛΗΜΕΡΑ'
     Τέλος_επανάληψης


Απάντηση


     Αφού οι τιμές που εμπλέκονται στην δομή είναι
     πραγματικού τύπου, κάνω το ακόλουθο τρικ:
     τις πολλαπλασιάζω όλες με το 10 και τις κάνω
     ακέραιες. Στο πρόχειρο μου ξαναγράφω την εντολή
          Για κ από 12 μέχρι 87 με_βήμα 2
                Εμφάνισε 'ΚΑΛΗΜΕΡΑ'
          Τέλος_επανάληψης
     Τώρα μπορώ εύκολα να υπολογίσω το πλήθος των
      επαναλήψεων με τον τύπο:
                (87-12) div 2 + 1 = 75 div 2 + 1 = 37+1 = 38

Σάββατο, 7 Μαΐου 2011

Άσκηση: συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο ένα
ακέραιο πίνακα Α[3, 4, 5] και υπολογίζει το μικρότερο
στοιχείο του και τη θέση του μέσα στον πίνακα.

Λύση

      ΔΙΑΔΙΚΑΣΙΑ ΜΙΚΡ(Α, ΜΙΝ, ΘΚ, ΘΛ, ΘΜ)
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α[3, 4, 5], ΜΙΝ, ΘΚ, ΘΛ, ΘΜ,
                                  Κ, Λ, Μ
      ΑΡΧΗ
            ΜΙΝ <-- Α[1, 1, 1]
            ΘΚ <-- 1
            ΘΛ <-- 1
            ΘΜ <-- 1
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
                  ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                        ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 5
                               ΑΝ Α[Κ, Λ, Μ] < ΜΙΝ ΤΟΤΕ
                                     ΜΙΝ <-- Α[Κ, Λ, Μ]
                                     ΘΚ <-- Κ
                                     ΘΛ <-- Λ
                                     ΘΜ <-- Μ
                               ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρασκευή, 6 Μαΐου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους τρεις
ακέραιες τιμές Α, Β, Γ και βρίσκει ποιο από τα Β, Γ
είναι πιο κοντά στο Α (θεωρείστε ότι τα Α, Β, Γ είναι
διαφορετικά μεταξύ τους).

Λύση

       ΣΥΝΑΡΤΗΣΗ ΚΟΝΤΑ(Α, Β, Γ) : ΑΚΕΡΑΙΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α, Β, Γ
       ΑΡΧΗ
              ΑΝ Α_Τ(Α-Β) < Α_Τ(Α-Γ) ΤΟΤΕ
                  ΚΟΝΤΑ <-- Β
              ΑΛΛΙΩΣ
                  ΚΟΝΤΑ <-- Γ
              ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Πέμπτη, 5 Μαΐου 2011

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Σε μια μεταβλητή ακεραίου τύπου μπορούμε να
    εκχωρήσουμε και το αποτέλεσμα μιας αριθμητικής
    παράστασης.
2. Μια τυπική επεξεργασία πινάκων είναι και η συγχώνευση.
3. Ο τμηματικός προγραμματισμός είναι μια τεχνική σχεδίαση
    προγραμμάτων που ξεκίνησε ως μια προσπάθεια περιο-
    ρισμού της εντολής GOTO.
4. Η ανάλυση ενός προβλήματος μπορεί να γίνει με μοναδικό  
    τρόπο.
5. Η παράσταση ΟΧΙ Ή Υ) έχει τιμή ΑΛΗΘΗΣ μόνο όταν
    τόσο το Χ όσο και το Υ έχει την τιμή ΨΕΥΔΗΣ.




Απάντηση

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ

Τρίτη, 3 Μαΐου 2011

άσκηση : πρόγραμμα+συνάρτηση

α) Γράψτε συνάρτηση που δέχεται ως παραμέτρους τα μήκη
    α, β των δύο κάθετων πλευρών ενός ορθογωνίου τριγώνου
    και υπολογίζει το μήκος της υποτείνουσάς του.
β) Γράψτε πρόγραμμα το οποίο:
    * διαβάζει τα μήκη α,β κάποιων ορθογωνίων τριγώνων
       (η είσοδος  δεδομένων ολοκληρώνεται μόλις δοθεί η
        απάντηση 'ΝΑΙ' στην υποβαλλόμενη προς το χρήστη
        ερώτηση 'Ολοκλήρωσες;'),
    * καλώντας τη συνάρτηση που γράψατε στο α) υπολογίζει
       το μήκος της υποτείνουσας κάθε ορθογωνίου τριγώνου
       και στη συνέχεια το εμφανίζει στην οθόνη με κατάλληλα
       διαμορφωμένο μήνυμα.

Λύση

      ΠΡΟΓΡΑΜΜΑ ΤΡΙΓΩΝ
      ΜΕΤΑΒΛΗΤΕΣ
            ΠΡΑΓΜΑΤΙΚΕΣ : α, β, γ
            ΧΑΡΑΚΤΗΡΕΣ: Απ
      ΑΡΧΗ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                  ΔΙΑΒΑΣΕ α, β
                  γ <-- Υποτείνουσα(α, β)
                  ΓΡΑΨΕ 'α =', α, 'β = ', β, 'Υποτείνουσα = ', γ
                  ΓΡΑΨΕ 'Ολοκλήρωσες;'
                  ΔΙΑΒΑΣΕ Απ
            ΜΕΧΡΙΣ_ΟΤΟΥ Απ = 'ΝΑΙ'
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


       ΣΥΝΑΡΤΗΣΗ Υποτείνουσα(α, β) : ΠΡΑΓΜΑΤΙΚΗ
       ΜΕΤΑΒΛΗΤΕΣ
            ΠΡΑΓΜΑΤΙΚΕΣ: α, β
       ΑΡΧΗ
            Υποτείνουσα <-- Τ_Ρ(α^2+β^2)
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

άσκηση : πορτοφόλι

Έχετε στη διάθεσή σας 135 ευρώ για την αγορά αγαθών από
ένα σουπερ μάρκετ. Γράψτε αλγόριθμο που:
α) διαβάζει την τιμή κάθε υποψήφιου προς αγορά προϊόντος
    ( οι αγορές ολοκληρώνονται όταν διατεθούν τουλάχιστον
       τα 134 ευρώ),
β) υπολογίζει και εμφανίζει:
    * πόσα προϊόντα αγοράστηκαν συνολικά,
    * το περίσσευμα των χρημάτων (αν υπάρχει),
    * το συνολικό ποσό που διατέθηκαν για αγορές.

Λύση

      Αλγόριθμος ΑΣΚ
      Διαθ <-- 135
      ΣΤΟΠ <-- Ψευδής
      Πρ <-- 0
      Όσο ΣΤΟΠ = Ψευδής επανάλαβε
            Διάβασε Τιμή
            Αν Διαθ >= Τιμή  τότε
                  Διαθ <-- Διαθ-Τιμή
                  Πρ <-- Πρ+1
            αλλιώς
                  Αν Διαθ <= 1 τότε
                        ΣΤΟΠ <-- Αληθής
                  Τέλος_αν
            Τέλος_αν             
      Τέλος_επανάληψης
      Αγορές <-- 135-Διαθ
      Εμφάνισε Πρ, Αγορές
      Αν Διαθ > 0 τότε
            Εμφάνισε Διαθ
      αλλιώς
            Εμφάνισε 'Δεν υπάρχει περίσσευμα'
      Τέλος_αν 
      Τέλος ΑΣΚ 

Δευτέρα, 2 Μαΐου 2011

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τον μεταγλωττιστή;
1. Παράγει ως αποτέλεσμα το αντικείμενο  πρόγραμμα.
2. Εντοπίζει τα λογικά λάθη.
3. Εντοπίζει τα συντακτικά λάθη.
4. Μεταφράζει και εκτελεί μια-μια τις εντολές.
5. Εξασφαλίζει μεγαλύτερη ταχύτητα εκτέλεσης των
    προγραμμάτων από τους διερμηνευτές.
6. Είναι αναπόσπαστο στοιχείο σε ένα προγραμματιστικό
    περιβάλλον.

Απάντηση

        1, 3,5, 6


Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τις γλώσσες 4ης γενιάς;
1. Απαιτούν τη χρήση συμβολομεταφραστή για την εκτέλεση
    των προγραμμάτων τους.
2. Αποκρύπτουν λεπτομέρειες από την αρχιτεκτονική του
    υπολογιστή.
3. Μπορούν να χρησιμοποιηθούν και από άτομα που δεν
    έχουν ιδιαίτερες γνώσεις προγραμματισμού.
4. Αποκαλούνται και γλώσσες 3ης γενιάς.
5. Παρέχουν τη δυνατότητα στο χρήστη να υποβάλλει
    ερωτήσεις στο σύστημα.
6. Έχουν κυριότερο εκπρόσωπό τους τη γλώσσα LOGO.

Απάντηση

       2, 3, 5


Κυριακή, 1 Μαΐου 2011

Έλεγχος αλγοριθμικών κριτηρίων

Ποιό ή ποιά αλγοριθμικά κριτήρια παραβιάζονται και γιατί;
     Αλγόριθμος ΑΣΚ
     Αν α > β τότε
          γ <-- α+β
     αλλιώς
          γ <-- α-β
     Τέλος_αν
     δ <-- 2*γ
     Τέλος ΑΣΚ

Απάντηση

     α) Είσοδος, γιατί τα α, β δεν έχουν τιμή.
     β) Έξοδος, γιατί ο αλγόριθμος δεν εμφανίζει κανένα
         αποτέλεσμα