Σάββατο, 27 Δεκεμβρίου 2014

Απλοποίηση

Θεωρήστε τον πραγματικό πίνακα Α[10, 7].
Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
    Για κ από 1 μέχρι 10
       Για λ από 1 μέχρι 7
           Αν (κ = 10) ΚΑΙ (λ < 4) τότε
                Εμφάνισε Α[κ, λ]
           Τέλος_αν
       Τέλος_επανάληψης
    Τέλος_επανάληψης

Λύση
  
       Για λ από μέχρι 3
           Εμφάνισε Α[10, λ]
       Τέλος_επανάληψης

Διορθώστε τις λανθασμένες προτάσεις

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Μια εγγραφή αποτελείται από πολλά αρχεία.
2. Προγράμματα+Διαγράμματα = Αλγόριθμοι.
3. Το ελάχιστο στοιχείο στον αλφαριθμητικό πίνακα
    Α[200] που είναι ταξινομημένος κατά αλφαβητική
    σειρά είναι το Α[200].
4. Ο πίνακας Α[12, 5, 2, 3] έχει 22 στοιχεία.
5. Ο πίνακας Α[12, 12, 12 ] είναι τετραγωνικός.


Απάντηση

1. Μια εγγραφή αποτελείται από πολλά πεδία.
2. Αλγόριθμοι+Δομές Δεδομένων = Προγράμματα.
3. Το ελάχιστο στοιχείο στον αλφαριθμητικό πίνακα
    Α[200] που είναι ταξινομημένος κατά αλφαβητική
    σειρά είναι το Α[1].
4. Ο πίνακας Α[12, 5, 2, 3] έχει 360 στοιχεία.
5. Ο πίνακας Α[12, 12, 12 ] είναι τρισδιάστατος.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Μια δυναμική δομή δεδομένων
    Α. αξιοποιεί τη μνήμη κατά το βέλτιστο τρόπο
    Β. δεσμεύει μνήμη καθ' όλη τη διάρκεια εκτέλεσης
         του προγράμματος
    Γ. είναι και ο πίνακας
    Δ. αποθηκεύεται πάντοτε σε ένα αρχείο εγγραφών

2. Ένας δυσδιάστατος πίνακας
    Α. μπορεί να σχεδιαστεί σαν ένα κύβο
    Β. έχει τύπο στοιχείων ίδιο με τον τύπο των
         δεικτών του
    Γ. μπορεί να θεωρηθεί ως τρισδιάστατος πίνακας
        με βάθος 2
    Δ. μπορεί να καταλαμβάνει λιγότερο χώρο στη
        μνήμη από ένα μονοδιάστατο πίνακα.

3. Για να προσδιορίσουμε τη θέση μεγίστου σε μια
    συγκεκριμένη γραμμή ενός δυσδιάστατου πίνακα
    πρέπει να εντοπίσουμε:
    Α. τη γραμμή στην οποία ανήκει το μέγιστο
    Β. τη στήλη στην οποία ανήκει το μέγιστο
    Γ. τη γραμμή και τη στήλη στην οποία ανήκει
        το μέγιστο
    Δ. την απόσταση από το κέντρο του πίνακα

4. Η σειριακή αναζήτηση
    Α. δεν μπορεί να χρησιμοποιηθεί σε ταξινομημένο
         πίνακα
    Β. είναι πολύ απλή και γρήγορη μέθοδος αναζήτησης
    Γ. είναι πολύ απλή αλλά αργή μέθοδος αναζήτησης
    Δ. είναι πιο γρήγορη από τη δυαδική

Απαντήσεις

1. Α
2. Δ
3. Β
4. Γ


Βρείτε το κέντρο του πίνακα

Θεωρήστε τον πίνακα Α[Ν, Ν], όπου Ν >=3 και
περιττός ακέραιος. Γράψτε τις εντολές που
απαιτούνται προκειμένου να εμφανίσετε την τιμή
του κεντρικού στοιχείου του Α.

Λύση

α' τρόπος

Το κεντρικό στοιχείο βρίσκεται στη μεσαία
γραμμή και στη μεσαία στήλη. Άρα αρκεί να
γράψουμε :
     Εμφάνισε Α[ (Ν+1) div 2, (N+1) div 2]

β' τρόπος

Όταν το Ν είναι περιττό, το κεντρικό στοιχείο
είναι το μοναδικό στοιχείο που ανήκει και στις
δύο κύριες διαγωνίους του πίνακα. Κατά συνέπεια
γράφουμε:
       Για κ από 1 μέχρι Ν
            Για λ από 1 μέχρι Ν
                 Αν (κ = λ) ΚΑΙ (κ+λ  = Ν+1) τότε
                     Εμφάνισε Α[κ, λ]
                 Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης

Βήμα-βήμα εκτέλεση

Θεωρήστε τον πίνακα Α[5] που περιέχει τις τιμές
     4, 5, 3, 13, -6
Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
Για κ από 1 μέχρι 3 με_βήμα 2
     Εμφάνισε (Α[κ]+Α[κ+1)^2 div 17
     Εμφάνισε Τ_Ρ(Α[κ]+Α[κ+1])/2
Τέλος_επανάληψης
Εμφάνισε Α_Τ(Α[κ]-100)


Λύση

κ = 1
      Αφού (Α[κ]+Α[κ+1)^2 div 17 = (Α1]+Α[2])^2 div 17 =
                (4+5)^2 div 17 =  9^2 div 17 = 81 div 17 = 4
      η Εμφάνισε τυπώνει : 4
     Αφού Τ_Ρ(Α[κ]+Α[κ+1])/2 =
               Τ_Ρ(Α[1]+Α[2])/2 = Τ_Ρ(4+5)/2 =
               Τ_Ρ(9)/2 = 3.0/2 = 1.5
     η Εμφάνισε τυπώνει : 1.5
κ = 3
      Αφού (Α[κ]+Α[κ+1)^2 div 17 = (Α3]+Α[4])^2 div 17 =
                (3+13)^2 div 17 =  16^2 div 17 = 256 div 17 = 15
      η Εμφάνισε τυπώνει : 15
     Αφού Τ_Ρ(Α[κ]+Α[κ+1])/2 =
               Τ_Ρ(Α[3]+Α[4])/2 = Τ_Ρ(3+13)/2 =
               Τ_Ρ(16)/2 = 4.0/2 = 2.0
     η Εμφάνισε τυπώνει : 2.0
Η Για τερματίζεται με κ = 5.
Αφού Α_Τ(Α[κ]-100) = Α_Τ(Α[5]-100) =
          Α_Τ(-6-100) = Α_Τ(-106) = 106
η Εμφάνισε τυπώνει : 106

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το στοιχείο Α[2, 7] ανήκει στην 2η κύρια __________
    του πίνακα Α[8, 8].
2. Ο αλφαριθμητικός πίνακας Α[100] μπορεί να περιέχει
    100 ___________.
3. Ένα δυσδιάστατος πίνακας έχει τουλάχιστον δύο
    γραμμές και τουλάχιστον δύο _____.
4. Ο ________ ενός μονοδιάστατου πίνακα είναι
    πάντοτε ακεραίου τύπου.
5. Οι τιμές ενός ______ πίνακα δεν μπορούν να
    ταξινομηθούν.

Απαντήσεις

1. διαγώνιο
2. συμβολοσειρές
3. στήλες
4. δείκτης




Παρασκευή, 26 Δεκεμβρίου 2014

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Κάθε τετραγωνικός πίνακας έχει δύο κυρίες διαγωνίους.
2. Το μέγιστο στοιχείο ενός πίνακα είναι πάντα μοναδικό.
3. Η εισαγωγή τιμών σε ένα δυσδιάστατο πίνακα γίνεται
    με ένα και μοναδικό τρόπο.
4. Αν διασχίσουμε τα στοιχεία ενός δυσδιάστατου πίνακα
    στήλη προς στήλη προκειμένου να βρούμε το γινόμενό
    τους, θα καταλήξουμε στο ίδιο αποτέλεσμα με αυτό
   που θα προέκυπτε αν διασχίζαμε τον πίνακα
   γραμμή-γραμμή.
5. Όταν δεν γνωρίζουμε το πλήθος των στοιχείων ενός
    ακέραιου μονοδιάστατου πίνακα Α, στο τμήμα δήλωσης
    των  μεταβλητών του προγράμματος γράφουμε:
        ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α[Ν]
   όπου Ν ακέραια μεταβλητή που αντιπροσωπεύει το
   πλήθος των στοιχείων του πίνακα.
           
   

Απάντηση

1. Σ
2. Λ
3. Λ
4. Σ
5. Λ



Επεξεργασία δυσδιάστατου πίνακα

Γράψτε αλγόριθμο που :
α) διαβάζει 25 ακέραιες τιμές και τις
    καταχωρεί σε κατάλληλο δυσδιάστατο πίνακα,
β) εμφανίζει όλα τα στοιχεία του πίνακα που
    έχουν τιμή μεγαλύτερη από την τιμή
    του κεντρικού στοιχείου του πίνακα,
γ)  εμφανίζει όλα τα στοιχεία του πίνακα που
    βρίσκονται κάτω από τη δεύτερη κύρια
    διαγώνιο.

Λύση

Αλγόριθμος Ασκ
Για κ από 1 μέχρι 5
   Για λ από 1 μέχρι 5
         Διάβασε Α[κ, λ]
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από μέχρι 5
   Για λ από μέχρι 5
         Αν Α[κ, λ] > Α[3, 3] τότε
              Εμφάνισε Α[κ, λ]
         Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από μέχρι 5
   Για λ από μέχρι 5
         Αν κ+λ > 6 τότε
              Εμφάνισε Α[κ, λ]
         Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ

Τρίτη, 23 Δεκεμβρίου 2014

Γέμισμα πίνακα με βάση κάποιο μαθηματικό τύπο


Αναζήτηση

Θεωρήστε τον πίνακα Απ[30, 50] που περιέχει
τις απαντήσεις 30 φοιτητών σε 50 ερωτήσεις
πολλαπλής επιλογής. Το περιεχόμενο κάθε
στοιχείου του πίνακα μπορεί να είναι:
* Σ, αν ο φοιτητής απάντησε σωστά
* Λ, αν ο φοιτητής απάντησε λάθος
Γράψτε αλγόριθμο που, με δεδομένο τον
παραπάνω πίνακα υπολογίζει το ποσοστό (%)
των φοιτητών που απάντησαν σωστά σε
τουλάχιστον 10 ερωτήσεις πριν κάνουν το
πρώτο τους λάθος.

Λύση


Αντιμετάθεση στοιχείων της διαγωνίου σε τετραγωνικό πίνακα


Γέμισμα δυσδιάστατου πίνακα


Σάββατο, 20 Δεκεμβρίου 2014

Έξοδος αποτελεσμάτων

Θεωρήστε ένα πίνακα Α[10] που περιέχει εναλλάξ τις
τιμές :
     2, 4, 5, 7, 20, 4, 12, 8, 1, 11
Τι θα εμφανίσει το παρακάτω σύνολο
εντολών;
     Για κ από 1 μέχρι 9 με_βήμα 2
         Εμφάνισε ( (Α[κ]+Α[κ+1]) div 2 )^2
     Τέλος_επανάληψης
     Εμφάνισε Α[κ-4]

Λύση

κ=1
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[1]+Α[2]) div 2 )^2 = ( (2+4) div 2 )^2 =
              (6 div 2 )^2 = 3^2 = 9, η Εμφάνισε τυπώνει : 9
κ=3
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[3]+Α[4]) div 2 )^2 = ( (5+7) div 2 )^2 =
              (12 div 2 )^2 = 6^2 = 36, η Εμφάνισε τυπώνει : 36
κ=5
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[5]+Α[6]) div 2 )^2 = ( (20+4) div 2 )^2 =
              (24 div 2 )^2 = 12^2 = 144,
     η Εμφάνισε τυπώνει : 144
κ=7
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[7]+Α[8]) div 2 )^2 = ( (12+8) div 2 )^2 =
              (20 div 2 )^2 = 10^2 = 100,
     η Εμφάνισε τυπώνει : 100
κ=9
    Αφού ( (Α[κ]+Α[κ+1]) div 2 )^2 =
              ( (Α[9]+Α[10]) div 2 )^2 = ( (1+11) div 2 )^2 =
              (12 div 2 )^2 = 6^2 = 36, η Εμφάνισε τυπώνει : 36
Η Για τερματίζεται με κ = 11.
Αφού κ-4 = 11-4 = 7 και Α[7] = 12, η Εμφάνισε τυπώνει : 12

Εμφωλευμένες δομές επανάληψης

Γράψτε αλγόριθμο που εντοπίζει τετράδες ακεραίων
αριθμών στο διάστημα [-200, 300] που έχουν άθροισμα
περιττό.

Λύση

Αλγόριθμος Ασκ
Για κ από -200  μέχρι  300
    Για λ από -200  μέχρι  300
       Για μ από -200  μέχρι  300
            Για ρ από -200  μέχρι  300
                 Αν (κ+λ+μ+ρ) mod 2 = 1 τότε
                      Εμφάνισε κ, λ, μ, ρ
                 Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ

Παρασκευή, 12 Δεκεμβρίου 2014

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η απαιτούμενη μνήμη για ένα πίνακα διατίθεται από
    το μεταγλωττιστή κατά την εκτέλεση του προγράμματος.
2. Ο πίνακας Α[10, 30] έχει 40 στοιχεία.
3. Το στοιχείο Α[3, 3] ανήκει στην 1η κύρια διαγώνιο του
    τετραγωνικού πίνακα Α[100, 100].
4. Ο πίνακας Α[9, 9, 9] είναι τριγωνικός.
5. Ο δείκτης ενός πίνακα είναι αριθμητικού τύπου
    (ακέραιος ή πραγματικός).




Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Λ



Τετάρτη, 3 Δεκεμβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Ο πίνακας Α[9,9] είναι:
    α. τρισδιάστατος  
    β. μονοδιάστατος
    γ. τετραγωνικός
    δ. τίποτα από τα παραπάνω

2. Τα στοιχεία ενός πίνακα
    α. ονομάζονται και κλειδιά
    β. μπορεί να είναι και διαφορετικού τύπου
    γ. αποθηκεύονται στη δευτερεύουσα μνήμη
    δ. τίποτα από τα παραπάνω

3. Η σειριακή αναζήτηση
    α. είναι ο πιο γρήγορος τρόπος αναζήτησης
    β. είναι η πιο δύσκολη μέθοδος αναζήτησης
    γ. χρησιμοποιείται μόνο σε ταξινομημένους πίνακες
    δ. τίποτα από τα παραπάνω

4, Αν η 3η στήλη του ακέραιου πίνακα Α[12, 8]
    έχει ταξινομηθεί, το μέγιστο στοιχείο της είναι
    το
    α. Α[1,3] ή Α[12, 3]
    β. Α[1, 3]
    γ. Α[12, 3]
    δ. τίποτα από τα παραπάνω

5, Αν η 7η γραμμή του ακέραιου πίνακα Α[12, 8]
    έχει ταξινομηθεί, το ελάχιστο στοιχείο της είναι
    το
    α. Α[7, 1]
    β. Α[7, 1] ή Α[7, 8]
    γ. Α[7, 8]
    δ. τίποτα από τα παραπάνω

Απαντήσεις

1. γ
2. α
3. δ
4. α
5. β




Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  (Χ mod 2 < > 0) = (X mod 2 = ____ ), αν Χ θετικός ακέραιος.
2.  Η είσοδος σε κάθε βρόχο γίνεται από την ______ του.
3.  Για να προσδιορίσουμε το στοιχείο ενός πίνακα
     χρησιμοποιούμε ένα ή περισσότερους _________.
4.  Η ________ σχεδίαση είναι μια μεθοδολογία/τεχνική
     διάσπασης ενός σύνθετου προβλήματος σε υποπροβλήματα.
5.  Η δομή ενός προβλήματος καταγράφεται κατά το στάδιο της
     ________.



Απαντήσεις

1. 1
2. αρχή
3. δείκτες
4. ιεραρχική
5. ανάλυσης






Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για την εντολή 
Για..από..μέχρι;
1. Χρησιμοποιείται μόνο όταν γνωρίζουμε επακριβώς το
    πλήθος των επαναλήψεων.
2. Είναι ιδανική για τη δημιουργία προγραμμάτων που
    λειτουργούν με μενού.
3. Είναι η πιο ισχυρή επαναληπτική δομή.
4. Είναι ιδανική για την επεξεργασία μονοδιάστατων
    πινάκων.
5. Έχει παραπλήσια διαγραμματική αναπαράσταση με
    την Όσο..επανάλαβε.
6. Χρησιμοποιείται σπάνια στους αλγορίθμους.

Απαντήσεις

1, 4, 5