Παρασκευή, 26 Δεκεμβρίου 2014

Επεξεργασία δυσδιάστατου πίνακα

Γράψτε αλγόριθμο που :
α) διαβάζει 25 ακέραιες τιμές και τις
    καταχωρεί σε κατάλληλο δυσδιάστατο πίνακα,
β) εμφανίζει όλα τα στοιχεία του πίνακα που
    έχουν τιμή μεγαλύτερη από την τιμή
    του κεντρικού στοιχείου του πίνακα,
γ)  εμφανίζει όλα τα στοιχεία του πίνακα που
    βρίσκονται κάτω από τη δεύτερη κύρια
    διαγώνιο.

Λύση

Αλγόριθμος Ασκ
Για κ από 1 μέχρι 5
   Για λ από 1 μέχρι 5
         Διάβασε Α[κ, λ]
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από μέχρι 5
   Για λ από μέχρι 5
         Αν Α[κ, λ] > Α[3, 3] τότε
              Εμφάνισε Α[κ, λ]
         Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από μέχρι 5
   Για λ από μέχρι 5
         Αν κ+λ > 6 τότε
              Εμφάνισε Α[κ, λ]
         Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου