Τετάρτη, 29 Οκτωβρίου 2014

Βρείτε τις τιμές

Ποιές τιμές πρέπει να έχουν οι λογικές μεταβλητές Χ, Υ
προκειμένου οι παρακάτω παραστάσεις να είναι Αληθής;
α) ΟΧΙΚΑΙ Υ)
β) ΟΧΙ Χ ΚΑΙ Υ
γ) Χ ΚΑΙ ΟΧΙ Υ
δ) ΟΧΙ Ή Υ)
ε) ΟΧΙ Χ Ή ΟΧΙ Υ

Λύση

α) Πρέπει Χ ΚΑΙ Υ = Ψευδής. Άρα έχουμε τις ακόλουθες
    περιπτώσεις:
         Χ = Αληθής, Υ = Ψευδής
         Χ = Ψευδής, Υ = Αληθής
         Χ = Ψευδής, Υ = Ψευδής
β) Πρέπει ΟΧΙ  Χ = Αληθής και Υ = Αληθής. Άρα:
         Χ = Ψευδής, Υ = Αληθής
γ) Πρέπει Χ = Αληθής και ΟΧΙ Υ = Αληθής. Άρα:
         Χ = Αληθής, Υ = Ψευδής
δ) Πρέπει Χ Ή Υ = Ψευδής. Άρα:
         Χ = Ψευδής, Υ = Ψευδής
ε) Πρέπει :
       ΟΧΙ Χ = Αληθής, ΟΧΙ Υ = Ψευδής
       ΟΧΙ Χ = Ψευδής, ΟΧΙ Υ = Αληθής
       ΟΧΙ Χ = Ψευδής, ΟΧΙ Υ = Ψευδής
   Άρα :
        Χ = Ψευδής, Υ = Αληθής
        Χ = Αληθής, Υ = Ψευδής
        Χ = Αληθής, Υ = Αληθής

Τρίτη, 28 Οκτωβρίου 2014

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τις συμβολικές
σταθερές
1. Είναι υποχρεωτικές στα προγράμματα.
2. Εμφανίζονται συχνά μέσα σε αλγορίθμους.
3. Είναι ονόματα που αντιπροσωπεύουν σταθερές
    τιμές.
4. Έχουν το δικό τους τμήμα δήλωσης μέσα στα
    προγράμματα.
5. Δεν καταλαμβάνουν χώρο στη μνήμη.
6. Έχουν τύπο δεδομένων που αναγράφεται στο
    τμήμα δήλωσης των μεταβλητών του προγράμματος.
7. Απαγορεύεται οποιαδήποτε μεταβολή του περιεχομένου
    τους.
8. Δυσχεραίνουν την κατανόηση και συντήρηση του
    προγράμματος.

Απαντήσεις

3, 4, 7

Εύρεση τελικής τιμής (εμφωλευμένες Για..από..μέχρι)


Μετατροπή


Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για μια μεταβλητή
προγράμματος;
1. Έχει ένα τύπο δεδομένων που μπορεί να αλλάζει
    κατά τη διάρκεια εκτέλεσης του προγράμματος.
2. Έχει ένα μοναδικό όνομα που τη χαρακτηρίζει.
3. Καταλαμβάνει συγκεκριμένο χώρο στην κύρια
    μνήμη του υπολογιστή.
4. Μπορεί να περιέχει μόνο αριθμητικές ή λογικές
    τιμές.
5. Η εμβέλεια του ονόματός της είναι τοπική.
6. Δηλώνεται υποχρεωτικά στο τμήμα δήλωσης
    των μεταβλητών του προγράμματος.
7. Πρέπει υποχρεωτικά μέσα στο πρόγραμμα να
    υπάρχει σχόλιο που να επεξηγεί το ρόλο της.

Απάντηση

2, 3, 5, 6

Φρουρός+Απάντηση σε ερώτηση+δοσμένο πλήθος (συνδυασμός)


Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
αντικαθιστώντας την Αν..τότε..αλλιώς_αν
με εντολές Αν..τότε
     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     αλλιώς_αν  Β < 100 τότε
          Εμφάνισε Α^2
     αλλιώς
          Εμφάνισε Β+1
     Τέλος_αν

Λύση

     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     Τέλος_αν
     Αν  (Β < 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Α^2
     Τέλος_αν
     Αν  (Β >= 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Β+1
     Τέλος_αν

Λογικό διάγραμμα

Κατασκευάστε το λογικό διάγραμμα του παρακάτω
αλγόριθμου



















Λύση

Κυριακή, 26 Οκτωβρίου 2014

Εκφώνηση προβλήματος

Δώστε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος

Αλγόριθμος Ασκ
Για κ από 120 μέχρι 300
      Αν mod 4 = 0) KAI mod 12 < > 0) τότε
           Εμφάνισε κ
      Τέλος_αν
Τέλος_επανάληψης
Τέλος Ασκ

Λύση

Γράψτε αλγόριθμο που εμφανίζει όλους τους
ακέραιους στο διάστημα [120, 300] που είναι
πολλαπλάσια του 4 αλλά όχι του 12

Τετάρτη, 22 Οκτωβρίου 2014

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Μια μεταβλητή που εμπεριέχει τη χωρητικότητα
    μιας αίθουσας είναι πραγματικού τύπου.
2. Η λογική πράξη ¨Η αποκαλείται σύζευξη.
3. Ο τελεστής < > είναι λογικός.
4. Κάθε δομή επιλογής τελειώνει με τη δεσμευμένη
    λέξη Τέλοςαν


Απαντήσεις

1. Μια μεταβλητή που εμπεριέχει τη χωρητικότητα
    μιας αίθουσας είναι ακεραίου τύπου.
2. Η λογική πράξη ¨Η αποκαλείται διάζευξη.
3. Ο τελεστής < > είναι συγκριτικός.
4. Κάθε δομή επιλογής τελειώνει με τη δεσμευμένη
    λέξη Τέλος_αν

Σάββατο, 18 Οκτωβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ο πολλαπλασιασμός αλά ρωσικά
    α. στηρίζεται στην πράξη της αφαίρεσης
    β. στηρίζεται στη λειτουργία της ολίσθησης
    γ. υλοποιείται μέσω της διαίρεσης
    δ. εφαρμόζεται μόνο σε αρνητικούς ακεραίους

2. Η σειριακή αναζήτηση
    α. δεν μπορεί να εφαρμοστεί σε ταξινομημένο πίνακα
    β. είναι μια μέθοδος ταξινόμησης
    γ. είναι η πιο γρήγορη μέθοδος αναζήτησης
    δ. τίποτα από τα παραπάνω

3. Στην εντολή Για..από..μέχρι
    α. το βήμα μπορεί να είναι αλφαριθμητικού τύπου
    β. το βήμα είναι πάντοτε θετικό
    γ. το βήμα μπορεί να είναι και αρνητικό
    δ. τίποτα από τα παραπάνω

4. Σε μια Όσο..επανάλαβε
    α. η περιεχόμενη ομάδα εντολών εκτελείται
        τουλάχιστον μία φορά
    β. απαγορεύεται η περιεχόμενη ομάδα εντολών
        να αλλάζει την τιμή της συνθήκης ελέγχου
    γ. η περιεχόμενη ομάδα εντολών πρέπει να
        επηρεάζει με κάποιον τρόπο τη συνθήκη
        ελέγχου ώστε κάποτε ο βρόχος να τερματιστεί
    δ. τίποτα από τα παραπάνω

Απαντήσεις

1. β
2. δ
3. γ
4. γ



Δώστε την εκφώνηση

Ποια είναι η εκφώνηση του προβλήματος που
επιλύει ο παρακάτω αλγόριθμος;
      Αλγόριθμος Ασκ
      Για Χ από -300 μέχρι 10
          Για Υ από -300 μέχρι 10
               Για Ζ από -300 μέχρι 10
                     Αν 2*Χ-4*Υ+Ζ = 6 τότε
                          Εμφάνισε Χ, Υ, Ζ
                     Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που επιλύει την εξίσωση
2*Χ-4*Υ+Ζ = 6 στο ακέραιο διάστημα
τιμών [-300, 10]

Δευτέρα, 6 Οκτωβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  Αν Χ < Υ τότε  ΟΧΙ (Χ < Υ) = ........
2,  Αν  Χ = 2.3 η εντολή ΓΡΑΨΕ Α_Μ(Χ)^2 θα
     εμφανίσει την τιμή ......
3.  Αν  Χ = 'ΑΛΦΑ' και ΒΗΤΑ = 'ΑΛΛΑ'
     Χ >=  ΒΗΤΑ = .............
4. Αν το βήμα είναι 0 σε μια Για,,από,,μέχρι τότε
    η περιεχόμενη ομάδα εντολών είτε δεν εκτελείται
    καθόλου είτε εκτελείται .............. φορές.
5. Η εντολή που είναι ιδανική για έλεγχο εγκυρότητας
    των εισερχόμενων δεδομένων είναι η ................  

Απαντήσεις

1, Ψευδής
2, 4
3. Αληθής
4. άπειρες
5. Μέχρις_ότου



Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Σε μια εντολή εκχώρησης πρέπει να υπάρχει
    απόλυτη ταύτιση ανάμεσα στον τύπο της
    μεταβλητής και της εκχωρηθείσας έκφρασης.
2. Ένας μονοδιάστατος πίνακας καταλαμβάνει
    πάντοτε λιγότερη μνήμη από ένα δυσδιάστατο
    πίνακα με το ίδιο πλήθος στοιχείων.
3. Η περιεχόμενη ομάδα εντολών μιας Αν..τότε
    εκτελείται τουλάχιστον μια φορά.
4, Αν ένα πρόβλημα είναι ημιδομημένο, αποκλείεται
    να είναι άλυτο.
5. Η γλώσσα C είναι κατάλληλη για τη δημιουργία
    λειτουργικών συστημάτων.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ