Σάββατο, 22 Αυγούστου 2015

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ποιο από τα παρακάτω είναι αλγοριθμικό κριτήριο;
    α. περατότητα
    β. κρισιμότητα
    γ. αντιμεταθετικότητα
    δ. μεταβατικότητα

2. Ποιος από τους παρακάτω είναι αποδεκτός τρόπος
    αναπαράστασης αλγορίθμου
    α. γράφος
    β. συνδεδεμένη λίστα
    γ. τεχνητή γλώσσα κατά βήματα
    δ. κωδικοποίηση

3. Ποια από τις παρακάτω αποτελεί σκοπιά εξέτασης των
    δεδομένων από την Πληροφορική;
    α. λογισμικού
    β. υλικού
    γ. φυσικών γλωσσών
    δ. αναδιάρθρωσης δεδομένων

4. Ποιο από τα παρακάτω δεν ισχύει για τις δυναμικές δομές
    δεδομένων;
    α. το πλήθος των κόμβων τους μπορεί να αυξηθεί ή να
        ελαττωθεί
    β. στηρίζονται στην τεχνική της δυναμικής παραχώρησης
        μνήμης
    γ. διατηρούν τα στοιχεία τους σε συνεχόμενες θέσεις στη
        μνήμη του υπολογιστή
    δ. είναι δυσκολότερες στη χρήση τους από τις στατικές
        δομές δεδομένων

Απαντήσεις


1. α
2. δ
3. β
4. γ


Συμπλήρωση κενών

Συμπληρώστε τα κενά στις παρακάτω προτάσεις
1. ΟΧΙ ( (Χ = 'ζ') Ή (Χ = 'κ') ) = (Χ < > 'ζ') _____ (Χ < > 'κ')
2. ΟΧΙ ( (Χ > 0) ΚΑΙ (Χ < 100) ) = (Χ <= 0) _____ (Χ >= 100)
3. (3*Χ+12*Υ) DIV 3 = _________
4. (12*X+24*Y) MOD 6 = _______
5. (X > 1)  Ή  (Χ < 1) = ______


Απαντήσεις

1. ΚΑΙ
2. Ή
3. X+4*Y
4. 0
5. Χ < > 1


Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Για να προσδιορίσουμε τη θέση ενός στοιχείου σε
    μονοδιάστατο πίνακα, χρησιμοποιούμε ένα δρομέα.
2. Το πρόγραμμα που καλεί τα υποπρογράμματα
    αποκαλείται κεντρικό.
3. Για να εμφανίσουμε το τελευταίο ψηφίο του ακέραιου
    Μ στην οθόνη, γράφουμε την εντολή;
          ΓΡΑΨΕ Μ DIV 10
4. Αν Μ = 'τεστ' η εντολή ΓΡΑΨΕ 'Μ' εμφανίζει:
      'τεστ'



Απαντήσεις

1. Για να προσδιορίσουμε τη θέση ενός στοιχείου σε
    μονοδιάστατο πίνακα, χρησιμοποιούμε ένα δείκτη.
2. Το πρόγραμμα που καλεί τα υποπρογράμματα
    αποκαλείται κύριο.
3. Για να εμφανίσουμε το τελευταίο ψηφίο του ακέραιου
    Μ στην οθόνη, γράφουμε την εντολή;
          ΓΡΑΨΕ Μ MOD 10
4. Αν Μ = 'τεστ' η εντολή ΓΡΑΨΕ 'Μ' εμφανίζει:
      Μ

Ικανές και αναγκαίες συνθήκες

Ποια πρέπει να είναι η τιμή των λογικών μεταβλητών Χ, Υ, Ζ
έτσι ώστε οι παρακάτω λογικές παραστάσεις να έχουν
την τιμή ΑΛΗΘΗΣ;
α) ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ ΚΑΙ Ζ
β) Χ ΚΑΙ Υ ΚΑΙ ΟΧΙ Ζ
γ) Χ Ή ΟΧΙ Ζ

Απαντήσεις

α) Πρέπει :
     ΟΧΙ Χ = ΑΛΗΘΗΣ, ΟΧΙ Υ = ΑΛΗΘΗΣ, Ζ = ΑΛΗΘΗΣ
    Και συνεπώς:
        Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΑΛΗΘΗΣ
β) Πρέπει :
     Χ = ΑΛΗΘΗΣ, Υ = ΑΛΗΘΗΣ, ΟΧΙ Ζ = ΑΛΗΘΗΣ
    Και συνεπώς:
        Χ = ΑΛΗΘΗΣ, Υ = ΑΛΗΘΗΣ, Ζ = ΨΕΥΔΗΣ
γ) Πρέπει :
     Χ = ΑΛΗΘΗΣ, ΟΧΙ Ζ = ΑΛΗΘΗΣ,  ή
     Χ = ΑΛΗΘΗΣ, ΟΧΙ Ζ = ΨΕΥΔΗΣ,  ή
     Χ = ΨΕΥΔΗΣ, ΟΧΙ Ζ = ΑΛΗΘΗΣ
    Και συνεπώς:
        Χ = ΑΛΗΘΗΣ, Ζ = ΨΕΥΔΗΣ,  ή
        Χ = ΑΛΗΘΗΣ, Ζ = ΑΛΗΘΗΣ,  ή
        Χ = ΨΕΥΔΗΣ, Ζ = ΨΕΥΔΗΣ

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Η πρώτη εντολή ενός προγράμματος είναι η επικεφαλίδα του.
2. Η πράξη DIV εφαρμόζεται σε ακέραιους τελεστέους και δίνει
    αποτέλεσμα ακεραίου τύπου,
3. Η ΑΝ..ΤΟΤΕ είναι δομή απλής επιλογής.
4. Ο ρόμβος σε ένα λογικό διάγραμμα έχει μόνο δύο εξόδους.
5. Ένας δυσδιάστατος πίνακας έχει περισσότερα στοιχεία από
    ένα μονοδιάστατο.

Απαντήσεις

1. Σ
2. Σ
3. Σ
4. Λ
5. Λ



Πέμπτη, 30 Ιουλίου 2015

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Η ονομαστική σταθερά είναι ένα όνομα που
    αντιπροσωπεύει μια σταθερή τιμή.
2. Οι τελεστέοι εφαρμόζονται πάνω σε τελεστές.
3. Ο τμηματικός προγραμματισμός στηρίζεται στη
    χρήση των αλγοριθμικών συνιστωσών.
4.  313 div 314 = 313
5.  Η συνάρτηση ΣΥΝ υπολογίζει το άθροισμα κάποιων
     τιμών.




Απαντήσεις

1. Η συμβολική σταθερά είναι ένα όνομα που
    αντιπροσωπεύει μια σταθερή τιμή.
2. Οι τελεστές εφαρμόζονται πάνω σε τελεστέους.
3. Ο δομημένος προγραμματισμός στηρίζεται στη
    χρήση των αλγοριθμικών συνιστωσών.
4.  313 mod 314 = 313
5.  Η συνάρτηση ΣΥΝ υπολογίζει το συνημίτονο κάποιας
     γωνίας.

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Ένας  αλγόριθμος τελειώνει με τη δεσμευμένη λέξη
     ΤΕΛΟΣ_ΑΛΓΟΡΙΘΜΟΥ
2.  Η πρώτη εντολή ενός προγράμματος είναι η
     επικεφαλίδα του.
3.  Μια συνάρτηση γράφεται σε φυσική γλώσσα κατά
     βήματα.
4.  Ο τελεστής = είναι λογικός.
5.  Η δομή επιλογής είναι μια από τις τρεις αλγοριθμικές
     συνιστώσες.


Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ



Παρασκευή, 19 Ιουνίου 2015

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Ο δείκτης
    α. χρησιμοποιείται για τον προσδιορισμό ενός πεδίου σε μια
        εγγραφή
    β. μπορεί να είναι και πραγματικού τύπου
    γ. χρησιμοποιείται για τον προσδιορισμό ενός στοιχείου σε ένα
        πίνακα
    δ. αποκαλείται και κορυφή του πίνακα

2. Η κωδικοποίηση ενός αλγορίθμου
    α. είναι ένα από τα αλγοριθμικά κριτήρια
    β. γίνεται σε 0 ή 1
    γ.  μπορεί να παραβιάσει την αποτελεσματικότητα
    δ. είναι ένας από τους τρόπους αναπαράστασης ενός αλγορίθμου

3. Ο δομημένος προγραμματισμός
    α. στηρίζεται στη χρήση των δομών ακολουθίας, επιλογής και
        επανάληψης
    β. αποκαλείται και ιεραρχικός προγραμματισμός
    γ. αποκαλείται και τμηματικός προγραμματισμός
    δ. οδηγεί στη δημιουργία δυσκολονόητων προγραμμάτων

4. Η συνάρτηση Α_Τ
    α. υπολογίζει το ακέραιο μέρος μιας πραγματικής τιμής
    β. επιστρέφει ένα αλφαριθμητικό αποτέλεσμα
    γ. ενεργοποιείται με την εντολή ΚΑΛΕΣΕ
    δ. ενεργοποιείται όταν το όνομα της βρεθεί μέσα σε μια
        οποιαδήποτε έκφραση

Απαντήσεις

1. γ
2. δ
3. α
4. δ


Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Ο αλγόριθμος περιλαμβάνει μια ___________ σειρά ενεργειών.
2. Ο ______ ενός μονοδιάστατου πίνακα είναι πάντοτε ακεραίου
    τύπου.
3. Μια συνάρτηση είναι ένα από τα δύο διαφορετικά είδη _____.
4. Μια διαδικασία ενεργοποιείται με την εντολή _____.
5. Η δομή επιλογής είναι μια _________ συνιστώσα (δομή).


Απαντήσεις

1. πεπερασμένη
2. δείκτης
3. υποπρογραμμάτων
4. ΚΑΛΕΣΕ
5. αλγοριθμική


Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για ένα πίνακα
1. Είναι στατική δομή δεδομένων
2. Καταλαμβάνει συνεχόμενες θέσεις στη μνήμη
3. Όλα τα στοιχεία του μοιράζονται το ίδιο όνομα
4. Έχει ένα μέγιστο και ένα ελάχιστο στοιχείο
5. Μπορεί να ταξινομηθεί κατά αύξουσα ή φθίνουσα σειρά
6. Δηλώνεται στο τμήμα δήλωσης μεταβλητών του προγράμματος
7. Είναι δυναμική δομή δεδομένων

Απάντηση

1, 2, 3, 6

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Μια μεταβλητή που ισχύει παντού λέμε ότι έχει καθολική
    εμβέλεια.
2. Η συνδεδεμένη λίστα είναι μια δομή δεδομένων.
3. Μια στοίβα μπορεί να υλοποιηθεί με τη βοήθεια ενός
    αρχείου εγγραφών.
4. Ο τελεστής ΚΑΙ είναι συγκριτικός.
5. ΟΧΙ ΚΑΙ Υ) = ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ


Ύλη πανελλαδικών εξετάσεων 2016

Από το βιβλίο «Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον» της Γ΄ τάξης Γενικού Λυκείου των Α. Βακάλη, Η. Γιαννόπουλου, Ν. Ιωαννίδη, Χ. Κοίλια, Κ. Μάλαμα, Ι. Μανωλόπουλου, Π. Πολίτη, έκδοση (Ι.Τ.Υ.Ε.) "Διόφαντος".


2. Βασικές Έννοιες Αλγορίθμων
2.1 Τι είναι αλγόριθμος.
2.3 Περιγραφή και αναπαράσταση αλγορίθμων.
2.4 Βασικές συνιστώσες/ εντολές ενός αλγορίθμου.
               2.4.1 Δομή ακολουθίας.
               2.4.2 Δομή Επιλογής.
2.4.3 Διαδικασίες πολλαπλών επιλογών (αφαιρείται η εντολή πολλαπλής επιλογής "Επίλεξε")
               2.4.4 Εμφωλευμένες Διαδικασίες.
               2.4.5 Δομή Επανάληψης.

3. Δομές Δεδομένων και Αλγόριθμοι
         3.2 Αλγόριθμοι + Δομές Δεδομένων =Προγράμματα
         3.3 Πίνακες
         3.4 Στοίβα
         3.5 Ουρά
         3.6 Αναζήτηση
         3.7 Ταξινόμηση
         3.9  Άλλες δομές δεδομένων

5. Ανάλυση Αλγορίθμων
         5.1  Επίδοση αλγορίθμων
 5.1.1  Χειρότερη περίπτωση ενός αλγορίθμου
 5.1.2  Μέγεθος  εισόδου ενός αλγορίθμου
 5.1.3  Χρόνος  εκτέλεσης προγράμματος ενός αλγορίθμου
 5.1.4  Αποδοτικότητα αλγορίθμων
         5.3 Πολυπλοκότητα αλγορίθμων

6. Εισαγωγή στον προγραμματισμό
         6.3 Φυσικές και τεχνητές γλώσσες.
         6.4 Τεχνικές σχεδίασης προγραμμάτων.
               6.4.1 Ιεραρχική σχεδίαση προγράμματος.
               6.4.2 Τμηματικός προγραμματισμός.
               6.4.3 Δομημένος προγραμματισμός.         
         6.7 Προγραμματιστικά περιβάλλοντα.

7. Βασικά στοιχεία προγραμματισμού.
7.1 Το αλφάβητο της ΓΛΩΣΣΑΣ.
7.2 Τύποι δεδομένων.
7.3 Σταθερές.
7.4 Μεταβλητές.
7.5 Αριθμητικοί τελεστές.
7.6 Συναρτήσεις.
7.7 Αριθμητικές εκφράσεις.
7.8 Εντολή εκχώρησης.
7.9 Εντολές εισόδου-εξόδου.
7.10 Δομή προγράμματος.

8. Επιλογή και επανάληψη
8.1 Εντολές Επιλογής
8.1.1 Εντολή ΑΝ
8.2 Εντολές επανάληψης
8.2.1 Εντολή ΟΣΟ...ΕΠΑΝΑΛΑΒΕ
8.2.2 Εντολή ΜΕΧΡΙΣ_ΟΤΟΥ
8.2.3 Εντολή ΓΙΑ...ΑΠΟ...ΜΕΧΡΙ

9. Πίνακες
9.1 Μονοδιάστατοι πίνακες.
9.2 Πότε πρέπει να χρησιμοποιούνται πίνακες.
9.3 Πολυδιάστατοι πίνακες.
9.4 Τυπικές επεξεργασίες πινάκων.

10. Υποπρογράμματα
10.1 Τμηματικός προγραμματισμός.
10.2 Χαρακτηριστικά των υποπρογραμμάτων.
10.3 Πλεονεκτήματα του τμηματικού προγραμματισμού.
10.4 Παράμετροι.
10.5 Διαδικασίες και συναρτήσεις.
10.5.1 Ορισμός και κλήση συναρτήσεων.
10.5.2 Ορισμός και κλήση διαδικασιών.
10.5.3 Πραγματικές και τυπικές παράμετροι.
10.6   Εμβέλεια μεταβλητών – σταθερών


ΠΑΡΑΤΗΡΗΣΕΙΣ
       Οι Αλγόριθμοι να υλοποιούνται σε αμιγώς προγραμματιστικό περιβάλλον και συγκεκριμένα αυτό της ΓΛΩΣΣΑΣ.
       Επισκόπηση της έννοιας του αλγορίθμου, των χαρακτηριστικών του και των τρόπων αναπαράστασής του, και εισαγωγή στα χαρακτηριστικά των γλωσσών προγραμματισμού και ειδικά της ΓΛΩΣΣΑΣ.
       Οι βασικές αλγοριθμικές δομές  του κεφαλαίου 2  (ακολουθίας, επιλογής και επανάληψης) να διδαχθούν συνοπτικά και παράλληλα με το κεφάλαιο 7 και 8 στην κατεύθυνση της κάλυψης τυχόν γνωσιακών κενών από την προηγούμενη τάξη, με τις ασκήσεις  να υλοποιούνται απ’ ευθείας σε ΓΛΩΣΣΑ.
       Στο κεφάλαιο 3:
     Να προστεθούν  ασκήσεις στη στοίβα και ουρά που επίσης θα υλοποιηθούν απ’ ευθείας σε ΓΛΩΣΣΑ. και με την πρόσθεση της  ενότητας 3.9  που θα διδαχθεί.
     Οι δυναμικές δομές της ενότητας 3.9  (λίστες, δένδρα, γράφοι) να διδαχθούν αποκλειστικά ως θεωρία.
     Οι πίνακες να διδαχθούν παράλληλα με το κεφάλαιο 9 με τις ασκήσεις  να υλοποιούνται απ’ ευθείας σε ΓΛΩΣΣΑ.
     Εισάγονται νέοι αλγόριθμοι αναζήτησης και ταξινόμησης σε πίνακες.
Στο κεφάλαιο 5 να διδαχθούν  οι ενότητες 5.1 (επίδοση αλγορίθμων), και 5.3 (πολυπλοκότητα αλγορίθμων). Η έννοια της επίδοσης να εξεταστεί με αναφορά στους αλγορίθμους αναζήτησης και ταξινόμησης.  Η πολυπλοκότητα αλγορίθμων θα διδαχθεί θεωρητικά με παραδείγματα και σε σύνδεση με την επίδοση χωρίς οι μαθητές να εμπλακούν σε ασκήσεις υπολογισμού της τάξης Ο ενός αλγορίθμου

Πέμπτη, 28 Μαΐου 2015

Σχολιασμός φετινών θεμάτων Πανελλαδικών εξετάσεων Ημερήσιου+Εσπερινού

Τα θέματα του εσπερινού ήταν σχεδόν ίδια με αυτά του
ημερήσιου (οι διαφορές εστιάζονται στις ερωτήσεις
Σωστού/Λάθους 4,5 και στο γεγονός ότι το ΘΕΜΑ Γ
πρέπει να λυθεί χωρίς τη χρήση υποπρογράμματος).
Ήταν πολύ βατά, με πολύ στρωτή και απειροελάχιστη
θεωρία. Τα κριτήρια αξιολόγησης δεν απαιτούσαν κάποια
ιδιαίτερη δεξιότητα και μπορούσαν να απαντηθούν με
άνεση. Στο ΘΕΜΑ Β για άλλη μια χρονιά απουσίαζε
η βήμα-βήμα εκτέλεση εντολών και η έξοδος των
αποτελεσμάτων τους . Αντί γι' αυτό επιλέχθηκε
(για άλλη μια φορά) η υλοποίηση ενός μικρού τμήματος
αλγορίθμου χωρίς ωστόσο ιδιαίτερες απαιτήσεις.
Το διάγραμμα ροής μπορούσε να σχεδιαστεί πολύ εύκολα,
η "παγίδα" ωστόσο υπήρχε στο ερώτημα Β1-β : εδώ
ο υποψήφιος έπρεπε να προσέξει ότι γίνεται πρώτα
η εντολή εκχώρησης και μετά εμφανίζεται η τιμή του y.
Ο προσδιορισμός της αρχικής και της τελικής τιμής για το
Για..από..μέχρι μπορεί να γίνει δοκιμάζοντας δύο διαφορετικές
τιμές για το x : μια άρτια (π.χ 6) και μια περιττή (π.χ 5).
Ήταν το πιο δύσκολο σημείο των φετινών θεμάτων κατά τη
γνώμη μου.
Στο ΘΕΜΑ Γ και στο ΘΕΜΑ Δ ένας υποψήφιος που γνωρίζει
στοιχειωδώς τις πιο τυποποιημένες μεθόδους επεξεργασίας
(με και χωρίς πίνακες) θα κάνει πραγματικά περίπατο.
Σε γενικές γραμμές υπερβολικά εύκολα θέματα για ένα
καλά προετοιμασμένο μαθητή,

Θέματα Πανελλαδικών εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2015






Θέματα Πανελλαδικών Εξετάσεων Γ' τάξης Ημερήσιου Γενικού Λυκείου 2015






Λύσεις Πανελλαδικών εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2015



Πέμπτη, 30 Απριλίου 2015

Απλοποίηση

Γράψτε απλούστερα το παρακάτω σύνολο εντολών
έτσι ώστε να τυπώνει το ίδιο αποτέλεσμα
    Για κ από 10 μέχρι 100 με_βήμα 10
        Για λ από 1 μέχρι 20 με_βήμα 4
              Αν κ+λ < 15 τότε
                   Διάβασε Χ
                   Εμφάνισε λ*Χ+κ
              Τέλος_αν
        Τέλος_επανάληψης
    Τέλος_επανάληψης

Απάντηση

Η συνθήκη κ+λ < 15 = Αληθής μόνο όταν κ = 10 και λ = 1.
Κατά συνέπεια έχουμε:
     Διάβασε Χ
     Εμφάνισε Χ+10

Προσδιορισμός πλήθους επαναλήψεων

Πόσες φορές τυπώνεται η λέξη 'ΑΕΠΠ';
   Για κ από 1.23 μέχρι 32.7 με_βήμα 0.003
        Εμφάνισε 'ΑΕΠΠ'
   Τέλος_επανάληψης

Απάντηση

Αν πολλαπλασιάσουμε όλες τις τιμές και το βήμα μεταβολής
με το 1000, η αρχική τιμή, η τελική τιμή και το βήμα θα
γίνουν ακέραια. Είναι σα να είχαμε μια τέτοια Για..από..μέχρι:
     Για κ από 1230 μέχρι 32700 με_βήμα 3
        Εμφάνισε 'ΑΕΠΠ'
   Τέλος_επανάληψης
Επομένως η λέξη ΑΕΠΠ θα τυπωθεί:
     (32700-1230) div 3 + 1 = 31470 div 3 + 1 = 10490+1 = 10491
     φορές

Προσδιορίστε τις προϋποθέσεις

Ποιά τιμή πρέπει να έχουν οι λογικές μεταβλητές Χ, Υ, Ζ
προκειμένου η συνθήκη ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ ΚΑΙ ΟΧΙ Ζ να είναι
Αληθής.

Απάντηση

Θα πρέπει ΟΧΙ Χ = Αληθής, ΟΧΙ Υ = Αληθής, ΟΧΙ Ζ = Αληθής.
Αρκεί λοιπόν Χ = Υ = Ζ = Ψευδής

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Οι πραγματικές παράμετροι αποκαλούνται και ορίσματα.
2. Ο μέσος όρος ύψους των μαθητών μιας τάξης είναι
    ακεραίου τύπου.
3. Οι πίνακες είναι δυναμικές δομές δεδομένων.
4. Το Μακεδονικό ζήτημα είναι ένα άλυτο πρόβλημα.
5. Τα δεδομένα είναι η αφηρημένη αναπαράσταση της
    πραγματικότητας.


Απαντήσεις

1. Οι τυπικές παράμετροι αποκαλούνται και ορίσματα.
2. Ο μέσος όρος ύψους των μαθητών μιας τάξης είναι
    πραγματικού τύπου.
3. Οι πίνακες είναι στατικές δομές δεδομένων.
4. Το Μακεδονικό ζήτημα είναι ένα ανοικτό πρόβλημα.
5. Τα δεδομένα είναι η αφαιρετική αναπαράσταση της
    πραγματικότητας.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ο συντάκτης χρησιμοποιείται
    α. για τη σύνδεση του αντικείμενου προγράμματος με
         βιβλιοθήκες
    β. για τη συγγραφή του αντικείμενου προγράμματος
    γ. για τη συγγραφή του πηγαίου προγράμματος
    δ. για τη συντακτική ανάλυση του προγράμματος

2.  Η ΗΜ είναι:
    α. αποδεκτό όνομα για συμβολική σταθερά
    β. αποδεκτό όνομα για μεταβλητή
    γ. ενσωματωμένη συνάρτηση της ΓΛΩΣΣΑΣ
    δ. αποδεκτό όνομα για δική μας συνάρτηση

3. Ένας δυσδιάστατος πίνακας  έχει τουλάχιστον
    α. μια γραμμή
    β. μια στήλη
    γ. δύο γραμμές ή δύο στήλες
    δ. δύο γραμμές και δύο στήλες

4. Το αποτέλεσμα μιας επεξεργασίας δεδομένων είναι:
    α. μια πληροφορία
    β, ένα άλλο δεδομένο
    γ. ένας αλγόριθμος
    δ. ο χώρος του προβλήματος που πρόκειται να επιλυθεί

Απαντήσεις

1. γ
2. γ
3. δ
4. α



Τετάρτη, 29 Απριλίου 2015

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η περατότητα είναι ένα αλγοριθμικό ________.
2. Για να χαρακτηριστεί μια κατάσταση ως πρόβλημα δεν πρέπει
    να έχει ______ λύση.
3. Ένα από τα κριτήρια κατηγοριοποίησης προβλημάτων είναι και
    η ______________.
4. Για να προσδιορίσουμε τη θέση ενός στοιχείου σε ένα πίνακα
    χρειαζόμαστε ένα ή περισσότερους ______.
5. Ο τμηματικός ___________ επεκτείνει τις δυνατότητες των
    γλωσσών προγραμματισμού.


Απαντήσεις

1. κριτήριο
2. προφανή
3, επιλυσιμότητα
4. δείκτες
5. προγραμματισμός



Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Ο μικρότερος πίνακας έχει 1 στοιχείο.
2. Ένα υποπρόγραμμα εκτελεί ένα ημιαυτόνομο έργο.
3. Τα αρχεία εγγραφών είναι στατικές δομές δεδομένων.
4, Η πράξη MOD μπορεί να εφαρμοστεί μόνο σε ακέραιους
    τελεστέους.
5. Ο δομημένος προγραμματισμός ξεκίνησε σα μια προσπάθεια
    περιορισμού της ανεξέλεγκτης χρήσης της εντολής GOTO.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ

Τετάρτη, 25 Μαρτίου 2015

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή επιλογή

1. Η γλώσσα C είναι:
    Α. συμβολική
    Β. μηχανής
    Γ. 3ης γενιάς
    Δ. 4ης γενιάς

2. Η αποτελεσματικότητα είναι:
    Α. αλγοριθμικό κριτήριο
    Β. τρόπος αναπαράστασης αλγορίθμων
    Γ. τρόπος αναπαράστασης προγραμμάτων
    Δ. κριτήριο κατηγοριοποίησης προβλημάτων

3. Μια  συνάρτηση
    Α. καλείται μόνο με εντολή εκχώρησης
    Β. επιστρέφει ένα μόνο αριθμητικό αποτέλεσμα
    Γ. δε γνωρίζει τις πραγματικές της παραμέτρους
    Δ. επιστρέφει μετά την ολοκλήρωση των εντολών της
        αμέσως μετά από το σημείο κλήσεως της

4. Οι πίνακες
    Α. είναι δυναμικές δομές δεδομένων
    Β. μπορούν να περιέχουν τιμές διαφόρων
         τύπων
    Γ.  δεν μπορούν να αποτελέσουν παραμέτρους
         σε υποπρογράμματα
    Δ. καταλαμβάνουν συγκεκριμένο πλήθος θέσεων στη
        μνήμη που δεν μπορεί να μεταβληθεί κατά τη
        διάρκεια εκτέλεσης του προγράμματος

Απαντήσεις

1. Γ
2. Α
3, Γ
4. Δ


Άσκηση με GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών, έτσι ώστε να
ικανοποιεί τις αρχές του δομημένου προγραμματισμού
10 : ΔΙΑΒΑΣΕ Χ
       ΓΡΑΨΕ Χ^2
       ΑΝ Χ > 0 ΤΟΤΕ GOTO 20
       ΓΡΑΨΕ Χ+1
20:  ΓΡΑΨΕ Χ-1
       ΔΙΑΒΑΣΕ Υ
       ΑΝ Υ < > Χ ΤΟΤΕ GOTO 10
       ΓΡΑΨΕ Α_Τ(Χ-1000)

Λύση

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
       ΔΙΑΒΑΣΕ Χ
       ΓΡΑΨΕ Χ^2
       ΑΝ Χ > 0 ΤΟΤΕ
              ΓΡΑΨΕ Χ-1
       ΑΛΛΙΩΣ
              ΓΡΑΨΕ Χ+1
       ΤΕΛΟΣ_ΑΝ
       ΔΙΑΒΑΣΕ Υ
    ΜΕΧΡΙΣ_ΟΤΟΥ  Υ =  Χ
    ΓΡΑΨΕ Α_Τ(Χ-1000)


Συγγραφή διαδικασίας (διάβασμα-γέμισμα πίνακα)

Θεωρήστε τους ακόλουθους πίνακες :
* Α[70,30], ακεραίου τύπου
* Β[70], ακεραίου τύπου
Αν ο πίνακας Β περιέχει το πλήθος των τιμών εισόδου
κάθε γραμμής του Α, γράψτε διαδικασία η οποία
εμφανίζει το περιεχόμενο του πίνακα Α στην οθόνη.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΤΥΠ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Α[70,30], Β[70], Κ, Λ
ΑΡΧΗ
       ΓΙΑ  Κ  ΑΠΟ  1  ΜΕΧΡΙ 70
             ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ Β[Κ]
                   ΓΡΑΨΕ Α[Κ, Λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τρίτη, 24 Μαρτίου 2015

Συγγραφή διαδικασίας

Θεωρήστε τον πίνακα ΟΝ[30] που περιέχει 
τα ονοματεπώνυμα των μαθητών μιας τάξης.
Αν κάθε μαθητής κάνει μια ακριβώς χειραψία
με καθένα από τους συμμαθητές του, γράψτε 
διαδικασία που εμφανίζει ποιος έκανε χειραψία
με ποιον.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΧΕΙΡΑΨΙΑ(ΟΝ)
ΜΕΤΑΒΛΗΤΕΣ
      ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[30]
      ΑΚΕΡΑΙΕΣ: Κ, Λ
ΑΡΧΗ
       ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 30
            ΓΙΑ Λ ΑΠΟ Κ+1 ΜΕΧΡΙ 30
                  ΓΡΑΨΕ ΟΝ[Κ], 'με', ΟΝ[Λ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Σάββατο, 7 Μαρτίου 2015

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το ελεύθερο κείμενο είναι ένας τρόπος _________
    του αλγόριθμου.
2. Η απλούστερη ________ δομή είναι η δομή ακολουθίας.
3. Η λειτουργία του _________ είναι η αντίστροφη της
    συγχώνευσης.
4.  ____________ + Δομές δεδομένων = Προγράμματα
5. Ο ________ + είναι αριθμητικός.

Απαντήσεις

1. αναπαράστασης
2. αλγοριθμική
3. διαχωρισμού
4. Αλγόριθμοι
5. τελεστής



Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
μόνο με Αν..τότε στη θέση της Αν..τότε..αλλιώς_αν
    Αν Α > Β τότε
        Εμφάνισε Α-Β
    αλλιώς_αν  Α mod 2 = 0 τότε
        Εμφάνισε Α+Β
    αλλιώς
        Εμφάνισε Α*Β
    Τέλος_αν

Λύση

   Αν Α > Β τότε
        Εμφάνισε Α-Β
   Τέλος_αν
   Αν  (Α <=  Β) ΚΑΙ (Α mod 2 = 0) τότε
        Εμφάνισε Α+Β
   Τέλος_αν
   Αν (Α <=  Β) ΚΑΙ (Α mod 2 < > 0) τότε
        Εμφάνισε Α*Β
   Τέλος_αν


Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Τα ορίσματα στα οποία εφαρμόζονται
     οι αριθμητικές ή λογικές πράξεις ονομάζονται
     τελεστέοι.
2. Στην ουρά ακολουθείται η πολιτική εξυπηρέτησης
    FIFO και υλοποιείται με τη βοήθεια ενός
    δυσδιάστατου πίνακα.
3. Ο τμηματικός προγραμματισμός είναι η υλοποίηση
    της ιεραρχικής σχεδίασης σε προγραμματιστικό
    επίπεδο.
4. Κάθε Αν..τότε μπορεί να αντικατασταθεί από μια
    Όσο..επανάλαβε που να επιφέρει το ίδιο αλγοριθμικό
    αποτέλεσμα.
5. Αν το βήμα σε μια Για..από..μέχρι είναι μηδέν
    παραλείπεται.


Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Λ
5. Λ




Κυκλώστε τα σωστά

Σε ποιες από τις παρακάτω περιπτώσεις θεωρείται
ότι είναι ιδανική η χρήση της Μέχρις_ότου;
1. Επεξεργασία των στοιχείων του πίνακα Α[100]
2. Επεξεργασία των στοιχείων του πίνακα Α[12, 34]
3. Εισαγωγή τιμών με έλεγχο της εγκυρότητάς τους.
4. Επεξεργασία κάποιων τιμών εισόδου *η είσοδος
    ολοκληρώνεται μόλις δοθεί μια μη θετική τιμή)
5. Μενού λειτουργιών
6. Επεξεργασία 50 τιμών εισόδου.

Απάντηση

3, 4, 5

Κυριακή, 22 Φεβρουαρίου 2015

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Οι τυπικές και οι πραγματικές παράμετροι είναι
    σε αντιστοιχία 1 - 1 μεταξύ τους.
2. Οι τυπικές παράμετροι αποκαλούνται και ορίσματα.
3. Μια συνάρτηση μπορεί (ως παρενέργεια) να αλλάξει
    το περιεχόμενο των πραγματικών παραμέτρων της.
4. Οι  παράμετροι εξασφαλίζουν την επικοινωνία των
    υποπρογραμμάτων με άλλα υποπρογράμματα και
    το κύριο πρόγραμμα.
5. Μόλις ολοκληρωθεί η εκτέλεση των εντολών μιας
    συνάρτησης, η ροή των εντολών συνεχίζεται από
    την εντολή εκείνη που βρίσκεται αμέσως μετά
    την ΚΑΛΕΣΕ.

Απαντήσεις

1. Σ
2. Σ
3. Λ
4, Σ
5. Λ


Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1. Ένα _________ επιτελεί ένα αυτόνομο έργο.
2. Μια συνάρτηση έχει ένα _______ που εξαρτάται
    από το υπολογισμό που πραγματοποιεί.
3. Οι διευθύνσεις ________ των υποπρογραμμάτων
    αποθηκεύονται στη ________ χρόνου εκτέλεσης.
4. Τα υποπρογράμματα έχουν μία είσοδο και μία _____.
5.  Οι μεταβλητές και οι συμβολικές σταθερές των
     υποπρογραμμάτων έχουν τοπική ______.

Απαντήσεις

1. υποπρόγραμμα
2. τύπο
3. επιστροφής, στοίβα
4. έξοδο
5. εμβέλεια


Κυκλώστε τα σωστά

Κυκλώστε τις σωστές προτάσεις
1. Η συνάρτηση μπορεί να πραγματοποιήσει οποιαδήποτε
    λειτουργία.
2. Κάθε συνάρτηση γράφεται πριν από το κύριο πρόγραμμα
    που την καλεί.
3. Μια διαδικασία μπορεί μόνο να τυπώνει.
4. Κάθε αποτέλεσμα σε μια διαδικασία αποτελεί ξεχωριστή
    παράμετρο στην επικεφαλίδα της.
5. Οι δικές μας συναρτήσεις ενεργοποιούνται με διαφορετικό
    τρόπο από ότι οι ενσωματωμένες συναρτήσεις της ΓΛΩΣΣΑΣ.
6. Κάθε συνάρτηση μπορεί να ενεργοποιηθεί μέσα από μια
    εντολή εκχώρησης ή ΓΡΑΨΕ.
7. Δεν μπορεί μια συνάρτηση να καλέσει μια διαδικασία.
8. Μια διαδικασία μπορεί να καλέσει μια συνάρτηση.


Απαντήσεις

1. 3, 4, 6, 8

Επιλέξτε τύπο υποπρογράμματος

Ποιο τύπο υποπρογράμματος (Σ - συνάρτηση, Δ - διαδικασία)
θα επιλέγατε για την  εκτέλεση των παρακάτω ενεργειών;
1. Υπολογισμός αθροίσματος στοιχείων δυσδιάστατου
    πίνακα.
2. Υπολογισμός αθροισμάτων ανά γραμμή σε δυσδιάστατο
    πίνακα.
3. Διάβασμα μονοδιάστατου πίνακα.
4. Υπολογισμός ελαχίστου στοιχείου τρισδιάστατου πίνακα.
5. Υπολογισμός μεγίστου στοιχείου και θέσης του σε
     μονοδιάστατο πίνακα.


Απαντήσεις

1. Σ
2. Δ
3. Δ
4. Σ
5. Δ



Βήμα-βήμα εκτέλεση

Θεωρείστε τη συνάρτηση Φ(Χ) η οποία επιστρέφει το
τριπλάσιο του Χ (Χ ακέραιος), Τι θα εμφανίσει η
παρακάτω διαδικασία
     ΔΙΑΔΙΚΑΣΙΑ Δ(Α, Β)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Κ
     ΑΡΧΗ
           ΓΙΑ  Κ ΑΠΟ Α ΜΕΧΡΙ Β
                 ΓΡΑΨΕ Φ(Κ+1), Κ+1, (Κ ΜΟD 2 = 0)
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΡΑΨΕ Φ(Κ+4)*1000
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
αν κληθεί από το κύριο πρόγραμμα με την εντολή
     ΚΑΛΕΣΕ Δ(Φ(4 MOD 7), Φ(17 DIV 3))

Λύση

Αφού Φ(4 MOD 7) = Φ(4) = 3*4 = 12 και
          Φ(17 DIV 3) = Φ(5) = 3*5 = 15
η κλήση της Δ έχει :
      Τυπικές               Πραγματικές       Τιμή
    παραμέτρους         παραμέτρους  
           Α                      Φ(4 MOD 7)          12      
           Β                      Φ(17 DIV 3)           15
Κ = Α = 12
      Αφού Κ+1 = 12+1 = 13, Φ(Κ+1) = Φ(13) = 3*13 = 39
      και (Κ ΜΟD 2 = 0) = (12 ΜΟD 2 = 0) = (0 = 0)
            = ΑΛΗΘΗΣ, η ΓΡΑΨΕ εμφανίζει:
            39     13    ΑΛΗΘΗΣ
Κ = 13
      Αφού Κ+1 = 13+1 = 14, Φ(Κ+1) = Φ(14) = 3*14 = 42
      και (Κ ΜΟD 2 = 0) = (13 ΜΟD 2 = 0) = (1 = 0)
            = ΨΕΥΔΗΣ, η ΓΡΑΨΕ εμφανίζει:
            42     14     ΨΕΥΔΗΣ
Κ = 14
      Αφού Κ+1 = 14+1 = 15, Φ(Κ+1) = Φ(15) = 3*15 = 45
      και (Κ ΜΟD 2 = 0) = (14 ΜΟD 2 = 0) = (0 = 0)
            = ΑΛΗΘΗΣ, η ΓΡΑΨΕ εμφανίζει:
            45     15     ΑΛΗΘΗΣ
Κ = 15
      Αφού Κ+1 = 15+1 = 16, Φ(Κ+1) = Φ(16) = 3*16 = 48
      και (Κ ΜΟD 2 = 0) = (15 ΜΟD 2 = 0) = (1 = 0)
            = ΨΕΥΔΗΣ, η ΓΡΑΨΕ εμφανίζει:
            48     16     ΨΕΥΔΗΣ
Η ΓΙΑ τερματίζεται με Κ = 16.
Αφού Φ(Κ+4)*1000 = Φ(16+4)*1000 = Φ(20)*1000 =
          60*1000 = 60000
η ΓΡΑΨΕ εμφανίζει : 60000





Συγγραφή διαδικασίας

Γράψτε διαδικασία που εμφανίζει όλες τις δυνατές
ακέραιες τετράδες στο διάστημα [Α, Β] (Α, Β ακέραιοι)
που έχουν άθροισμα μεγαλύτερο από 2700.

Λύση

ΔΙΑΔΙΚΑΣΙΑ Τετράδες(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ, Κ
ΑΡΧΗ
       ΓΙΑ Χ ΑΠΟ Α ΜΕΧΡΙ Β
            ΓΙΑ Υ ΑΠΟ Α ΜΕΧΡΙ Β
                 ΓΙΑ Ζ ΑΠΟ Α ΜΕΧΡΙ Β
                        ΓΙΑ Κ ΑΠΟ Α ΜΕΧΡΙ Β
                             ΑΝ Χ+Υ+Ζ+Κ > 2700 ΤΟΤΕ
                                      ΓΡΑΨΕ Χ, Υ, Ζ, Κ
                             ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Συγγραφή διαδικασίας

Γράψτε διαδικασία που διαβάζει το μέσο μεταφοράς
που επιλέξατε για τη μετακίνησή σας (επιτρεπτές
τιμές εισόδου : αεροπλάνο, πλοίο, λεωφορείο,
τρένο).

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΜΜΜ (Μέσο)
ΜΕΤΑΒΛΗΤΕΣ
      ΧΑΡΑΚΤΗΡΕΣ : Μέσο
ΑΡΧΗ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Δώσε το μέσο μεταφοράς'
          ΔΙΑΒΑΣΕ Μέσο
      ΜΕΧΡΙΣ_ΟΤΟΥ (Μέσο = 'αεροπλάνο') Ή 
                      (Μέσο = 'πλοίο') Ή (Μέσο = 'λεωφορείο') Ή
                      (Μέσο = 'τρένο')
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δευτέρα, 19 Ιανουαρίου 2015

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Δεν μπορεί να δημιουργηθεί το εκτελέσιμο πρόγραμμα
    όταν υπάρχουν __________ λάθη.
2. Ο αλγόριθμος είναι ένας μηχανισμός παραγωγής ______.
3. Ο συντάκτης είναι ένας εξειδικευμένος _________
    που χρησιμοποιείται για τη συγγραφή των _______
    προγραμμάτων.
4. Ο τελεστής / είναι  __________.
5. Τη μεγαλύτερη προτεραιότητα από τους λογικούς
     τελεστές έχει ο ______.


Απαντήσεις

1. συντακτικά
2. πληροφοριών
3. κειμενογράφος, πηγαίων
4. αριθμητικός
5. ΟΧΙ


Ταξινόμηση με πολλαπλά κριτήρια

Θεωρήστε τους πίνακες ΟΝ[300], ΕΠΩΝ[300], ΑΜ[300] που
περιέχουν τα ονόματα, τα επώνυμα και τους αριθμούς
μητρώου των 300 μαθητών ενός γενικού λυκείου.
Γράψτε αλγόριθμο που εμφανίζει τους αριθμούς μητρώου,
τα ονόματα και τα επώνυμα των μαθητών κατά αλφαβητική
σειρά των επωνύμων. Σε περίπτωση που δύο ή περισσότεροι
μαθητές έχουν το ίδιο επίθετο, ακολουθείται η αλφαβητική
σειρά των ονομάτων. Όταν και τα ονόματα συμπίπτουν
προηγούνται στη σειρά εμφάνισης οι μαθητές με το
μικρότερο αριθμό μητρώου.

Λύση

Αλγόριθμος Λίστα
Δεδομένα // ΟΝ, ΕΠΩΝ, ΑΜ //
Για κ από 2 μέχρι 300
    Για λ από 300 μέχρι κ με_βήμα -1
        Αν ΕΠΩΝ[λ-1] > ΕΠΩΝ[λ] τότε
            Αντιμετάθεσε ΕΠΩΝ[λ-1], ΕΠΩΝ[λ]
            Αντιμετάθεσε ΟΝ[λ-1], ΟΝ[λ]
            Αντιμετάθεσε ΑΜ[λ-1], ΑΜ[λ]
        αλλιώς_αν (ΕΠΩΝ[λ-1] = ΕΠΩΝ[λ]) ΚΑΙ
                           (ΟΝ[λ-1] > ΟΝ[λ]) τότε
            Αντιμετάθεσε ΟΝ[λ-1], ΟΝ[λ]
            Αντιμετάθεσε ΑΜ[λ-1], ΑΜ[λ]
        αλλιώς
             Αν (ΕΠΩΝ[λ-1] = ΕΠΩΝ[λ]) ΚΑΙ
                   (ΟΝ[λ-1] = ΟΝ[λ]) ΚΑΙ
                   (ΑΜ[λ-1] > ΑΜ[λ])  τότε
                    Αντιμετάθεσε ΑΜ[λ-1], ΑΜ[λ]
             Τέλος_αν
        Τέλος_αν
    Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από 1 μέχρι 300
     Εμφάνισε ΟΝ[κ], ΕΠΩΝ[κ], ΑΜ[κ]
Τέλος_επανάληψης
Τέλος Λίστα

Πέμπτη, 8 Ιανουαρίου 2015

Αντιμετάθεση δύο στηλών

Γράψτε αλγόριθμο που:
α) διαβάζει μια ακέραια τιμή Ν τέτοια ώστε 1 < Ν < 32,
β) διαβάζει μια ακέραια τιμή Μ τέτοια ώστε 1 < Μ < 32.
γ) αντιμεταθέτει τα στοιχεία της Ν στήλης με αυτά της Μ
    στήλης στον πραγματικό πίνακα Α[78, 32].

Λύση

Αλγόριθμος Αντιμ
Δεδομένα // Α //
Αρχή_επανάληψης
     Διάβασε Ν
Μέχρις_ότου (Ν > 1) ΚΑΙ (Ν < 32)
Αρχή_επανάληψης
     Διάβασε Μ
Μέχρις_ότου (Μ > 1) ΚΑΙ (Μ  < 32)
Για κ από 1 μέχρι 78
       Αντιμετάθεσε Α[κ, Ν], Α[κ, Μ]
Τέλος_επανάληψης
Αποτελέσματα // Α //
Τέλος Αντιμ

Αντιμετάθεση δύο διαδοχικών γραμμών

Θεωρείστε έναν ακέραιο πίνακα Α[15, 23] και μια
ακέραια τιμή Ν τέτοια ώστε 1 < Ν < 15. Γράψτε
αλγόριθμο που αντιμεταθέτει τα στοιχεία της
Ν γραμμής με αυτά της Ν+1 γραμμής στον
παραπάνω πίνακα.

Λύση

Αλγόριθμος Αντιμ
Δεδομένα // Α, Ν //
Για λ από 1 μέχρι 23
     Αντιμετάθεσε Α[Ν, λ], Α[Ν+1, λ]
Τέλος_επανάληψης
Αποτελέσματα // Α //
Τέλος Αντιμ

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Ο πίνακας είναι μια μορφή αρχείου εγγραφών.
2. Τα στοιχεία ενός πίνακα ονομάζονται και πεδία.
3. Μια από τις σκοπιές που εξετάζει η Πληροφορική
    τα δεδομένα είναι και αυτή των Δομών Δεδομένων.
4. Ο τρισδιάστατος πίνακας Α[10, 10, 10] έχει τη
    γεωμετρική αναπαράσταση ενός κύβου.
5. Όλες οι επεξεργασίες ενός μονοδιάστατου πίνακα
    μπορούν να γίνουν με ένα μόνο Για..από..μέχρι


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Λ