Σάββατο, 31 Δεκεμβρίου 2011

Εξαφανίστε την GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ακολουθεί τις αρχές του δομημένου προγραμματισμού
     Α <-- 0
     Κ <-- 100
10 : ΑΝ Κ < 0 ΤΟΤΕ GOTO 60
       Λ <-- 4
20 : ΑΝ Λ > 80 ΤΟΤΕ GOTO 70
       ΓΡΑΨΕ Κ^2+Λ^2
       Λ <-- Λ+4
       GOTO 20
       K <-- K-1
       GOTO 10
       ΓΡΑΨΕ 'ΑΝΤΙΟ 2011'

Λύση

     Α <-- 0
     Κ <-- 100
     ΟΣΟ Κ >= 0 ΕΠΑΝΑΛΑΒΕ
          Λ <-- 4
          ΟΣΟ Λ <= 80 ΕΠΑΝΑΛΑΒΕ
               ΓΡΑΨΕ Κ^2+Λ^2
               Λ <-- Λ+4
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          K <-- K-1
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΓΡΑΨΕ 'ΑΝΤΙΟ 2011'

      

Παρασκευή, 30 Δεκεμβρίου 2011

Πίνακας αλήθειας

Κατασκευάστε τον πίνακα αλήθειας της παράστασης
     ΟΧΙ ΚΑΙ Υ) Ή  Ζ

Λύση
Ας συμβολίσουμε για λόγους εξοικονόμησης χώρου με Α την
τιμή Αληθής και Ψ την τιμή Ψευδής. Ο πίνακας αλήθειας είναι
ο ακόλουθος:

Χ   Υ   Ζ   Χ ΚΑΙ Υ  ΟΧΙ(Χ ΚΑΙ Υ)  ΟΧΙ(Χ ΚΑΙ Υ) Ή Ζ
Α   Α   Α        Α                 Ψ                            Α
Α   Α   Ψ        Α                 Ψ                            Ψ
Α   Ψ   Α        Ψ                 Α                            Α
Α   Ψ   Ψ        Ψ                 Α                            Α
Ψ   Α   Α        Ψ                 Α                            Α
Ψ   Α   Ψ        Ψ                 Α                            Α
Ψ   Ψ   Α        Ψ                 Α                            Α
Ψ   Ψ   Ψ        Ψ                 Α                            Α

Πέμπτη, 29 Δεκεμβρίου 2011

Γέμισμα δυσδιάστατου πίνακα

Γράψτε αλγόριθμο που γεμίζει (γραμμή-γραμμή) τον πίνακα
Α[5, 2] με την προπαίδεια του Μ (θεωρείστε το Μ ως
δεδομένο).

Λύση

    Αλγόριθμος Ασκ
    Δεδομένα // Μ //
    Ρ <-- 1
    Για κ από 1 μέχρι 5
         Για λ από 1 μέχρι 2
               Α[κ, λ] <-- Ρ*Μ
               Ρ <-- Ρ+1
         Τέλος_επανάληψης
    Τέλος_επανάληψης
    Αποτελέσματα // Α //
    Τέλος Ασκ

Δευτέρα, 26 Δεκεμβρίου 2011

Επεξεργασία μονοδιάστατου πίνακα

Γράψτε αλγόριθμο που:
α) διαβάζει 15 ακέραιες  τιμές και τις καταχωρεί στον
    ακέραιο πίνακα Α[15],
β) υπολογίζει και εμφανίζει:
    * πόσα στοιχεία του πίνακα είναι μικρότερα του 5,
    * το ποσοστό (%) των στοιχείων του πίνακα που
       είναι θετικά,
    * το μέσο όρο των αρνητικών στοιχείων του πίνακα.

Λύση

     Αλγόριθμος ΑΣΚ
     Για κ από 1 μέχρι 15
           Διάβασε Α[κ]
     Τέλος_επανάληψης
     φ5 <-- 0
     θετ <-- 0
     σ <-- 0
     Αρν <-- 0
     Για κ από 1 μέχρι 15
          Αν Α[κ] < 5 τότε
               φ5 <-- φ5+1
          Τέλος_αν
          Αν Α[κ] > 0 τότε
              θετ  <-- θετ+1
          Τέλος_αν
          Αν Α[κ] < 0 τότε
                σ <-- σ+Α[κ]
                Αρν <-- Αρν+1
          Τέλος_αν
     Τέλος_επανάληψης
     Αν  Αρν > 0 τότε
          ΜΟΑρν <-- σ/Αρν
          Εμφάνισε ΜΟΑρν
     αλλιώς
          Εμφάνισε 'Δεν υπάρχουν καθόλου αρνητικοί!'
     Τέλος_αν
     ΠΟΣ <-- 100*Θετ/15
     Εμφάνισε ΠΟΣ
     Τέλος ΑΣΚ

Σάββατο, 24 Δεκεμβρίου 2011

Εμφωλευμένες δομές επανάληψης

Γράψτε αλγόριθμο που:
α) διαβάζει τις μηνιαίες εισπράξεις των τελευταίων 10 ετών
    για 15 επιχειρήσεις του Ηρακλείου,
β) υπολογίζει και εμφανίζει:
    * τις ετήσιες εισπράξεις κάθε επιχείρησης, για κάθε χρόνο
       ξεχωριστά,
    * τη μέση ετήσια είσπραξη για κάθε επιχείρηση ξεχωριστά,
    * τη μεγαλύτερη μηνιαία είσπραξη, τον αύξοντα αριθμό
       (1- 15) της επιχείρησης που την πραγματοποίησε και
       πότε συνέβη αυτό (αύξοντα αριθμό μήνα, αύξοντα αριθμό
       έτους).

Λύση

       Αλγόριθμος Επιχειρ
       Μεγ <-- -100
       Για κ από 1 μέχρι 15
            Αθρ <-- 0
            Για λ από 1 μέχρι 10
                  σ <-- 0
                  Για μ από 1 μέχρι 12
                       Διάβασε Μην
                       Αν Μην > Μεγ τότε
                             Μην <-- Μεγ
                             ΑΑΕπ <-- κ
                             ΑΑΧρ <-- λ
                             ΑΑΜην <-- μ
                       Τέλος_αν
                       σ <-- σ+Μην
                  Τέλος_επανάληψης
                  Εμφάνισε σ
                  Αθρ <-- Αθρ+σ
            Τέλος_επανάληψης
            ΜΟ <-- Αθρ/10
            Εμφάνισε ΜΟ
       Τέλος_επανάληψης
       Εμφάνισε Μεγ, ΑΑΕπ, ΑΑΧρ, ΑΑΜην
       Τέλος Επιχειρ

Παρασκευή, 23 Δεκεμβρίου 2011

Επιλέξτε είδος υποπρογράμματος

Προσδιορίστε το είδος του υποπρογράμματος (Σ - συνάρτηση,
Δ - διαδικασία) που απαιτείται για τα ακόλουθα έργα:
1. Εισαγωγή τριών ακεραίων αριθμών
2. Έλεγχος για την επιβεβαίωση μιας συγκεκριμένης ιδιότητας
    από όλα τα στοιχεία ενός πίνακα
3. Ταξινόμηση ενός πίνακα
4. Υπολογισμός περιμέτρου τραπεζίου
5. Υπολογισμός μέσου όρου κάποιων τιμών (η είσοδος
    δεδομένων ολοκληρώνεται μόλις δοθεί από το
    πληκτρολόγιο τιμή μη θετική)

Απαντήσεις

1. Δ
2. Σ
3. Δ
4. Σ
5. Δ

Πέμπτη, 22 Δεκεμβρίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[100, 3] και αντιγράφει τα στοιχεία της
1ης, 2ης και 3ης στήλης στους ακέραιους πίνακες Β[100],
Γ[100], και Δ[100] αντίστοιχα.

Λύση

    ΔΙΑΔΙΚΑΣΙΑ ΑΝΤΙΓΡ(Α, Β, Γ, Δ)
    ΜΕΤΑΒΛΗΤΕΣ
         ΑΚΕΡΑΙΕΣ: Α[100, 3], Β[100], Γ[100], Δ[100], Κ
    ΑΡΧΗ
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 100
                Β[Κ] <-- Α[Κ, 1]
                Γ[Κ] <-- Α[Κ, 2]
                Δ[Κ] <-- Α[Κ, 3]
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τετάρτη, 21 Δεκεμβρίου 2011

Χρησιμοποιήστε μόνο την λογική πράξη ΚΑΙ

Ξαναγράψτε τις παρακάτω λογικές εκφράσεις χρησιμοποιώντας
μόνο τη λογική πράξη ΚΑΙ
1. ΟΧΙ (Χ = 18) ΚΑΙ  ( (Χ > 5) Ή (Χ = 5) )
2. ΟΧΙ ( (Χ < 2) Ή (Χ >= 19) )
3. ΟΧΙ (ΟΧΙ ( (Χ > 0) ΚΑΙ MOD 2 = 0) ) )
4. ΟΧΙ ΟΧΙ (Χ < 0) Ή ΟΧΙ (Υ = 'Α') )

Απαντήσεις


1. (Χ < > 18) ΚΑΙ (Χ >=5)
2. (Χ >= 2) ΚΑΙ (Χ < 19)
3. (Χ > 0) ΚΑΙ (Χ MOD 2 = 0)
4. (Χ < 0) ΚΑΙ (Υ = 'Α')

Τρίτη, 20 Δεκεμβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[11, 11] και ελέγχει αν το άθροισμα των
στοιχείων της 1ης κυρίας διαγωνίου είναι ίσο με το
άθροισμα των στοιχείων της 2ης κυρίας διαγωνίου.

Λύση

    ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ (Α) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Α[11, 11], Κ, ΑΘΡ1, ΑΘΡ2
    ΑΡΧΗ
          ΑΘΡ1 <-- 0
          ΑΘΡ2 <-- 0
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 11
                ΑΘΡ1 <-- ΑΘΡ1+Α[Κ, Κ]
                ΑΘΡ2 <-- ΑΘΡ2+Α[Κ, 12-Κ]
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΕΛΕΓΧΟΣ <-- (ΑΘΡ1 = ΑΘΡ2)
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Κυριακή, 18 Δεκεμβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μια εντολή _________ είναι ιδανική για τον έλεγχο
    εγκυρότητας εισερχόμενων δεδομένων.
2. Η ισχύς των μεταβλητών και των συμβολικών σταθερών
    σε ένα υποπρόγραμμα είναι _______.
3. Μεγαλύτερη προτεραιότητα από όλους τους τελεστές
    έχουν οι _________.
4. Για να προσδιορίσουμε ένα στοιχείο κάποιου πίνακα
    απαιτούνται ένας ή περισσότεροι ______.
5. Ένα ______ πρόβλημα επιδέχεται τουλάχιστον μια λύση.

Απαντήσεις

1. Μέχρις_ότου
2. τοπική
3. αριθμητικοί
4. δείκτες
5. επιλύσιμο

Πέμπτη, 15 Δεκεμβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μια _________ παράσταση έχει ως αποτέλεσμά την τιμή
    ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ.
2. Οι λειτουργίες της εισαγωγής και της _______ δεν μπορούν
    να γίνουν σε έναν πίνακα.
3. Ένα υποπρόγραμμα εκτελεί ένα ___________ έργο.
4. Ο ____________ είναι ένα μέσο παραγωγής πληροφοριών.
5. Για να περιγράψουμε το αποτέλεσμα μιας εξεταστικής
    διαδικασίας (επιτυχημένη ή αποτυχημένη) μπορούμε να
    χρησιμοποιήσουμε μια λογική ή _______ μεταβλητή.


Απαντήσεις

1. λογική
2. διαγραφής
3. αυτόνομο
4. αλγόριθμος
5. αλφαριθμητική

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος
1. Ένα πρόγραμμα  έχει τουλάχιστον μια εντολή.
2. Ο τύπος των συμβολικών σταθερών δηλώνεται σε
    ξεχωριστό τμήμα δηλώσεων του προγράμματος.
3. Εμφωλευμένες δομές ακολουθίας είναι δύο ή
   περισσότερες δομές ακολουθίας που βρίσκονται η
   μία μέσα στην άλλη.
4. Τα αλφαριθμητικά δεδομένα δεν μπορούν να
    ταξινομηθούν.
5. Μια διαδικασία μπορεί να κληθεί και μέσα από μια
    εντολή ΓΡΑΨΕ.


Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Λ
5. Λ

Τετάρτη, 14 Δεκεμβρίου 2011

Συγγραφή διαδικασίας

Θεωρείστε τους ακόλουυθους πίνακες:
* ΣΥΓΚ[200], που περιέχει τα ονόματα 200 μουσικών
   συγκροτημάτων,
* ΕΘΝ[200], που περιέχει τη χώρα προέλευσης των
  συγκροτημάτων αυτών.
Γράψτε διαδικασία που δέχεται ως παραμέτρους τους
δύο παραπάνω πίνακες και :
α) υπολογίζει το συνολικό πλήθος των συγκροτημάτων
    που προέρχονται από την ΕΛΛΑΔΑ,
β) καταχωρεί σε πίνακα τα ονόματα των συγκροτημάτων
    αυτών.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΜΟΥΣΙΚΗ(ΣΥΓΚ, ΕΘΝ, Ελλ, ΣυγκΕλλ)
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Ελλ, Κ
          ΧΑΡΑΚΤΗΡΕΣ: ΣΥΓΚ[200], ΕΘΝ[200], ΣυγκΕλλ[200]
     ΑΡΧΗ
           Ελλ <-- 0
           ΓΙΑ Κ ΑΠΌ 1 ΜΕΧΡΙ 200
               ΑΝ ΕΘΝ[Κ] = 'ΕΛΛΑΔΑ' ΤΟΤΕ
                    Ελλ <-- Ελλ+1
                    ΣυγκΕλλ[Ελλ] <-- ΣΥΓΚ[Κ]
               ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τρίτη, 13 Δεκεμβρίου 2011

Άσκηση : δυσδιάστατοι πίνακες

Οι 25 μαθητές μιας τάξης υποβάλλονται σε 10 ερωτήσεις
προκειμένου να αξιολογηθούν από τον καθηγητή τους.
Γράψτε αλγόριθμο που:
α) διαβάζει τι απάντησαν οι μαθητές σε κάθε ερώτηση
    και καταχωρεί τα δεδομένα αυτά στον αλφαριθμητικό
    πίνακα ΑΠ[25, 10] (δυνατές τιμές εισόδου είναι:
    Σ - σωστή απάντηση, Λ - λανθασμένη απάντηση,
    ΔΕΝ - δεν δόθηκε απάντηση),
β) υπολογίζει και καταχωρεί στον πίνακα ΕΡ[10, 3]
     πόσες σωστές, λανθασμένες και καθόλου απαντήσεις
     δόθηκαν σε κάθε ερώτηση,
γ) εμφανίζει τον αριθμό της ερώτησης που αποδείχθηκε
    πιο εύκολη (θεωρείστε ότι είναι μοναδική).
Παρατήρηση : Ο αλγόριθμος πρέπει να διασφαλίζει την
εγκυρότητα των εισερχόμενων δεδομένων.

Λύση

      Αλγόριθμος Τάξη
      Για κ από 1 μέχρι 25
          Για λ από 1 μέχρι 10
               Αρχή_επανάληψης
                     Διάβασε ΑΠ[κ, λ]
               Μέχρις_ότου (ΑΠ[κ, λ] = 'Σ') Ή (ΑΠ[κ, λ] = 'Λ')
                                     Ή (ΑΠ[κ, λ] = 'ΔΕΝ')
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για κ από 1 μέχρι 10
          Για λ από 1 μέχρι 3
               ΕΡ[κ, λ] <-- 0  
         Τέλος_επανάληψης

      Τέλος_επανάληψης
      Για λ από 1 μέχρι 10
          Για κ από 1 μέχρι 25
               Αν ΑΠ[κ, λ] = 'Σ' τότε
                    ΕΡ[λ, 1] <-- ΕΡ[λ, 1]+1   
               αλλιώς_αν ΑΠ[κ, λ] = 'Λ' τότε
                    ΕΡ[λ, 2] <-- ΕΡ[λ, 2]+1
               αλλιώς
                    ΕΡ[λ, 3] <-- ΕΡ[λ, 3]+1
                Τέλος_αν 
         Τέλος_επανάληψης

      Τέλος_επανάληψης
      Μεγ <-- ΕΡ[1, 1]
      ΑΑΜεγ <-- 1
      Για κ από 2 μέχρι 10
          Αν ΕΡ[κ, 1] > Μεγ τότε
               Μεγ <-- ΕΡ[κ, 1]
               ΑΑΜεγ <-- κ
          Τέλος_αν
      Τέλος_επανάληψης
      Εμφάνισε ΑΑΜεγ
      Αποτελέσματα // ΕΡ // 
      Τέλος Τάξη


     

Παρασκευή, 9 Δεκεμβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιές από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος;
1. Κάθε πρόγραμμα μπορεί να υλοποιηθεί και ως συνάρτηση.
2. Η στοίβα χρόνου εκτέλεσης "φιλοξενεί" τις διευθύνσεις
    επιστροφής των υποπρογραμμάτων.
3. Μια συνάρτηση μπορεί να κληθεί μόνο μέσα από το
    κύριο πρόγραμμα και ποτέ μέσα από κάποιο άλλο
    υποπρόγραμμα.
4. Οι πίνακες δίνουν απεριόριστες δυνατότητες στους
    προγραμματιστές.
5. Τα αρχεία εγγραφών είναι δομές δεδομένων
    δευτερεύουσας μνήμης.


Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους δύο
τιμές Ν, Μ (θεωρείστε ότι το Ν είναι διάφορο του μηδενός)
και ελέγχει αν το Μ είναι πολλαπλάσιο του Ν ή όχι.

Λύση

     ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Ν, Μ) : ΛΟΓΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Ν, Μ
     ΑΡΧΗ
          ΑΝ M MOD N = 0 TOTE
                 ΕΛΕΓΧΟΣ <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
                 ΕΛΕΓΧΟΣ <-- ΨΕΥΔΗΣ

          ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Παρατήρηση
Η ΑΝ..ΤΟΤΕ..ΑΛΛΙΩΣ θα μπορούσε να αντικατασταθεί
ως εξής:
       ΕΛΕΓΧΟΣ <-- (Μ MOD N = 0)
   

Τετάρτη, 7 Δεκεμβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
ακέραιο πίνακα Α[200] και εξετάζει αν ισχύει η
ιδιότητα :
       Α[Κ] <= Α[Κ+2] <= Α[Κ+1]
για Κ = 1, 2, ..., 198

Λύση

      ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Α) : ΛΟΓΙΚΗ
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Α[200], Κ
             ΛΟΓΙΚΕΣ : ΑΠ
      ΑΡΧΗ
             ΑΠ <-- ΑΛΗΘΗΣ
             Κ <-- 1
             ΟΣΟ (Κ <= 198) ΚΑΙ (ΑΠ = ΑΛΗΘΗΣ) ΕΠΑΝΑΛΑΒΕ
                   ΑΝ (Α[Κ] > Α[Κ+2]) Ή (Α[Κ+2] > Α[Κ+1) ΤΟΤΕ
                          ΑΠ <-- ΨΕΥΔΗΣ
                   ΑΛΛΙΩΣ
                          Κ <-- Κ+1
                   ΤΕΛΟΣ_ΑΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΕΛΕΓΧΟΣ <-- ΑΠ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δευτέρα, 5 Δεκεμβρίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που διαβάζει τα χρώματα κάποιων
t-shirt (η είσοδος δεδομένων τερματίζεται μόλις
δοθεί ως χρώμα η λέξη 'ΑΧΡΩΜΟ') και υπολογίζει :
α) πόσα t-shirt είχαν χρώμα ΛΕΥΚΟ,
β) το ποσοστό (%) των t-shirt  που είχαν χρώμα ΜΑΥΡΟ,
γ) το συνολικό πλήθος όλων των t-shirt.
Παρατήρηση : Θεωρείστε ότι δόθηκαν δεδομένα για
τουλάχιστον ένα t-shirt.

Λύση


       ΔΙΑΔΙΚΑΣΙΑ ΧΡΩΜΑΤΑ(Πληθ, Λευκ, ΠΟΣ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ : Πληθ, Λευκ, Μαυρ
             ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
             ΧΑΡΑΚΤΗΡΕΣ: Χρ
       ΑΡΧΗ
              Πληθ <-- 0
              Λευκ <-- 0
              Μαυρ <-- 0
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                     ΔΙΑΒΑΣΕ Χρ
                     ΑΝ Χρ < > 'ΑΧΡΩΜΟ' ΤΟΤΕ
                           Πληθ <-- Πληθ+1
                           ΑΝ Χρ = 'ΛΕΥΚΟ' ΤΟΤΕ
                                 Λευκ <-- Λευκ+1
                           ΤΕΛΟΣ_ΑΝ
                           ΑΝ Χρ = 'ΜΑΥΡΟ' ΤΟΤΕ
                                 Μαυρ <-- Μαυρ+1
                           ΤΕΛΟΣ_ΑΝ
                     ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ Χρ = 'ΑΧΡΩΜΟ'
              ΠΟΣ <-- 100*Μαυρ/Πληθ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ




Σάββατο, 3 Δεκεμβρίου 2011

Άσκηση : Εμφωλευμένα Για+βοηθητικός πίνακας

Θέλετε να σχεδιάσετε πάνω σε μια κόλλα χαρτί  τέσσερα
τετράγωνα. Γράψτε αλγόριθμο που εμφανίζει όλους τους
δυνατούς συνδυασμούς χρωμάτων με τους οποίους μπορείτε να
τα σχεδιάσετε.Τα χρώματα που μπορείτε να χρησιμοποιήσετε
για το καθένα είναι μπλε, κόκκινο, πράσινο και κίτρινο.

Λύση

     Αλγόριθμος Ασκ
     Χ[1] <-- 'μπλε'
     Χ[2] <-- 'κόκκινο'
     Χ[3] <-- 'πράσινο'
     Χ[4] <-- 'κίτρινο'
     Για κ από 1 μέχρι 4
         Για λ από 1 μέχρι 4
              Για μ από 1 μέχρι 4
                   Για ρ από 1 μέχρι 4
                       Εμφάνισε Χ[κ], Χ[λ], Χ[μ], Χ[ρ]
                   Τέλος_επανάληψης
              Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Τέλος Ασκ

Πέμπτη, 1 Δεκεμβρίου 2011

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η εντολή Διαβάστε Χ έχει ένα λογικό λάθος.
2. Η εντολή Εμφάνισε '1+2*3' εμφανίζει στη μονάδα
    εξόδου : 5
3. Μια αριθμητική μεταβλητή χρειάζεται για την
    αποθήκευσή της στη μνήμη 2 bytes.
4. Οι εντολές Όσο..επανάλαβε και Για..από..μέχρι
    είναι ισοδύναμες μεταξύ τους.
5. Ένας μονοδιάστατος πίνακας έχει τουλάχιστον ένα
    στοιχείο.



Απαντήσεις

1. Η εντολή Διαβάστε Χ έχει ένα συντακτικό λάθος.
2. Η εντολή Εμφάνισε '1+2*3' εμφανίζει στη μονάδα
    εξόδου :1+2*3
3. Μια αριθμητική μεταβλητή χρειάζεται για την
    αποθήκευσή της στη μνήμη 2 ή 4  bytes.
4. Οι εντολές Όσο..επανάλαβε και Μέχρις_ότου
    είναι ισοδύναμες μεταξύ τους.
5.  Ένας μονοδιάστατος πίνακας έχει τουλάχιστον δύο 
     στοιχεία.

Παρασκευή, 25 Νοεμβρίου 2011

Άσκηση: συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν
ακέραιο πίνακα  Α[34, 12] και υπολογίζει:
α) πόσα στοιχεία της 3ης γραμμής είναι μηδενικά,
β) το ποσοστό (%) των στοιχείων της 7ης στήλης
    που είναι μεγαλύτερα του 50.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛ(Α, φ3, ποσ7)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[34, 12], Κ, Φ3, Φ7
           ΠΡΑΓΜΑΤΙΚΕΣ : ποσ7
     ΑΡΧΗ
           φ3 <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                 ΑΝ Α[3, Κ] = 0 ΤΟΤΕ
                       φ3 <-- φ3+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           φ7 <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 34
                 ΑΝ Α[Κ, 7] > 50 ΤΟΤΕ
                       φ7 <-- φ7+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ποσ7 <-- 100*φ7/34
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τρίτη, 22 Νοεμβρίου 2011

Άσκηση : επεξεργασία στοιχείων των διαγωνίων

Γράψτε διαδικασία η οποία γεμίζει τα στοιχεία των δύο
κυρίων διαγωνίων του ακέραιου πίνακα Α[20, 20]
με μηδενικά.


Λύση

    ΔΙΑΔΙΚΑΣΙΑ ΓεμΠιν(Α)
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Α[20, 20], Κ
    ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
                 Α[Κ, Κ] <-- 0
                 Α[Κ, 21-Κ] <-- 0
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
      

Δευτέρα, 21 Νοεμβρίου 2011

Γέμισμα πίνακα

Γράψτε το περιεχόμενο του πίνακα Α[6] μετά την εκτέλεση
των παρακάτω εντολών;
      Α[1] <-- 10
      Για κ από 2 μέχρι 6
           Α[κ] <-- Α[κ-1]+10
      Τέλος_επανάληψης


Λύση

    Οι εντολές γεμίζουν τον πίνακα Α[6] ως εξής:
    * Το πρώτο στοιχείο παίρνει την τιμή 10
    * Κάθε άλλο στοιχείο ισούται με το προηγούμενό του
       αυξημένο κατά 10 
    Συνεπώς το περιεχόμενο του Α είναι:
        10     20    30    40    50   60

Παρασκευή, 18 Νοεμβρίου 2011

Άσκηση : Φρουρός

Γράψτε αλγόριθμο που :
α) διαβάζει το πλήθος των χαρακτήρων που περιλαμβάνουν
    οι εκθέσεις κάποιων μαθητών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί μια μη θετική τιμή),
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των εκθέσεων,
    * το μέσο όρο πλήθους χαρακτήρων ανά έκθεση,
    * τον αύξοντα αριθμό της συντομότερης έκθεσης.
Παρατήρηση : Θεωρείστε ότι καμιά έκθεση δεν είχε
περισσότερους από 1200 χαρακτήρες.


Λύση


     Αλγόριθμος Εκθέσεις
     Πληθ <-- 0
     σ <-- 0
     Μικ <-- 1201
     Αρχή_επανάληψης
           Διάβασε Χαρ
           Αν Χαρ > 0 τότε
                Πληθ <-- Πληθ+1
                σ <-- σ+Χαρ
                Αν Χαρ < Μικ τότε
                     Μικ <-- Χαρ
                     ΘΜικ <-- Πληθ
                Τέλος_αν
           Τέλος_αν
     Μέχρις_ότου Χαρ <= 0
     Αν Πληθ > 0 τότε
           ΜΟ <-- σ/Πληθ
           Εμφάνισε Πληθ, ΜΟ, ΘΜικ
     αλλιώς
           Εμφάνισε 'Δε δόθηκαν καθόλου δεδομένα!'
     Τέλος_αν
     Τέλος Εκθέσεις

Άσκηση : εμφωλευμένα Για

Γράψτε αλγόριθμο που :
α) διαβάζει δύο τιμές ακέραιες τιμές ΑΡΧ,ΤΕΛ τέτοιες
    ώστε ΑΡΧ < ΤΕΛ,
β) διαβάζει τρεις τιμές Α, Β, Γ,
γ) επιλύει την εξίσωση
       ΑΧ-ΒΥ-Γ = 0
    στο διάστημα [ΑΡΧ, ΤΕΛ]
Παρατήρηση : οι όποιες λύσεις (αν υπάρχουν είναι
ακεραίου τύπου)

Λύση

     Αλγόριθμος ΕΞΙΣ
     Αρχή_επανάληψης
           Διάβασε ΑΡΧ, ΤΕΛ
     Μέχρις_ότου ΑΡΧ < ΤΕΛ
     Διάβασε Α, Β, Γ
     Λύσεις <-- 0
     Για Χ από ΑΡΧ μέχρι ΤΕΛ
          Για Υ από ΑΡΧ μέχρι ΤΕΛ
               Για Ζ από ΑΡΧ μέχρι ΤΕΛ
                    Αν Α*Χ-Β*Υ-Γ = 0 τότε
                         Εμφάνισε Χ, Υ, Ζ
                         Λύσεις <-- Λύσεις+1
                    Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης      
      Τέλος_επανάληψης
     Αν Λύσεις = 0 τότε
          Εμφάνισε 'Η εξίσωση δεν έχει καμιά λύση!'
     Τέλος_αν
     Τέλος ΕΞΙΣ

Πέμπτη, 17 Νοεμβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω προτάσεις.
1.  Ο τελεστής ^ υλοποιεί την πράξη της ύψωσης σε ______.
2. Η εντολή ΓΡΑΨΕ Ε(1) εμφανίζει στην οθόνη την τιμή της
    βάσης _____ των νεπέριων λογαρίθμων.
3. Τα επιμέρους στοιχεία μιας δομής δεδομένων αποκαλούνται
    και _______.
4. Ένας μονοδιάστατος πίνακας δεν μπορεί να ταξινομηθεί
    μόνο όταν είναι _______ τύπου.
5. Η ______ γλώσσα κατά βήματα είναι ένας από τους τρόπους
    αναπαράστασης ενός αλγορίθμου.

Απαντήσεις

1. δύναμη
2. e
3. κόμβοι
4. λογικού
5. φυσική

Τετάρτη, 16 Νοεμβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Υπάρχεουν τρεις μορφές δομής επιλογής : η απλή, η
    σύνθετη και η εμφωλευμένη.
2. Η δομή ακολουθίας αποκαλείται και βρόχος.
3. Το μέγεθος της μνήμης που χρειάζεται ένας πίνακας
    καθορίζεται κατά την εκτέλεση του προγράμματος.
4. Ένας μεταγλωττιστής μπορεί να εντοπίζει τα συντακτικά
    αλλά όχι τα λογικά λάθη.
5. Η ιεραρχική σχεδίαση είναι μια τεχνική ανάλυσης προβλη-
    μάτων σε υποπροβλήματα.




Απάντηση

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ

Δευτέρα, 14 Νοεμβρίου 2011

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω σχέσεις είναι σωστές και
ποιες λάθος;
1. ΟΧΙ mod 3 = 0)  = (X mod 3 = 1)
2.  (Αληθής >= Ψευδής) = Αληθής
3. ('ΑΕΤΟΣ' <= 'ΦΩΛΙΑ') = Αληθής
4. ('ΩΧΨ' > 'ΩΧΑ') = Αληθής
5. Χ div (X+1) = 0

Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Λ

Κυριακή, 13 Νοεμβρίου 2011

Φρουρός

Γράψτε αλγόριθμο που διαβάζει τις ειδικότητες και την
προϋπηρεσία σε χρόνια κάποιων γιατρών (η είσοδος δεδομένων
ολοκληρώνεται μόλις δοθεί η λέξη 'ΤΙΠΟΤΑ') υπολογίζει και
εμφανίζει:
α) πόσοι γιατροί έχουν ειδικότητα ορθοπεδικού,
β) το μέσο χρόνο προϋπηρεσίας των παθολόγων.
Παρατήρηση : Θεωρείστε ότι δόθηκαν δεδομένα για ένα
τουλάχιστον γιατρό.

Λύση

      Αλγόριθμος ΑΣΚ
      Ορθ <-- 0
      Παθ <-- 0
      σ <-- 0
      Αρχή_επανάληψης
            Διάβασε Ειδ
            Αν Ειδ < > 'ΤΙΠΟΤΑ' τότε
                  Διάβασε Χρον
                  Αν Ειδ = 'ΟΡΘΟΠΕΔΙΚΟΣ' τότε
                        Ορθ <- Ορθ+1
                  Τέλος_αν
                  Αν Ειδ = 'ΠΑΘΟΛΟΓΟΣ' τότε
                        Παθ <-- Παθ+1
                        σ <-- σ+Χρον
                  Τέλος_αν
            Τέλος_αν
      Μέχρις_ότου Ειδ = 'ΤΙΠΟΤΑ'
      Εμφάνισε Ορθ
      Αν Παθ > 0 τότε
            ΜΟΠ <-- σ/Παθ
            Εμφάνισε ΜΟΠ
      αλλιώς
            Εμφάνισε 'Δεν υπάρχουν παθολόγοι!'
      Τέλος_αν
      Τέλος ΑΣΚ

Τρίτη, 8 Νοεμβρίου 2011

GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ακολουθεί τις αρχές του δομημένου προγραμματισμού
      ΔΙΑΒΑΣΕ Υ
      ΑΝ Χ < 100 ΤΟΤΕ GOTO 100
      AN X ΜΟD 5 < >  0 ΤΟΤΕ GOTO 100
      Y <-- Y+X
100 : ΓΡΑΨΕ Υ

Απάντηση


       ΔΙΑΒΑΣΕ Υ
       ΑΝ Χ > = 100 ΤΟΤΕ
            ΑΝ Χ ΜΟD 5 = 0 TOTE
                  Υ <-- Υ+Χ
            TEΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
       ΓΡΑΨΕ Υ

Δευτέρα, 7 Νοεμβρίου 2011

Άσκηση : Πίνακας συχνοτήτων

Δίνεται πίνακας  Γεν[25, 3] που περιέχει τις ημερομηνίες
γέννησης των 25 μαθητών μιας τάξης (η 1η στήλη περιέχει
τη μέρα, η 2η στήλη το μήνα και η 3η στήλη το έτος γέννησης).
Γράψτε αλγόριθμο, που με δεδομένο τον παραπάνω πίνακα,
υπολογίζει πόσοι μαθητές γεννήθηκαν Ιανουάριο,
Φεβρουάριο, ..., Δεκέμβριο.

Λύση

    Αλγόριθμος Μαθ
    Δεδομένα // Γεν //
    Για κ από 1 μέχρι 12
         Συχν[κ] <-- 0
    Τέλος_επανάληψης
    Για κ από 1 μέχρι 25
         ΑρΜην <-- Γεν[κ, 2]
         Συχν[ΑρΜην] <-- Συχν[ΑρΜην]+1
    Τέλος_επανάληψης
    Αποτελέσματα // Συχν //
    Τέλος Μαθ


Κυριακή, 6 Νοεμβρίου 2011

Άσκηση : τετραγωνικός πίνακας

Δίνεται ακέραιος πίνακας Α[14, 14]. Γράψτε αλγόριθμο
που αντιμεταθέτει τα στοιχεία της 1ης κύριας διαγωνίου
με τον ακόλουθο τρόπο:
     το Α[1, 1] με το Α[14, 14]
     το Α[2, 2] με το Α[13, 13]
     ....
     το Α[7, 7] με το Α[8, 8]

Λύση

        Αλγόριθμος ΕπεξΠιν
        Δεδομένα // Α //
        Για κ από 1 μέχρι 7
              Βοηθ <-- Α[κ, κ]
              Α[κ, κ] <-- Α[15-κ, 15-κ]
              Α[15-κ, 15-κ] <-- Βοηθ
        Τέλος_επανάληψης
        Αποτελέσματα // Α //
        Τέλος ΕπεξΠιν

Πέμπτη, 3 Νοεμβρίου 2011

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με μια μόνο Για
     Α <-- 0
     Για κ από 1 μέχρι 120 με_βήμα 3
         Α <-- Α+κ
         Για λ από 1 μέχρι 32 με_βήμα 5
                Αν λ = 11 τότε
                      Α <-- Α+λ
                Τέλος_αν
                Για μ από 1 μέχρι 43 με_βήμα 7
                       Αν μ = 29 τότε
                            Α <-- Α+μ
                       Τέλος_αν
                Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης


Λύση


     Α <-- 0
     Για κ από μέχρι 120 με_βήμα 3
         Α <-- Α+κ+11+(7*29)
     Τέλος_επανάληψης

Τετάρτη, 2 Νοεμβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
είναι λάθος;
1. Η εντολή Χ <-- Χ^2 αποτελεί χαρακτηριστική
    περίπτωση συντακτικού λαθους.
2. Η εντολή Όσο..επανάλαβε είναι μια από τις τρεις
   αλγοριθμικές δομές (συνιστώσες).
3. Η εντολή Μέχρις_ότου δεν μπορεί να παρασταθεί
    διαγραμματικά.
4. Η  αποδοτικότητα είναι ένα από τα αλγοριθμικά
    κριτήρια.
5. Η λέξη ΔΙΑΔΙΚΑΣΙΑ είναι δεσμευμένη στη
   ΓΛΩΣΣΑ.



Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ



Τρίτη, 1 Νοεμβρίου 2011

Άσκηση : τι περιεχόμενο έχει ο πίνακας

Ποιο είναι το περιεχόμενο του πίνακα Α[3, 3] μετά την εκτέλεση
των παρακάτω εντολών;
      Για κ από 1 μέχρι 3
          Για λ από 1 μέχρι 3
               Α[κ, λ] <-- κ*λ+2
          Τέλος_επανάληψης
      Τέλος_επανάληψης


Απάντηση
   
     Ο κανόνας απόδοσης τιμών στα στοιχεία του πίνακα είναι
     απλός: εκχωρούμε σε μια οποιαδήποτε θέση του πίνακα
     το αποτέλεσμα του γινομένου των συντεταγμένων της
     αυξημένο κατά 2. Κατά συνέπεια ο πίνακας αποκτά το
     ακόλουθο περιεχόμενο:

              3       4      5
              4       6      8
              5       8      11

Κυριακή, 30 Οκτωβρίου 2011

Δώστε την εκφώνηση του προβλήματος

Γράψτε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος
     Αλγόριθμος ΑΣΚ
     Γ <-- 1
     Πληθ <-- 0
     Αρχή_επανάληψης
         Διάβασε Χ
         Πληθ <-- Πληθ+1
         Γ <-- Γ*Χ
         Εμφάνισε 'Υπάρχουν άλλα δεδομένα;'
         Διάβασε Απ
     Μέχρις_ότου (Πληθ = 120) Ή (Απ = 'ΟΧΙ')
     Αποτελέσματα // Γ //
     Τέλος ΑΣΚ

Απάντηση

     Γράψτε αλγόριθμο που διαβάζει κάποιες αριθμητικές τιμές
     ( η είσοδος δεδομένων ολοκληρώνεται μόλις το πλήθος
     των τιμών εισόδου φθάσει το 120 ή όταν δοθεί η απάντηση
     'ΟΧΙ' στην υποβαλλόμενη προς το χρήστη ερώτηση
     'Υπάρχουν άλλα δεδομένα;') και υπολογίζει το γινόμενό
     τους.

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η δομή επανάληψης είναι μια προγραμματιστική
    δομή.
2. Η δομή επιλογής περιλαμβάνει μια σειρά εντολών
    που εκτελούνται ακριβώς μια φορά με τη σειρά που
    έχουν γραφεί.
3. Το πρόβλημα υπολογισμού της απόστασης δύο
    σημείων του επιπέδου είναι αδόμητο.
4. Ένας δισδιάστατος πίνακας που έχει ίδιο αριθμό
    γραμμών και στηλών αποκαλείται τετράγωνος.
5. Για να είναι σωστή η εντολή
            Ζ <-- Χ < Υ
    θα πρέπει οι μεταβλητές Ζ, Χ, Υ να είναι λογικού τύπου.



Απαντήσεις

1. Η δομή επανάληψης είναι μια αλγοριθμική
    δομή.
2. Η δομή ακολουθίας περιλαμβάνει μια σειρά εντολών
    που εκτελούνται ακριβώς μια φορά με τη σειρά που
    έχουν γραφεί.

3. Το πρόβλημα υπολογισμού της απόστασης δύο
    σημείων του επιπέδου είναι δομημένο.

4. Ένας δισδιάστατος πίνακας που έχει ίδιο αριθμό
    γραμμών και στηλών αποκαλείται τετραγωνικός.

5. Για να είναι σωστή η εντολή
            Ζ <-- Χ < Υ
    θα πρέπει η μεταβλητή Ζ να είναι λογικού τύπου
    και οι μεταβλητές Χ, Υ αριθμητικού τύπου (ακέραιες
    ή πραγματικές).


Πέμπτη, 27 Οκτωβρίου 2011

Φρουρός+απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει δυάδες αριθμών, υπολογίζει
και εμφανίζει το γινόμενό τους. Η είσοδος των δεδομένων
ολοκληρώνεται μόλις μια τουλάχιστον από τις τιμές εισόδου
είναι αρνητική ή όταν δοθεί η απάντηση 'Ν' στην υποβαλλόμενη
προς το χρήστη ερώτηση 'Θέλεις να σταματήσεις;'

Λύση

     Αλγόριθμος ΑΣΚ
     Αρχή_επανάληψης
           Διάβασε α, β
           Αν (α >= 0) ΚΑΙ (β >= 0) τότε
                 γ <-- α*β
                 Εμφάνισε γ
           Τέλος_αν
            Εμφάνισε 'Θέλεις να σταματήσεις;'
            Διάβασε Απ
     Μέχρις_ότου (α < 0) Ή (β < 0) Ή (Απ = 'Ν')
     Τέλος ΑΣΚ

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει 120 αριθμητικές τιμές,
υπολογίζει και εμφανίζει πόσες από αυτές είναι ακέραιες.

Λύση

     Αλγόριθμος ΑΣΚ
     Ακερ <-- 0
     Για κ από 1 μέχρι 120
          Διάβασε Χ
          Αν Α_Μ(Χ) = Χ τότε
               Ακερ <-- Ακερ+1
          Τέλος_αν
     Τέλος_επανάληψης
     Εμφάνισε Ακερ
     Τέλος ΑΣΚ

Τρίτη, 25 Οκτωβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω προτάσεις
1. Η περατότητα είναι ένα αλγοριθμικό ________.
2. Τα δομημένα είναι μια υποκατηγορία των επιλύσιμων
     προβλημάτων με κριτήριο το βαθμό _______ των
     λύσεων.
3. Οι γλώσσες ____________ αναπτύχθηκαν προκειμένου
     να επικοινωνεί ο άνθρωπος με τη μηχανή.
4. Το ________ δήλωσης των μεταβλητών ενός προγράμματος
    ξεκινάει με τη δεσμευμένη λέξη ΜΕΤΑΒΛΗΤΕΣ.
5. Η εντολή ___________ και η εντολή ΔΙΑΒΑΣΕ είναι οι
    μοναδικοί τρόποι αλλαγής του περιεχομένου μιας μεταβλητής.

Απάντηση

1. κριτήριο
2. δόμησης
3. προγραμματισμού
4. τμήμα
5. εκχώρησης

Ερωτήσεις σωστού λάθους

Ποιές από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος;
1. Τα συντακτικά λάθη εντοπίζονται κατά τη φάση της
    σύνδεσης του αντικείμενου προγράμματος με τις
    βιβλιοθήκες.
2. Ο συντάκτης είναι ένας ειδικευμένος κειμενογράφος,
    κατάλληλος για τη συγγραφή πηγαίων προγραμμάτων.
3. Μια μεταβλητή της ΓΛΩΣΣΑΣ αντιστοιχεί σε μια
    συγκεκριμένη θέση μνήμης του υπολογιστή.
4. Σ' ένα πρόγραμμα δεν μπορούμε να χρησιμοποιήσουμε
    τις δηλώσεις Δεδομένα και Αποτελέσματα.
5. Κάθε πρόγραμμα δίνει τα ίδια πάντα αποτελέσματα όποτε
    εκτελείται.



Απάντηση

1. Λ
2. Σ
3. Σ
4. Σ
5. Λ

Κυριακή, 23 Οκτωβρίου 2011

Άσκηση : Γέμισμα πίνακα

Με ποιές τιμές γεμίζει ο πίνακας Α[10] μετά την εκτέλεση
των παρακάτω εντολών;
        Χ <-- 28
        Για κ από 1 μέχρι 5
             Α[κ] <-- Χ mod 4
             A[11-κ] <-- A[κ]+1
             Χ <-- Χ-4
        Τέλος_επανάληψης


Λύση


       Το Χ παίρνει διαδοχικά τις τιμές 28, 24, 20, 16, 12, και 8.
       Καθεμιά από αυτές είναι πολλαπλάσιο του 4, πράγμα που
       σημαίνει ότι το  Χ mod 4 ισούται με 0.
       Κατά συνέπεια:
       * τα στοιχεία Α[1], Α[2], Α[3], Α[4] και  Α[5] θα πάρουν
          την τιμή 0,
       * τα στοιχεία Α[6], Α[7], Α[8], Α[9] και  Α[10] θα πάρουν
          την τιμή 1.
       Το περιεχόμενο του Α είναι λοιπόν:
              0   0   0   0   0  1   1   1   1   1
     

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο ένα θετικό
τετραψήφιο Ν και διαβάζει συνεχώς θετικούς τετραψήφιους
(να γίνεται έλεγχος εγκυρότητας των εισερχόμενων τιμών)
μέχρι να δοθεί μια τιμή εισόδου ίση με το Ν ή το συνολικό
πλήθος των τιμών εισόδου (εξαιρουμένων των μη θετικών
τετραψήφιων) να φτάσει το 5. Αυτό το συνολικό πλήθος των
τιμών εισόδου αποτελεί και τη μοναδική παράμετρο αποτελέσματος
της  διαδικασίας.


Λύση


       ΔΙΑΔΙΚΑΣΙΑ ΒΡΕΣ(Ν, ΠΛΗΘ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Ν, ΠΛΗΘ, Χ
       ΑΡΧΗ
             ΠΛΗΘ <-- 0
             ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
                       ΓΡΑΨΕ 'Δώσε θετικό τετραψήφιο:'
                       ΔΙΑΒΑΣΕ Χ
                   ΜΕΧΡΙΣ_ΟΤΟΥ (Χ >= 1000) ΚΑΙ (Χ <= 9999)
                   ΠΛΗΘ <-- ΠΛΗΘ+1
             ΜΕΧΡΙΣ_ΟΤΟΥ (Χ = Ν) Ή (ΠΛΗΘ = 5)
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Παρασκευή, 21 Οκτωβρίου 2011

Γέμισμα πίνακα

Ποιο είναι το περιεχόμενο του πίνακα Α[100] μετά την εκτέλεση
των παρακάτω εντολών (θεωρείστε ότι το Ν είναι
θετικός ακέραιος)
     Για κ από 1 μέχρι 100
          Αν κ mod 2 = 1 τότε
               Α[κ] <-- Ν mod (N+1)
          αλλιώς
               Α[κ] <-- Ν div (N+1)
          Τέλος_αν
     Τέλος_επανάληψης


Απάντηση


      Αφού το Ν είναι θετικός ακέραιος, ισχύουν οι σχέσεις:
            Ν mod (N+1) = Ν
            Ν div (N+1) = 0
      Κατά συνέπεια, ο πίνακας Α γεμίζει με τον ακόλουθο
      τρόπο:
           * τα περιττά στοιχεία του (Α[1], Α[3], ..., Α[99])
              παίρνουν την τιμή Ν
           * τα άρτια στοιχεία του (Α[2], Α[4], ..., Α[100])
              παίρνουν την τιμή 0.
      Το περιεχόμενο του Α λοιπόν είναι :
             Ν, 0, Ν, 0, ...., Ν, 0

Πέμπτη, 20 Οκτωβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Σ' ένα πολιτιστικό σύλλογο αποφάσισαν να διαθέσουν το 15%
των ετήσιων εσόδων του (από τις εισφορές των μελών), στην
αγορά βιβλίων. Ωστόσο το ποσό αυτό δεν πρέπει να υπερβαίνει
τα 250 ευρώ. Αν η ετήσια εισφορά κάθε μέλους είναι 30 ευρώ,
γράψτε συνάρτηση η οποία δέχεται ως παράμετρο το πλήθος
των μελών του συλλόγου και υπολογίζει το ποσό που διατέ-
θηκε τελικά για την αγορά βιβλίων.

Λύση

      ΣΥΝΑΡΤΗΣΗ ΒΙΒΛΙΑ(ΠΛΗΘ) : ΠΡΑΓΜΑΤΙΚΗ
      ΣΤΑΘΕΡΕΣ
             ΣΥΝΔΡΟΜΗ = 30
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: ΠΛΗΘ, ΕΙΣΦ
            ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ
      ΑΡΧΗ
            ΕΙΣΦ <-- ΠΛΗΘ*ΣΥΝΔΡΟΜΗ
            ΠΟΣΟ <-- ΕΙΣΦ*15/100
            ΑΝ ΠΟΣΟ > 250 ΤΟΤΕ
                   ΠΟΣΟ <-- 250
            ΤΕΛΟΣ_ΑΝ
            ΒΙΒΛΙΑ <-- ΠΟΣΟ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σάββατο, 15 Οκτωβρίου 2011

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παραμέτρους μια γωνία Χ
και υπολογίζει το ημίτονο, το συνημίτονο, την εφαπτομένη και
τη συνεφαπτομένη της γωνίας αυτής. Αν δεν είναι εφικτός ο
υπολογισμός της εφαπτομένης ή της συνεφαπτομένης, να
εκχωρείται στις αντίστοιχες παραμέτρους αποτελέσματος η
τιμή -9999.9

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΤΡΙΓ(Χ, ΗΜΧ, ΣΥΝΧ, ΕΦΧ, ΣΦΧ)
     ΜΕΤΑΒΛΗΤΕΣ
           ΠΡΑΓΜΑΤΙΚΕΣ: Χ, ΗΜΧ, ΣΥΝΧ, ΕΦΧ, ΣΦΧ
     ΑΡΧΗ
           ΗΜΧ <-- ΗΜ(Χ)
           ΣΥΝΧ <-- ΣΥΝ(Χ)
           ΑΝ ΣΥΝΧ < > 0 ΤΟΤΕ           
                 ΕΦΧ <-- ΕΦ(Χ)
           ΑΛΛΙΩΣ
                 ΕΦΧ <-- -9999.9
           ΤΕΛΟΣ_ΑΝ
           ΑΝ ΗΜΧ < > 0 ΤΟΤΕ           
                 ΣΦΧ <-- 1/ΕΦΧ
           ΑΛΛΙΩΣ
                 ΣΦΧ <-- -9999.9
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους:
* το συνολικό πλήθος των μαθητών μιας τάξης,
* το πλήθος των αγοριών
και υπολογίζει το ποσοστό (%) των αγοριών στην
τάξη αυτή (αν δεν είναι δυνατός ο υπολογισμός
η συνάρτηση επιστρέφει -1).

Λύση

       ΣΥΝΑΡΤΗΣΗ ΠΟΣ(Πληθ, Αγόρια) : ΠΡΑΓΜΑΤΙΚΗ
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Πληθ, Αγόρια
       ΑΡΧΗ
             ΑΝ Πληθ > 0 ΤΟΤΕ
                   ΠΟΣ <-- 100*Αγόρια/Πληθ
             ΑΛΛΙΩΣ
                   ΠΟΣ <-- -1
             ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τρίτη, 11 Οκτωβρίου 2011

Επίτευξη στόχου

Θέλετε να μαζέψετε 1000 ευρώ προκειμένου να πάτε
καλοκαιρινές διακοπές. Για το σκοπό αυτό αποταμιεύετε
κάποιο χρηματικό ποσό κάθε μέρα. Γράψτε αλγόριθμο ο
οποίος:
α) διαβάζει το ποσό που αποταμιεύετε καθημερινά,
β) υπολογίζει και εμφανίζει:
    * πόσες ημέρες χρειάστηκαν για να πετύχετε το
       στόχο σας,
    * το πιθανό περίσσευμα χρημάτων αν υπάρχει.

Λύση

      Αλγόριθμος Κουμπαράς
      Ημέρες <-- 0
      Σύνολο <-- 0
      Όσο Σύνολο < 1000 επανάλαβε
            Διάβασε Ποσό
            Σύνολο <-- Σύνολο+Ποσό
            Ημέρες <-- Ημέρες+1
      Τέλος_επανάληψης
      Εμφάνισε Ημέρες
      Αν Σύνολο > 1000 τότε
            Εμφάνισε Σύνολο-1000
      αλλιώς
            Εμφάνισε 'Δεν υπάρχει περίσσευμα'
      Τέλος_αν
      Τέλος Κουμπαράς

Κυριακή, 9 Οκτωβρίου 2011

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις
με σωστό τρόπο.
1. Αν Χ θετικός ακέραιος, τότε  το Χ mod 4 είναι μεγαλύτερο
    του 0 και όχι μεγαλύτερο από το 4.
2. Η λογική πράξη ΚΑΙ έχει τη μεγαλύτερη προτεραιότητα
    από κάθε άλλη λογική πράξη.
3. Η εντολή Υ <-- Τ_Ρ(Χ) μπορεί να παραβιάζει το
    κριτήριο της αποτελεσματικότητας αν Χ < 0.
4. Το γεωμετρικό σχήμα του ρόμβου απεικονίζει μια
    εντολή εκχώρησης σ' ένα λογικό διάγραμμα.
5. Η μοναδική εντολή εξόδου σ' ένα πρόγραμμα της
    ΓΛΩΣΣΑΣ είναι η ΕΜΦΑΝΙΣΕ.


Απάντηση


1. Αν Χ θετικός ακέραιος, τότε  το Χ mod 4 είναι τουλάχιστον
    0 και όχι μεγαλύτερο από το 3.
2. Η λογική πράξη ΟΧΙ έχει τη μεγαλύτερη προτεραιότητα
    από κάθε άλλη λογική πράξη.
3. Η εντολή Υ <-- Τ_Ρ(Χ) μπορεί να παραβιάζει το
    κριτήριο της καθοριστικότητας αν Χ < 0.
4. Το γεωμετρικό σχήμα του ορθογωνίου παραλληλογράμμου
    απεικονίζει μια εντολή εκχώρησης σ' ένα λογικό διάγραμμα.
5. Η μοναδική εντολή εξόδου σ' ένα πρόγραμμα της
    ΓΛΩΣΣΑΣ είναι η ΓΡΑΨΕ.

Σάββατο, 8 Οκτωβρίου 2011

Υπολογισμός πλήθους επαναλήψεων

Πόσες φορές εκτελείται η παρακάτω Για..από..μέχρι;
     Για κ από 1.2 μέχρι 7.3 με_βήμα 0.04
          Εμφάνισε 'τεστ'
     Τέλος_επανάληψης


Απάντηση


     Πολλαπλασιάζω όλες τις τιμές με τη μικρότερη
     δύναμη του 10 που τις καθιστά ακέραιες. Η
     παρακάτω Για..από..μέχρι είναι ισοδύναμη με
     την αρχική:
         Για κ από 120  μέχρι 730 με_βήμα 4
              Εμφάνισε 'τεστ'
        Τέλος_επανάληψης
    Κατά συνέπεια το πλήθος των επαναλήψεων είναι:
         (730-120) div 4 + 1 = 610 div 4 + 1 = 152+1 = 153

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Η ιεραρχική σχεδίαση
    Α. χρησιμοποιεί κατά κύριο λόγο την GOTO
    B. είναι μια τεχνική ανάλυσης προβλημάτων από
         "πάνω προς τα κάτω"
    Γ. είναι μια ξεπερασμένη μέθοδος προγραμματισμού
    Δ. χρησιμοποιείται σπάνια

2. Ένας  αλγόριθμος
    Α. είναι διατυπωμένος σε γλώσσα προγραμματισμού
    Β. είναι άμεσα εκτελέσιμος στον υπολογιστή
    Γ. μπορεί να διατυπωθεί με τέσσερις εναλλακτικούς
        τρόπους
    Δ. μπορεί να μην τελειώνει ποτέ

3. Η εντολή Όσο..επανάλαβε
    Α. μπορεί να χρησιμοποιηθεί μόνο όταν γνωρίζουμε το
         πλήθος των επαναλήψεων
    Β. είναι πιο ισχυρή από την Μέχρις_ότου
    Γ. χρησιμοποιείται σπάνια
    Δ. είναι μια μορφή βρόχου

4. Ένας πίνακας
    Α. μπορεί να περιέχει τόσο αλφαριθμητικά όσο και
         αριθμητικά δεδομένα
    Β. μπορεί να μην έχει κάποιο συγκεκριμένο τύπο δεδομένων
    Γ. καταλαμβάνει συνεχόμενες θέσεις μνήμης στον υπολογιστή
    Δ. είναι μια δυναμική δομή δεδομένων

5. Μια συνάρτηση
    Α. υπολογίζει και επιστρέφει ένα μόνο αποτέλεσμα
    Β. έχει μία ή περισσότερες παραμέτρους
    Γ. τελειώνει με τη δεσμευμένη λέξη ΤΕΛΟΣ
    Δ. μπορεί να κληθεί μόνο μέσα από το κύριο πρόγραμμα

Απαντήσεις

1. Β
2. Γ
3. Δ
4. Γ
5. Α

Τρίτη, 4 Οκτωβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1.  2 div 9 = 0
2.  0 div  9 = απροσδιόριστο
3.  2 mod 9 = 2
4.  (2*κ+7) mod 2 = 1
5. (4*κ+8) div 2 > 2*κ+4 = ΑΛΗΘΗΣ

Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ


Σάββατο, 1 Οκτωβρίου 2011

Θέματα Επαναληπτικών Πανελλαδικών Εξετάσεων Εσπερινού Γενικού Λυκείου 2011
























Λύσεις Επαναληπτικών Πανελλαδικών Εξετάσεων Εσπερινού Γενικού Λυκείου 2011


Επαναληπτικές Πανελλαδικές εξετάσεις Δ’ τάξης Εσπερινού Γενικού Λυκείου 2011

ΘΕΜΑ Α
Οι λύσεις όλων των ερωτημάτων είναι ίδιες με αυτές των επαναληπτικών του ημερήσιου, εκτός από το ερώτημα 5 του Α4 :
Α = 1   Μ = 8127  Β = 1

ΘΕΜΑ Β
Οι λύσεις όλων των ερωτημάτων είναι ίδιες με αυτές των επαναληπτικών του ημερήσιου.

ΘΕΜΑ Γ
Η λύση είναι ίδια με αυτή των επαναληπτικών του ημερήσιου.

ΘΕΜΑ Δ

Αλγόριθμος ΘΔ
Για κ απο 1 μεχρι 20
Διαβασε Ονομ[κ]
Τελος_επαναληψης
Για κ απο 1 μεχρι 20
Για λ απο 1 μεχρι 5
Διαβασε Κερδη[κ, λ]
Τελος_επαναληψης
Τελος_επαναληψης
Μεγ <-- -100
Για κ απο 1 μεχρι 20
Σ <-- 0
Για λ απο 1 μεχρι 5
Σ <-- Σ+Κερδη[κ, λ]
Τελος_επαναληψης
Αν Σ > Μεγ τότε
Μεγ <-- Σ
ΘΜεγ <-- κ
Τέλος_αν
Τελος_επαναληψης
Εμφάνισε Ονομ[ΘΜεγ]
Διάβασε Εταιρεία
Βρεθ <-- Ψευδής
Θέση <-- 0
κ <-- 1
Όσο (κ <= 20) ΚΑΙ (Βρεθ = Ψευδής) επανάλαβε
Αν Ονομ[κ] = Εταιρεία τότε
Βρεθ <-- Αληθής
Θέση <-- κ
αλλιώς
κ <-- κ+1
Τέλος_αν
Τέλος_επανάληψης
Αν Βρεθ = Αληθής τότε
Μικ <-- Κέρδη[Θέση, 1]
ΘΜικ <-- 1
Για λ από 2 μέχρι 5
Αν Κέρδη[Θέση, λ] < Μικ τότε
Μικ <-- Κέρδη[Θέση, λ]
ΘΜικ <-- λ
Τέλος_αν
Τέλος_επανάληψης
Έτος <-- 2000+ΘΜικ
Εμφάνισε Έτος
αλλιώς
Εμφάνισε ‘Δεν υπάρχει αυτό το όνομα εταιρείας’
Τέλος_αν
Τέλος ΘΔ