Σάββατο, 8 Οκτωβρίου 2011

Υπολογισμός πλήθους επαναλήψεων

Πόσες φορές εκτελείται η παρακάτω Για..από..μέχρι;
     Για κ από 1.2 μέχρι 7.3 με_βήμα 0.04
          Εμφάνισε 'τεστ'
     Τέλος_επανάληψης


Απάντηση


     Πολλαπλασιάζω όλες τις τιμές με τη μικρότερη
     δύναμη του 10 που τις καθιστά ακέραιες. Η
     παρακάτω Για..από..μέχρι είναι ισοδύναμη με
     την αρχική:
         Για κ από 120  μέχρι 730 με_βήμα 4
              Εμφάνισε 'τεστ'
        Τέλος_επανάληψης
    Κατά συνέπεια το πλήθος των επαναλήψεων είναι:
         (730-120) div 4 + 1 = 610 div 4 + 1 = 152+1 = 153

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου