Σάββατο, 1 Οκτωβρίου 2011

Λύσεις Επαναληπτικών Πανελλαδικών Εξετάσεων Εσπερινού Γενικού Λυκείου 2011


Επαναληπτικές Πανελλαδικές εξετάσεις Δ’ τάξης Εσπερινού Γενικού Λυκείου 2011

ΘΕΜΑ Α
Οι λύσεις όλων των ερωτημάτων είναι ίδιες με αυτές των επαναληπτικών του ημερήσιου, εκτός από το ερώτημα 5 του Α4 :
Α = 1   Μ = 8127  Β = 1

ΘΕΜΑ Β
Οι λύσεις όλων των ερωτημάτων είναι ίδιες με αυτές των επαναληπτικών του ημερήσιου.

ΘΕΜΑ Γ
Η λύση είναι ίδια με αυτή των επαναληπτικών του ημερήσιου.

ΘΕΜΑ Δ

Αλγόριθμος ΘΔ
Για κ απο 1 μεχρι 20
Διαβασε Ονομ[κ]
Τελος_επαναληψης
Για κ απο 1 μεχρι 20
Για λ απο 1 μεχρι 5
Διαβασε Κερδη[κ, λ]
Τελος_επαναληψης
Τελος_επαναληψης
Μεγ <-- -100
Για κ απο 1 μεχρι 20
Σ <-- 0
Για λ απο 1 μεχρι 5
Σ <-- Σ+Κερδη[κ, λ]
Τελος_επαναληψης
Αν Σ > Μεγ τότε
Μεγ <-- Σ
ΘΜεγ <-- κ
Τέλος_αν
Τελος_επαναληψης
Εμφάνισε Ονομ[ΘΜεγ]
Διάβασε Εταιρεία
Βρεθ <-- Ψευδής
Θέση <-- 0
κ <-- 1
Όσο (κ <= 20) ΚΑΙ (Βρεθ = Ψευδής) επανάλαβε
Αν Ονομ[κ] = Εταιρεία τότε
Βρεθ <-- Αληθής
Θέση <-- κ
αλλιώς
κ <-- κ+1
Τέλος_αν
Τέλος_επανάληψης
Αν Βρεθ = Αληθής τότε
Μικ <-- Κέρδη[Θέση, 1]
ΘΜικ <-- 1
Για λ από 2 μέχρι 5
Αν Κέρδη[Θέση, λ] < Μικ τότε
Μικ <-- Κέρδη[Θέση, λ]
ΘΜικ <-- λ
Τέλος_αν
Τέλος_επανάληψης
Έτος <-- 2000+ΘΜικ
Εμφάνισε Έτος
αλλιώς
Εμφάνισε ‘Δεν υπάρχει αυτό το όνομα εταιρείας’
Τέλος_αν
Τέλος ΘΔ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου