Παρασκευή, 30 Σεπτεμβρίου 2011

Λύσεις Επαναληπτικών Πανελλαδικών Εξετάσεων Ημερήσιου Γενικού Λυκείου 2011


Επαναληπτικές Πανελλαδικές εξετάσεις Γ’ τάξης 
Ημερήσιου Γενικού Λυκείου 2011

ΘΕΜΑ Α

Α1.  Βλέπε σχολικό βιβλίο, σελ. 16-18

Α2.
Αν Χ < > Α_Μ(Χ) τότε
Γράψε “Λάθος”
Τέλος_αν
Αν (Χ = Α_Μ(Χ)) ΚΑΙ (Χ <= 0) τότε
Γράψε ‘Μη θετικός’
Τέλος_αν
Αν (Χ = Α_Μ(Χ)) ΚΑΙ (Χ > 0) τότε
Γράψε ‘Θετικός’
Τέλος_αν

Α3.
(α)
 <-- 1
Για j από 1 μέχρι 100
Εμφάνισε Α[i, j]
<--  i+1
Τέλος_επανάληψης

(β)
Για j από 1 μέχρι 100
Εμφάνισε Α[50, j]
Τέλος_επανάληψης

Α4.
Περίπτωση
Α
Μ
Β
1
1
100
1
2
200
10
-1
3
-200
-1
1
4
100
200
2
5
13
8125
13

Α5.
Αλγόριθμος Αναζήτηση
Δεδομένα // table, N, key //
Βρέθηκε <-- Ψευδής
ΔενΒρέθηκε ß Αληθής
 <-- 1
Όσο ΔενΒρέθηκε = Αληθής ΚΑΙ i <= N επανάλαβε
Αν table[i] = Key τότε
Εμφάνισε “Βρέθηκε στη θέση”, i
Βρέθηκε <-- Αληθής
αλλιώς_αν table[i] > key τότε
ΔενΒρέθηκε <-- Ψευδής
Τέλος_αν
i <-- i+1
Τέλος_επανάληψης
Αποτελέσματα // Βρέθηκε //
Τέλος Αναζήτηση

ΘΕΜΑ Β

Β1.
α.
Φορές <-- 0
Αρχή_επανάληψης
Διάβασε α
Αν α <= 0 τότε
Φορές <-- Φορές+1
Τέλος_αν
Αν Φορές = 0 τότε
Εμφάνισε ‘Σωστά’
Τέλος_αν
Μέχρις_ότου α > 0
Εμφάνισε Φορές

β.
σ <-- 0
Πληθ <-- 0
Αρχή_επανάληψης
Διάβασε α
Αν α <= 0 τότε
Πληθ ß Πληθ+1
σ <-- σ+α
Τέλος_αν
Μέχρις_ότου α > 0
Αν Πληθ > 0 τότε
ΜΟ <-- σ/Πληθ
Εμφάνισε ΜΟ
αλλιώς
Εμφάνισε ‘Δεν υπάρχουν μη θετικοί αριθμοί’
Τέλος_αν

γ.
Μεγ <-- -100
Αρχή_επανάληψης
Διάβασε α
Αν α <= 0 τότε
Αν Α_Τ(α) > Μεγ τότε
Μεγ <-- Α_Τ(α)
Αριθμ <-- α
Τέλος_αν
Τέλος_αν
Μέχρις_ότου α > 0
Αν Μεγ > 0 τότε
Εμφάνισε α
αλλιώς
Εμφάνισε ‘Δεν υπάρχουν μη θετικοί αριθμοί’
Τέλος_αν

Β2.
i = 1
j = 4
Αφού i <= 3 = 1 <= 3 = Αληθής, η Όσο εκτελείται τουλάχιστον μια φορά.
1η επανάληψη
πρόχειρο = A[4] = 13
A[4] = A[1] = 3
Α[1] = πρόχειρο = 13
Η Γράψε εμφανίζει:
13    5    8
i = i+1 = 1+1 = 2
j = j-1 = 4-1 = 3
Αφού i <= 3 = 2 <= 3 = Αληθής, η Όσο συνεχίζεται.
2η επανάληψη
πρόχειρο = A[3] = 8
A[3] = A[2] = 5
Α[2] = πρόχειρο = 8
Η Γράψε εμφανίζει:
13    8    5
i = i+1 = 2+1 = 3
j = j-1 = 3-1 = 2
Αφού i <= 3 = 3 <= 3 = Αληθής, η Όσο συνεχίζεται.
3η επανάληψη
πρόχειρο = A[2] = 8
A[2] = A[3] = 5
Α[3] = πρόχειρο = 8
Η Γράψε εμφανίζει:
13    5    8
i = i+1 = 3+1 = 4
j = j-1 = 3-1 = 1
Αφού i <= 3 = 4 <= 3 = Αληθής, η Όσο τερματίζεται.

ΘΕΜΑ Γ

Αλγόριθμος Πρατήριο
Αρχή_επανάληψης
Διάβασε Διαθ
Μέχρις_ότου (Διαθ >= 0) ΚΑΙ (Διαθ <= 10000)
ΣΤΟΠ <-- Ψευδής
Πληθ <-- 0
Σ <-- 0
Εξυπ <-- 0
Ανεφ <-- 0
Όσο ΣΤΟΠ = Ψευδής επανάλαβε
Διάβασε Τύπος
Αν Τύπος = ‘Β’ τότε
Ανεφ ß Ανεφ+(10000-Διαθ)
Διαθ <-- 10000
αλλιώς ! ‘Ε’
Διάβασε Ποσότητα
Αν Διαθ >= Ποσότητα τότε
Σ <-- Σ+Ποσότητα
Εξυπ <-- Εξυπ+1
Διαθ <-- Διαθ-Ποσότητα
Πληθ <-- 0
Αν Διαθ = 0 τότε
ΣΤΟΠ <-- Αληθής
Τέλος_αν
αλλιώς
Εμφάνισε ‘Το επιβατικό δεν μπορεί να εξυπηρετηθεί!’
Πληθ <-- Πληθ+1
Αν Πληθ = 3 τότε
ΣΤΟΠ <-- Αληθής
Τέλος_αν
Τέλος_αν
Τέλος_αν
Τέλος_επανάληψης
ΜΟ <-- Σ/Εξυπ
Εμφάνισε ΜΟ, Ανεφ
Τέλος Πρατήριο

ΘΕΜΑ Δ

ΠΡΟΓΡΑΜΜΑ ΘΔ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Κ, Λ, ΤΡΙΕΤ
ΠΡΑΓΜΑΤΙΚΕΣ: ΚΕΡΔΗ[20, 5], Κερδ5, ΜΟ,
Μεγ, Τρ1, Τρ2, Τρ3
ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜ[20]
ΑΡΧΗ
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
ΔΙΑΒΑΣΕ ΟΝΟΜ[Κ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 5
ΔΙΑΒΑΣΕ ΚΕΡΔΗ[Κ, Λ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
Κερδ5 <-- ΠΕΝΤΑΕΤΙΑ(ΚΕΡΔΗ, Κ)
ΜΟ <-- Κερδ5/5
ΓΡΑΨΕ ΜΟ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
Τρ1 <-- 0
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 3
Τρ1 <-- Τρ1+ΚΕΡΔΗ[Κ, Λ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τρ2 <-- 0
ΓΙΑ Λ ΑΠΟ 2 ΜΕΧΡΙ 4
Τρ2 <-- Τρ2+ΚΕΡΔΗ[Κ, Λ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τρ3 <-- 0
ΓΙΑ Λ ΑΠΟ 3 ΜΕΧΡΙ 5
Τρ3 <-- Τρ3+ΚΕΡΔΗ[Κ, Λ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μεγ <-- Τρ1
ΤΡΙΕΤ <-- 1
ΑΝ Τρ2 > Μεγ ΤΟΤΕ
Μεγ <-- Τρ2
ΤΡΙΕΤ <-- 2
ΤΕΛΟΣ_ΑΝ
ΑΝ Τρ3 > Μεγ ΤΟΤΕ
Μεγ <-- Τρ3
ΤΡΙΕΤ <-- 3
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ‘Η τριετία με το μεγαλύτερο κέρδος ήταν :’
ΑΝ ΤΡΙΕΤ = 1 ΤΟΤΕ
ΓΡΑΨΕ ‘2001-2003’
ΓΡΑΨΕ ‘Πρώτο έτος : 2001’
ΑΛΛΙΩΣ_ΑΝ ΤΡΙΕΤ = 2 ΤΟΤΕ
ΓΡΑΨΕ ‘2002-2004’
ΓΡΑΨΕ ‘Πρώτο έτος : 2002’
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘2003-2005’
ΓΡΑΨΕ ‘Πρώτο έτος : 2003’
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΠΕΝΤΑΕΤΙΑ(ΚΕΡΔΗ, ΕΤΑΙΡ) : ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΚΕΡΔΗ[20, 5], Σ
ΑΚΕΡΑΙΕΣ: ΕΤΑΙΡ, Λ
ΑΡΧΗ
Σ <-- 0
ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 5
Σ <-- Σ+ΚΕΡΔΗ[ΕΤΑΙΡ, Λ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΠΕΝΤΑΕΤΙΑ <-- Σ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου