Σάββατο, 3 Σεπτεμβρίου 2011

Ποιά είναι η τελική τιμή της μεταβλητής

Ποια είναι η τελική τιμή της μεταβλητής ζ μετά την
εκτέλεση των παρακάτω εντολών;
     ζ <-- 0
     Για κ από 1 μέχρι 4
          Για ρ από 1 μέχρι 8
                Για λ από μέχρι 10
                      Αν λ <= 5 τότε
                         ζ <-- ζ+1
                      αλλιώς
                         ζ <-- ζ+2
                      Τέλος_αν
                Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης


Λύση
     
      Στο πιο εσωτερικό Για, η  μεταβλητή ζ αυξάνει κατά 1
      5 φορές και κατά 2 επίσης 5 φορές. Κατά συνέπεια:
            ζ = 0+4*8*(5*1+5*2) = 32*15 = 480

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου