Παρασκευή, 23 Σεπτεμβρίου 2011

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει τις τιμές πώλησης 15
βιβλίων και υπολογίζει:
α) τη μέση τιμή πώλησης,
β) το ποσοστό (%) των βιβλίων που κοστίζουν το
    πολύ 18 ευρώ.

Λύση


       Αλγόριθμος Βιβλία
       σ <-- 0
       φ <-- 0
       Για κ από 1 μέχρι 15
             Διάβασε Τιμή
             σ <-- σ+Τιμή
             Αν Τιμή <= 18 τότε
                  φ <-- φ+1
             Τέλος_αν
       Τέλος_επανάληψης
       ΜΟ <-- σ/15
       ΠΟΣ <-- 100*φ/15
       Αποτελέσματα // ΜΟ, ΠΟΣ //
       Τέλος Βιβλία

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου