Κυριακή, 4 Σεπτεμβρίου 2011

Δώστε την εκφώνηση του προβλήματος

Ποιά είναι η εκφώνηση του προβλήματος που φιλοδοξεί
να επιλύσει ο παρακάτω αλγόριθμος;
       Αλγόριθμος Ασκ
       Δεδομένα // Α //
       φ <-- 0
       Για κ από 1 μέχρι 3
            Για λ από 1 μέχρι 4
                  Αν mod 2 = 0) KAI (A[κ, λ] mod 3 = 0) τότε
                        φ <-- φ+1
                  Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης 
       Αποτελέσματα // φ //
       Τέλος Ασκ

Απάντηση

       Δίνεται ακέραιος πίνακας Α[3, 4]. Γράψτε αλγόριθμο
       ο οποίος υπολογίζει πόσα από τα στοιχεία του πίνακα 
      που βρίσκονται σε άρτια στήλη του είναι πολλαπλάσια
      του 3.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου