Παρασκευή, 29 Μαρτίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Οι εντολές ενός αλγορίθμου πρέπει να είναι
    _______ εκτελέσιμες.
2. Το πεδίο που ταυτοποιεί μια εγγραφή ονομάζεται
    _______ κλειδί.
3. Το φαινόμενο της __________ εκδηλώνεται όταν
    κάνουμε ώθηση σε μια γεμάτη στοίβα.
4. Για να υλοποιήσουμε μια ουρά χρειαζόμαστε
    ένα μονοδιάστατο πίνακα και δύο _____.
5. Ένα υποπρόγραμμα εκτελεί ______ έργο.

Απαντήσεις

1. άμεσα
2. πρωτεύων
3. υπερχείλισης
4. δείκτες
5. αυτόνομο


Φιλτράρισμα


Δευτέρα, 25 Μαρτίου 2013

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η δυαδική αναζήτηση είναι μέθοδος ταξινόμησης
    πίνακα.
2. Μια συνάρτηση δε γνωρίζει τις τυπικές παραμέτρους της.
3. Η δομή επιλογής είναι μια αλγοριθμική διαδικασία.
4. Οι πληροφορίες σ' ένα πρόβλημα γίνονται αντιληπτές
    με μια από τις ανθρώπινες αισθήσεις.
5. Η δομή επανάληψης αποκαλείται και ανακύκλωση.



Απαντήσεις

1. Η δυαδική αναζήτηση είναι μέθοδος αναζήτησης
    μιας τιμής μέσα σε ταξινομημένο πίνακα.
2. Μια συνάρτηση δε γνωρίζει τις πραγματικές παραμέτρους
    της.
3. Η δομή επιλογής είναι μια αλγοριθμική συνιστώσα.

4. Τα δεδομένα σ' ένα πρόβλημα γίνονται αντιληπτές
    με μια από τις ανθρώπινες αισθήσεις.
5. Η δομή επανάληψης αποκαλείται και βρόχος.

Σάββατο, 23 Μαρτίου 2013

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών και
ξαναγράψτε το με ισοδύναμο τρόπο
    Για κ από 10 μέχρι 10 με_βήμα 7
         Για λ από κ+1 μέχρι 2*κ με_βήμα κ-4
                 Αν κ+λ > 22 τότε
                       Εμφάνισε (κ-λ)^2
                 αλλιώς
                       Εμφάνισε 3*κ-λ
                       Εμφάνισε (κ-λ)^2
                 Τέλος_αν
         Τέλος_επανάληψης
    Τέλος_επανάληψης
    Εμφάνισε κ

Λύση

         Για λ από 11 μέχρι 20 με_βήμα 6
                 Αν λ <= 12 τότε                   
                       Εμφάνισε 30-λ                     
                 Τέλος_αν
                 Εμφάνισε (10-λ)^2
         Τέλος_επανάληψης
         Εμφάνισε 17

Απλοποίηση

Γράψτε το παρακάτω σύνολο εντολών με ισοδύναμο τρόπο,
χωρίς τη χρήση λογικών τελεστών
      Αν  ΟΧΙ (Β) ΚΑΙ ( ( Α < 10) ή (Α > 10)) τότε 
            Εμφάνισε Χ
      Τέλος_αν

Λύση

      Αν  Β = Ψευδής τότε
           Αν  Α < > 10 τότε 
               Εμφάνισε Χ
           Τέλος_αν
      Τέλος_αν

Πέμπτη, 21 Μαρτίου 2013

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ο αλγόριθμος
    α. είναι μοναδικός για κάθε πρόβλημα
    β. περιλαμβάνει τουλάχιστον μια δομή επανάληψης
    γ. μπορεί να έχει πεπερασμένα βήματα αλλά
        να εκτελείται επ' άπειρον
    δ. είναι ένας τρόπος λύσης με συγκεκριμένα ποιοτικά
        χαρακτηριστικά

2. Η επεξεργασία των δεδομένων
    α. γίνεται μόνο από τον αναθρώπινο εγκέφαλο
    β. είναι ένας μηχανισμός δημιουργίας δεδομένων
    γ. μπορεί να γίνει και από τον ηλεκτρονικό υπολογιστή
    δ. δεν έχει καμία σχέση με την έννοια του αλγόριθμου

3. Η συνάρτηση
    α. είναι ένας από τους τρόπους αναπαράστασης ενός
        αλγορίθμου
    β. είναι διατυπωμένη σε ψευδογλώσσα
    γ. είναι συστατικό στοιχείο του τμηματικού
       προγραμματισμού
    δ. επιστρέφει 0 ή περισσότερα αποτελέσματα

4. Η δομή επιλογής
    α. παριστάνεται διαγραμματικά μ' ένα ρόμβο
    β. επαναλαμβάνει μια ομάδα εντολών πολλές
        φορές
    γ. χρησιμοποιείται για την επίλυση των
        απλούστερων προβλημάτων
    δ. δεν χρησιμοποιείται τόσο συχνά στη
        σχεδίαση των αλγορίθμων

5. Τα προβλήματα
    α. πρέπει να διατυπώνονται με σαφήνεια και ακρίβεια
    β. δεν μπορούν να κατηγοριοποιηθούν
    γ. μπορεί να είναι είτε επιλύσιμα είτε άλυτα
    δ. λύνονται πάντοτε με τη βοήθεια ενός ηλεκτρονικού
        υπολογιστή.
       


Απαντήσεις

1. δ
2. γ
3. γ
4. α
5. α


Σάββατο, 16 Μαρτίου 2013

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Κάθε τετραγωνικός πίνακας έχει δύο κύριες
    διαγωνίους.
2. Μια συνάρτηση που δεν επιστρέφει κανένα αποτέλεσμα
    δεν έχει τύπο.
3. Η γλώσσα C είναι ιδανική για τη δημιουργία λειτουργικών
    συστημάτων.
4. Τα προβλήματα που έχουν μία και μοναδική λύση
    χαρακτηρίζονται ημιδομημένα.
5. Οι συναρτήσεις δεν μπορούν να αλλάξουν το
    περιεχόμενο των πραγματικών παραμέτρων τους.


Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Λ
5. Σ


Τετάρτη, 13 Μαρτίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  (Β > 10) Ή (Β = 10)  =  Β ____ 10
2.  (Β < 10) Ή (Β > 10) = Β ____ 10
3.  Η τιμή ΑΛΗΘΗΣ είναι μια λογική ______.
4.  e = _____
5.  Αν Χ ='δοκιμή' τότε η μεταβλητή Χ είναι
     ________.

Απαντήσεις

1. >=
2. < >
3. σταθερά
4. E(1)
5. αλφαριθμητική


Σάββατο, 2 Μαρτίου 2013

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1. Οι γλώσσες προγραμματισμού είναι _______ γλώσσες.
2. Η ιεραρχική ______ είναι μια μεθοδολογία ανάλυσης
    των προβλημάτων από πάνω προς τα _____.
3. Οι γλώσσες ______ επιπέδου αποκαλούνται και
    γλώσσες 3ης γενιάς.
4. Οι πίνακες _________ τις δυνατότητες του προγράμματος.
5. Η επίσκεψη ενός κόμβου προκειμένου να εξετάσουμε ή
    να τροποποιήσουμε το περιεχόμενό του αποκαλείται
    _________.


Απαντήσεις

1. τεχνητές
2. σχεδίαση, κάτω
3. υψηλού
4. περιορίζουν
5. προσπέλαση

Παρασκευή, 1 Μαρτίου 2013

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η εντολή ΓΡΑΨΕ "1+3" εμφανίζει την τιμή 4 στην οθόνη.
2. Η εντολή ΔΙΑΒΑΣΕ Χ μπλοκάρει προσωρινά την εκτέλεση
    του προγράμματος μέχρι να δοθεί μια ακέραια τιμή από
    το πληκτρολόγιο.
3. Ο αλγόριθμος του πολλαπλασιασμού αλά ρωσικά στηρίζεται
    στη λειτουργία της ολίσθησης.
4. Ο τελεστής της διαίρεσης στη ΓΛΩΣΣΑ είναι ο  :
5. Η δήλωση του τύπου των μεταβλητὠν σ' ένα αλγόριθμο
    είναι υποχρεωτική.


 

Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Λ