Παρασκευή, 25 Νοεμβρίου 2011

Άσκηση: συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν
ακέραιο πίνακα  Α[34, 12] και υπολογίζει:
α) πόσα στοιχεία της 3ης γραμμής είναι μηδενικά,
β) το ποσοστό (%) των στοιχείων της 7ης στήλης
    που είναι μεγαλύτερα του 50.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛ(Α, φ3, ποσ7)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[34, 12], Κ, Φ3, Φ7
           ΠΡΑΓΜΑΤΙΚΕΣ : ποσ7
     ΑΡΧΗ
           φ3 <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                 ΑΝ Α[3, Κ] = 0 ΤΟΤΕ
                       φ3 <-- φ3+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           φ7 <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 34
                 ΑΝ Α[Κ, 7] > 50 ΤΟΤΕ
                       φ7 <-- φ7+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ποσ7 <-- 100*φ7/34
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τρίτη, 22 Νοεμβρίου 2011

Άσκηση : επεξεργασία στοιχείων των διαγωνίων

Γράψτε διαδικασία η οποία γεμίζει τα στοιχεία των δύο
κυρίων διαγωνίων του ακέραιου πίνακα Α[20, 20]
με μηδενικά.


Λύση

    ΔΙΑΔΙΚΑΣΙΑ ΓεμΠιν(Α)
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Α[20, 20], Κ
    ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
                 Α[Κ, Κ] <-- 0
                 Α[Κ, 21-Κ] <-- 0
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
      

Δευτέρα, 21 Νοεμβρίου 2011

Γέμισμα πίνακα

Γράψτε το περιεχόμενο του πίνακα Α[6] μετά την εκτέλεση
των παρακάτω εντολών;
      Α[1] <-- 10
      Για κ από 2 μέχρι 6
           Α[κ] <-- Α[κ-1]+10
      Τέλος_επανάληψης


Λύση

    Οι εντολές γεμίζουν τον πίνακα Α[6] ως εξής:
    * Το πρώτο στοιχείο παίρνει την τιμή 10
    * Κάθε άλλο στοιχείο ισούται με το προηγούμενό του
       αυξημένο κατά 10 
    Συνεπώς το περιεχόμενο του Α είναι:
        10     20    30    40    50   60

Παρασκευή, 18 Νοεμβρίου 2011

Άσκηση : Φρουρός

Γράψτε αλγόριθμο που :
α) διαβάζει το πλήθος των χαρακτήρων που περιλαμβάνουν
    οι εκθέσεις κάποιων μαθητών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί μια μη θετική τιμή),
β) υπολογίζει και εμφανίζει:
    * το συνολικό πλήθος των εκθέσεων,
    * το μέσο όρο πλήθους χαρακτήρων ανά έκθεση,
    * τον αύξοντα αριθμό της συντομότερης έκθεσης.
Παρατήρηση : Θεωρείστε ότι καμιά έκθεση δεν είχε
περισσότερους από 1200 χαρακτήρες.


Λύση


     Αλγόριθμος Εκθέσεις
     Πληθ <-- 0
     σ <-- 0
     Μικ <-- 1201
     Αρχή_επανάληψης
           Διάβασε Χαρ
           Αν Χαρ > 0 τότε
                Πληθ <-- Πληθ+1
                σ <-- σ+Χαρ
                Αν Χαρ < Μικ τότε
                     Μικ <-- Χαρ
                     ΘΜικ <-- Πληθ
                Τέλος_αν
           Τέλος_αν
     Μέχρις_ότου Χαρ <= 0
     Αν Πληθ > 0 τότε
           ΜΟ <-- σ/Πληθ
           Εμφάνισε Πληθ, ΜΟ, ΘΜικ
     αλλιώς
           Εμφάνισε 'Δε δόθηκαν καθόλου δεδομένα!'
     Τέλος_αν
     Τέλος Εκθέσεις

Άσκηση : εμφωλευμένα Για

Γράψτε αλγόριθμο που :
α) διαβάζει δύο τιμές ακέραιες τιμές ΑΡΧ,ΤΕΛ τέτοιες
    ώστε ΑΡΧ < ΤΕΛ,
β) διαβάζει τρεις τιμές Α, Β, Γ,
γ) επιλύει την εξίσωση
       ΑΧ-ΒΥ-Γ = 0
    στο διάστημα [ΑΡΧ, ΤΕΛ]
Παρατήρηση : οι όποιες λύσεις (αν υπάρχουν είναι
ακεραίου τύπου)

Λύση

     Αλγόριθμος ΕΞΙΣ
     Αρχή_επανάληψης
           Διάβασε ΑΡΧ, ΤΕΛ
     Μέχρις_ότου ΑΡΧ < ΤΕΛ
     Διάβασε Α, Β, Γ
     Λύσεις <-- 0
     Για Χ από ΑΡΧ μέχρι ΤΕΛ
          Για Υ από ΑΡΧ μέχρι ΤΕΛ
               Για Ζ από ΑΡΧ μέχρι ΤΕΛ
                    Αν Α*Χ-Β*Υ-Γ = 0 τότε
                         Εμφάνισε Χ, Υ, Ζ
                         Λύσεις <-- Λύσεις+1
                    Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης      
      Τέλος_επανάληψης
     Αν Λύσεις = 0 τότε
          Εμφάνισε 'Η εξίσωση δεν έχει καμιά λύση!'
     Τέλος_αν
     Τέλος ΕΞΙΣ

Πέμπτη, 17 Νοεμβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω προτάσεις.
1.  Ο τελεστής ^ υλοποιεί την πράξη της ύψωσης σε ______.
2. Η εντολή ΓΡΑΨΕ Ε(1) εμφανίζει στην οθόνη την τιμή της
    βάσης _____ των νεπέριων λογαρίθμων.
3. Τα επιμέρους στοιχεία μιας δομής δεδομένων αποκαλούνται
    και _______.
4. Ένας μονοδιάστατος πίνακας δεν μπορεί να ταξινομηθεί
    μόνο όταν είναι _______ τύπου.
5. Η ______ γλώσσα κατά βήματα είναι ένας από τους τρόπους
    αναπαράστασης ενός αλγορίθμου.

Απαντήσεις

1. δύναμη
2. e
3. κόμβοι
4. λογικού
5. φυσική

Τετάρτη, 16 Νοεμβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Υπάρχεουν τρεις μορφές δομής επιλογής : η απλή, η
    σύνθετη και η εμφωλευμένη.
2. Η δομή ακολουθίας αποκαλείται και βρόχος.
3. Το μέγεθος της μνήμης που χρειάζεται ένας πίνακας
    καθορίζεται κατά την εκτέλεση του προγράμματος.
4. Ένας μεταγλωττιστής μπορεί να εντοπίζει τα συντακτικά
    αλλά όχι τα λογικά λάθη.
5. Η ιεραρχική σχεδίαση είναι μια τεχνική ανάλυσης προβλη-
    μάτων σε υποπροβλήματα.




Απάντηση

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ

Δευτέρα, 14 Νοεμβρίου 2011

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω σχέσεις είναι σωστές και
ποιες λάθος;
1. ΟΧΙ mod 3 = 0)  = (X mod 3 = 1)
2.  (Αληθής >= Ψευδής) = Αληθής
3. ('ΑΕΤΟΣ' <= 'ΦΩΛΙΑ') = Αληθής
4. ('ΩΧΨ' > 'ΩΧΑ') = Αληθής
5. Χ div (X+1) = 0

Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Λ

Κυριακή, 13 Νοεμβρίου 2011

Φρουρός

Γράψτε αλγόριθμο που διαβάζει τις ειδικότητες και την
προϋπηρεσία σε χρόνια κάποιων γιατρών (η είσοδος δεδομένων
ολοκληρώνεται μόλις δοθεί η λέξη 'ΤΙΠΟΤΑ') υπολογίζει και
εμφανίζει:
α) πόσοι γιατροί έχουν ειδικότητα ορθοπεδικού,
β) το μέσο χρόνο προϋπηρεσίας των παθολόγων.
Παρατήρηση : Θεωρείστε ότι δόθηκαν δεδομένα για ένα
τουλάχιστον γιατρό.

Λύση

      Αλγόριθμος ΑΣΚ
      Ορθ <-- 0
      Παθ <-- 0
      σ <-- 0
      Αρχή_επανάληψης
            Διάβασε Ειδ
            Αν Ειδ < > 'ΤΙΠΟΤΑ' τότε
                  Διάβασε Χρον
                  Αν Ειδ = 'ΟΡΘΟΠΕΔΙΚΟΣ' τότε
                        Ορθ <- Ορθ+1
                  Τέλος_αν
                  Αν Ειδ = 'ΠΑΘΟΛΟΓΟΣ' τότε
                        Παθ <-- Παθ+1
                        σ <-- σ+Χρον
                  Τέλος_αν
            Τέλος_αν
      Μέχρις_ότου Ειδ = 'ΤΙΠΟΤΑ'
      Εμφάνισε Ορθ
      Αν Παθ > 0 τότε
            ΜΟΠ <-- σ/Παθ
            Εμφάνισε ΜΟΠ
      αλλιώς
            Εμφάνισε 'Δεν υπάρχουν παθολόγοι!'
      Τέλος_αν
      Τέλος ΑΣΚ

Τρίτη, 8 Νοεμβρίου 2011

GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ακολουθεί τις αρχές του δομημένου προγραμματισμού
      ΔΙΑΒΑΣΕ Υ
      ΑΝ Χ < 100 ΤΟΤΕ GOTO 100
      AN X ΜΟD 5 < >  0 ΤΟΤΕ GOTO 100
      Y <-- Y+X
100 : ΓΡΑΨΕ Υ

Απάντηση


       ΔΙΑΒΑΣΕ Υ
       ΑΝ Χ > = 100 ΤΟΤΕ
            ΑΝ Χ ΜΟD 5 = 0 TOTE
                  Υ <-- Υ+Χ
            TEΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
       ΓΡΑΨΕ Υ

Δευτέρα, 7 Νοεμβρίου 2011

Άσκηση : Πίνακας συχνοτήτων

Δίνεται πίνακας  Γεν[25, 3] που περιέχει τις ημερομηνίες
γέννησης των 25 μαθητών μιας τάξης (η 1η στήλη περιέχει
τη μέρα, η 2η στήλη το μήνα και η 3η στήλη το έτος γέννησης).
Γράψτε αλγόριθμο, που με δεδομένο τον παραπάνω πίνακα,
υπολογίζει πόσοι μαθητές γεννήθηκαν Ιανουάριο,
Φεβρουάριο, ..., Δεκέμβριο.

Λύση

    Αλγόριθμος Μαθ
    Δεδομένα // Γεν //
    Για κ από 1 μέχρι 12
         Συχν[κ] <-- 0
    Τέλος_επανάληψης
    Για κ από 1 μέχρι 25
         ΑρΜην <-- Γεν[κ, 2]
         Συχν[ΑρΜην] <-- Συχν[ΑρΜην]+1
    Τέλος_επανάληψης
    Αποτελέσματα // Συχν //
    Τέλος Μαθ


Κυριακή, 6 Νοεμβρίου 2011

Άσκηση : τετραγωνικός πίνακας

Δίνεται ακέραιος πίνακας Α[14, 14]. Γράψτε αλγόριθμο
που αντιμεταθέτει τα στοιχεία της 1ης κύριας διαγωνίου
με τον ακόλουθο τρόπο:
     το Α[1, 1] με το Α[14, 14]
     το Α[2, 2] με το Α[13, 13]
     ....
     το Α[7, 7] με το Α[8, 8]

Λύση

        Αλγόριθμος ΕπεξΠιν
        Δεδομένα // Α //
        Για κ από 1 μέχρι 7
              Βοηθ <-- Α[κ, κ]
              Α[κ, κ] <-- Α[15-κ, 15-κ]
              Α[15-κ, 15-κ] <-- Βοηθ
        Τέλος_επανάληψης
        Αποτελέσματα // Α //
        Τέλος ΕπεξΠιν

Πέμπτη, 3 Νοεμβρίου 2011

Απλοποίηση

Ξαναγράψτε το παρακάτω σύνολο εντολών με μια μόνο Για
     Α <-- 0
     Για κ από 1 μέχρι 120 με_βήμα 3
         Α <-- Α+κ
         Για λ από 1 μέχρι 32 με_βήμα 5
                Αν λ = 11 τότε
                      Α <-- Α+λ
                Τέλος_αν
                Για μ από 1 μέχρι 43 με_βήμα 7
                       Αν μ = 29 τότε
                            Α <-- Α+μ
                       Τέλος_αν
                Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης


Λύση


     Α <-- 0
     Για κ από μέχρι 120 με_βήμα 3
         Α <-- Α+κ+11+(7*29)
     Τέλος_επανάληψης

Τετάρτη, 2 Νοεμβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
είναι λάθος;
1. Η εντολή Χ <-- Χ^2 αποτελεί χαρακτηριστική
    περίπτωση συντακτικού λαθους.
2. Η εντολή Όσο..επανάλαβε είναι μια από τις τρεις
   αλγοριθμικές δομές (συνιστώσες).
3. Η εντολή Μέχρις_ότου δεν μπορεί να παρασταθεί
    διαγραμματικά.
4. Η  αποδοτικότητα είναι ένα από τα αλγοριθμικά
    κριτήρια.
5. Η λέξη ΔΙΑΔΙΚΑΣΙΑ είναι δεσμευμένη στη
   ΓΛΩΣΣΑ.



Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ



Τρίτη, 1 Νοεμβρίου 2011

Άσκηση : τι περιεχόμενο έχει ο πίνακας

Ποιο είναι το περιεχόμενο του πίνακα Α[3, 3] μετά την εκτέλεση
των παρακάτω εντολών;
      Για κ από 1 μέχρι 3
          Για λ από 1 μέχρι 3
               Α[κ, λ] <-- κ*λ+2
          Τέλος_επανάληψης
      Τέλος_επανάληψης


Απάντηση
   
     Ο κανόνας απόδοσης τιμών στα στοιχεία του πίνακα είναι
     απλός: εκχωρούμε σε μια οποιαδήποτε θέση του πίνακα
     το αποτέλεσμα του γινομένου των συντεταγμένων της
     αυξημένο κατά 2. Κατά συνέπεια ο πίνακας αποκτά το
     ακόλουθο περιεχόμενο:

              3       4      5
              4       6      8
              5       8      11