Παρασκευή, 25 Νοεμβρίου 2011

Άσκηση: συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν
ακέραιο πίνακα  Α[34, 12] και υπολογίζει:
α) πόσα στοιχεία της 3ης γραμμής είναι μηδενικά,
β) το ποσοστό (%) των στοιχείων της 7ης στήλης
    που είναι μεγαλύτερα του 50.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛ(Α, φ3, ποσ7)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[34, 12], Κ, Φ3, Φ7
           ΠΡΑΓΜΑΤΙΚΕΣ : ποσ7
     ΑΡΧΗ
           φ3 <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                 ΑΝ Α[3, Κ] = 0 ΤΟΤΕ
                       φ3 <-- φ3+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           φ7 <-- 0
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 34
                 ΑΝ Α[Κ, 7] > 50 ΤΟΤΕ
                       φ7 <-- φ7+1
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ποσ7 <-- 100*φ7/34
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου