Δευτέρα, 7 Νοεμβρίου 2011

Άσκηση : Πίνακας συχνοτήτων

Δίνεται πίνακας  Γεν[25, 3] που περιέχει τις ημερομηνίες
γέννησης των 25 μαθητών μιας τάξης (η 1η στήλη περιέχει
τη μέρα, η 2η στήλη το μήνα και η 3η στήλη το έτος γέννησης).
Γράψτε αλγόριθμο, που με δεδομένο τον παραπάνω πίνακα,
υπολογίζει πόσοι μαθητές γεννήθηκαν Ιανουάριο,
Φεβρουάριο, ..., Δεκέμβριο.

Λύση

    Αλγόριθμος Μαθ
    Δεδομένα // Γεν //
    Για κ από 1 μέχρι 12
         Συχν[κ] <-- 0
    Τέλος_επανάληψης
    Για κ από 1 μέχρι 25
         ΑρΜην <-- Γεν[κ, 2]
         Συχν[ΑρΜην] <-- Συχν[ΑρΜην]+1
    Τέλος_επανάληψης
    Αποτελέσματα // Συχν //
    Τέλος Μαθ


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου