Τρίτη, 8 Νοεμβρίου 2011

GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ακολουθεί τις αρχές του δομημένου προγραμματισμού
      ΔΙΑΒΑΣΕ Υ
      ΑΝ Χ < 100 ΤΟΤΕ GOTO 100
      AN X ΜΟD 5 < >  0 ΤΟΤΕ GOTO 100
      Y <-- Y+X
100 : ΓΡΑΨΕ Υ

Απάντηση


       ΔΙΑΒΑΣΕ Υ
       ΑΝ Χ > = 100 ΤΟΤΕ
            ΑΝ Χ ΜΟD 5 = 0 TOTE
                  Υ <-- Υ+Χ
            TEΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
       ΓΡΑΨΕ Υ

1 σχόλιο:

  1. Με τη παραπάνω λύση η ΓΡΑΨΕ Υ θα εκτελεστεί έτσι και αλλιως. Το σωστό είνα:

    ΔΙΑΒΑΣΕ Υ
    ΑΝ Χ > = 100 KAI Χ ΜΟD 5 = 0 TOTE
    Υ ← Υ+Χ
    ΑΛΛΙΩΣ
    ΓΡΑΨΕ Υ
    ΤΕΛΟΣ_ΑΝ

    ΑπάντησηΔιαγραφή