Τρίτη, 1 Νοεμβρίου 2011

Άσκηση : τι περιεχόμενο έχει ο πίνακας

Ποιο είναι το περιεχόμενο του πίνακα Α[3, 3] μετά την εκτέλεση
των παρακάτω εντολών;
      Για κ από 1 μέχρι 3
          Για λ από 1 μέχρι 3
               Α[κ, λ] <-- κ*λ+2
          Τέλος_επανάληψης
      Τέλος_επανάληψης


Απάντηση
   
     Ο κανόνας απόδοσης τιμών στα στοιχεία του πίνακα είναι
     απλός: εκχωρούμε σε μια οποιαδήποτε θέση του πίνακα
     το αποτέλεσμα του γινομένου των συντεταγμένων της
     αυξημένο κατά 2. Κατά συνέπεια ο πίνακας αποκτά το
     ακόλουθο περιεχόμενο:

              3       4      5
              4       6      8
              5       8      11

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου