Κυριακή, 13 Νοεμβρίου 2011

Φρουρός

Γράψτε αλγόριθμο που διαβάζει τις ειδικότητες και την
προϋπηρεσία σε χρόνια κάποιων γιατρών (η είσοδος δεδομένων
ολοκληρώνεται μόλις δοθεί η λέξη 'ΤΙΠΟΤΑ') υπολογίζει και
εμφανίζει:
α) πόσοι γιατροί έχουν ειδικότητα ορθοπεδικού,
β) το μέσο χρόνο προϋπηρεσίας των παθολόγων.
Παρατήρηση : Θεωρείστε ότι δόθηκαν δεδομένα για ένα
τουλάχιστον γιατρό.

Λύση

      Αλγόριθμος ΑΣΚ
      Ορθ <-- 0
      Παθ <-- 0
      σ <-- 0
      Αρχή_επανάληψης
            Διάβασε Ειδ
            Αν Ειδ < > 'ΤΙΠΟΤΑ' τότε
                  Διάβασε Χρον
                  Αν Ειδ = 'ΟΡΘΟΠΕΔΙΚΟΣ' τότε
                        Ορθ <- Ορθ+1
                  Τέλος_αν
                  Αν Ειδ = 'ΠΑΘΟΛΟΓΟΣ' τότε
                        Παθ <-- Παθ+1
                        σ <-- σ+Χρον
                  Τέλος_αν
            Τέλος_αν
      Μέχρις_ότου Ειδ = 'ΤΙΠΟΤΑ'
      Εμφάνισε Ορθ
      Αν Παθ > 0 τότε
            ΜΟΠ <-- σ/Παθ
            Εμφάνισε ΜΟΠ
      αλλιώς
            Εμφάνισε 'Δεν υπάρχουν παθολόγοι!'
      Τέλος_αν
      Τέλος ΑΣΚ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου