Παρασκευή, 18 Νοεμβρίου 2011

Άσκηση : εμφωλευμένα Για

Γράψτε αλγόριθμο που :
α) διαβάζει δύο τιμές ακέραιες τιμές ΑΡΧ,ΤΕΛ τέτοιες
    ώστε ΑΡΧ < ΤΕΛ,
β) διαβάζει τρεις τιμές Α, Β, Γ,
γ) επιλύει την εξίσωση
       ΑΧ-ΒΥ-Γ = 0
    στο διάστημα [ΑΡΧ, ΤΕΛ]
Παρατήρηση : οι όποιες λύσεις (αν υπάρχουν είναι
ακεραίου τύπου)

Λύση

     Αλγόριθμος ΕΞΙΣ
     Αρχή_επανάληψης
           Διάβασε ΑΡΧ, ΤΕΛ
     Μέχρις_ότου ΑΡΧ < ΤΕΛ
     Διάβασε Α, Β, Γ
     Λύσεις <-- 0
     Για Χ από ΑΡΧ μέχρι ΤΕΛ
          Για Υ από ΑΡΧ μέχρι ΤΕΛ
               Για Ζ από ΑΡΧ μέχρι ΤΕΛ
                    Αν Α*Χ-Β*Υ-Γ = 0 τότε
                         Εμφάνισε Χ, Υ, Ζ
                         Λύσεις <-- Λύσεις+1
                    Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης      
      Τέλος_επανάληψης
     Αν Λύσεις = 0 τότε
          Εμφάνισε 'Η εξίσωση δεν έχει καμιά λύση!'
     Τέλος_αν
     Τέλος ΕΞΙΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου