Κυριακή, 22 Φεβρουαρίου 2015

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Οι τυπικές και οι πραγματικές παράμετροι είναι
    σε αντιστοιχία 1 - 1 μεταξύ τους.
2. Οι τυπικές παράμετροι αποκαλούνται και ορίσματα.
3. Μια συνάρτηση μπορεί (ως παρενέργεια) να αλλάξει
    το περιεχόμενο των πραγματικών παραμέτρων της.
4. Οι  παράμετροι εξασφαλίζουν την επικοινωνία των
    υποπρογραμμάτων με άλλα υποπρογράμματα και
    το κύριο πρόγραμμα.
5. Μόλις ολοκληρωθεί η εκτέλεση των εντολών μιας
    συνάρτησης, η ροή των εντολών συνεχίζεται από
    την εντολή εκείνη που βρίσκεται αμέσως μετά
    την ΚΑΛΕΣΕ.

Απαντήσεις

1. Σ
2. Σ
3. Λ
4, Σ
5. Λ


Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1. Ένα _________ επιτελεί ένα αυτόνομο έργο.
2. Μια συνάρτηση έχει ένα _______ που εξαρτάται
    από το υπολογισμό που πραγματοποιεί.
3. Οι διευθύνσεις ________ των υποπρογραμμάτων
    αποθηκεύονται στη ________ χρόνου εκτέλεσης.
4. Τα υποπρογράμματα έχουν μία είσοδο και μία _____.
5.  Οι μεταβλητές και οι συμβολικές σταθερές των
     υποπρογραμμάτων έχουν τοπική ______.

Απαντήσεις

1. υποπρόγραμμα
2. τύπο
3. επιστροφής, στοίβα
4. έξοδο
5. εμβέλεια


Κυκλώστε τα σωστά

Κυκλώστε τις σωστές προτάσεις
1. Η συνάρτηση μπορεί να πραγματοποιήσει οποιαδήποτε
    λειτουργία.
2. Κάθε συνάρτηση γράφεται πριν από το κύριο πρόγραμμα
    που την καλεί.
3. Μια διαδικασία μπορεί μόνο να τυπώνει.
4. Κάθε αποτέλεσμα σε μια διαδικασία αποτελεί ξεχωριστή
    παράμετρο στην επικεφαλίδα της.
5. Οι δικές μας συναρτήσεις ενεργοποιούνται με διαφορετικό
    τρόπο από ότι οι ενσωματωμένες συναρτήσεις της ΓΛΩΣΣΑΣ.
6. Κάθε συνάρτηση μπορεί να ενεργοποιηθεί μέσα από μια
    εντολή εκχώρησης ή ΓΡΑΨΕ.
7. Δεν μπορεί μια συνάρτηση να καλέσει μια διαδικασία.
8. Μια διαδικασία μπορεί να καλέσει μια συνάρτηση.


Απαντήσεις

1. 3, 4, 6, 8

Επιλέξτε τύπο υποπρογράμματος

Ποιο τύπο υποπρογράμματος (Σ - συνάρτηση, Δ - διαδικασία)
θα επιλέγατε για την  εκτέλεση των παρακάτω ενεργειών;
1. Υπολογισμός αθροίσματος στοιχείων δυσδιάστατου
    πίνακα.
2. Υπολογισμός αθροισμάτων ανά γραμμή σε δυσδιάστατο
    πίνακα.
3. Διάβασμα μονοδιάστατου πίνακα.
4. Υπολογισμός ελαχίστου στοιχείου τρισδιάστατου πίνακα.
5. Υπολογισμός μεγίστου στοιχείου και θέσης του σε
     μονοδιάστατο πίνακα.


Απαντήσεις

1. Σ
2. Δ
3. Δ
4. Σ
5. Δ



Βήμα-βήμα εκτέλεση

Θεωρείστε τη συνάρτηση Φ(Χ) η οποία επιστρέφει το
τριπλάσιο του Χ (Χ ακέραιος), Τι θα εμφανίσει η
παρακάτω διαδικασία
     ΔΙΑΔΙΚΑΣΙΑ Δ(Α, Β)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Κ
     ΑΡΧΗ
           ΓΙΑ  Κ ΑΠΟ Α ΜΕΧΡΙ Β
                 ΓΡΑΨΕ Φ(Κ+1), Κ+1, (Κ ΜΟD 2 = 0)
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΡΑΨΕ Φ(Κ+4)*1000
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
αν κληθεί από το κύριο πρόγραμμα με την εντολή
     ΚΑΛΕΣΕ Δ(Φ(4 MOD 7), Φ(17 DIV 3))

Λύση

Αφού Φ(4 MOD 7) = Φ(4) = 3*4 = 12 και
          Φ(17 DIV 3) = Φ(5) = 3*5 = 15
η κλήση της Δ έχει :
      Τυπικές               Πραγματικές       Τιμή
    παραμέτρους         παραμέτρους  
           Α                      Φ(4 MOD 7)          12      
           Β                      Φ(17 DIV 3)           15
Κ = Α = 12
      Αφού Κ+1 = 12+1 = 13, Φ(Κ+1) = Φ(13) = 3*13 = 39
      και (Κ ΜΟD 2 = 0) = (12 ΜΟD 2 = 0) = (0 = 0)
            = ΑΛΗΘΗΣ, η ΓΡΑΨΕ εμφανίζει:
            39     13    ΑΛΗΘΗΣ
Κ = 13
      Αφού Κ+1 = 13+1 = 14, Φ(Κ+1) = Φ(14) = 3*14 = 42
      και (Κ ΜΟD 2 = 0) = (13 ΜΟD 2 = 0) = (1 = 0)
            = ΨΕΥΔΗΣ, η ΓΡΑΨΕ εμφανίζει:
            42     14     ΨΕΥΔΗΣ
Κ = 14
      Αφού Κ+1 = 14+1 = 15, Φ(Κ+1) = Φ(15) = 3*15 = 45
      και (Κ ΜΟD 2 = 0) = (14 ΜΟD 2 = 0) = (0 = 0)
            = ΑΛΗΘΗΣ, η ΓΡΑΨΕ εμφανίζει:
            45     15     ΑΛΗΘΗΣ
Κ = 15
      Αφού Κ+1 = 15+1 = 16, Φ(Κ+1) = Φ(16) = 3*16 = 48
      και (Κ ΜΟD 2 = 0) = (15 ΜΟD 2 = 0) = (1 = 0)
            = ΨΕΥΔΗΣ, η ΓΡΑΨΕ εμφανίζει:
            48     16     ΨΕΥΔΗΣ
Η ΓΙΑ τερματίζεται με Κ = 16.
Αφού Φ(Κ+4)*1000 = Φ(16+4)*1000 = Φ(20)*1000 =
          60*1000 = 60000
η ΓΡΑΨΕ εμφανίζει : 60000





Συγγραφή διαδικασίας

Γράψτε διαδικασία που εμφανίζει όλες τις δυνατές
ακέραιες τετράδες στο διάστημα [Α, Β] (Α, Β ακέραιοι)
που έχουν άθροισμα μεγαλύτερο από 2700.

Λύση

ΔΙΑΔΙΚΑΣΙΑ Τετράδες(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ, Κ
ΑΡΧΗ
       ΓΙΑ Χ ΑΠΟ Α ΜΕΧΡΙ Β
            ΓΙΑ Υ ΑΠΟ Α ΜΕΧΡΙ Β
                 ΓΙΑ Ζ ΑΠΟ Α ΜΕΧΡΙ Β
                        ΓΙΑ Κ ΑΠΟ Α ΜΕΧΡΙ Β
                             ΑΝ Χ+Υ+Ζ+Κ > 2700 ΤΟΤΕ
                                      ΓΡΑΨΕ Χ, Υ, Ζ, Κ
                             ΤΕΛΟΣ_ΑΝ
                        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Συγγραφή διαδικασίας

Γράψτε διαδικασία που διαβάζει το μέσο μεταφοράς
που επιλέξατε για τη μετακίνησή σας (επιτρεπτές
τιμές εισόδου : αεροπλάνο, πλοίο, λεωφορείο,
τρένο).

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΜΜΜ (Μέσο)
ΜΕΤΑΒΛΗΤΕΣ
      ΧΑΡΑΚΤΗΡΕΣ : Μέσο
ΑΡΧΗ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ 'Δώσε το μέσο μεταφοράς'
          ΔΙΑΒΑΣΕ Μέσο
      ΜΕΧΡΙΣ_ΟΤΟΥ (Μέσο = 'αεροπλάνο') Ή 
                      (Μέσο = 'πλοίο') Ή (Μέσο = 'λεωφορείο') Ή
                      (Μέσο = 'τρένο')
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ