Τετάρτη, 25 Μαρτίου 2015

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή επιλογή

1. Η γλώσσα C είναι:
    Α. συμβολική
    Β. μηχανής
    Γ. 3ης γενιάς
    Δ. 4ης γενιάς

2. Η αποτελεσματικότητα είναι:
    Α. αλγοριθμικό κριτήριο
    Β. τρόπος αναπαράστασης αλγορίθμων
    Γ. τρόπος αναπαράστασης προγραμμάτων
    Δ. κριτήριο κατηγοριοποίησης προβλημάτων

3. Μια  συνάρτηση
    Α. καλείται μόνο με εντολή εκχώρησης
    Β. επιστρέφει ένα μόνο αριθμητικό αποτέλεσμα
    Γ. δε γνωρίζει τις πραγματικές της παραμέτρους
    Δ. επιστρέφει μετά την ολοκλήρωση των εντολών της
        αμέσως μετά από το σημείο κλήσεως της

4. Οι πίνακες
    Α. είναι δυναμικές δομές δεδομένων
    Β. μπορούν να περιέχουν τιμές διαφόρων
         τύπων
    Γ.  δεν μπορούν να αποτελέσουν παραμέτρους
         σε υποπρογράμματα
    Δ. καταλαμβάνουν συγκεκριμένο πλήθος θέσεων στη
        μνήμη που δεν μπορεί να μεταβληθεί κατά τη
        διάρκεια εκτέλεσης του προγράμματος

Απαντήσεις

1. Γ
2. Α
3, Γ
4. Δ


Άσκηση με GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών, έτσι ώστε να
ικανοποιεί τις αρχές του δομημένου προγραμματισμού
10 : ΔΙΑΒΑΣΕ Χ
       ΓΡΑΨΕ Χ^2
       ΑΝ Χ > 0 ΤΟΤΕ GOTO 20
       ΓΡΑΨΕ Χ+1
20:  ΓΡΑΨΕ Χ-1
       ΔΙΑΒΑΣΕ Υ
       ΑΝ Υ < > Χ ΤΟΤΕ GOTO 10
       ΓΡΑΨΕ Α_Τ(Χ-1000)

Λύση

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
       ΔΙΑΒΑΣΕ Χ
       ΓΡΑΨΕ Χ^2
       ΑΝ Χ > 0 ΤΟΤΕ
              ΓΡΑΨΕ Χ-1
       ΑΛΛΙΩΣ
              ΓΡΑΨΕ Χ+1
       ΤΕΛΟΣ_ΑΝ
       ΔΙΑΒΑΣΕ Υ
    ΜΕΧΡΙΣ_ΟΤΟΥ  Υ =  Χ
    ΓΡΑΨΕ Α_Τ(Χ-1000)


Συγγραφή διαδικασίας (διάβασμα-γέμισμα πίνακα)

Θεωρήστε τους ακόλουθους πίνακες :
* Α[70,30], ακεραίου τύπου
* Β[70], ακεραίου τύπου
Αν ο πίνακας Β περιέχει το πλήθος των τιμών εισόδου
κάθε γραμμής του Α, γράψτε διαδικασία η οποία
εμφανίζει το περιεχόμενο του πίνακα Α στην οθόνη.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΤΥΠ(Α, Β)
ΜΕΤΑΒΛΗΤΕΣ
      ΑΚΕΡΑΙΕΣ: Α[70,30], Β[70], Κ, Λ
ΑΡΧΗ
       ΓΙΑ  Κ  ΑΠΟ  1  ΜΕΧΡΙ 70
             ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ Β[Κ]
                   ΓΡΑΨΕ Α[Κ, Λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Τρίτη, 24 Μαρτίου 2015

Συγγραφή διαδικασίας

Θεωρήστε τον πίνακα ΟΝ[30] που περιέχει 
τα ονοματεπώνυμα των μαθητών μιας τάξης.
Αν κάθε μαθητής κάνει μια ακριβώς χειραψία
με καθένα από τους συμμαθητές του, γράψτε 
διαδικασία που εμφανίζει ποιος έκανε χειραψία
με ποιον.

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΧΕΙΡΑΨΙΑ(ΟΝ)
ΜΕΤΑΒΛΗΤΕΣ
      ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[30]
      ΑΚΕΡΑΙΕΣ: Κ, Λ
ΑΡΧΗ
       ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 30
            ΓΙΑ Λ ΑΠΟ Κ+1 ΜΕΧΡΙ 30
                  ΓΡΑΨΕ ΟΝ[Κ], 'με', ΟΝ[Λ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Σάββατο, 7 Μαρτίου 2015

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το ελεύθερο κείμενο είναι ένας τρόπος _________
    του αλγόριθμου.
2. Η απλούστερη ________ δομή είναι η δομή ακολουθίας.
3. Η λειτουργία του _________ είναι η αντίστροφη της
    συγχώνευσης.
4.  ____________ + Δομές δεδομένων = Προγράμματα
5. Ο ________ + είναι αριθμητικός.

Απαντήσεις

1. αναπαράστασης
2. αλγοριθμική
3. διαχωρισμού
4. Αλγόριθμοι
5. τελεστής



Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
μόνο με Αν..τότε στη θέση της Αν..τότε..αλλιώς_αν
    Αν Α > Β τότε
        Εμφάνισε Α-Β
    αλλιώς_αν  Α mod 2 = 0 τότε
        Εμφάνισε Α+Β
    αλλιώς
        Εμφάνισε Α*Β
    Τέλος_αν

Λύση

   Αν Α > Β τότε
        Εμφάνισε Α-Β
   Τέλος_αν
   Αν  (Α <=  Β) ΚΑΙ (Α mod 2 = 0) τότε
        Εμφάνισε Α+Β
   Τέλος_αν
   Αν (Α <=  Β) ΚΑΙ (Α mod 2 < > 0) τότε
        Εμφάνισε Α*Β
   Τέλος_αν


Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Τα ορίσματα στα οποία εφαρμόζονται
     οι αριθμητικές ή λογικές πράξεις ονομάζονται
     τελεστέοι.
2. Στην ουρά ακολουθείται η πολιτική εξυπηρέτησης
    FIFO και υλοποιείται με τη βοήθεια ενός
    δυσδιάστατου πίνακα.
3. Ο τμηματικός προγραμματισμός είναι η υλοποίηση
    της ιεραρχικής σχεδίασης σε προγραμματιστικό
    επίπεδο.
4. Κάθε Αν..τότε μπορεί να αντικατασταθεί από μια
    Όσο..επανάλαβε που να επιφέρει το ίδιο αλγοριθμικό
    αποτέλεσμα.
5. Αν το βήμα σε μια Για..από..μέχρι είναι μηδέν
    παραλείπεται.


Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Λ
5. Λ