Τετάρτη, 27 Αυγούστου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
    Για κ από 2 μέχρι 38 με_βήμα 2
          Αν mod 4 = 0) KAI mod 3 = 0) τότε
              Εμφάνισε κ
          Τέλος_αν
    Τέλος_επανάληψης 

Απάντηση

Το παραπάνω σύνολο εντολών εμφανίζει όλους τους ζυγούς
ακέραιους αριθμούς στο διάστημα [2, 38] που είναι πολλαπλάσια
τόσο του 4 όσο και του 3. Κατά συνέπεια η έξοδος των εντολών
είναι:
        12
        24
        36

Σάββατο, 23 Αυγούστου 2014

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω
σύνολο εντολών

  Για κ από (7 mod 8) μέχρι (11 div 12) με βήμα -1
     Διάβασε Χ
     Αν Χ < 15 τότε
         Εμφάνισε Α_Τ(15-Χ)+4
     αλλιώς_αν Χ > 15 τότε
         Εμφάνισε Α_Τ(15-Χ)+15
     αλλιώς
         Εμφάνισε Χ*20
     Τέλος_αν
  Τέλος_επανάληψης

Απάντηση

   Για κ από μέχρι με βήμα -1
     Διάβασε Χ
     Αν Χ < 15 τότε
         Εμφάνισε 19-Χ
     αλλιώς_αν Χ > 15 τότε
         Εμφάνισε Χ
     αλλιώς
         Εμφάνισε 300
     Τέλος_αν
  Τέλος_επανάληψης

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια κριτήρια παραβιάζει ο
ακόλουθος υποτιθέμενος αλγόριθμος;
   Αλγόριθμος  Ασκ
   Διάβασε Χ
   Όσο (Χ > 0) Ή (Χ <=0) επανάλαβε
        Εμφάνισε 3/(Χ-4)
        Διάβασε Χ
   Τέλος_επανάληψης
   Τέλος Ασκ

Απαντήσεις

Παραβιάζεται η :
α) περατότητα γιατί η συνθήκη της Όσο..επανάλαβε
    είναι πάντοτε αληθής και η επανάληψη δεν
    τερματίζεται ποτέ, και
β) καθοριστικήτητα, γιατί αν Χ = 4 η εντολή
    Εμφάνισε δεν μπορεί να εκτελεστεί.

Πίνακας αλήθειας

Αν Κ, Λ, Μ, Ν λογικές μεταβλητές, να κατασκευάσετε
τον πίνακα αλήθειας της λογικής παράστασης
    ΟΧΙ Κ Ή (Λ ΚΑΙ ΟΧΙ Μ)

Απάντηση

Ας συμβολίσουμε με Α την τιμή Αληθής και 
Ψ την τιμή ψευδής.
Αν Σ1 = Λ ΚΑΙ ΟΧΙ Μ και
Σ = ΟΧΙ Κ Ή (Λ ΚΑΙ ΟΧΙ Μ) = ΟΧΙ Κ Ή Σ1 
έχουμε:

Κ      Λ   Μ     Ν        ΟΧΙ Κ   ΟΧΙ Μ        Σ1    Σ
Α     Α   Α    Α       Ψ            Ψ        Ψ     Ψ
Α     Α   Α    Ψ       Ψ            Ψ        Ψ     Ψ
Α     Α   Ψ    Α       Ψ            Α        Α      Α
Α     Α   Ψ    Ψ       Ψ            Α        Α      Α
Α     Ψ   Α    Α       Ψ            Ψ        Ψ      Ψ
Α     Ψ   Α    Ψ       Ψ            Ψ        Ψ      Ψ
Α     Ψ   Ψ    Α       Ψ            Α        Ψ      Ψ
Α     Ψ   Ψ    Ψ       Ψ            Α        Ψ      Ψ
Ψ     Α   Α    Α        Α            Ψ       Ψ      Α
Ψ     Α   Α    Ψ        Α            Ψ       Ψ      Α
Ψ     Α   Ψ    Α        Α            Α       Α       Α
Ψ     Α   Ψ    Ψ        Α           Α        Α       Α
Ψ     Ψ   Α    Α        Α           Ψ        Ψ       Α
Ψ     Ψ   Α    Ψ        Α           Ψ        Ψ       Α
Ψ     Ψ   Ψ    Α        Α           Α         Ψ      Α
Ψ     Ψ   Ψ    Ψ        Α           Α         Ψ      Α

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Ο αλγόριθμος του πολλαπλασιασμού αλά ρωσικά
    πραγματοποιεί προκαθορισμένο πλήθος
    επαναλήψεων.
2. Κάθε πρόγραμμα δεσμεύει συγκεκριμένο χώρο
    της δευτερεύουσας μνήμης του υπολογιστή.
3. Δεν επιτρέπεται να εκχωρήσουμε μια τιμή σε
    μια συμβολική σταθερά.
4. ΟΧΙ (Χ ΚΑΙ Υ) = ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ
5. Αληθής Ή (Κ <= Λ) = Αληθής


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Σ



Σάββατο, 9 Αυγούστου 2014

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Οι σταθερές είναι ονόματα που αντιπροσωπεύουν
    σταθερές τιμές.
2. Όταν το Χ δεν είναι πολλαπλάσιο του 7 ισχύει η
    σχέση Χ mod 7 = 1
3.  (2*M+4*K) div 2 = 0
4. Η συνάρτηση Α_Μ(Χ) υπολογίζει την απόλυτη
    τιμή του Χ.


Απαντήσεις

1. Οι συμβολικές σταθερές είναι ονόματα που αντιπροσωπεύουν
    σταθερές τιμές.
2. Όταν το Χ δεν είναι πολλαπλάσιο του 7 ισχύει η
    σχέση Χ mod 7 < > 0
3.  (2*M+4*K) mod 2 = 0
4. Η συνάρτηση Α_Τ(Χ) υπολογίζει την απόλυτη
    τιμή του Χ.


Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η διαδικασία μπορεί να επιτελέσει οποιαδήποτε
    _________.
2. Η τοποθέτηση των κόμβων μιας δομής δεδομένων
    κατά αύξουσα ή φθίνουσα σειρά αποκαλείται _______.
3. Η ______ σχεδίαση είναι μια μεθοδολογία
    διάσπασης ενός προβλήματος σε υποπροβλήματα.
4. Τα ________ προβλήματα επιλύονται μέσα από
    μια αυτοματοποιημένη διαδικασία.


Απαντήσεις

1. λειτουργία
2. ταξινόμηση
3. ιεραρχική
4. δομημένα