Δευτέρα, 19 Ιανουαρίου 2015

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Δεν μπορεί να δημιουργηθεί το εκτελέσιμο πρόγραμμα
    όταν υπάρχουν __________ λάθη.
2. Ο αλγόριθμος είναι ένας μηχανισμός παραγωγής ______.
3. Ο συντάκτης είναι ένας εξειδικευμένος _________
    που χρησιμοποιείται για τη συγγραφή των _______
    προγραμμάτων.
4. Ο τελεστής / είναι  __________.
5. Τη μεγαλύτερη προτεραιότητα από τους λογικούς
     τελεστές έχει ο ______.


Απαντήσεις

1. συντακτικά
2. πληροφοριών
3. κειμενογράφος, πηγαίων
4. αριθμητικός
5. ΟΧΙ


Ταξινόμηση με πολλαπλά κριτήρια

Θεωρήστε τους πίνακες ΟΝ[300], ΕΠΩΝ[300], ΑΜ[300] που
περιέχουν τα ονόματα, τα επώνυμα και τους αριθμούς
μητρώου των 300 μαθητών ενός γενικού λυκείου.
Γράψτε αλγόριθμο που εμφανίζει τους αριθμούς μητρώου,
τα ονόματα και τα επώνυμα των μαθητών κατά αλφαβητική
σειρά των επωνύμων. Σε περίπτωση που δύο ή περισσότεροι
μαθητές έχουν το ίδιο επίθετο, ακολουθείται η αλφαβητική
σειρά των ονομάτων. Όταν και τα ονόματα συμπίπτουν
προηγούνται στη σειρά εμφάνισης οι μαθητές με το
μικρότερο αριθμό μητρώου.

Λύση

Αλγόριθμος Λίστα
Δεδομένα // ΟΝ, ΕΠΩΝ, ΑΜ //
Για κ από 2 μέχρι 300
    Για λ από 300 μέχρι κ με_βήμα -1
        Αν ΕΠΩΝ[λ-1] > ΕΠΩΝ[λ] τότε
            Αντιμετάθεσε ΕΠΩΝ[λ-1], ΕΠΩΝ[λ]
            Αντιμετάθεσε ΟΝ[λ-1], ΟΝ[λ]
            Αντιμετάθεσε ΑΜ[λ-1], ΑΜ[λ]
        αλλιώς_αν (ΕΠΩΝ[λ-1] = ΕΠΩΝ[λ]) ΚΑΙ
                           (ΟΝ[λ-1] > ΟΝ[λ]) τότε
            Αντιμετάθεσε ΟΝ[λ-1], ΟΝ[λ]
            Αντιμετάθεσε ΑΜ[λ-1], ΑΜ[λ]
        αλλιώς
             Αν (ΕΠΩΝ[λ-1] = ΕΠΩΝ[λ]) ΚΑΙ
                   (ΟΝ[λ-1] = ΟΝ[λ]) ΚΑΙ
                   (ΑΜ[λ-1] > ΑΜ[λ])  τότε
                    Αντιμετάθεσε ΑΜ[λ-1], ΑΜ[λ]
             Τέλος_αν
        Τέλος_αν
    Τέλος_επανάληψης
Τέλος_επανάληψης
Για κ από 1 μέχρι 300
     Εμφάνισε ΟΝ[κ], ΕΠΩΝ[κ], ΑΜ[κ]
Τέλος_επανάληψης
Τέλος Λίστα

Πέμπτη, 8 Ιανουαρίου 2015

Αντιμετάθεση δύο στηλών

Γράψτε αλγόριθμο που:
α) διαβάζει μια ακέραια τιμή Ν τέτοια ώστε 1 < Ν < 32,
β) διαβάζει μια ακέραια τιμή Μ τέτοια ώστε 1 < Μ < 32.
γ) αντιμεταθέτει τα στοιχεία της Ν στήλης με αυτά της Μ
    στήλης στον πραγματικό πίνακα Α[78, 32].

Λύση

Αλγόριθμος Αντιμ
Δεδομένα // Α //
Αρχή_επανάληψης
     Διάβασε Ν
Μέχρις_ότου (Ν > 1) ΚΑΙ (Ν < 32)
Αρχή_επανάληψης
     Διάβασε Μ
Μέχρις_ότου (Μ > 1) ΚΑΙ (Μ  < 32)
Για κ από 1 μέχρι 78
       Αντιμετάθεσε Α[κ, Ν], Α[κ, Μ]
Τέλος_επανάληψης
Αποτελέσματα // Α //
Τέλος Αντιμ

Αντιμετάθεση δύο διαδοχικών γραμμών

Θεωρείστε έναν ακέραιο πίνακα Α[15, 23] και μια
ακέραια τιμή Ν τέτοια ώστε 1 < Ν < 15. Γράψτε
αλγόριθμο που αντιμεταθέτει τα στοιχεία της
Ν γραμμής με αυτά της Ν+1 γραμμής στον
παραπάνω πίνακα.

Λύση

Αλγόριθμος Αντιμ
Δεδομένα // Α, Ν //
Για λ από 1 μέχρι 23
     Αντιμετάθεσε Α[Ν, λ], Α[Ν+1, λ]
Τέλος_επανάληψης
Αποτελέσματα // Α //
Τέλος Αντιμ

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Ο πίνακας είναι μια μορφή αρχείου εγγραφών.
2. Τα στοιχεία ενός πίνακα ονομάζονται και πεδία.
3. Μια από τις σκοπιές που εξετάζει η Πληροφορική
    τα δεδομένα είναι και αυτή των Δομών Δεδομένων.
4. Ο τρισδιάστατος πίνακας Α[10, 10, 10] έχει τη
    γεωμετρική αναπαράσταση ενός κύβου.
5. Όλες οι επεξεργασίες ενός μονοδιάστατου πίνακα
    μπορούν να γίνουν με ένα μόνο Για..από..μέχρι


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Λ


Σάββατο, 27 Δεκεμβρίου 2014

Απλοποίηση

Θεωρήστε τον πραγματικό πίνακα Α[10, 7].
Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
    Για κ από 1 μέχρι 10
       Για λ από 1 μέχρι 7
           Αν (κ = 10) ΚΑΙ (λ < 4) τότε
                Εμφάνισε Α[κ, λ]
           Τέλος_αν
       Τέλος_επανάληψης
    Τέλος_επανάληψης

Λύση
  
       Για λ από μέχρι 3
           Εμφάνισε Α[10, λ]
       Τέλος_επανάληψης

Διορθώστε τις λανθασμένες προτάσεις

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Μια εγγραφή αποτελείται από πολλά αρχεία.
2. Προγράμματα+Διαγράμματα = Αλγόριθμοι.
3. Το ελάχιστο στοιχείο στον αλφαριθμητικό πίνακα
    Α[200] που είναι ταξινομημένος κατά αλφαβητική
    σειρά είναι το Α[200].
4. Ο πίνακας Α[12, 5, 2, 3] έχει 22 στοιχεία.
5. Ο πίνακας Α[12, 12, 12 ] είναι τετραγωνικός.


Απάντηση

1. Μια εγγραφή αποτελείται από πολλά πεδία.
2. Αλγόριθμοι+Δομές Δεδομένων = Προγράμματα.
3. Το ελάχιστο στοιχείο στον αλφαριθμητικό πίνακα
    Α[200] που είναι ταξινομημένος κατά αλφαβητική
    σειρά είναι το Α[1].
4. Ο πίνακας Α[12, 5, 2, 3] έχει 360 στοιχεία.
5. Ο πίνακας Α[12, 12, 12 ] είναι τρισδιάστατος.