Πέμπτη, 30 Απριλίου 2015

Απλοποίηση

Γράψτε απλούστερα το παρακάτω σύνολο εντολών
έτσι ώστε να τυπώνει το ίδιο αποτέλεσμα
    Για κ από 10 μέχρι 100 με_βήμα 10
        Για λ από 1 μέχρι 20 με_βήμα 4
              Αν κ+λ < 15 τότε
                   Διάβασε Χ
                   Εμφάνισε λ*Χ+κ
              Τέλος_αν
        Τέλος_επανάληψης
    Τέλος_επανάληψης

Απάντηση

Η συνθήκη κ+λ < 15 = Αληθής μόνο όταν κ = 10 και λ = 1.
Κατά συνέπεια έχουμε:
     Διάβασε Χ
     Εμφάνισε Χ+10

Προσδιορισμός πλήθους επαναλήψεων

Πόσες φορές τυπώνεται η λέξη 'ΑΕΠΠ';
   Για κ από 1.23 μέχρι 32.7 με_βήμα 0.003
        Εμφάνισε 'ΑΕΠΠ'
   Τέλος_επανάληψης

Απάντηση

Αν πολλαπλασιάσουμε όλες τις τιμές και το βήμα μεταβολής
με το 1000, η αρχική τιμή, η τελική τιμή και το βήμα θα
γίνουν ακέραια. Είναι σα να είχαμε μια τέτοια Για..από..μέχρι:
     Για κ από 1230 μέχρι 32700 με_βήμα 3
        Εμφάνισε 'ΑΕΠΠ'
   Τέλος_επανάληψης
Επομένως η λέξη ΑΕΠΠ θα τυπωθεί:
     (32700-1230) div 3 + 1 = 31470 div 3 + 1 = 10490+1 = 10491
     φορές

Προσδιορίστε τις προϋποθέσεις

Ποιά τιμή πρέπει να έχουν οι λογικές μεταβλητές Χ, Υ, Ζ
προκειμένου η συνθήκη ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ ΚΑΙ ΟΧΙ Ζ να είναι
Αληθής.

Απάντηση

Θα πρέπει ΟΧΙ Χ = Αληθής, ΟΧΙ Υ = Αληθής, ΟΧΙ Ζ = Αληθής.
Αρκεί λοιπόν Χ = Υ = Ζ = Ψευδής

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Οι πραγματικές παράμετροι αποκαλούνται και ορίσματα.
2. Ο μέσος όρος ύψους των μαθητών μιας τάξης είναι
    ακεραίου τύπου.
3. Οι πίνακες είναι δυναμικές δομές δεδομένων.
4. Το Μακεδονικό ζήτημα είναι ένα άλυτο πρόβλημα.
5. Τα δεδομένα είναι η αφηρημένη αναπαράσταση της
    πραγματικότητας.


Απαντήσεις

1. Οι τυπικές παράμετροι αποκαλούνται και ορίσματα.
2. Ο μέσος όρος ύψους των μαθητών μιας τάξης είναι
    πραγματικού τύπου.
3. Οι πίνακες είναι στατικές δομές δεδομένων.
4. Το Μακεδονικό ζήτημα είναι ένα ανοικτό πρόβλημα.
5. Τα δεδομένα είναι η αφαιρετική αναπαράσταση της
    πραγματικότητας.

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ο συντάκτης χρησιμοποιείται
    α. για τη σύνδεση του αντικείμενου προγράμματος με
         βιβλιοθήκες
    β. για τη συγγραφή του αντικείμενου προγράμματος
    γ. για τη συγγραφή του πηγαίου προγράμματος
    δ. για τη συντακτική ανάλυση του προγράμματος

2.  Η ΗΜ είναι:
    α. αποδεκτό όνομα για συμβολική σταθερά
    β. αποδεκτό όνομα για μεταβλητή
    γ. ενσωματωμένη συνάρτηση της ΓΛΩΣΣΑΣ
    δ. αποδεκτό όνομα για δική μας συνάρτηση

3. Ένας δυσδιάστατος πίνακας  έχει τουλάχιστον
    α. μια γραμμή
    β. μια στήλη
    γ. δύο γραμμές ή δύο στήλες
    δ. δύο γραμμές και δύο στήλες

4. Το αποτέλεσμα μιας επεξεργασίας δεδομένων είναι:
    α. μια πληροφορία
    β, ένα άλλο δεδομένο
    γ. ένας αλγόριθμος
    δ. ο χώρος του προβλήματος που πρόκειται να επιλυθεί

Απαντήσεις

1. γ
2. γ
3. δ
4. α



Τετάρτη, 29 Απριλίου 2015

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η περατότητα είναι ένα αλγοριθμικό ________.
2. Για να χαρακτηριστεί μια κατάσταση ως πρόβλημα δεν πρέπει
    να έχει ______ λύση.
3. Ένα από τα κριτήρια κατηγοριοποίησης προβλημάτων είναι και
    η ______________.
4. Για να προσδιορίσουμε τη θέση ενός στοιχείου σε ένα πίνακα
    χρειαζόμαστε ένα ή περισσότερους ______.
5. Ο τμηματικός ___________ επεκτείνει τις δυνατότητες των
    γλωσσών προγραμματισμού.


Απαντήσεις

1. κριτήριο
2. προφανή
3, επιλυσιμότητα
4. δείκτες
5. προγραμματισμός



Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Ο μικρότερος πίνακας έχει 1 στοιχείο.
2. Ένα υποπρόγραμμα εκτελεί ένα ημιαυτόνομο έργο.
3. Τα αρχεία εγγραφών είναι στατικές δομές δεδομένων.
4, Η πράξη MOD μπορεί να εφαρμοστεί μόνο σε ακέραιους
    τελεστέους.
5. Ο δομημένος προγραμματισμός ξεκίνησε σα μια προσπάθεια
    περιορισμού της ανεξέλεγκτης χρήσης της εντολής GOTO.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ