Σάββατο, 19 Ιουλίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Η  επεξεργασία των δεδομένων
    Α. είναι ένας μηχανισμός παραγωγής πληροφοριών.
    Β. δεν μπορεί να πραγματοποιηθεί με τη βοήθεια
         του ηλεκτρονικού υπολογιστή.
    Γ. γίνεται αποκλειστικά από τον ανθρώπινο εγκέφαλο
    Δ. δίνει πάντοτε ένα αριθμητικό αποτέλεσμα

2. Ο αλγόριθμος
    Α. γράφεται σε γλώσσα προγραμματισμού
    Β. γράφεται σε ψευδογλώσσα
    Γ. δεν μπορεί να αναπαρασταθεί διαγραμματικά
    Δ. ονομάζεται και υποπρόγραμμα

3. Οι πίνακες
    Α. είναι δυναμικές δομές δεδομένων
    Β. αποθηκεύονται στην δευτερεύουσα μνήμη
    Γ. καταλαμβάνουν συνεχόμενες θέσεις της
        κύριας μνήμης
    Δ. επεκτείνουν τις δυνατότητες του προγραμματιστή

4. Ένα υποπρόγραμμα
    Α. μπορεί να μην έχει είσοδο
    Β. μπορεί να μην έχει έξοδο
    Γ. έχει μεγάλη εξάρτηση από το κύριο πρόγραμμα
    Δ. εκτελεί αυτόνομο έργο

Απαντήσεις

1. Α
2. Β
3. Γ
4. Δ



Πέμπτη, 17 Ιουλίου 2014

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει 20 πραγματικές
τιμές και εμφανίζει το ακέραιο μέρος τους.

Λύση

Αλγόριθμος Ασκ
Για κ από 1 μέχρι 20
     Διάβασε Χ
     Εμφάνισε Α_Μ(Χ)
Τέλος_επανάληψης
Τέλος Ασκ

Διόρθωση λανθασμένων προτάσεων και επαναδιατύπωσή τους

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Οι πληροφορίες γίνονται αντιληπτές από έναν
    εξωτερικό παρατηρητή με μία από τις πέντε
    ανθρώπινες αισθήσεις.
2. Η αντιμετάθεση είναι μια από τις βασικές λειτουργίες
    του υπολογιστή με τη βοήθεια της οποίας γίνονται
    οι λογικές πράξεις.
3. Η κωδικοποίηση ενός αλγορίθμου γίνεται με
    φυσική γλώσσα κατά βήματα.
4. Αλγόριθμοι+Προγράμματα = Επεξεργασία
5. Η τιμή 'ΑΛΗΘΗΣ' είναι μια λογική σταθερά.


Απαντήσεις

1. Τα δεδομένα γίνονται αντιληπτά από έναν
    εξωτερικό παρατηρητή με μία από τις πέντε
    ανθρώπινες αισθήσεις.
2. Η σύγκριση είναι μια από τις βασικές λειτουργίες
    του υπολογιστή με τη βοήθεια της οποίας γίνονται
    οι λογικές πράξεις.
3.  Η κωδικοποίηση ενός αλγορίθμου γίνεται σε 
     ψευδογλώσσα.
4.  Αλγόριθμοι+Δομές δεδομένων = Προγράμματα
5.  Η τιμή ΑΛΗΘΗΣ είναι μια λογική σταθερά.


Τετάρτη, 16 Ιουλίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μια δομή επανάληψης ελέγχεται από μια _______
    συνθήκη.
2. Τα σχόλια σε ένα πρόγραμμα είναι μη _______.
3. Μια σειρά ενεργειών που δεν τερματίζεται ποτέ
    ονομάζεται _________ διαδικασία.
4. Οι πίνακες _______ τις δυνατότητες των προγραμματιστών.
5. Μια παράμετρος είναι μια ειδική μορφή ________.

Απαντήσεις

1. συνθήκη
2. εκτελέσιμα
3. υπολογιστική
4. περιορίζουν
5. μεταβλητής


Ερωτήσεις σωστού λάθους

Ποιες από τις ερωτήσεις είναι σωστές και ποιες
λάθος;
1. Οι πράξεις div και mod εφαρμόζονται μόνο
    πάνω σε ακέραιους τελεστέους.
2. Ο τμηματικός προγραμματισμός στηρίζεται
    στην εκτεταμένη χρήση της εντολής GOTO.
3. Το πρόβλημα του έτους 2000 είχε να κάνει
    με τον τρόπο αποθήκευσης της ημερομηνίας
    στους παλιούς υπολογιστές.
4. Οι διαγραμματικές τεχνικές εμφανίζονται
    ολοένα και σπανιότερα στη βιβλιογραφία.
5. Οι κόμβοι μιας δυναμικής δομής δεδομένων
    καταλαμβάνουν συνεχόμενες θέσεις στην
   κύρια μνήμη.



Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ




Τρίτη, 15 Ιουλίου 2014

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία διαβάζει 120 πραγματικές
τιμές και τις καταχωρεί στον πραγματικό πίνακα
Α[3, 4, 10].

Λύση

ΔΙΑΔΙΚΑΣΙΑ ΔιαβΠιν(Α)
ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Κ, Λ, Μ
        ΠΡΑΓΜΑΤΙΚΕΣ: Α[3, 4, 10]
ΑΡΧΗ
        ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
             ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                  ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                         ΔΙΑΒΑΣΕ Α[Κ, Λ, Μ]
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει 35 ακέραιους αριθμούς
και εμφανίζει το τετράγωνο και την τετραγωνική τους ρίζα
(εφόσον είναι εφικτό).

Λύση

Αλγόριθμος Επεξ
Για κ από 1 μέχρι 35
     Διάβασε Χ
     Εμφάνισε Χ^2
     Αν Χ >= 0 τότε
         Εμφάνισε Τ_Ρ(Χ)
     αλλιώς
         Εμφάνισε 'Δεν ορίζεται τετραγωνική ρίζα για το ', Χ
     Τέλος_αν
Τέλος_επανάληψης
Τέλος  Επεξ