Τετάρτη, 29 Οκτωβρίου 2014

Βρείτε τις τιμές

Ποιές τιμές πρέπει να έχουν οι λογικές μεταβλητές Χ, Υ
προκειμένου οι παρακάτω παραστάσεις να είναι Αληθής;
α) ΟΧΙΚΑΙ Υ)
β) ΟΧΙ Χ ΚΑΙ Υ
γ) Χ ΚΑΙ ΟΧΙ Υ
δ) ΟΧΙ Ή Υ)
ε) ΟΧΙ Χ Ή ΟΧΙ Υ

Λύση

α) Πρέπει Χ ΚΑΙ Υ = Ψευδής. Άρα έχουμε τις ακόλουθες
    περιπτώσεις:
         Χ = Αληθής, Υ = Ψευδής
         Χ = Ψευδής, Υ = Αληθής
         Χ = Ψευδής, Υ = Ψευδής
β) Πρέπει ΟΧΙ  Χ = Αληθής και Υ = Αληθής. Άρα:
         Χ = Ψευδής, Υ = Αληθής
γ) Πρέπει Χ = Αληθής και ΟΧΙ Υ = Αληθής. Άρα:
         Χ = Αληθής, Υ = Ψευδής
δ) Πρέπει Χ Ή Υ = Ψευδής. Άρα:
         Χ = Ψευδής, Υ = Ψευδής
ε) Πρέπει :
       ΟΧΙ Χ = Αληθής, ΟΧΙ Υ = Ψευδής
       ΟΧΙ Χ = Ψευδής, ΟΧΙ Υ = Αληθής
       ΟΧΙ Χ = Ψευδής, ΟΧΙ Υ = Ψευδής
   Άρα :
        Χ = Ψευδής, Υ = Αληθής
        Χ = Αληθής, Υ = Ψευδής
        Χ = Αληθής, Υ = Αληθής

Τρίτη, 28 Οκτωβρίου 2014

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τις συμβολικές
σταθερές
1. Είναι υποχρεωτικές στα προγράμματα.
2. Εμφανίζονται συχνά μέσα σε αλγορίθμους.
3. Είναι ονόματα που αντιπροσωπεύουν σταθερές
    τιμές.
4. Έχουν το δικό τους τμήμα δήλωσης μέσα στα
    προγράμματα.
5. Δεν καταλαμβάνουν χώρο στη μνήμη.
6. Έχουν τύπο δεδομένων που αναγράφεται στο
    τμήμα δήλωσης των μεταβλητών του προγράμματος.
7. Απαγορεύεται οποιαδήποτε μεταβολή του περιεχομένου
    τους.
8. Δυσχεραίνουν την κατανόηση και συντήρηση του
    προγράμματος.

Απαντήσεις

3, 4, 7

Εύρεση τελικής τιμής (εμφωλευμένες Για..από..μέχρι)


Μετατροπή


Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για μια μεταβλητή
προγράμματος;
1. Έχει ένα τύπο δεδομένων που μπορεί να αλλάζει
    κατά τη διάρκεια εκτέλεσης του προγράμματος.
2. Έχει ένα μοναδικό όνομα που τη χαρακτηρίζει.
3. Καταλαμβάνει συγκεκριμένο χώρο στην κύρια
    μνήμη του υπολογιστή.
4. Μπορεί να περιέχει μόνο αριθμητικές ή λογικές
    τιμές.
5. Η εμβέλεια του ονόματός της είναι τοπική.
6. Δηλώνεται υποχρεωτικά στο τμήμα δήλωσης
    των μεταβλητών του προγράμματος.
7. Πρέπει υποχρεωτικά μέσα στο πρόγραμμα να
    υπάρχει σχόλιο που να επεξηγεί το ρόλο της.

Απάντηση

2, 3, 5, 6

Φρουρός+Απάντηση σε ερώτηση+δοσμένο πλήθος (συνδυασμός)


Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών
αντικαθιστώντας την Αν..τότε..αλλιώς_αν
με εντολές Αν..τότε
     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     αλλιώς_αν  Β < 100 τότε
          Εμφάνισε Α^2
     αλλιώς
          Εμφάνισε Β+1
     Τέλος_αν

Λύση

     Αν Α < > Β τότε
          Εμφάνισε Α-Β
     Τέλος_αν
     Αν  (Β < 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Α^2
     Τέλος_αν
     Αν  (Β >= 100) ΚΑΙ (Α = Β) τότε
          Εμφάνισε Β+1
     Τέλος_αν