Σάββατο, 18 Οκτωβρίου 2014

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση
1. Ο πολλαπλασιασμός αλά ρωσικά
    α. στηρίζεται στην πράξη της αφαίρεσης
    β. στηρίζεται στη λειτουργία της ολίσθησης
    γ. υλοποιείται μέσω της διαίρεσης
    δ. εφαρμόζεται μόνο σε αρνητικούς ακεραίους

2. Η σειριακή αναζήτηση
    α. δεν μπορεί να εφαρμοστεί σε ταξινομημένο πίνακα
    β. είναι μια μέθοδος ταξινόμησης
    γ. είναι η πιο γρήγορη μέθοδος αναζήτησης
    δ. τίποτα από τα παραπάνω

3. Στην εντολή Για..από..μέχρι
    α. το βήμα μπορεί να είναι αλφαριθμητικού τύπου
    β. το βήμα είναι πάντοτε θετικό
    γ. το βήμα μπορεί να είναι και αρνητικό
    δ. τίποτα από τα παραπάνω

4. Σε μια Όσο..επανάλαβε
    α. η περιεχόμενη ομάδα εντολών εκτελείται
        τουλάχιστον μία φορά
    β. απαγορεύεται η περιεχόμενη ομάδα εντολών
        να αλλάζει την τιμή της συνθήκης ελέγχου
    γ. η περιεχόμενη ομάδα εντολών πρέπει να
        επηρεάζει με κάποιον τρόπο τη συνθήκη
        ελέγχου ώστε κάποτε ο βρόχος να τερματιστεί
    δ. τίποτα από τα παραπάνω

Απαντήσεις

1. β
2. δ
3. γ
4. γ



Δώστε την εκφώνηση

Ποια είναι η εκφώνηση του προβλήματος που
επιλύει ο παρακάτω αλγόριθμος;
      Αλγόριθμος Ασκ
      Για Χ από -300 μέχρι 10
          Για Υ από -300 μέχρι 10
               Για Ζ από -300 μέχρι 10
                     Αν 2*Χ-4*Υ+Ζ = 6 τότε
                          Εμφάνισε Χ, Υ, Ζ
                     Τέλος_αν
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που επιλύει την εξίσωση
2*Χ-4*Υ+Ζ = 6 στο ακέραιο διάστημα
τιμών [-300, 10]

Δευτέρα, 6 Οκτωβρίου 2014

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  Αν Χ < Υ τότε  ΟΧΙ (Χ < Υ) = ........
2,  Αν  Χ = 2.3 η εντολή ΓΡΑΨΕ Α_Μ(Χ)^2 θα
     εμφανίσει την τιμή ......
3.  Αν  Χ = 'ΑΛΦΑ' και ΒΗΤΑ = 'ΑΛΛΑ'
     Χ >=  ΒΗΤΑ = .............
4. Αν το βήμα είναι 0 σε μια Για,,από,,μέχρι τότε
    η περιεχόμενη ομάδα εντολών είτε δεν εκτελείται
    καθόλου είτε εκτελείται .............. φορές.
5. Η εντολή που είναι ιδανική για έλεγχο εγκυρότητας
    των εισερχόμενων δεδομένων είναι η ................  

Απαντήσεις

1, Ψευδής
2, 4
3. Αληθής
4. άπειρες
5. Μέχρις_ότου



Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Σε μια εντολή εκχώρησης πρέπει να υπάρχει
    απόλυτη ταύτιση ανάμεσα στον τύπο της
    μεταβλητής και της εκχωρηθείσας έκφρασης.
2. Ένας μονοδιάστατος πίνακας καταλαμβάνει
    πάντοτε λιγότερη μνήμη από ένα δυσδιάστατο
    πίνακα με το ίδιο πλήθος στοιχείων.
3. Η περιεχόμενη ομάδα εντολών μιας Αν..τότε
    εκτελείται τουλάχιστον μια φορά.
4, Αν ένα πρόβλημα είναι ημιδομημένο, αποκλείεται
    να είναι άλυτο.
5. Η γλώσσα C είναι κατάλληλη για τη δημιουργία
    λειτουργικών συστημάτων.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ




    

Σάββατο, 20 Σεπτεμβρίου 2014

Διορθώστε τις λανθασμένες προτάσεις

Διορθώστε τις παρακάτω λανθασμένες προτάσεις
και επαναδιατυπώστε τις με σωστό τρόπο
1. Μια λογική παράσταση αποτιμάται με την τιμή
    'Ψευδής' ή 'Αληθής'.
2. Μια έλλειψη έχει μία ή περισσότερες εξόδους
    για απάντηση σ' ένα λογικό διάγραμμα.
3. Κάθε πρόγραμμα έχει τουλάχιστον μια μεταβλητή.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις
    της δευτερεύουσας μνήμης του υπολογιστή.
5. Ένα υποπρόγραμμα πρέπει να εξαρτάται άμεσα
    από το κύριο πρόγραμμα.



Απάντηση

1. Μια λογική παράσταση αποτιμάται με την τιμή  
    Ψευδής ή Αληθής.
2. Ένας ρόμβος  έχει μία ή περισσότερες εξόδους
    για απάντηση σ' ένα λογικό διάγραμμα.
3. Ένα πρόγραμμα μπορεί να  μην έχει καμία 
     μεταβλητή.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις
    της κύριας μνήμης του υπολογιστή.
5. Ένα υποπρόγραμμα πρέπει να είναι ανεξάρτητο
    από το κύριο πρόγραμμα.

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τους αλγόριθμους;
1. Γράφονται σε μια γλώσσα προγραμματισμού
2. Γράφονται σε ψευδογλώσσα.
3. Πληρούν συγκεκριμένα κριτήρια.
4. Εκτελούνται απευθείας στον υπολογιστή.
5. Δεν έχουν καμιά σχέση με τα προγράμματα.

Απάντηση

2, 3

Κυριακή, 14 Σεπτεμβρίου 2014

Ερωτήσεις σωστού/λάθους

Ποιες από τις παρακάτω προτάσεις είναι
σωστές και ποιες λάθος;
1. Η κωδικοποίηση των αλγορίθμων είναι
    ένα αλγοριθμικό κριτήριο.
2. Η περατότητα είναι ένας από τους τρόπους
   αναπαράστασης των αλγορίθμων.
3. Τα διαγράμματα ροής ολοκληρώνονται με
    έναν κύκλο.
4. Αν Χ πραγματική μεταβλητή, Α_Μ(Χ) <= Χ.
5. Αν Χ ακέραια μεταβλητή και Α_Τ(Χ) < > Χ,
    το περιεχόμενο της μεταβλητής είναι αρνητικό.


Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ