Πέμπτη, 28 Ιουλίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν ακέραιο
αριθμό ετών και υπολογίζει σε πόσες χιλιετίες, αιώνες και έτη
αντιστοιχεί (π.χ. τα 6789 έτη αντιστοιχούν σε 6 χιλιετίες,
7 αιώνες και 89 έτη).

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΣΤ(Ετη, Χιλ, Αιων, Χρον)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Έτη, Χιλ, Αιων, Χρον
     ΑΡΧΗ
           Χιλ <-- Έτη DIV 1000
           Αιων <-- (Έτη MOD 1000) DIV 100
           Χρον <--  (Έτη MOD 1000) MOD 100
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δευτέρα, 25 Ιουλίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παραμέτρους τρεις
πραγματικές τιμές α, β, γ, ελέγχει αν αποτελούν μήκη πλευρών
τριγώνου και στη συνέχεια:
* αν τα α, β, γ είναι μήκη, υπολογίζεται το εμβαδόν Εμβ και
   η περίμετρος Περ του αντίστοιχου τριγώνου,
* αν τα α, β, γ δεν είναι μήκη, οι παράμετροι αποτελέσματος
   Εμβ και Περ παίρνουν ως τιμή τους το -1.
Υπενθυμίσεις
Ι. Τα α, β, γ είναι μήκη πλευρών τριγώνου αν είναι θετικά
    και  ικανοποιούν την τριγωνική ανισότητα:
         α+β > γ
         β+γ > α
         α+γ > β
ΙΙ. Το εμβαδόν Εμβ μπορεί να υπολογιστεί με τη
      βοήθεια  του παρακάτω τύπου (διατυπωμένου από
      τον Ήρωνα τον Αλεξανδρέα)
          Εμβ*Εμβ = Μ*(Μ-α)*(Μ-β)*(Μ-γ), 
      όπου Μ = (α+β+γ)/2


Λύση


       ΔΙΑΔΙΚΑΣΙΑ ΤΡΙΓ(α, β, γ, Εμβ, Περ)
       ΜΕΤΑΒΛΗΤΕΣ
               ΠΡΑΓΜΑΤΙΚΕΣ : α, β, γ, Μ, Εμβ, Περ
       ΑΡΧΗ
               ΑΝ (α > 0) ΚΑΙ (β > 0) ΚΑΙ (γ > 0) ΚΑΙ
                     (α+β > γ) ΚΑΙ (β+γ > α) ΚΑΙ (α+γ > β)
               ΤΟΤΕ
                      Περ <-- α+β+γ
                      Μ <-- Περ/2
                      Εμβ <-- Τ_Ρ(Μ*(Μ-α)*(Μ-β)*(Μ-γ))
               ΑΛΛΙΩΣ
                      Εμβ <-- -1
                      Περ <-- -1
               ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος
1. Το αποτέλεσμα του τελεστή / είναι ακέραιο.
2. Τα σχόλια είναι προαιρετικά και ξεκινάνε με το
    χαρακτήρα &
3. Η συγγραφή ενός υποπρογράμματος ξεκινάει με τη
    δεσμευμένη λέξη ΥΠΟΠΡΟΓΡΑΜΜΑ.
4. Σε μια μεταβλητή πραγματικού τύπου μπορούμε να
    εκχωρήσουμε το αποτέλεσμα μιας ακέραιας αριθμη-
    τικής παράστασης.
5. Ο ακέραιος πίνακας Α[20] απαιτεί 40 bytes για την
    αποθήκευσή του στην κύρια μνήμη του υπολογιστή.



Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ

Παρασκευή, 22 Ιουλίου 2011

Άσκηση: συγγραφή διαδικασίας

Σ' ένα σούπερ μάρκετ πωλούνται 4 διαφορετικές μάρκες
μαλακτικού ρούχων. Για καθεμιά από τις μάρκες αυτές
διατίθενται 3 διαφορετικές συσκευασίες προϊόντος (1,5
λίτρου, 3 λίτρων και 5,5 λίτρων).
Γράψτε διαδικασία η οποία:
α) διαβάζει τις τιμές πώλησης του κάθε προϊόντος,
β) υπολογίζει :
    * τον αύξοντα αριθμό (1-4) της μάρκας και τον αύξοντα αριθμό
       (1-3) της συσκευασίας του πιο ακριβού προϊόντος,
    * τον αύξοντα αριθμό (1-4) της μάρκας και τον αύξοντα αριθμό
       (1-3) της συσκευασίας του  προϊόντος που αποτελεί την πιο
       συμφέρουσα επιλογή για έναν πελάτη.
Παρατήρηση : Καμιά συσκευασία δε στοίχιζε περισσότερο από 
20 ευρώ.




Λύση


      ΔΙΑΔΙΚΑΣΙΑ ΑΓΟΡΑ(ΜεγM, ΣυσκΜ, ΣυμφΜ, ΣυμφΣυσκ)
      ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ : Μεγ, Μικ, Τιμ, Ογκ[3], ΤιμΛ
             ΑΚΕΡΑΙΕΣ: Κ, Λ, ΜεγM, ΣυσκΜ, ΣυμφΜ, ΣυμφΣυσκ,                 
      ΑΡΧΗ
             Μεγ <-- -100
             Μικ <-- 21
             Ογκ[1] <-- 1.5
             Ογκ[2] <-- 3
             Ογκ[3] <-- 5.5
             ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 4
                   ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 3
                         ΔΙΑΒΑΣΕ Τιμ
                         ΑΝ Τιμ > Μεγ ΤΟΤΕ
                                Τιμ <-- Μεγ
                                ΜεγΜ <-- Κ
                                ΣυσκΜ <-- Λ
                         ΤΕΛΟΣ_ΑΝ
                         ΤιμΛ <-- Τιμ/Ογκ[Λ]
                         ΑΝ ΤιμΛ < Μικ ΤΟΤΕ
                               Μικ <-- ΤιμΛ
                               ΣυμφΜ <-- Κ
                               ΣυμφΣυσκ <-- Λ
                         ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο έναν
θετικό ακέραιο αριθμό Ν και κάνει τα ακόλουθα:
α) αν ο αριθμός είναι μονοψήφιος επιστρέφει το διπλάσιο
   του,
β)  σε οποιαδήποτε άλλη περίπτωση,
     * υπολογίζει τα ψηφία του Ν,
     * αν ο αριθμός είναι διψήφιος επιστρέφει το άθροισμά
        τους,
     * αν ο αριθμός είναι τριψήφιος επιστρέφει το γινόμενό
        τους,
     * αν ο αριθμός είναι τετραψήφιος επιστρέφει το αποτέ-
        λεσμα που προκύπτει αν υψώσουμε στο τετράγωνο
        κάθε ψηφίο και αθροίσουμε τις δυνάμεις αυτές,
     * σε οποιαδήποτε άλλη περίπτωση επιστρέφει την
        τιμή -1.

Λύση

       ΣΥΝΑΡΤΗΣΗ AΠOT(Ν) : ΑΚΕΡΑΙΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Ν, Ψ3, Ψ2, Ψ1, Ψ0
       ΑΡΧΗ
              ΑΝ Ν <= 9 ΤΟΤΕ
                    ΑΠΟΤ <-- 2*Ν
              ΑΛΛΙΩΣ_ΑΝ Ν <= 99 ΤΟΤΕ
                    Ψ1 <-- Ν DIV 10
                    Ψ0 <-- Ν MOD 10
                    ΑΠΟΤ <-- Ψ1+Ψ0
              ΑΛΛΙΩΣ_ΑΝ Ν <= 999 ΤΟΤΕ
                    Ψ2 <-- Ν DIV 100
                    Ψ1 <-- (Ν MOD 100)  DIV 10
                    Ψ0 <-- (Ν MOD 100)  MOD 10
                    ΑΠΟΤ <-- Ψ2*Ψ1*Ψ0
              ΑΛΛΙΩΣ_ΑΝ Ν <= 9999 ΤΟΤΕ
                    Ψ3 <-- Ν DIV 1000
                    Ψ2 <-- (Ν MOD 1000) DIV 100
                    Ψ1 <--  ( (Ν MOD 1000) MOD 100) DIV 10
                    Ψ0 <-- ( (Ν MOD 1000) MOD 100) MOD 10
                    ΑΠΟΤ <-- Ψ3^2+Ψ2^2+Ψ1^2+Ψ0^2
               ΑΛΛΙΩΣ
                    ΑΠΟΤ <-- -1
               ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τετάρτη, 20 Ιουλίου 2011

Άσκηση : επεξεργασία δοσμένου πλήθους δεδομένων (Για..από..μέχρι)

Γράψτε αλγόριθμο που διαβάζει το εμβαδόν σε τετραγωνικά
μέτρα 27 διαμερισμάτων, υπολογίζει και εμφανίζει:
α) το μέσο όρο εμβαδού ανά διαμέρισμα,
β) πόσα διαμερίσματα είχαν εμβαδόν μικρότερο από 80
    τετραγωνικά μέτρα,
γ) τον αύξοντα αριθμό (1-27) του πιο ευρύχωρου διαμερί-
    σματος.

Λύση

       Αλγόριθμος Διαμ
       σ <-- 0
       φ <-- 0
       Μεγ <-- -100
       Για κ από 1 μέχρι 27
            Διάβασε Εμβ
            σ <-- σ+Εμβ
            Αν Εμβ < 80 τότε
                 φ <-- φ+1
            Τέλος_αν
            Αν Εμβ > Μεγ τότε
                 Μεγ <-- Εμβ
                 ΑΑΜεγ <-- κ
            Τέλος_αν
       Τέλος_επανάληψης
       ΜΟ <-- σ/27
       Εμφάνισε ΜΟ, φ, ΑΑΜεγ
       Τέλος Διαμ

Τρίτη, 19 Ιουλίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
πραγματικό πίνακα Α[12, 30] και υπολογίζει το
πλήθος των στοιχείων του πίνακα που υπολείπονται
του μέσου όρου του.

Λύση

        ΣΥΝΑΡΤΗΣΗ ΥΠΟΛ(Α) : ΑΚΕΡΑΙΑ
        ΜΕΤΑΒΛΗΤΕΣ
              ΠΡΑΓΜΑΤΙΚΕΣ: Α[12, 30], Σ, ΜΟ
              ΑΚΕΡΑΙΕΣ: Κ, Λ, Φ
        ΑΡΧΗ
              Σ <-- 0
              ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                   ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 30
                         Σ <-- Σ+Α[Κ, Λ]
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΜΟ <-- Σ/360
              Φ <-- 0
              ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 12
                   ΓΙΑ Λ ΑΠΟ ΜΕΧΡΙ 30
                        ΑΝ Α[Κ, Λ] < ΜΟ ΤΟΤΕ
                                Φ <-- Φ+1
                        ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΥΠΟΛ <-- Φ
        ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν
ακέραιο Ν και εμφανίζει όλους τους περιττούς
αριθμούς στο διάστημα [1, Ν].

Λύση

          ΔΙΑΔΙΚΑΣΙΑ ΠΕΡΙΤΤΟΙ(Ν)
          ΜΕΤΑΒΛΗΤΕΣ
                 ΑΚΕΡΑΙΕΣ: Ν, Κ
          ΑΡΧΗ
                 ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Ν
                        ΑΝ Κ MOD 2 = 1 ΤΟΤΕ
                              ΓΡΑΨΕ Κ
                        ΤΕΛΟΣ_ΑΝ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρασκευή, 15 Ιουλίου 2011

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος
1. Η δομή ενός προβλήματος καταγράφεται κατά τη
    διάρκεια της ανάλυσής του σε άλλα υποπροβλήματα.
2. Οι αλγόριθμοι μπορούν να διατυπωθούν και
    διαγραμματικά.
3. Οι  πίνακες δεν μπορούν να χρησιμοποιηθούν ως
    παράμετροι στα υποπρογράμματα.
4. Η μεταβλητή μιας συνάρτησης έχει καθολική ισχύ.
5. Η γλώσσα C είναι ιδανική για την εισαγωγή στον
    προγραμματισμό πολύ μικρών μαθητών.


Απάντηση

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ

Προσδιορισμός τύπου μεταβλητών

Προσδιορίστε τον τύπο των μεταβλητών που αναπαριστά-
νουν τα ακόλουθα:
1. Τίτλος ενός CD
2. Αριθμός μορίων ενός μαθητή
3. Πλήθος πρώτων αριθμών στο διάστημα [α, β]
4. Μέσος όρος εισπράξεων ενός καταστήματος
5. Η λύση Χ της εξίσωσης ΑΧ = Β
6. Αποτέλεσμα σκόπευσης (πέτυχε, δεν πέτυχε)

Απάντηση

1. Χαρακτήρες
2. Ακέραιες
3. Ακέραιες
4. Πραγματικές
5. Πραγματικές
6. Λογικές ή χαρακτήρες

Τετάρτη, 13 Ιουλίου 2011

Έλεγχος ορθότητας εντολών εκχώρησης

Θεωρήστε το παρακάτω τμήμα μεταβλητών ενός
προγράμματος
    ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Χ
             ΠΡΑΓΜΑΤΙΚΕΣ : Υ
             ΧΑΡΑΚΤΗΡΕΣ : Ζ
             ΛΟΓΙΚΕΣ : Μ
Ποιες από τις παρακάτω εντολές εκχώρησης είναι
σωστές και ποιες λάθος. Αιτιολογήστε μόνο τις
λανθασμένες περιπτώσεις.

1. Χ <-- Υ*2
2. Υ <-- Χ^2+1.35
3. Ζ <-- 'Χ+Υ'
4. Μ <-- 'ΨΕΥΔΗΣ'
5. Μ <-- Χ+Υ > 0
6. Ζ <-- ΟΛΟΣ

Απάντηση

1. Λάθος (γιατί στο δεξιό μέρος έχουμε πραγματική
    αριθμητική παράσταση)
2. Σωστό
3. Σωστό
4. Λάθος (γιατί στο δεξιό μέρος έχουμε αλφαριθμητικά
    δεδομένα)
5. Σωστό
6. Λάθος (γιατί το κείμενο δεν περικλείεται από απο-
    στρόφους)

Τρίτη, 12 Ιουλίου 2011

Έλεγχος ορθότητας ονομάτων

Ποια από τα παρακάτω είναι έγκυρα ονόματα μεταβλητών
στην ψευδογλώσσα και ποια όχι. Αιτιολογήστε μόνο τις
αρνητικές απαντήσεις.
1. Αν_τότε
2. Αρχη
    γός
3. Α ρ α ι ό
4. προγ1προγ2
5. Αποτελέσματα
6. 7επτά

Απάντηση

1. Έγκυρο
2. Άκυρο (δεν επιτρέπεται η αλλαγή γραμμής)
3. Άκυρο (υπάρχουν κενά διαστήματα)
4. Έγκυρο
5. Άκυρο (δεσμευμένη λέξη)
6. Άκυρο (ξεκινάει με ψηφίο)

Εντολές εκχώρησης

Διατυπώστε τις εντολές εκχώρησης που υλοποιούν τους
παρακάτω υπολογισμούς
1. Εκχώρησε στην Α το τριπλάσιο της Β ελαττωμένο κατά 1.
2. Εκχώρησε στην Α το τετράγωνο της Β.
3. Εκχώρησε στην Γ την τετραγωνική ρίζα της απόλυτης τιμής
    του Α.
4. Εκχώρησε στην Γ το γινόμενο των Α, Β αυξημένο κατά 1.2
5. Εκχώρησε στην Α το υπόλοιπο της διαίρεσης του Β με το
    άθροισμα των Δ, Λ.

Απάντηση

1. Α <-- 3*Β-1
2. Α <-- Β^2
3. Γ <-- Τ_Ρ(Α_Τ(Α))
4. Γ <-- Α*Β+1.2
5. Α <-- Β mod (Δ+Λ)

Διατύπωση περιορισμών

Διατυπώστε τους παρακάτω περιορισμούς στη ΓΛΩΣΣΑ
1. Το Χ είναι 1 ή 2
2. Το Υ είναι άρτιο αλλά όχι πολλαπλάσιο του 8
3. Το Ζ είναι ανάμεσα στο 1 και στο 80 (χωρίς να
     συμπεριλαμβάνονται τα δύο άκρα)
4. Το Κ βρίσκεται έξω από το διάστημα τιμών (4, 89).

Απάντηση


1. (Χ = 1) Ή (Χ = 2)
2. (Y MOD 2 = 0) KAI (Y MOD 8 < > 0)
3. (Z > 1) KAI (Z < 80)
4. (K <= 4) Ή (Κ >= 89)

Δευτέρα, 11 Ιουλίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως  παράμετρο έναν
ακέραιο πίνακα Α[4, 5] και υπολογίζει το αποτέλεσμα
της παράστασης Χ+3Υ, όπου:
* Χ είναι το άθροισμα των στοιχείων της 3ης γραμμής
* Υ είναι το γινόμενο των στοιχείων της 1ης στήλης.

Λύση

      ΣΥΝΑΡΤΗΣΗ Φ(Α) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α[4, 5], Κ, Χ, Υ
      ΑΡΧΗ
            Χ <-- 0
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5
                  Χ <-- Χ+Α[3, Κ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Υ <-- 1
            ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 4
                  Υ <-- Υ*Α[Κ, 1]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Φ <-- Χ+3*Υ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σάββατο, 9 Ιουλίου 2011

Πίνακας δεδομένων-ζητουμένων/μαθηματική μορφοποίηση

Τρεις άνθρωποι (Α, Β, Γ) έχουν συνολικό βάρος 220 κιλά.
Το βάρος του Β είναι κατά 30 % μεγαλύτερο από το
βάρος του Α, ενώ ο Γ ζυγίζει 4 κιλά περισσότερα από τον Β.
Πόσα κιλά ζυγίζει ο κάθε άνθρωπος΄
α) Κατασκευάστε πίνακα δεδομένων-ζητουμένων.
β) Μορφοποιήστε με μαθηματικό τρόπο το πρόβλημα.

Λύση

α)
           ________________________________________
           Δεδομένα       * Το συνολικό βάρος των Α, Β, Γ
                                      είναι 220 κιλά.
                                   * Το βάρος του Β είναι κατά 30 %
                                      μεγαλύτερο από το βάρος του Α.
                                   * Ο Γ ζυγίζει 4 κιλά περισσότερα
                                      από τον Β.
           _______________________________________
           Ζητούμενα      * Το βάρος του Α σε κιλά
                                   * Το βάρος του Β σε κιλά
                                   * Το βάρος του Γ σε κιλά
          ________________________________________

β)
      Ας συμβολίσουμε με ΒΑ, ΒΒ, ΒΓ τα βάρη σε κιλά
      των Α, Β, Γ αντίστοιχα. Ισχύουν οι σχέσεις:
                ΒΑ+ΒΒ+ΒΓ = 220
                ΒΒ = ΒΑ+ΒΑ*30/100
                ΒΓ = ΒΒ+4

Κυριακή, 3 Ιουλίου 2011

Δώστε την εκφώνηση του προβλήματος

για τον παρακάτω αλγόριθμο:
      Αλγόριθμος Ασκ
      Δεδομένα // Α //
      σ <-- 0
      Για κ από 1 μέχρι 6
           Για λ από 1 μέχρι 7 με_βήμα 2
                σ <-- σ+Α[κ, λ]
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      Αποτελέσματα // σ //
      Τέλος Ασκ

Απάντηση

      Γράψτε αλγόριθμο που δοθέντος του πίνακα Α[6, 7]
      υπολογίζει το άθροισμα των στοιχείων του πίνακα
      αυτού που ανήκουν στις στήλες που έχουν περιττό
      αριθμό (1, 3, 5 και 7).

Παρασκευή, 1 Ιουλίου 2011

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1. Η διατύπωση ενός προβλήματος πρέπει να χαρακτηρίζεται
    από _________.
2. Όταν η περιεχόμενη ομάδα εντολών σε μια Αν..τότε είναι
    μονομελής, το _______ μπορεί να παραληφθεί.
3. Η Όσο..επανάλαβε είναι μια _______ δομή.
4. Κάθε πρόγραμμα τελειώνει με τη δεσμευμένη λέξη ____.
5. Κάθε τετραγωνικός πίνακας έχει _____ κύριες διαγωνίους.


Απαντήσεις

1. σαφήνεια
2. Τέλος_αν
3. επαναληπτική
4. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
5. δύο

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε
τις με σωστό τρόπο.
1. Τα επιλύσιμα προβλήματα είναι υποκατηγορία των
    αδόμητων προβλημάτων.
2. Ο πολλαπλασιασμός αλά ρωσικά είναι μια από τις
    βασικές αριθμητικές λειτουργίες του υπολογιστή.
3. Μια μεταβλητή έχει μεταβαλλόμενο τύπο.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις του
    σκληρού δίσκου του υπολογιστή.
5. Μια διαδικασία τελειώνει πάντοτε με τη δεσμευμένη
    λέξη ΤΕΛΟΣ.

 

Απαντήσεις

1. Τα αδόμητα προβλήματα είναι υποκατηγορία των
    επιλύσιμων προβλημάτων.
2. Η πρόσθεση  είναι μια από τις βασικές αριθμητικές 
    λειτουργίες του υπολογιστή.
3. Μια μεταβλητή έχει μεταβαλλόμενο περιεχόμενο.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις της
    κύριας μνήμης του υπολογιστή.
5. Μια διαδικασία τελειώνει πάντοτε με τη δεσμευμένη
    λέξη ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ.

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Το πρόβλημα του έτους 2000 ήταν ένα ημιδομημένο
    πρόβλημα.
2. Ο αλγόριθμος δεν μπορεί να αναπαρασταθεί με
    γραφικό τρόπο.
3. Μια από τις λειτουργίες που μπορούν να γίνουν
    σε μια δομή δεδομένων είναι και η αναζήτηση.
4. Όλα τα άρτια στοιχεία ενός μονοδιάστατου πίνακα
    αποθηκεύονται σε συνεχόμενες θέσεις στη μνήμη.
5. Οποιαδήποτε λειτουργία επιτελεί ένα πρόγραμμα μπορεί
    να υλοποιηθεί και ως διαδικασία.



Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ
5. Σ