Τρίτη, 19 Ιουλίου 2011

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο έναν
ακέραιο Ν και εμφανίζει όλους τους περιττούς
αριθμούς στο διάστημα [1, Ν].

Λύση

          ΔΙΑΔΙΚΑΣΙΑ ΠΕΡΙΤΤΟΙ(Ν)
          ΜΕΤΑΒΛΗΤΕΣ
                 ΑΚΕΡΑΙΕΣ: Ν, Κ
          ΑΡΧΗ
                 ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Ν
                        ΑΝ Κ MOD 2 = 1 ΤΟΤΕ
                              ΓΡΑΨΕ Κ
                        ΤΕΛΟΣ_ΑΝ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου