Τρίτη, 19 Ιουλίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παράμετρο έναν
πραγματικό πίνακα Α[12, 30] και υπολογίζει το
πλήθος των στοιχείων του πίνακα που υπολείπονται
του μέσου όρου του.

Λύση

        ΣΥΝΑΡΤΗΣΗ ΥΠΟΛ(Α) : ΑΚΕΡΑΙΑ
        ΜΕΤΑΒΛΗΤΕΣ
              ΠΡΑΓΜΑΤΙΚΕΣ: Α[12, 30], Σ, ΜΟ
              ΑΚΕΡΑΙΕΣ: Κ, Λ, Φ
        ΑΡΧΗ
              Σ <-- 0
              ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
                   ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 30
                         Σ <-- Σ+Α[Κ, Λ]
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΜΟ <-- Σ/360
              Φ <-- 0
              ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 12
                   ΓΙΑ Λ ΑΠΟ ΜΕΧΡΙ 30
                        ΑΝ Α[Κ, Λ] < ΜΟ ΤΟΤΕ
                                Φ <-- Φ+1
                        ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΥΠΟΛ <-- Φ
        ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου