Παρασκευή, 22 Ιουλίου 2011

Άσκηση: συγγραφή διαδικασίας

Σ' ένα σούπερ μάρκετ πωλούνται 4 διαφορετικές μάρκες
μαλακτικού ρούχων. Για καθεμιά από τις μάρκες αυτές
διατίθενται 3 διαφορετικές συσκευασίες προϊόντος (1,5
λίτρου, 3 λίτρων και 5,5 λίτρων).
Γράψτε διαδικασία η οποία:
α) διαβάζει τις τιμές πώλησης του κάθε προϊόντος,
β) υπολογίζει :
    * τον αύξοντα αριθμό (1-4) της μάρκας και τον αύξοντα αριθμό
       (1-3) της συσκευασίας του πιο ακριβού προϊόντος,
    * τον αύξοντα αριθμό (1-4) της μάρκας και τον αύξοντα αριθμό
       (1-3) της συσκευασίας του  προϊόντος που αποτελεί την πιο
       συμφέρουσα επιλογή για έναν πελάτη.
Παρατήρηση : Καμιά συσκευασία δε στοίχιζε περισσότερο από 
20 ευρώ.




Λύση


      ΔΙΑΔΙΚΑΣΙΑ ΑΓΟΡΑ(ΜεγM, ΣυσκΜ, ΣυμφΜ, ΣυμφΣυσκ)
      ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ : Μεγ, Μικ, Τιμ, Ογκ[3], ΤιμΛ
             ΑΚΕΡΑΙΕΣ: Κ, Λ, ΜεγM, ΣυσκΜ, ΣυμφΜ, ΣυμφΣυσκ,                 
      ΑΡΧΗ
             Μεγ <-- -100
             Μικ <-- 21
             Ογκ[1] <-- 1.5
             Ογκ[2] <-- 3
             Ογκ[3] <-- 5.5
             ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 4
                   ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 3
                         ΔΙΑΒΑΣΕ Τιμ
                         ΑΝ Τιμ > Μεγ ΤΟΤΕ
                                Τιμ <-- Μεγ
                                ΜεγΜ <-- Κ
                                ΣυσκΜ <-- Λ
                         ΤΕΛΟΣ_ΑΝ
                         ΤιμΛ <-- Τιμ/Ογκ[Λ]
                         ΑΝ ΤιμΛ < Μικ ΤΟΤΕ
                               Μικ <-- ΤιμΛ
                               ΣυμφΜ <-- Κ
                               ΣυμφΣυσκ <-- Λ
                         ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου