Τετάρτη, 20 Ιουλίου 2011

Άσκηση : επεξεργασία δοσμένου πλήθους δεδομένων (Για..από..μέχρι)

Γράψτε αλγόριθμο που διαβάζει το εμβαδόν σε τετραγωνικά
μέτρα 27 διαμερισμάτων, υπολογίζει και εμφανίζει:
α) το μέσο όρο εμβαδού ανά διαμέρισμα,
β) πόσα διαμερίσματα είχαν εμβαδόν μικρότερο από 80
    τετραγωνικά μέτρα,
γ) τον αύξοντα αριθμό (1-27) του πιο ευρύχωρου διαμερί-
    σματος.

Λύση

       Αλγόριθμος Διαμ
       σ <-- 0
       φ <-- 0
       Μεγ <-- -100
       Για κ από 1 μέχρι 27
            Διάβασε Εμβ
            σ <-- σ+Εμβ
            Αν Εμβ < 80 τότε
                 φ <-- φ+1
            Τέλος_αν
            Αν Εμβ > Μεγ τότε
                 Μεγ <-- Εμβ
                 ΑΑΜεγ <-- κ
            Τέλος_αν
       Τέλος_επανάληψης
       ΜΟ <-- σ/27
       Εμφάνισε ΜΟ, φ, ΑΑΜεγ
       Τέλος Διαμ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου