Δευτέρα, 11 Ιουλίου 2011

Άσκηση : συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως  παράμετρο έναν
ακέραιο πίνακα Α[4, 5] και υπολογίζει το αποτέλεσμα
της παράστασης Χ+3Υ, όπου:
* Χ είναι το άθροισμα των στοιχείων της 3ης γραμμής
* Υ είναι το γινόμενο των στοιχείων της 1ης στήλης.

Λύση

      ΣΥΝΑΡΤΗΣΗ Φ(Α) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Α[4, 5], Κ, Χ, Υ
      ΑΡΧΗ
            Χ <-- 0
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5
                  Χ <-- Χ+Α[3, Κ]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Υ <-- 1
            ΓΙΑ Κ ΑΠΟ ΜΕΧΡΙ 4
                  Υ <-- Υ*Α[Κ, 1]
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Φ <-- Χ+3*Υ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου