Σάββατο, 27 Οκτωβρίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία διαβάζει 120 δυάδες ακεραίων
αριθμών, υπολογίζει και εμφανίζει το γινόμενο, το άθροισμα
και τη διαφορά κάθε δυάδας.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΔΥΑΔΕΣ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Κ, Α, Β
     ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 120
              ΔΙΑΒΑΣΕ Α, Β
              ΓΡΑΨΕ 'ΑΘΡΟΙΣΜΑ =', Α+Β
              ΓΡΑΨΕ 'ΔΙΑΦΟΡΑ =', Α-Β
              ΓΡΑΨΕ 'ΓΙΝΟΜΕΝΟ = ', Α*Β
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ 

Παρασκευή, 26 Οκτωβρίου 2012

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια αλγοριθμικά κριτήρια παραβιάζονται στον
παρακάτω υποτιθέμενο αλγόριθμο;
    Αλγόριθμος Ασκ
    Διάβασε Χ
    Όσο (Χ+1) <= Α_Τ(Χ+1) επανάλαβε
         Αν Χ >= 0 τότε
              Ζ <-- 1/(Χ-100)
         αλλιώς
              Ζ <-- Χ^2
         Τέλος_αν
          Ζ <-- Ζ+Υ
    Τέλος_επανάληψης
    Τέλος Ασκ

Απαντήσεις

α) Είσοδος, γιατί το Υ δεν έχει πάρει καμία τιμή.
β) Έξοδος, γιατί ο αλγόριθμος δεν εμφανίζει κανένα
    αποτέλεσμα.
γ) Καθοριστικότητα, γιατί αν Χ = 100 η εντολή
    Ζ <-- 1/(Χ-100) δεν μπορεί να εκτελεστεί
δ) Περατότητα, αφού η συνθήκη της Όσο είναι
    πάντοτε αληθής και η επανάληψη δεν τερμα-
    τίζεται ποτέ.

Πέμπτη, 25 Οκτωβρίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Για να λύσουμε ένα πρόβλημα πρέπει προηγουμένως
    να οριοθετήσουμε το χρόνο του.
2. Οι μοναδικοί τελεστές σύγκρισης που μπορούν να
    εφαρμοστούν σε αλφαριθμητικά δεδομένα είναι
    το = και το < >.
3. Οι βιβλιοθήκες περιέχουν προγράμματα που
     υλοποιούν συγκεκριμένες λειτουργίες.
4. Ο τμηματικός προγραμματισμός προέκυψε κυρίως
     μέσα από μια συντονισμένη προσπάθεια
     περιορισμού χρήσης της εντολής GOTO.
5. Οι γλώσσες υψηλού επιπέδου αποκαλούνται και
    συμβολικές γλώσσες.


Απαντήσεις


1. Για να λύσουμε ένα πρόβλημα πρέπει προηγουμένως
    να οριοθετήσουμε το χώρο του.
2. Οι μοναδικοί τελεστές σύγκρισης που μπορούν να
    εφαρμοστούν σε λογικά δεδομένα είναι
    το = και το < >.

3. Οι βιβλιοθήκες περιέχουν υποπρογράμματα που
     υλοποιούν συγκεκριμένες λειτουργίες.

4. Ο δομημένος προγραμματισμός προέκυψε κυρίως
     μέσα από μια συντονισμένη προσπάθεια
     περιορισμού χρήσης της εντολής GOTO.

5. Οι γλώσσες χαμηλού επιπέδου αποκαλούνται και
    συμβολικές γλώσσες.


Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τις λογικές
παραστάσεις;
1. Όταν ολοκληρωθεί ο υπολογισμός τους έχουν την
    τιμή Αληθής ή Ψευδής.
2. Χρησιμοποιούνται για τον έλεγχο δομών επιλογής
    ή επανάληψης.
3. Δεν περιλαμβάνουν αριθμητικές μεταβλητές.
4. Οι λογικές πράξεις που εμπεριέχουν εκτελούνται από
    τα αριστερά προς τα δεξιά.
5. Εμπεριέχουν μόνο λογικές πράξεις και όχι
    συγκρίσεις.
6. Αποκαλούνται και λογικές εκφράσεις ή συνθήκες.


Απαντήσεις

1, 2,  6

Τετάρτη, 24 Οκτωβρίου 2012

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η επικοινωνία του υπολογιστή με τον άνθρωπο γίνεται
    με τη βοήθεια των φυσικών γλώσσών,
2. Δύο εμφωλευμένες Αν..τότε μπορούν να αντικατασταθούν
    από μία κατάλληλα διατυπωμένη Αν..τότε που να
    επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.
3. Μια  σταθερά μπορεί να είναι ακέραια ή πραγματική ή
    αλφαριθμητική ή λογική.
4. Ο βρόχος επανάληψης που τερματίζεται μετά από
    κάποιο αριθμό επαναλήψεων αποκαλείται και
    ατέρμων.
5. Χ ΚΑΙ ΑΛΗΘΗΣ = Χ

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Σ

Πέμπτη, 18 Οκτωβρίου 2012

Κουμπαράς

Θέλετε να μαζέψετε 50000 ευρώ προκειμένου να αγοράσετε
ένα οικόπεδο. Από τα ετήσια εισοδήματα σας καταφέρνετε
να αποταμιεύετε ένα ποσοστό (%) τους. Γράψτε αλγόριθμο
ο οποίος:
α) διαβάζει τα εισοδήματα που είχατε κάθε χρόνο και το
    ποσοστό (%) επί των εισοδημάτων αυτών που καταφέρνατε
    να αποταμιεύετε (οι δύο παραπάνω τιμές εισόδου είναι
    διαφορετικές για κάθε χρόνο),
β) υπολογίζει και εμφανίζει πόσα χρόνια χρειάζονται για
    να πετύχετε το στόχο σας.

Λύση

     Αλγόριθμος Οικόπεδο
     Χρόνια <-- 0
     Αθρ <-- 0
     Όσο Αθρ < 50000 επανάλαβε
          Διάβασε Εισοδ, Ποσοστό
          Αθρ <-- Αθρ+Εισοδ*Ποσοστό/100
          Χρόνια <-- Χρόνια+1
     Τέλος_επανάληψης
     Εμφάνισε Χρόνια
     Τέλος Οικόπεδο

Τρίτη, 16 Οκτωβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που:
α) διαβάζει τις τιμές πώλησης και τις μάρκες κάποιων
    tablet (η είσοδος δεδομένων ολοκληρώνεται μόλις
    δοθεί η απάντηση 'Ο'΄στην υποβαλλόμενη προς
    το χρήστη ερώτηση 'Υπάρχει άλλο tablet?')
β) υπολογίζει και εμφανίζει:
    * τη μάρκα της ακριβότερης συσκευής,
    * πόσα tablet στοίχιζαν περισσότερο από 300 ευρώ.

Λύση

     Αλγόριθμος tablet
     MAX <-- -9
     φ <-- 0
     Αρχή_επανάληψης
         Διάβασε Τιμή
         Διάβασε Μάρκα
         Αν Τιμή > ΜΑΧ τότε
              ΜΑΧ <-- Τιμή
              ΜαρκΜΑΧ <-- Μάρκα
         Τέλος_αν
         Αν Τιμή > 300 τότε
              φ <-- φ+1
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλο tablet?'
         Διάβασε Απ
     Μέχρις_ότου Απ = 'Ο'
     Εμφάνισε ΜαρκΜΑΧ, φ
     Τέλος tablet
   

Δευτέρα, 15 Οκτωβρίου 2012

Φρουρός

Γράψτε αλγόριθμο που :
α) διαβάζει τους συντελεστές κάποιων πρωτοβάθμιων εξισώσεων
    ΑΧ = Β ( η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί
    ως τιμή εισόδου για το Α το 0),
β) επιλύει την κάθε εξίσωση ξεχωριστά και εμφανίζει τα αποτελέσματα
    στη μονάδα εξόδου.

Λύση

    Αλγόριθμος Εξισώσεις
    Αρχή_επανάληψης
        Διάβασε Α, Β
        Αν Α < > 0 τότε
            Χ <-- Β/Α
            Εμφάνισε Χ
        Τέλος_αν
    Μέχρις_ότου Α = 0
    Τέλος Εξισώσεις

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τους αγαπημένους προορισμούς
διακοπών 130 αλλοδαπών τουριστών, υπολογίζει και εμφανίζει:
α) το ποσοστό (%) των τουριστών που επέλεξαν ως προορισμό
    τους την ΕΛΛΑΔΑ,
β) πόσοι δεν επέλεξαν ως προορισμό τους τη ΓΕΡΜΑΝΙΑ.

Λύση

      Αλγόριθμος Τουρ
      Ελλαδ <-- 0
      ΟχιΓερμ <-- 0
      Για κ από 1 μέχρι 130
           Διάβασε Προ
           Αν Προ = 'ΕΛΛΑΔΑ' τότε
               Ελλαδ <-- Ελλαδ+1
           Τέλος_αν
           Αν Προ < >  'ΓΕΡΜΑΝΙΑ' τότε
               ΟχιΓερμ <-- ΟχιΓερμ+1
           Τέλος_αν            
      Τέλος_επανάληψης
      ΠΟΣ <-- 100*Ελλαδ/130
      Εμφάνισε ΠΟΣ, ΟχιΓερμ
      Τέλος Τουρ

Τρίτη, 9 Οκτωβρίου 2012

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για την Αν..τότε..αλλιώς_αν;
  1. Είναι μια δομή πολλαπλής επιλογής.
  2. Αποκαλείται και εμφωλευμένος βρόχος.
  3. Χρησιμοποιείται όταν τα ενδεχόμενα είναι τουλάχιστον
      τρία.
  4. Χρησιμοποιείται όταν τα ενδεχόμενα είναι τουλάχιστον
      δύο.
  5. Παριστάνεται διαγραμματικά με ένα ρόμβο που έχει
      τουλάχιστον τρεις εξόδους για απάντηση.
  6. Τελειώνει με τη δεσμευμένη λέξη Τέλος_αν.
  7. Είναι μια δομή επανάληψης


Απαντήσεις

1, 3, 6

Πίνακας αντιστοίχησης

Δίνονται οι ακόλουθες έννοιες
    1. ελεύθερο κείμενο
    2. υπολογιστική διαδικασία
    3. αλγόριθμος
    4. γλώσσα μηχανής
    5. υποπρόγραμμα
και οι πιθανές ερμηνείες-ορισμοί
    α. τρόπος αναπαράστασης προγράμματος
    β. τρόπος αναπαράστασης αλγορίθμου
    γ. μηχανισμός παραγωγής πληροφοριών
    δ. επεξεργασία δεδομένων μέσω υπολογιστή
    ε. γλώσσα 4ης γενιάς
    στ. μια ακολουθία από 0 και 1
    ζ. ένα πρόγραμμα που εκτελεί υποδεέστερο έργο
    η. ένα τμήμα προγράμματος που εκτελεί ένα
        αυτόνομο έργο
    θ. ένας αλγόριθμος που δεν τελειώνει ποτέ
Γράψτε τον αριθμό (1-5) και δίπλα το γράμμα (α-θ)
στο οποίο αντιστοιχεί.

Απαντήσεις

1. β
2. θ
3. γ
4. στ
5. η

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η ___________ σταθερά είναι ένα όνομα που
    αντιπροσωπεύει μια σταθερή ποσότητα.
2. Κάθε  _________ ενός προγράμματος δεσμεύει
    συγκεκριμένο χώρο στην κύρια μνήμη του υπολογιστή.
3. Ο ___________ μεταφράζει ένα πρόγραμμα από
    γλώσσα χαμηλού επιπέδου σε γλώσσα μηχανής.
4. Η εντολή GOTO αλλάζει βίαια τη ________ εκτέλεσης
    των εντολών.
5. Η είσοδος είναι ένα από τα ________ κριτήρια.

Απαντήσεις

1. συμβολική
2. μεταβλητή
3. συμβολομεταφραστής
4. σειρά
5. αλγοριθμικά

Πέμπτη, 4 Οκτωβρίου 2012

Διατύπωση περιορισμών

Διατυπώστε τους παρακάτω περιορισμούς στη ΓΛΩΣΣΑ
1. Το Απ μπορεί να είναι 'Ν' ή 'ν'
2. Το ΡΕΣ δεν μπορεί να είναι ούτε 'ΑΡΧΗ' ούτε
    'ΤΕΛΟΣ'
3. Η πραγματική μεταβλητή Χ περιέχει ακέραιο και
    θετικό περιεχόμενο.
4. Το Χ δεν ανήκει στο διάστημα τιμών (0, 20)
5. Το Χ είναι τουλάχιστον 50 αλλά δεν υπερβαίνει
    το 100


Απαντήσεις

1. (Απ = 'Ν') Ή (Απ = 'ν')
2. (ΡΕΣ < > 'ΑΡΧΗ') ΚΑΙ (ΡΕΣ < > 'ΤΕΛΟΣ')
3. (Α_Μ(Χ) = Χ) ΚΑΙ (Χ > 0)
4. (Χ <= 0) Ή (Χ >= 20)
5. (Χ >= 50) ΚΑΙ (Χ <= 100)


Τετάρτη, 3 Οκτωβρίου 2012

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η πράξη div εφαρμόζεται μόνο πάνω σε ακέραια ορίσματα.
2. Η πράξη mod δίνει αποτέλεσμα πραγματικού τύπου.
3. Η λογική πράξη ΔΕΝ είναι γνωστή και ως άρνηση.
4. Η συνάρτηση Τ_Ρ υπολογίζει την τετραγωνική ρίζα
    του ορίσματός της.
5. Ο τελεστής * έχει μικρότερη ιεραρχία από τον 
    τελεστή /.



Απάντηση

1. Σ
2. Λ
3. Λ
4. Σ
5. Λ





Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Ο αλγόριθμος παριστάνεται σχηματικά με ένα
    ραβδόγραμμα.
2. Η συνθήκη που ελέγχει μια εντολή Όσο..επανάλαβε
    είναι μια παράσταση.
3. Η εντολή ΓΡΑΨΕ μπλοκάρει προσωρινά την
    εκτέλεση των εντολών ενός προγράμματος.
4. Η εντολή Για..από..μέχρι είναι ιδανική για έλεγχο
    εγκυρότητας των εισερχόμενων δεδομένων.
5. Ο πίνακας Α[2,3,5] είναι μονοδιάστατος.


Απαντήσεις

1. Ο αλγόριθμος παριστάνεται σχηματικά με ένα
    λογικό διάγραμμα.
2.  Η συνθήκη που ελέγχει μια εντολή Όσο..επανάλαβε 
     είναι μια λογική παράσταση.
3.   Η εντολή ΔΙΑΒΑΣΕ μπλοκάρει προσωρινά την
    εκτέλεση των εντολών ενός προγράμματος.
4. Η εντολή Μέχρις_ότου είναι ιδανική για έλεγχο
    εγκυρότητας των εισερχόμενων δεδομένων.
5. Ο πίνακας Α[2,3,5] είναι τρισδιάστατος.