Τρίτη, 16 Οκτωβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που:
α) διαβάζει τις τιμές πώλησης και τις μάρκες κάποιων
    tablet (η είσοδος δεδομένων ολοκληρώνεται μόλις
    δοθεί η απάντηση 'Ο'΄στην υποβαλλόμενη προς
    το χρήστη ερώτηση 'Υπάρχει άλλο tablet?')
β) υπολογίζει και εμφανίζει:
    * τη μάρκα της ακριβότερης συσκευής,
    * πόσα tablet στοίχιζαν περισσότερο από 300 ευρώ.

Λύση

     Αλγόριθμος tablet
     MAX <-- -9
     φ <-- 0
     Αρχή_επανάληψης
         Διάβασε Τιμή
         Διάβασε Μάρκα
         Αν Τιμή > ΜΑΧ τότε
              ΜΑΧ <-- Τιμή
              ΜαρκΜΑΧ <-- Μάρκα
         Τέλος_αν
         Αν Τιμή > 300 τότε
              φ <-- φ+1
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλο tablet?'
         Διάβασε Απ
     Μέχρις_ότου Απ = 'Ο'
     Εμφάνισε ΜαρκΜΑΧ, φ
     Τέλος tablet
   

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου