Παρασκευή, 26 Οκτωβρίου 2012

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια αλγοριθμικά κριτήρια παραβιάζονται στον
παρακάτω υποτιθέμενο αλγόριθμο;
    Αλγόριθμος Ασκ
    Διάβασε Χ
    Όσο (Χ+1) <= Α_Τ(Χ+1) επανάλαβε
         Αν Χ >= 0 τότε
              Ζ <-- 1/(Χ-100)
         αλλιώς
              Ζ <-- Χ^2
         Τέλος_αν
          Ζ <-- Ζ+Υ
    Τέλος_επανάληψης
    Τέλος Ασκ

Απαντήσεις

α) Είσοδος, γιατί το Υ δεν έχει πάρει καμία τιμή.
β) Έξοδος, γιατί ο αλγόριθμος δεν εμφανίζει κανένα
    αποτέλεσμα.
γ) Καθοριστικότητα, γιατί αν Χ = 100 η εντολή
    Ζ <-- 1/(Χ-100) δεν μπορεί να εκτελεστεί
δ) Περατότητα, αφού η συνθήκη της Όσο είναι
    πάντοτε αληθής και η επανάληψη δεν τερμα-
    τίζεται ποτέ.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου