Δευτέρα, 15 Οκτωβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τους αγαπημένους προορισμούς
διακοπών 130 αλλοδαπών τουριστών, υπολογίζει και εμφανίζει:
α) το ποσοστό (%) των τουριστών που επέλεξαν ως προορισμό
    τους την ΕΛΛΑΔΑ,
β) πόσοι δεν επέλεξαν ως προορισμό τους τη ΓΕΡΜΑΝΙΑ.

Λύση

      Αλγόριθμος Τουρ
      Ελλαδ <-- 0
      ΟχιΓερμ <-- 0
      Για κ από 1 μέχρι 130
           Διάβασε Προ
           Αν Προ = 'ΕΛΛΑΔΑ' τότε
               Ελλαδ <-- Ελλαδ+1
           Τέλος_αν
           Αν Προ < >  'ΓΕΡΜΑΝΙΑ' τότε
               ΟχιΓερμ <-- ΟχιΓερμ+1
           Τέλος_αν            
      Τέλος_επανάληψης
      ΠΟΣ <-- 100*Ελλαδ/130
      Εμφάνισε ΠΟΣ, ΟχιΓερμ
      Τέλος Τουρ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου